These forums have been archived and are now read-only.

The new forums are live and can be found at

EVE Launcher

  • Topic is locked indefinitely.

I need help with Resource loading and payment issues but Support AFK

Valin Ozran
Nuclear Shadow Inc
#1 - 2016-05-01 18:21:05 UTC  |  Edited by: Valin Ozran
Alright, I'm certainly frustrated and I don't want to waste any more time on this than I have to so I'll try to make this clear and short as possible.

I haven't played EVE since roughly 2013 but I had recently seen a few things concerning the game and I decided to reinstall. Before doing so I submitted a Discussion on the Steam forums requesting some help on finding my direction in the game to find out if it really was worth it to return and really wasn't met with much help at all...

However, my desire to play prevailed and I tried to to reactivate my account anyways on the EVE website. 4 times I believe I submitted a payment (from an account I know had sufficient funds) and it kept coming up with an error message which instructed me to try again later or contact support. I also tried this on PLEX and was met with the same issue. I was pretty frustrated because it seemed that return to the game was timed well, as I could return to the game on their $10 special, but I submitted a ticket and moved on to Amazon, where I had to pay the extra $5. At which point I had issues with applying the game time to my account and was not provided with an activation key, nor the ability to link my EVE and Amazon account. So I again submitted another ticket to EVE and contacted Amazon support where I spent nearly an hour talking to 4 different customer service people before the issue was resolved. It's been several days now and I have yet to hear back from EVE support... but I'd like to say thanks to Ravi from Amazon, nice guy. The game time was eventually applied and I was able to begin playing... or so I thought.

Since Ive been in game a large portion of my time has been stuck in resource loading. I lost a harbinger to a player because of it and wasn't able to target and basically froze. Lost an Omen maybe too... I haven't been back on to check yet. I've continued to ask for help on Steam and CCP Alpha who was taking part in the discussion hasn't addressed ANY of my issues. I also submitted a ticket concerning this as well. Have yet to hear anything.

I really want to play this game but I need some help. I work and I'm not going to waste too much more of the time off I have on this issue. I'm asking for assistance.