These forums have been archived and are now read-only.

The new forums are live and can be found at https://forums.eveonline.com/

Macintosh

 
  • Topic is locked indefinitely.
 

Wine support for Mac

First post First post
Author
Lizzie Lefthand Marstolt
Aperture Interstellar Innovations
#21 - 2016-03-07 23:31:23 UTC
Except too bad I couldn't get it to work yet myself... Submitted bug report: EBR-71036
CCP Snorlax
C C P
C C P Alliance
#22 - 2016-03-07 23:37:54 UTC
Lizzie Lefthand Marstolt wrote:
Except too bad I couldn't get it to work yet myself... Submitted bug report: EBR-71036

Are you on OS X 10.9 by any chance?

CCP Snorlax - Software Architect - Team RnB - @CCP_Snorlax - http://ccpsnorlax.blogspot.is/

Lizzie Lefthand Marstolt
Aperture Interstellar Innovations
#23 - 2016-03-07 23:45:55 UTC
iMac (late 2009) / Yosemite 10.10.5
3.06 GHz core 2 duo
8 gb ddr3
Nvidia geforce 9400
Leora Risalo
Insomnis Group
Goonswarm Federation
#24 - 2016-03-08 00:27:37 UTC  |  Edited by: Leora Risalo
-
Invisusira
Escalated.
Project Gungnir.
#25 - 2016-03-08 00:30:21 UTC  |  Edited by: Invisusira
Vincent Athena wrote:
It did not work.
I set it to Wine; version: Latest.
It downloaded a bunch of stuff, copied stuff, and eventually settled down, and looked just like the launcher normally does. I tried to start a session. The little white triangle by the name of one of my accounts turned into a square when I clicked on it, just like normal.
Nothing further happened for abut a minute. Then the square turned back to a triangle. No session of Eve started.
I switched it back to Cider, and the session did start when I wanted it to.
I tried Wine again, and it still failed.

In the above, whenever it failed, I would close and re-open the launcher, and try a second time. The fails were always fails.

BTW, I hope this works out, and thanks for working on it. Those using Wine seem to like it, so I am looking forward to being able to dump Cider forever and ever.

Exact same issue here. If you could let me know where the logs are, that would be great - not having any luck finding any logs here.

OSX 10.8.5
2.7 Ghz i5 iMac

edit: my bug report. are we even being serious right now lmao
Ronald Sotken
Redpimp's WhoreEmporium
#26 - 2016-03-08 00:52:32 UTC  |  Edited by: Ronald Sotken
This is great. Already noticed some much better functionality, such as multi locking with ctrl + mouse click drag not causing the client to lag out. Undocking is much cleaner too, and before I was having unhandled memory exceptions. I'll submit a report if it happens again.

But anyway, if any one was wondering, I was able to migrate the old settings profile from the cider wrapper to the wine wrapper by copying the settings sub directory from the following location

/Users/yourName/Library/Application Support/EVE Online/p_drive/Local Settings/Application Data/CCP/EVE/c_tq_tranquility/PROFILE

to this location

/Users/yourName/Library/Application Support/EVE Online/p_drive/Local Settings/Application Data/CCP/EVE/SharedCache/wineenv/drive_c/users/yourName/Local Settings/Application Data/CCP/EVE/c_tq_tranquility/PROFILE


Hope that helps some people out.
Ronald Sotken
Redpimp's WhoreEmporium
#27 - 2016-03-08 01:05:55 UTC
Leora Risalo wrote:
Could you please post a guide for newbies? i ve never used wine and experience issues with native mac client. Id rather try out this new option prior installing windows

It's as simple as launching the EVE Launcher, selecting Eve Launcher > Preferences (command + ,), and selecting the option to use Wine, instead of Cider on the wrapper type.

The launcher will install Wine and configure it to work. After that, restart the launcher and launch clients as per normal. You'll have to migrate settings, but there should be a fix in the coming week or so.

Good luck!
Invisusira
Escalated.
Project Gungnir.
#28 - 2016-03-08 01:19:01 UTC
Ronald Sotken wrote:
/Users/yourName/Library/Application Support/EVE Online/p_drive/Local Settings/Application Data/CCP/EVE/SharedCache/wineenv/drive_c/users/rob/Local Settings/Application Data/CCP/EVE/c_tq_tranquility/PROFILE


Hope that helps some people out.


Interestingly, there's nothing there at all for me (and it wasn't working for me, see above post). Goes as far as Users/yourName/Library/Application Support/EVE Online/p_drive/Local Settings/Application Data/CCP/EVE/SharedCache/wineenv/drive_c/users/yourName/Local Settings/Application Data/ but then CCP and beyond is missing.
trever
7-2 Ronin
#29 - 2016-03-08 02:35:00 UTC
I ran into same issues as those above me. Where i followed the procedure and it tries to start but fails. Submitted a support ticket with my logs.

Thanks for all your work CCP Snorlax.
sytaqe violacea
Circus of midnight
#30 - 2016-03-08 02:45:31 UTC  |  Edited by: sytaqe violacea
+1
Eventually, I got to be able to input Japanese text to EVE Client directly ! Big smile
(For a long time, I have used external text editor to input Japanese text because copy & paste was the only way to speak Japanese in OSX client.)
Invisusira
Escalated.
Project Gungnir.
#31 - 2016-03-08 04:21:21 UTC
Tried uninstalling Wine (which is... not really possible, apparently?) using the uninstall thing here:

http://winebottler.kronenberg.org/wp/faqs/category/winebottler/

Didn't seem to do anything; same result - launcher tries to launch, but no client is instantiated.
Dragosta DinTei
HERO.
#32 - 2016-03-08 05:07:29 UTC
Ronald Sotken wrote:


/Users/yourName/Library/Application Support/EVE Online/p_drive/Local Settings/Application Data/CCP/EVE/SharedCache/wineenv/drive_c/users/rob/Local Settings/Application Data/CCP/EVE/c_tq_tranquility/PROFILE


Hope that helps some people out.


Just one fix: this part: ".../drive_c/users/rob/Local Settings/..." where it says "rob" it's your mac username, or "yourName" as Ronald says at the beggining "/Users/yourName/..."
Dragosta DinTei
HERO.
#33 - 2016-03-08 05:16:06 UTC  |  Edited by: Dragosta DinTei
here, made a simple guide on activating Wine wrapper

Step-by-Step
Invisusira
Escalated.
Project Gungnir.
#34 - 2016-03-08 05:43:20 UTC
Here's the error (or lack thereof) some of us are getting where the Launcher doesn't do anything when Wine is selected:

http://i.imgur.com/EU8FtFE.gifv
Miranda Hanomaa
New Kamio Mining Authority
#35 - 2016-03-08 06:26:51 UTC
Please bring this to Linux as well, ASAP :)
Ima Wreckyou
The Conference Elite
CODE.
#36 - 2016-03-08 08:16:20 UTC
To celebrate this occasion here is a posting I made in 2011 :-)
Quote:
I don't think that supporting a native Linux Client would be wise. The only way that makes sense in my opinion is to support wine as an official platform. This way there is only one client that supports Win Xp/Vista/7 and wine this could also replace the Mac client. I have no idea why CCP outsources the Mac client to Transgaming, maybe they don't have the know how to support wine.

source
epicurus ataraxia
Illusion of Solitude.
Illusion of Solitude
#37 - 2016-03-08 12:30:38 UTC
A bit fiddly to reset everything up, but it probably needed a good clean up by now Lol
Not sur what to report, I cannot exactly define what has changed yet, but the impression is it looks cleaner and sharper, and I can see the icons properly for the first time since the overview changes.

No I cannot be persuaded to go back to Cider Lol
Thanks, a worthwhile piece of work.

There is one EvE. Many people. Many lifestyles. WE are EvE

GM Mechanic
Game Masters
C C P Alliance
#38 - 2016-03-08 12:52:30 UTC
Invisusira wrote:
Vincent Athena wrote:
It did not work.
I set it to Wine; version: Latest.
It downloaded a bunch of stuff, copied stuff, and eventually settled down, and looked just like the launcher normally does. I tried to start a session. The little white triangle by the name of one of my accounts turned into a square when I clicked on it, just like normal.
Nothing further happened for abut a minute. Then the square turned back to a triangle. No session of Eve started.
I switched it back to Cider, and the session did start when I wanted it to.
I tried Wine again, and it still failed.

In the above, whenever it failed, I would close and re-open the launcher, and try a second time. The fails were always fails.

BTW, I hope this works out, and thanks for working on it. Those using Wine seem to like it, so I am looking forward to being able to dump Cider forever and ever.

Exact same issue here. If you could let me know where the logs are, that would be great - not having any luck finding any logs here.

OSX 10.8.5
2.7 Ghz i5 iMac

edit: my bug report. are we even being serious right now lmao



To open the folder where the launcher logs are located please open the finder and select go to folder, copy and paste the following:

~/Library/Application Support/CCP/EVE/launcher

This should open the correct folder to where the log files are located.

With regards,

GM Mechanic,

CCP Customer Service | EVE Online | EVE Valkyrie

woooooooooooo
AOJI Colliery
Curatores Veritatis Alliance
#39 - 2016-03-08 13:08:29 UTC  |  Edited by: woooooooooooo
my client got white out'd when i did several times of gesture swipe. i lost my hecate while running wh site.. anyway.
also, client does not load POS field, and specific UI elements like a ship status. like this. https://cdn.eveonline.kr/files/attach/images/133/235/016/71ef6cbf6b37dad75fc4e3f633310d9c.png
i will make bug report with log.

EDIT : i delete my client so i cannot acquire my log file.. so this is reproduction steps.
1. open launcher.
2. open preference and select Wine as Wrapper.
3. launch client.
4. press command + return
5. perform four finger gesture for viewing multiple desktop
6. perform three finger gesture for transition between multiple desktop.
7. client got white out, i can hear sound, but whole client is turning white and does not accept any of inputs.
8. kill client.
9. relaunch client through launcher. at this time, client does not display my profile image(when character select window), and ship image. i think kind of cache problem.
10. kill client.
11. relaunch client through launcher.
12. client launched, but crashes immediately.
13. return to launcher, and select Cider as Wrapper.
14. launch client, and client does not running.
15. reinstall client.

Enviroment.
OS : El Capitan (10.11.3)
Device : MacBook Pro (Retina, 15-inch, Mid 2014)
Something interesting situation : when EVE Online client is running, Chrome(web browser) got crashed, and always crashed. and few attempts after chrome works properly, but all of extensions are crashed. also, when chrome is running properly, EVE online client got crashed also.
Anorak Halliday Art3mis
Ministry of War
Amarr Empire
#40 - 2016-03-08 13:30:10 UTC
I downloaded Eve on my Mac, but it already came wrapped in wine. I looked in the Library\Application Support\EVE there were default Windows directories, and in one of them was the eve data. So is that purposeful, because it doesn't look purposeful from this post.