These forums have been archived and are now read-only.

The new forums are live and can be found at https://forums.eveonline.com/

Linux

 
  • Topic is locked indefinitely.
Previous page123Next page
 

Captain's Quarters

First post
Author
Syrix Death
24th Imperial Crusade
Amarr Empire
#21 - 2016-01-13 14:33:51 UTC
CCP Snorlax wrote:
Not sure if anybody's tried yet, but Captain's Quarters should now work under Wine :)

It only took me a few years to get around to fixing this elusive bug...


yea cool thanks, but no, I wont try that essential feature. With that speed of development for linux users I expect a native linux client in like 55years.
Messenger Of Truth
Butlerian Crusade
#22 - 2016-01-13 22:13:41 UTC
CCP Snorlax wrote:
Not sure if anybody's tried yet, but Captain's Quarters should now work under Wine :)

It only took me a few years to get around to fixing this elusive bug...


I have to say you're a pretty cool guy!

Was it a bug in WINE or in EVE?

Trade Hub Price Checker: stop.hammerti.me.uk/pricecheck

Visit "Haulers Channel" in game for all matters courier-related.

Structure name/system API: stop.hammerti.me.uk/api

guigui lechat
the no fock given
#23 - 2016-01-14 13:42:50 UTC
Jenshae Chiroptera wrote:
CCP Snorlax wrote:
Not sure if anybody's tried yet, but Captain's Quarters should now work under Wine :)

It only took me a few years to get around to fixing this elusive bug...
Thank you.
What must I do for you to have EVE work on Wine 64 bit?

(Tried contacting PlayOnLinux team?)


try to install it on a 64b prefix ?

download the last launcher (.exe) in ~/downloads/EveLauncher.exe

install eve with
WINEPREFIX=~/bin/eveonline  wine ~/downloads/EveLauncher.exe


install vcrun (if needed) with
WINEPREFIX=~/bin/eveonline winetricks vcrun2012 vcrun2013


then create a script in ~/bin/ containing
#!/bin/bash
prefix=~/bin/eveonline
install="drive_c/Program\ Files/Eve/eve.exe"
WINEPREFIX=$prefix wine "$prefix/$install"


Then you have a 64b eve running in a 64b wine.
CCP Snorlax
C C P
C C P Alliance
#24 - 2016-01-14 13:50:54 UTC
Jenshae Chiroptera wrote:
CCP Snorlax wrote:
Not sure if anybody's tried yet, but Captain's Quarters should now work under Wine :)

It only took me a few years to get around to fixing this elusive bug...
Thank you.
What must I do for you to have EVE work on Wine 64 bit?

(Tried contacting PlayOnLinux team?)

EVE is a 32 bit app so it will require a 32 bit Wine - see http://wiki.winehq.org/Wine64.


CCP Snorlax - Software Architect - Team RnB - @CCP_Snorlax - http://ccpsnorlax.blogspot.is/

CCP Snorlax
C C P
C C P Alliance
#25 - 2016-01-14 13:57:33 UTC
Messenger Of Truth wrote:
CCP Snorlax wrote:
Not sure if anybody's tried yet, but Captain's Quarters should now work under Wine :)

It only took me a few years to get around to fixing this elusive bug...


I have to say you're a pretty cool guy!

Was it a bug in WINE or in EVE?

It appears to be a bug in a 3rd party SDK we're using where it causes memory corruption that for some reason does not seem to have any adverse side effects on Windows. I got around this by intercepting all memory allocations for that particular SDK and padding them by 16 bytes.

I'm guessing that the underlying memory allocation scheme is different enough so that a bug we got away with on Windows crashed under Wine.

CCP Snorlax - Software Architect - Team RnB - @CCP_Snorlax - http://ccpsnorlax.blogspot.is/

guigui lechat
the no fock given
#26 - 2016-01-14 14:13:18 UTC  |  Edited by: guigui lechat
here is a script to automate installation

#!/bin/bash

prefix=~/bin/eveonline
launcher=launcher.exe
install="drive_c/EVE/eve.exe"

# wine prefix to install eve
prefix=~/bin/eveonline

#name of the launcher we download
launcher=launcher.exe

# windows internal installation, default is C:\\EVE
install="drive_c/EVE/eve.exe"


function run {
    echo run
    if [ ! -d "$prefix" ]; then inst ; fi
    WINEPREFIX=$prefix wine "$prefix/$install"
}

function inst {
    echo "instaling eve"
    mkdir -p "$prefix"
    if [ ! -f "$prefix/$launcher" ]; then
        link=$(wget http://community.eveonline.com/support/download/ -q -O - | grep binaries | grep exe | sed "s/.*href=\"\\(.*\\)\" class.*/\\1/g")
        echo "link resource is $link"
    wget "$link" -O "$prefix/$launcher"
    fi
    WINEPREFIX="$prefix" wine "$prefix/$launcher"
}

function clean {
    rm "$prefix/$launcher"
}

function del {
    rm -rf "$prefix"
}

if [ $# -eq 0 ]; then
   run
   exit 0
fi

case "$1" in
"run") run ;;
"inst") inst ;;
"del") del;;
"clean") clean;;
*) echo "unknown option $1";;
esac


edit : modifications of the resource to download it
Merende Macaco
Tr0pa de elite.
Test Alliance Please Ignore
#27 - 2016-01-14 15:59:33 UTC
Thank you for the squishing. Guess we can stop debating whether EvE merits platinum status.Big smile
Neuntausend
Rens Nursing Home
#28 - 2016-01-14 17:04:17 UTC
guigui lechat wrote:
here is a script to automate installation

#!/bin/bash

prefix=~/bin/eveonline
launcher=launcher.exe
install="drive_c/EVE/eve.exe"

# wine prefix to install eve
prefix=~/bin/eveonline

#name of the launcher we download
launcher=launcher.exe

# windows internal installation, default is C:\\EVE
install="drive_c/EVE/eve.exe"


function run {
    echo run
    if [ ! -d "$prefix" ]; then inst ; fi
    WINEPREFIX=$prefix wine "$prefix/$install"
}

function inst {
    echo "instaling eve"
    mkdir -p "$prefix"
    if [ ! -f "$prefix/$launcher" ]; then
        link=$(wget http://community.eveonline.com/support/download/ -q -O - | grep binaries | grep exe | sed "s/.*href=\"\\(.*\\)\" class.*/\\1/g")
        echo "link resource is $link"
    wget "$link" -O "$prefix/$launcher"
    fi
    WINEPREFIX="$prefix" wine "$prefix/$launcher"
}

function clean {
    rm "$prefix/$launcher"
}

function del {
    rm -rf "$prefix"
}

if [ $# -eq 0 ]; then
   run
   exit 0
fi

case "$1" in
"run") run ;;
"inst") inst ;;
"del") del;;
"clean") clean;;
*) echo "unknown option $1";;
esac


edit : modifications of the resource to download it


Thanks, that looks like it could come in handy.
d 474
The Dutch association of Capsuleers
#29 - 2016-01-15 14:18:42 UTC
WORKS LIKE A CHARM! thank you verry mutch for the fix!

https://imgur.com/SCj0nmJ

i use a msi gtx 750ti 2g

Dmitry Kuvora
Sovetsky Soyuz
R.E.V.O.L.U.T.I.O.N
#30 - 2016-01-16 05:12:27 UTC
gj
now its crashing even without captain's quarters Big smile
Tyranis Marcus
Bloody Heathens
#31 - 2016-01-17 00:53:53 UTC  |  Edited by: Tyranis Marcus
Rhyme Bittern wrote:
and my body seems to be transparent to the lights which shine brightly behind it.


You've been cloned too many times!

Do not run. We are your friends.

Nana Skalski
Taisaanat Kotei
#32 - 2016-01-17 13:24:28 UTC  |  Edited by: Nana Skalski
Torgeir Hekard wrote:
Hey, Santa, you're a bit late this year.

Although I'm getting all artifacty in CQ here when running nvidia via primusrun (running on intel looks fine).

http://i.imgur.com/JjCWrM9.png

Happens in wine 1.7.55 as well as 1.9.0 staging.
Driver is 340.96

Tried switching CSMT/__GL_THREADED_OPTIMIZATIONS/glsl - nothing helps

EDIT: it seems to be resolution-related.

I play in windowed mode with a 1920x1031 window (to fit into the screen leaving space for the task panel), and if i go back-and-forth between window/fullscreen and set a proper resolution, the flickering stops, but resumes once I resize the window to a custom resolution.

PS:

Now if only we had a way to convert stuff to .bik in linux...
Or, better yet, if fancy CQ home cinema accepted some saner formats...Roll


BIK is fairly sane if you use correct compression ratios, I have seen a thread in "My EvE" section, where you can find Scope videos converted to BIK. I have all of them converted and few commercials, but they are 700 MB all. Fairly big library.
ASTORBG
A Blessed Bean
Pandemic Horde
#33 - 2016-01-17 15:01:28 UTC
Thank you CCP!
Torgeir Hekard
I MYSELF AND ME
#34 - 2016-01-18 07:57:07 UTC
Nana Skalski wrote:

BIK is fairly sane if you use correct compression ratios, I have seen a thread in "My EvE" section, where you can find Scope videos converted to BIK. I have all of them converted and few commercials, but they are 700 MB all. Fairly big library.

BIK does not have an encoder apart from the radtools.
ffmpeg only has a reverse-engineered decoder.
radtools don't work under wine.
CCP Snorlax
C C P
C C P Alliance
#35 - 2016-01-18 09:49:15 UTC
We are in the process of switching all videos to webm. No firm dates on when that makes it to Tranquility, but it will happen.

CCP Snorlax - Software Architect - Team RnB - @CCP_Snorlax - http://ccpsnorlax.blogspot.is/

Torgeir Hekard
I MYSELF AND ME
#36 - 2016-01-18 11:45:34 UTC
CCP Snorlax wrote:
We are in the process of switching all videos to webm. No firm dates on when that makes it to Tranquility, but it will happen.

Considering DoD, will we have dynamically updated channels and online streams on CQTV?Roll
helana Tsero
Science and Trade Institute
Caldari State
#37 - 2016-01-19 01:09:59 UTC  |  Edited by: helana Tsero
Torgeir Hekard wrote:
CCP Snorlax wrote:
We are in the process of switching all videos to webm. No firm dates on when that makes it to Tranquility, but it will happen.

Considering DoD, will we have dynamically updated channels and online streams on CQTV?Roll


WANT !

Also CCP news show on CQ screens please !

and CQ in citadels !

"...ppl need to get out of caves and they will see something new.... thats where eve is placed... not in cave."  | zoonr-Korsairs |

Meanwhile Citadel release issues: "tried to bug report this and the bug report is bugged as well" | Rafeau |

Tau-El
Nova-Tek
#38 - 2016-01-21 19:11:02 UTC
Thanks CCP Snorlax!
Jenny Starwolf
Deep Core Mining Inc.
Caldari State
#39 - 2016-01-25 01:44:40 UTC  |  Edited by: Jenny Starwolf
In the CQ there seems to be a bug on the character textures where they almost appear to have an oily black surface.

I assume this is nvidia-related as no one I know with an AMD gpu has this problem, and everyone I know with an Nvidia gpu does.
Not sure if it's client or wine related, though.
It also appears to be a shader-related issue, as turning shaders down fixes the issue.

On a side, someone unrealated note - In the game's display & graphics settings, under Display Adapter, it says "NVIDIA GeForce GTX 470 for all Nvidia users, regardless of what GPU they actually have - this is true for everyone i've tested on the list below:
GTX 400
GTX 450
GTX 650
GTX 690
GTX 740
GTX 750
GTX 750-Ti
GTX 790
GTX 960
GTX 980
GTX Titan
GTX Titan-X
Noserenity
Astrological Dominance
#40 - 2016-01-25 14:17:35 UTC
Jenny Starwolf wrote:
In the CQ there seems to be a bug on the character textures where they almost appear to have an oily black surface.

I assume this is nvidia-related as no one I know with an AMD gpu has this problem, and everyone I know with an Nvidia gpu does.
Not sure if it's client or wine related, though.
It also appears to be a shader-related issue, as turning shaders down fixes the issue.

On a side, someone unrealated note - In the game's display & graphics settings, under Display Adapter, it says "NVIDIA GeForce GTX 470 for all Nvidia users, regardless of what GPU they actually have - this is true for everyone i've tested on the list below:
GTX 400
GTX 450
GTX 650
GTX 690
GTX 740
GTX 750
GTX 750-Ti
GTX 790
GTX 960
GTX 980
GTX Titan
GTX Titan-X

Confirmed on a 980 ti this is also the case. Says 470.
Previous page123Next page