These forums have been archived and are now read-only.

The new forums are live and can be found at https://forums.eveonline.com/

EVE Launcher

 
  • Topic is locked indefinitely.
12Next page
 

EVE Launcher version 995234

First post
Author
CCP Snorlax
C C P
C C P Alliance
#1 - 2016-01-07 14:23:28 UTC
Version 995234 of the launcher has been released with the following changes:

  • Client settings dialog now has an explicit copy button rather than relying only on dragging between columns.
  • The launcher now forces the use of angle rather than desktop opengl for Qt rendering.
  • The launcher now checks for a network connection before attempting to download.
  • Refreshing manually now also reloads the web page.
  • Download test now checks for errors rather than misinterpreting results as ridiculously fast downloads.
  • Fixes to translations.
  • Added Japanese translations.
  • Minor logging changes.


Windows only:

  • The launcher now reconnects to existing processes when restarting.

CCP Snorlax - Software Architect - Team RnB - @CCP_Snorlax - http://ccpsnorlax.blogspot.is/

Mazulka
Imperial Academy
Amarr Empire
#2 - 2016-01-07 17:32:07 UTC
i Have isues with new patch it is downaloding but in one hour it only downloaded 2%. i tryed to restart the laucer and pc, it doenst helped.

http://imgur.com/GKe4w8p
Faldal Dartan
Sebiestor Tribe
Minmatar Republic
#3 - 2016-01-07 18:14:25 UTC  |  Edited by: Faldal Dartan
Can't you provide an external download link?
If not, please don't run the download-server on a Nokia 3210.


This is a joke...
https://gyazo.com/252417e28a690261059be818d242f818
Alexander Skor
Koshaku
#4 - 2016-01-07 18:44:02 UTC
This is ridiculous!
Faldal Dartan
Sebiestor Tribe
Minmatar Republic
#5 - 2016-01-07 18:53:28 UTC
https://i.gyazo.com/6ee2936e94fdb9debe3ba62b51e268bc.png

Not reachable.

CCP CAN YOU PLEASE PROVIDE EXTERNAL LINKS FOR THE UPDATES, SO THAT WE CAN PLAY?
Alexander Skor
Koshaku
#6 - 2016-01-07 18:58:33 UTC
I have tried to download launcher from here http://community.eveonline.com/support/download/ with no success!
Shalmon Aliatus
Bluestar Enterprises
The Craftsmen
#7 - 2016-01-07 19:16:09 UTC  |  Edited by: Shalmon Aliatus
The download starts, the download finishes, the updater.exe starts in a nice console window, runs for a while, then the launcher starts again and downloads Version 995234 again, until I kill the launcher or the udater

Restarted my computer, still does the endless cycle of launcher update.

Hmm, after letting it run for some it time it seems to finally behave...
Faldal Dartan
Sebiestor Tribe
Minmatar Republic
#8 - 2016-01-07 19:34:58 UTC  |  Edited by: Faldal Dartan
So you guys are hosting your launcher on Amazon Cloudfront?
No wonder people have problems....

http://d17ueqc3zm9j8o.cloudfront.net/EveLauncher-995234.exe

Sorry CCP but this is so stupid and embarrassing. You are not able to host this on an own server?
Jack Hayson
The Scope
Gallente Federation
#9 - 2016-01-07 19:50:52 UTC  |  Edited by: Jack Hayson
Took half an hour to get to 99% and now it's stuck there.
Why are you hosting this on a potato?

EDIT: used a VPN and it downloaded the launcher in seconds
Svipull
Republic Logistics II
#10 - 2016-01-07 20:12:29 UTC
CCP Snorlax wrote:
Version 995234 of the launcher has been released with the following changes:

  • Client settings dialog now has an explicit copy button rather than relying only on dragging between columns.
  • The launcher now forces the use of angle rather than desktop opengl for Qt rendering.
  • The launcher now checks for a network connection before attempting to download.
  • Refreshing manually now also reloads the web page.
  • Download test now checks for errors rather than misinterpreting results as ridiculously fast downloads.
  • Fixes to translations.
  • Added Japanese translations.
  • Minor logging changes.


Windows only:

  • The launcher now reconnects to existing processes when restarting.


- - -

Actually - I can't start the client at all.

The following happened :

a) I had to install a new client this morning, because the former one got corrupted - for whatever reason.
b) The download took place at around 05:00 CET
c) Everything went fine. I was online again until about DT.

2h after DT - I tried to restart the client.
Ever since it says : Downloading new version 995234
Actually it is my 4th try - it started 30 minutes ago - now is still at 2 %

I sent a mail to "support@eveonline.com"
Ticket is 102159.
That was 2 hours ago.

Up to now - no nothing.

That's an interesting evening - isn't it. Tranquility has 31656 online - and I'm unable to punish the FW-opponents.

*pokes at the screen* *come on guys*
Faldal Dartan
Sebiestor Tribe
Minmatar Republic
#11 - 2016-01-07 20:19:37 UTC  |  Edited by: Faldal Dartan
Yeah, the problem with the download is a Amazon Cloudfront thing. Many Europeans and especially Germans have DNS problems with that. If you have problems downloading, you need to use a VPN.

It is really emberassing that CCP can not provide their own server for that.
Shalmon Aliatus
Bluestar Enterprises
The Craftsmen
#12 - 2016-01-07 20:52:19 UTC
Hmm, this is how I have to start EVE at the moment:

- Start the launcher
- Launcher loads the new launcher version 995234
- Updater starts
- Launcher starts again loading launcher version 995234
- cancel the update
- Launcher downloads 400mb of data
- I can play EVE (and have to close the launcher, because it will start the updater again)


Windows only:

The launcher now reconnects to existing processes when restarting.

Feels like it reconnects to the download version 995234 process tbh :)
Zaepho
GoonWaffe
Goonswarm Federation
#13 - 2016-01-07 21:02:09 UTC
After this update applied, I now do not get a Launcher window when executing the launcher. I do get a process in my process list consuming about 4.6MB of RAM and 0 CPU but no launcher window at all. I have reinstalled the launcher and get the same results. I have given the launch over 1 hour to load with no luck.
Tho'mas
Arm of Coryphaeus
#14 - 2016-01-07 23:16:32 UTC
I reinstalled the launcher, specifically said I wanted to copy over my interface settings, and then when I log into the game, my entire interface has been reset to default settings. How to I move over my old interface settings?
TumZ
Alpha Republic - Transcenders of Space and Time
Solyaris Chtonium
#15 - 2016-01-08 00:17:08 UTC
I decided to come back to the game after many months of not playing. Only to find a launcher that did not work out of the box.

I had to check run as administrator and all seemed fine until today when a new patch applied. Now the "(blank)" thing won't even display but is listed in the task manager. I reinstalled the launcher and found that it couldn't even find my current installation. So it began installing the entire game. To make matters worse it would only download if the mouse was being moved over the active launcher screen. So now I'm forced to download the cab files at a slow (just under 4MB/sec) throttled speed. In about an hour after it's complete I fully expect the launcher to fail again. Crossing my fingers it doesn't. I really do like the game and it's community but you guys really need to work on support and focus on appropriate of development. I'd like to invite more players to them game but I surely am going to be embarrassed when they have similar issues trying to install and run.

To make matters worse the online support and forums are lacking. Would be nice if you guys took your knowledge base and posted fixes for the community that you guys know that work. There are lots of possible fixes listed from the community but, no offense, many of them are so of base with their fixes they are just general things to try that do not really address the issue at all.

I have worked IT and support for over twenty years and I assure you that you can improve upon your short comings with the right leadership and focus.
TumZ
Alpha Republic - Transcenders of Space and Time
Solyaris Chtonium
#16 - 2016-01-08 01:21:43 UTC
After downloading and running the offline installer yields the following:

The installer has encountered an unexpected error installing this package. This may indicate a problem with this package. The error code is 2709.

Rinse, repeat, same problem.
Iria Ahrens
Space Perverts and Forum Pirates
#17 - 2016-01-08 03:01:54 UTC  |  Edited by: Iria Ahrens
The new launcher needs to be a bit more explicit that a new patch was downloaded. While I did get a pop-up window that the launcher updated, The client update happened so fast that I could have easily missed it being out of the room or just looking away for the one second it took to DL.

Reading patch notes can be pretty important, so there should be something to alert a player that there was a patch to the client. It's not as if a normal player would memorize the patch# and notice that it has changed without a prompt or some kind of visual clue. Something to indicate, "There are unread patch notes." etc.

Thank you.

My choice of pronouns is based on your avatar. Even if I know what is behind the avatar.

Svipull
Republic Logistics II
#18 - 2016-01-08 04:50:07 UTC
Svipull wrote:
CCP Snorlax wrote:
Version 995234 of the launcher has been released with the following changes:

  • Client settings dialog now has an explicit copy button rather than relying only on dragging between columns.
  • The launcher now forces the use of angle rather than desktop opengl for Qt rendering.
  • The launcher now checks for a network connection before attempting to download.
  • Refreshing manually now also reloads the web page.
  • Download test now checks for errors rather than misinterpreting results as ridiculously fast downloads.
  • Fixes to translations.
  • Added Japanese translations.
  • Minor logging changes.


Windows only:

  • The launcher now reconnects to existing processes when restarting.


- - -

Actually - I can't start the client at all.

The following happened :

a) I had to install a new client this morning, because the former one got corrupted - for whatever reason.
b) The download took place at around 05:00 CET
c) Everything went fine. I was online again until about DT.

2h after DT - I tried to restart the client.
Ever since it says : Downloading new version 995234
Actually it is my 4th try - it started 30 minutes ago - now is still at 2 %

I sent a mail to "support@eveonline.com"
Ticket is 102159.
That was 2 hours ago.

Up to now - no nothing.

That's an interesting evening - isn't it. Tranquility has 31656 online - and I'm unable to punish the FW-opponents.

*pokes at the screen* *come on guys*


- - - - -

The updater.exe was written to disk today = 08 jan 2016 at 00:08 CET
Thereof follows : the download process for 995234 took about 6 hours and 20 minutes.
(( There was/is a flatrate 16MBit line available. ))
Now, everything seems to work as intended.
Thx to "Faldal Dartan" for his comment.

This User (me) deserves a refund for 2 accounts being disabled for about 16 h.





Enrique d'Ancourt
The Scope
Gallente Federation
#19 - 2016-01-08 16:44:30 UTC
Zaepho wrote:
After this update applied, I now do not get a Launcher window when executing the launcher. I do get a process in my process list consuming about 4.6MB of RAM and 0 CPU but no launcher window at all. I have reinstalled the launcher and get the same results. I have given the launch over 1 hour to load with no luck.


Similar story here. No visual feedback whatsoever of a download progressing.
This is bad practice, chasing away players that once embraced new tech from CCP
(the hard core that is willing to tryout improvements, so to speak)

Please fix this embarrassing episode.


(revoking the X-mas bonus from the one(s) responsible came across my mind)
Yoruno Konton
Native Freshfood
Minmatar Republic
#20 - 2016-01-09 01:05:59 UTC
No problem with 973659.
995234 keeps on crashing: brings a white window then "evelauncher has stopped working" ends to "close program".

crash.txt
2016-01-09T01:22:57.587Z Crashed, minidump saved at C:\EVE\Launcher\c0fd7085-01ea-4f46-a85c-cec0c1ecc833.dmp
2016-01-09T01:23:04.857Z Crash dump uploaded - RESULT_SUCCEEDED


launcherlog-2016.01.09-01.22.56.714.txt
2016-01-09T01:22:57.167Z    debug    EVE Launcher version 995234
2016-01-09T01:22:57.167Z    debug    Version type: "release"
2016-01-09T01:22:57.167Z    debug    Running on "Windows 7" "6.1.7600"
2016-01-09T01:22:57.167Z    debug    Run clients with logging: false
2016-01-09T01:22:57.167Z    debug    Run clients with DX9: false
2016-01-09T01:22:57.167Z    debug    Download everything: true
2016-01-09T01:22:57.167Z    debug    Language: ""
2016-01-09T01:22:57.167Z    debug    Qt version: 5.5.1
2016-01-09T01:22:57.167Z    debug    Current folder: "C:/EVE/Launcher"
2016-01-09T01:22:57.167Z    debug    Cache folder: "C:/EVE/SharedCache/"
2016-01-09T01:22:57.167Z    debug    Application dir: "C:/EVE/Launcher"
2016-01-09T01:22:57.167Z    debug    Client logs folder: "C:/Users/olivier/AppData/Local/CCP/EVE/ClientLogs"
2016-01-09T01:22:57.167Z    debug    Landing page url: "https://launcher.eveonline.com/release/"
2016-01-09T01:22:57.167Z    debug    Base url for binaries: "https://binaries.eveonline.com/"
2016-01-09T01:22:57.167Z    debug    Base url for resources: "http://res.eveonline.ccpgames.com/"
2016-01-09T01:22:57.167Z    debug    Space available on "C:/" : "245.67GB"
2016-01-09T01:22:57.245Z    debug    Creating web view for QUrl("https://launcher.eveonline.com/release/")
2016-01-09T01:22:57.260Z    debug    Checking running processes
2016-01-09T01:22:57.260Z    debug    Checking version at "https://binaries.eveonline.com/evelauncher_release.json"
2016-01-09T01:22:57.416Z    debug    Scheduled task "Version info downloader"
2016-01-09T01:22:57.416Z    debug    Starting task "Version info downloader"
2016-01-09T01:22:57.416Z    debug    "Version info downloader" go: 0


Did almost everything from reboot, killing all non-system process, to complete EVE wipe (even profiles) and reinstall, 995234 doesn't work.
Workaround is to replace 995234's evelauncher.exe by 973659's version: after canceling launcher update, you can update resfiles and play EVE.
12Next page