These forums have been archived and are now read-only.

The new forums are live and can be found at https://forums.eveonline.com/

EVE New Citizens Q&A

 
  • Topic is locked indefinitely.
 

Game wont recognize dedicated graphics card

First post
Author
Hunter Zazueta
School of Applied Knowledge
Caldari State
#1 - 2015-12-14 19:00:15 UTC
Ive been trying to fix this for awhile now, so any help would be appreciated. I have 2 GPUs in my laptop, one is a Nvidia GT740M (dedicated GPU) and the other is Intel Graphics 4600 (Integrated GPU). Ive tried to get EVE to run on the Nvidia, but no matter what I do (Nvidia control panel, launch using right click>run with...), it still only lists that damn internal garbage in the settings every time. Just ask if you need any more info, thanks for your help.
Xercodo
Cruor Angelicus
#2 - 2015-12-14 20:20:46 UTC
Poke around the launcher settings and try launching it in DX12 mode?

It might be defaulting to DX9, not sure.

There should be something you can do in the nvidia control panel....

The Drake is a Lie

Bumblefck
Kerensky Initiatives
#3 - 2015-12-14 22:22:42 UTC
It displayed that it was using the Intel HD in my settings, but it was actually using the GTX 870. I checked this by manually changing the default processor in the Nvidia control panel, and compared the framerates - it was definitely a LOT choppier than before, so my assumption was that it was just a display bug.

Perfection is a dish best served like wasabi .

Bumble's Space Log

StonerPhReaK
Herb Men
#4 - 2015-12-14 23:20:38 UTC
how to attract players to my lotto channel?

Signatures wer cooler when we couldn't remove them completely.

Hasikan Miallok
Republic University
Minmatar Republic
#5 - 2015-12-14 23:57:16 UTC
The Nvidia software has a list of known games that need to be handled by the dedicated graphics. Possible that has gone wrong.

Try this:

  1. Go to NVIDIA control panel (you should be able to get to this easily by right-clicking on desktop or looking in your system tray).
  2. Click on Manage 3D settings.
  3. Add the EVE game executable (and maybe patcher ?) to the list.
Solecist Project
#6 - 2015-12-15 22:17:59 UTC  |  Edited by: Solecist Project
It's a bug.

To be clear: it uses the gpu.

You can verify tha by activating the taskbar icon at bottom right ...
... in case you don't already have, of course ...
... and hovering your mouse over it.

A click will bring a list of applications, including EVE.

That ringing in your ears you're experiencing right now is the last gasping breathe of a dying inner ear as it got thoroughly PULVERISED by the point roaring over your head at supersonic speeds. - Tippia

Solecist Project
#7 - 2015-12-15 22:24:43 UTC  |  Edited by: Solecist Project
That said ... I do question this.

At max settings you would have a clear difference in fps with vsync off.
You would have mentioned that.

Google would have told you the same, btw.

You're angry and you call intel's garbage ... which is hilarious !

Why?

Because you run the game locked at vsync ...
... most likely 60fps ...
... and there is no difference to intel's noticeable.

Anyway, as this seems to be true, you should not need to worry about it. :)

That ringing in your ears you're experiencing right now is the last gasping breathe of a dying inner ear as it got thoroughly PULVERISED by the point roaring over your head at supersonic speeds. - Tippia

Tau Cabalander
Retirement Retreat
Working Stiffs
#8 - 2015-12-15 23:40:53 UTC  |  Edited by: Tau Cabalander
The Intel GPU is acting as a "dumb" frame-buffer (and display controller) that the Nvidia GPU draws into.

It is a common display bug that the wrong GPU is reported, even though the Nvidia is actually being used.
[DirectX apps will always use the Nvidia by default.]

Don't worry about it.
ISD Supogo
ISD BH
ISD Alliance
#9 - 2015-12-19 21:21:00 UTC
I flat out disabled my integrated GPU via the BIOS after installing my dedicated GPU. I highly suggest you do the same, it will make your life so much easier.

ISD BH Supogo

Bughunter

Equipment Certification and Anomaly Investigations Division (ECAID)

Interstellar Services Department

Hasikan Miallok
Republic University
Minmatar Republic
#10 - 2015-12-20 23:50:48 UTC
ISD Supogo wrote:
I flat out disabled my integrated GPU via the BIOS after installing my dedicated GPU. I highly suggest you do the same, it will make your life so much easier.


Gaming laptops tend to use the integrated card whenever possible to extend battery life and reduce heat and only switch to the dedicated GPU when necessary. This switching can cause serious issues at times. Disabling the integrated card may work but will probably reduce battery life and the laptop may run hotter.