These forums have been archived and are now read-only.

The new forums are live and can be found at https://forums.eveonline.com/

Test Server Feedback

 
  • Topic is locked indefinitely.
12Next page
 

Mac OS X Cider Engine Update Feedback

First post
Author
CCP Sledgehammer
C C P
C C P Alliance
#1 - 2015-04-10 22:41:55 UTC
Greetings, Macsuleers!

We have just deployed the latest version of Cider to Singularity and are eager to get your feedback!

We have, along with our partners, identified that Anti Aliasing on certain hardware was causing severe stability issues and peculiar graphical defects. To mitigate this, we have made the decision to temporarily disable Anti Aliasing on Mac clients until a satisfactory fix has been found.

Issues you can expect to be fixed:

  • Unplugging/turning off USB/Bluetooth devices no longer freezes the client.
  • Text with CR format line endings correctly pastes into the client.
  • Settings menu becomes locked out after taking a screenshot until window is refocused.
  • Apples App nap feature causes client crashes and freezes in certain circumstances.
  • Low quality characters have grey sclera in the Character Creator.


Known old and new issues:

  • Client may freeze when resizing 3D Preview windows****
  • Player characters may sometimes appear as a black silhouettes or have white eyes in Character Customisation and Captain's Quarters.
  • EVE disables screensaver active corners until a OS relog occurs - Known OS X issue in Mavericks and above

  • **** Although not 100% fixed, the incidence has been largely reduced.


Looking forwards to seeing your feedback,

Best regards,

CCP Sledgehammer.

Graphical QA Analyst | EVE Quality Assurance | Team TriLambda

Hoeveer Parmala
Enemy of Man
Already Replaced.
#2 - 2015-04-11 03:35:13 UTC
Well, the fact that I can actually undock my ship without having the game lock-up and ask me if I want a crash report created like is happening with my EVE client on Tranquility since this afternoon is a good sign.

Hopefully the Cider update can be fast-pathed to the current production version.

Agile anyone?
Vincent Athena
Photosynth
#3 - 2015-04-11 14:29:22 UTC
It patched OK, and seemed that basic flying around worked. I tested if the fps had improved, so I turned on asteroid effects and went to a belt. Nope, the FPS still drops to less than 2.
I decided to try it with multi-threaded open GL on. Normally, this is a bad idea as it causes lockups. I figured the client required a restart test with the graphics change, so I did.
It did not restart. The client got stuck downloading bulk data at 90. I quit the client (a normal command-Q did it) and tried again.
The launcher displayed a white window, then Firefox opened. In its address window some words appeared. I don't remember exactly but it was sort of like: "Something en steam token" . I have no idea what that was. I have never used Steam.
I tried a couple more times, with exactly the same results.
Figuring something major had been glitched in my system, I restarted the computer. Then eve worked.
More testing to come.

Know a Frozen fan? Check this out

Frozen fanfiction

Arthur Aihaken
CODE.d
#4 - 2015-04-11 15:46:34 UTC  |  Edited by: Arthur Aihaken
CCP Sledgehammer wrote:
Greetings, Macsuleers!
We have just deployed the latest version of Cider to Singularity and are eager to get your feedback!

I performed a clean client install, launcher and patch update - went flawlessly. EVE ran without a hitch and I didn't notice any significant changes from the current Scylla client (stability issues have generally been all over the place and will be hard to pin down to any specific action). Frame rate (with OpenGL inactive) as consistent with Scylla also (around 60 fps). I was really hoping for a "High" shader setting with this update, but alas - no joy in toyland...

I am currently away, traveling through time and will be returning last week.

Syrinie
Federal Navy Academy
Gallente Federation
#5 - 2015-04-13 00:34:06 UTC  |  Edited by: Syrinie
Syrinie wrote:
Issues multiboxing on the same account.

The situation:

When creating multiple instances of the client on the same machine, only the most recent instance will accept keyboard events (typing). Versions created before will ignore keyboard events.

Mouse events, however, work fine for all concurrent instances.

This bug has been replicated with/without multiple spaces/desktops and with/without multiple launcher instances.

–––––––––––––

System:

Mac OSX 10.10.2 Macbook Pro

–––––––––––––

So, using multiple clients on one computer is pretty cool! Please look at this before you move the build to TQ.



This issue has been acknowledged in this thread:
https://forums.eveonline.com/default.aspx?g=posts&t=418380
Tiberius StarGazer
Deep Core Mining Inc.
Caldari State
#6 - 2015-04-14 13:25:08 UTC
I cant get onto SiSi with my mac client because I'm dumb and can't get the terminal bit to work properly.

Can anyone confirm when running more than one client that they don't all crash when one is closed?
CCP Sledgehammer
C C P
C C P Alliance
#7 - 2015-04-14 13:26:53 UTC
Tiberius StarGazer wrote:
I cant get onto SiSi with my mac client because I'm dumb and can't get the terminal bit to work properly.

Can anyone confirm when running more than one client that they don't all crash when one is closed?


If you use clonemaker that will not be an issue. As for getting on to Sisi, could you paste your terminal command in here and let me know where your Sisi install is located?

Graphical QA Analyst | EVE Quality Assurance | Team TriLambda

Rufelza
Widowmakers
#8 - 2015-04-15 08:24:20 UTC
Just like to say thanks for all the hard work put into this update. It was a real shame the Apple went and did a update not long after your previous pass on the Mac client and Cider.

I am personally so very happy about you fixing the USB bug and will be glad with the return to stability on the Mac client.

I pray to Bob that one day we will have a native Mac client until then keep up the good work!
Lenie Ernaga
Pleasant Peninsula Productions
Cauldron of Ecstasy
#9 - 2015-04-16 21:53:48 UTC
As of today, my launcher is a "white screen" as though a web page isn't rendering properly...

Thoughts??
CCP Sledgehammer
C C P
C C P Alliance
#10 - 2015-04-17 00:11:55 UTC
Lenie Ernaga wrote:
As of today, my launcher is a "white screen" as though a web page isn't rendering properly...

Thoughts??


Hi Lenie,

Are you able to provide what launcher version you are using right now? The version is shown in the title bar of the launcher window.

Is the launcher still functional? Can you log in?

Any more information you can provide will help us out a lot.

Best,

Sledge.

Graphical QA Analyst | EVE Quality Assurance | Team TriLambda

Lenie Ernaga
Pleasant Peninsula Productions
Cauldron of Ecstasy
#11 - 2015-04-17 02:05:57 UTC  |  Edited by: Lenie Ernaga
Launcher v 2.2.876350

Additional notes: the launcher won't "close" I have to "force kill" it.
Vincent Athena
Photosynth
#12 - 2015-04-17 13:34:53 UTC
I had that happen once. Rebooting the computer fixed it

Know a Frozen fan? Check this out

Frozen fanfiction

Vincent Athena
Photosynth
#13 - 2015-04-17 15:57:29 UTC
Tiberius StarGazer wrote:
I cant get onto SiSi with my mac client because I'm dumb and can't get the terminal bit to work properly.

Can anyone confirm when running more than one client that they don't all crash when one is closed?

It worked properly for me. I run the clients in windows, and used the clonemaker.

Know a Frozen fan? Check this out

Frozen fanfiction

Amarisen Gream
Pleasant Peninsula Productions
Cauldron of Ecstasy
#14 - 2015-04-17 16:29:53 UTC
Vincent Athena wrote:
Tiberius StarGazer wrote:
I cant get onto SiSi with my mac client because I'm dumb and can't get the terminal bit to work properly.

Can anyone confirm when running more than one client that they don't all crash when one is closed?

It worked properly for me. I run the clients in windows, and used the clonemaker.



if you just "Duplicate" your EVE Program and rename it, that works too. only takes like 500mb if that do to the shared cache

"The Lord loosed upon them his fierce anger All of his fury and rage. He dispatched against them a band of Avenging Angels" - The Scriptures, Book II, Apocalypse 10:1

#NPCLivesMatter #Freetheboobs

Amarisen Gream
Pleasant Peninsula Productions
Cauldron of Ecstasy
#15 - 2015-04-17 16:57:32 UTC
From my little test in Thera - - - at the ore belt

Max settings - 15-25 FPS
Performance settings - 45-60 FPS.
Performance with all the extras ticked - 45-55 FPS

Beyond that, nothing seems to different from current TQ build.

Model Name: iMac
Model Identifier: iMac13,1
Processor Name: Intel Core i5
Processor Speed: 2.7 GHz
Number of Processors: 1
Total Number of Cores: 4
L2 Cache (per Core): 256 KB
L3 Cache: 6 MB
Memory: 8 GB
Boot ROM Version: IM131.010A.B05
SMC Version (system): 2.9f5

GPU Chipset Model: NVIDIA GeForce GT 640M
Type: GPU
Bus: PCIe
PCIe Lane Width: x16
VRAM (Total): 512 MB
Vendor: NVIDIA (0x10de)
Device ID: 0x0fd8
Revision ID: 0x00a2
ROM Revision: 3707

"The Lord loosed upon them his fierce anger All of his fury and rage. He dispatched against them a band of Avenging Angels" - The Scriptures, Book II, Apocalypse 10:1

#NPCLivesMatter #Freetheboobs

Arthur Aihaken
CODE.d
#16 - 2015-04-19 19:23:10 UTC
iMac Retina 5k (Late 2014)
OS X Yosemite 10.10.3
4 GHz Intel Core i7, AMD Radeon R9 M295X 4GB
16GB RAM, 250GB Flash Drive
.....

1. On first launching SiSi, the launcher appears in "Offline Mode" (Tranquility server: Status unknown).
2. Launching the launcher a second time brings up a completely blank (white) launcher window. The only thing that displays is the header: "EVE Online Launcher v.2.2.871709".
3. The third time is apparently the charm, as the launcher finally loads and begins downloading the EVE Launcher update (it should be noted that the server name, status, character and password fields as well as the "Launch" button are absent). Then the launcher quits (or crashes, couldn't tell).
4. Apparently the third time wasn't the charm, as the fourth launch attempt now alternates between "Downloading" and "Installing", without actually doing anything.
5. Now on launch attempt number five, and it's once again download the EVE Launcher Update - which once again terminates on the download bar reaching the end. This time, however - there appears to be a new folder (EVE Online-2.2.876350.macosx).
6. Launch number six, which finally seems to be working (Singularity server status, number of online pilots, pre-selected username and password field). The client patches were downloaded/applied, and "Client is Ready".

Nope, back to square one (Offline mode). Second launch attempt, I get the login screen - click launch but it quits. Tried a third time with the same results. Looks like either the Mac EVE SiSi client is pooched or it doesn't like OS X Yosemite 10.10.3. Looks like I better put an extended training schedule in since I won't be playing after the 28th.
Cry

I am currently away, traveling through time and will be returning last week.

Dersen Lowery
The Scope
#17 - 2015-04-19 21:35:30 UTC
I'm trying to get onto Singularity, and I'm caught in a bind: if I use Clonemaker, or your shortcut down into the app bundle, then I get a client that can't connect to Singularity because of an incompatible release. So I duplicated a client, cleared the cache, and tried to launch it with "open /Applications/Singularity.app --args "/server:singularity" (and a variant with an IP address) and that would present me a launcher connected to Tranquility.

Finally, I tried to set the command line arguments for the client in the launcher options. This results in a launcher connected to Tranquility firing up a client which fails to connect to Singularity because of an incompatible release.

I share Vincent's suspicion that this has something to do with OS X 10.10(.3), which I'm running.

27" iMac (late 2012)
2.9GHz Intel Core i5
NVIDIA GeForce GTX 660M 512MB
24GB RAM

Proud founder and member of the Belligerent Desirables.

I voted in CSM X!

Arthur Aihaken
CODE.d
#18 - 2015-04-19 22:36:24 UTC  |  Edited by: Arthur Aihaken
Dersen Lowery wrote:
I'm trying to get onto Singularity, and I'm caught in a bind: if I use Clonemaker, or your shortcut down into the app bundle, then I get a client that can't connect to Singularity because of an incompatible release. So I duplicated a client, cleared the cache, and tried to launch it with "open /Applications/Singularity.app --args "/server:singularity" (and a variant with an IP address) and that would present me a launcher connected to Tranquility.

Finally, I tried to set the command line arguments for the client in the launcher options. This results in a launcher connected to Tranquility firing up a client which fails to connect to Singularity because of an incompatible release.

I share Vincent's suspicion that this has something to do with OS X 10.10(.3), which I'm running.

I'm essentially having the same issues, which only started after my update to OS X 10.10.3 today. What are the realistic chances of Cider being updated to support the latest Mac OS X? Because I'm not going back...

I am currently away, traveling through time and will be returning last week.

CCP Sledgehammer
C C P
C C P Alliance
#19 - 2015-04-20 10:10:03 UTC
Hey guys, sorry I haven't been active over the weekend, have been moving!

Can I ask if you updated the master client before running clones or using terminal commands?

Graphical QA Analyst | EVE Quality Assurance | Team TriLambda

CCP Sledgehammer
C C P
C C P Alliance
#20 - 2015-04-20 11:26:54 UTC
Dersen Lowery wrote:
I'm trying to get onto Singularity, and I'm caught in a bind: if I use Clonemaker, or your shortcut down into the app bundle, then I get a client that can't connect to Singularity because of an incompatible release. So I duplicated a client, cleared the cache, and tried to launch it with "open /Applications/Singularity.app --args "/server:singularity" (and a variant with an IP address) and that would present me a launcher connected to Tranquility.

Finally, I tried to set the command line arguments for the client in the launcher options. This results in a launcher connected to Tranquility firing up a client which fails to connect to Singularity because of an incompatible release.

I share Vincent's suspicion that this has something to do with OS X 10.10(.3), which I'm running.

27" iMac (late 2012)
2.9GHz Intel Core i5
NVIDIA GeForce GTX 660M 512MB
24GB RAM


Hey Dersen,

Remove the quotation marks around /server:singularity and it should work fine. Just tested with your command line and it opens TQ for me, but removing the quotation marks gets Sisi's launcher up correctly.

Best,

Sledgehammer.

Graphical QA Analyst | EVE Quality Assurance | Team TriLambda

12Next page