These forums have been archived and are now read-only.

The new forums are live and can be found at https://forums.eveonline.com/

Test Server Feedback

 
  • Topic is locked indefinitely.
 

test launcher?

Author
Sosana
Planet Industires co.
#1 - 2015-02-26 17:43:13 UTC
it seems that I'm now running a "pre-release" version of the launcher, so, won't let me on
Zamory
Alpha Centauri Corp
#2 - 2015-02-26 17:50:21 UTC
Sosana wrote:
it seems that I'm now running a "pre-release" version of the launcher, so, won't let me on


Exactly the same for me, just posted a topic about it in slight detail, seems as if the "RES CACHE" isn't being installed/downloaded o.O No idea what that even means though, but it's definitely important! :/
Sosana
Planet Industires co.
#3 - 2015-02-26 17:58:16 UTC
my launcher version is ........ 2.2.865769, still not working
Zamory
Alpha Centauri Corp
#4 - 2015-02-26 18:04:13 UTC
Sosana wrote:
my launcher version is ........ 2.2.865769, still not working


It works now btw, atleast for me, but seems a bit glitchy.. hm
Mr Mac
Dark Goliath
#5 - 2015-02-26 18:05:29 UTC
mine worked in two ways cache/download.
but i can't move items in cargo and hangar. seems big bug
Sosana
Planet Industires co.
#6 - 2015-02-26 18:06:28 UTC
nope, mine still not working
Emilia Istis
Dom Spokojnej Starosci - CBC Retirement Island
MOSTLY AFK
#7 - 2015-02-26 21:40:29 UTC  |  Edited by: Emilia Istis
same here pre-release version

i copy my sisi folder from current TQ bild and run repair tool
still not work

launcher say "DOWNLOADING UPDATES TO RES CACHE" 100% and stuck
Ghaustyl Kathix
Rising Thunder
#8 - 2015-02-27 00:31:15 UTC  |  Edited by: Ghaustyl Kathix
Emilia Istis wrote:
launcher say "DOWNLOADING UPDATES TO RES CACHE" 100% and stuck
Same thing's happening to me, too. Everything works fine, but the launcher freezes completely as soon as it hits 100% while downloading resource cache.

Edit: Now it starts and gets stuck at 0% of downloading updates to resource cache.
Faridah
Horde Armada
Pandemic Horde
#9 - 2015-02-27 05:59:12 UTC  |  Edited by: Faridah
CCP requested feedback on new launcher here: https://forums.eveonline.com/default.aspx?g=posts&t=408821&find=unread

When 'updating res cache files' gets stuck, try deleting the res_temp folder in C:\ProgramData\CCP\EVE\SharedCache and restart launcher. Worked for me.

Others say running as Administrator solved it.

So there is some sort of issue when updating res cache files, that's for sure.

More edit..

Running as Administrator might be the clue here, c:\appdata on a standard install seems to have some spesial rights applied to a 'normal' user.

Up until now CCP has been using appdata in users profile directory (C:\Users\xxx\appdata) to store patches and settings, having it stored in the common c:\appdata is another set of rules.
Loraine Gess
Confedeferate Union of Tax Legalists
#10 - 2015-02-27 10:08:14 UTC
You need to run the repair tool in sisi mode and then re-launch the sisi launcher.
Mr Mac
Dark Goliath
#11 - 2015-02-27 12:00:11 UTC
afair CCP said they didn't update repair tool for lastest version
Tuttomenui II
Aliastra
Gallente Federation
#12 - 2015-02-27 18:05:28 UTC  |  Edited by: Tuttomenui II
I was having the issue of it crashing after the pre-release text if I select ok and loading but not updating or asking me If I wanted to prime my cache if I selected cancel.

The First thing I tried was to delete the named launcher folder in the /launcher/appdata and replacing just that from my TQ folder.
It did't work, so I deleted the entire launcher folder and replaced that from my TQ folder. Another miss.

I then replaced my entire test eve files with the TQ ones and after it had its launcher updated the problem persisted. So I went looking at my system appdata folder through my profile folder on desktop (win 7). I went into /Local/CCP/EVE and I found some folders in there called:

(I am guessing here cause they didn't get replaced So just putting what I remember was in the names, My test install is on my D: drive in a folder called Eve Test,)
d_Eve Test _ccp_eve
d_Eve Test _ccp_eve_tranquility
d_Eve Test _ccp_eve_Singularity

and some others called (and these still exist so these are exact and not from memory. These are for my TQ install on my F: drive.)

f_program files (x86)_ccp_eve
f_program files (x86)_ccp_eve_tranquility

So finding these I deleted the d_ ones and then replaced all the files in my Eve test folder again from the TQ folder. And now I still get the pre-release message but no crashing, and I finally got the 'Do you want to prime cache' message I said selected 'No' and doubled checked it had a custom location for the shared cache, selected to download entire cache and also let it do its update.

Now it is hung up at 100%. So I killed it and restarted the launcher and selecting ok at the pre-release prompt I am now back to getting the crash.

Now I need to reread the posts about the hanging on download and go from there.

EDIT:
Tried deleting the res_temp folder and I am back to getting this http://eve-files.com/dl/272657
Gerart en Daire
HY-AE
#13 - 2015-03-01 01:12:09 UTC
I posted my initial troubles on getting the current launcher to work (so I could test DoD, opportunities, the new NPE static sites etc) in the dev blog thread on the DoD client, posts 147 and 148.

I'm basically getting http://eve-files.com/dl/272657 too, (this is my first time trying to get into Singularity), except the launcher doesn't crash on its own, and it doesn't ask either about cache priming or about updating to a pre-release version. It just automatically (and pretty quickly) updates the launcher to 2.2.865769 once I start the launcher after copying the files from the Tranquility folder (and starting from a /server:Singularity shortcut). What does always crash it is clicking on the settings button (the cog) so I could change the SharedCache location.

Tried repair.exe --server=sisi earlier, no change.

Deleted the d_ folders (which were all for the test server folders I have, my base EVE install didn't seem to have one, so I gues they're DoD-related?) in AppData\Local\CCP\EVE\ . No change to Singularity launcher behaviour from this yet. After checking that, also did a fresh copy of all non- .stuff files from the Tranquility folder like Tuttomenul II did, but that didn't change anything either.

Attempting to startup with exefile.exe /server:Singularity got me to the in-game login screen, which refused to connect due to "Incompatible (Release)". Then I noticed that I now had a ProgramData\CCP\EVE\SharedCache\ResFiles folder, which it hadn't created before (just had an empty ProgramData\CCP\EVE\SharedCache earlier, no matter what I did). No res_temp though, just 256hexadecimal-numbered folders. Launcher still the same. Tried a sisi repair, it did seem to patch the folder to sisi stuff, but launcher was still the same.

Running as administrator didn't help. Tried exefile.exe /server:Singularity again, it didn't give the same error message anymore after the repair! Success! The game did take a long while to load up and move on from the in-game login screen though, and was unresponsive while doing so.

Got into the character selection screen, got into the game. I watched the intro video because my wife hadn't seen it yet, but after that was over, loading up the station view including my ship was practically instant. Undocking felt pretty much the same as on the regular client, the only thing I noticed was that the planet the station was orbiting around did take a while to pop up its graphics. It's getting really late, so I left further testing for later. One problem which I am facing is that it seems to be downloading the shared cache to the default C:\ProgramData\CCP\EVE\SharedCache\ResFiles\ now (got to about 1 GB while I did a bit of quick testing), and I don't actually have enough space on C: to fit the whole shared cache. I'll have to see if there's a way to change that without using the launcher's settings window.
Annexe
I N E X T R E M I S
Tactical Narcotics Team
#14 - 2015-03-01 14:09:51 UTC
I tried out the new DoD for SISI client. Set a custom location as defined in the post

http://community.eveonline.com/news/news-channels/eve-online-news/testing-eve-online-download-on-demand-your-first-steps/

SISI client went about extracting the resource cache to this location.

However on starting TQ client, I get the same msg about running a pre-alpha version of the launcher, and a 7.44GB download starts.


I thought the DoD was only meant to affect the SISI launcher, and now i have to re-download eve all over again?


Did i miss something?

Annexe

ITAI - VIP

"i will pop your wreck with faction loot"

Annexe
I N E X T R E M I S
Tactical Narcotics Team
#15 - 2015-03-01 14:11:35 UTC
so while the eve repair tool was downloading the 7.44GB patch, i reopened the TQ launcher and it had a 75MB patch.. this quickly loaded and the game opened. So I canceled the repair tool download..

Now all my game settings are reset. UI, everything.


So far, I'd say this DoD is a fail.

Annexe

ITAI - VIP

"i will pop your wreck with faction loot"

Annexe
I N E X T R E M I S
Tactical Narcotics Team
#16 - 2015-03-01 14:12:38 UTC
And now, i closed eve to copy my saved UI files back into the user local folder.. restarted client... 7.4GB patch..

Please someone help me restore the client. This is bullsh*t.

Annexe

ITAI - VIP

"i will pop your wreck with faction loot"

Tuttomenui II
Aliastra
Gallente Federation
#17 - 2015-03-03 20:55:57 UTC  |  Edited by: Tuttomenui II
I can't seem to get it to give the message about the dod 'Prime cache' anymore. I got it to do it once. But there seems to be a location where some stuff is getting saved that I don't know about. After I wipe out the test files and replace them and remove the d_ folder in my appdata, the client seems to remember my location preference for the shared cache folder. This leads me to the conclusion that there is somewhere this preference is being saved and this location might have other stuff that is screwed up.

The 'Launcher.exe has stopped working' crash persists.

"Problem signature:
Problem Event Name: APPCRASH
Application Name: launcher.exe_unknown
Application Version: 0.0.0.0
Application Timestamp: 49180193
Fault Module Name: MSVCP90.dll
Fault Module Version: 9.0.30729.6161
Fault Module Timestamp: 4dace5bd
Exception Code: c0000005
Exception Offset: 0000d930
OS Version: 6.1.7601.2.1.0.256.1
Locale ID: 1033
Additional Information 1: 0a9e
Additional Information 2: 0a9e372d3b4ad19135b953a78882e789
Additional Information 3: 0a9e
Additional Information 4: 0a9e372d3b4ad19135b953a78882e789" In case someone knows how to decipher that garbage.

I am using Win7 ultimate 64 bit.


Edit:

Ok so I tried something else. I went into the launcher settings and cleared the cache with the option there. And after it restarted I chose ok at the pre-release dialogue and it didn't crash this time. It also started downloading stuff.

Edit more:

It is now stuck at 100% 'Downloading Updates To Res Cache' Will attempt the work around.

Edit more more:

Workaround of delete the res_temp folder in the shared cache failed it went full yellow bar and showed 0% on 'Downloading Updates to Res Cache' So I tried deleting everything in the shared cache folder and this time it started downloading properly. Although it may fail again because I forgot to 'run as admin' on this last launch. Yep failed again stuck at 100%. Will reattempt with 'run admin' this time.

Edit Again:

Another fail, stuck at 100% again. But it looks like the crash by selecting ok for the pre-release dialogue has at least disappeared by clearing the cache through the launcher settings.

http://eve-files.com/dl/272724

Edit Final:

Ok so while I was making the screen shot of the launcher settings and uploading it and linking it above I had left the launcher running. Then I went and pressed the clear cache button again which kind of locked it up but I noticed the download had changed from the 100% of the res cache that's 531mb or so to a new one and it was 2% of res cache that is 12 gigs. Nutty stuff. So it might not have been stuck just kind of thinking. So I restarted the launcher again it checked for the res updates then went back to downloading the 12 gigs. So I will let that run now and see what happens. I think the 12 gigs has something to do with my selecting the option 'Download all the resource files'.

Edit Conclusion:

I went to do other stuff while it downloaded and hours later......

AttentionAttention SUCCESS AttentionAttention

Revised work around for Win7 (possibly Vista and 8):

Manually delete the cache files that correspond to your test install located here: C:\Users\yourWindowsUsername\AppData\Local\CCP\EVE\c_eve-sisi_singularity\ <- Win 7/8

Manual deletion won't fix the crashing but it is best to get rid of it in my opinion, and then use the clear cache in the launcher settings.

(If my assumptions hold and your able to select 'cancel' at this dialogue http://eve-files.com/dl/272658 ) Go into the launcher settings and under the 'Advanced' tab press the 'Clear' button for 'Clear all cached data' http://eve-files.com/dl/272724.

You will get a message asking if you would like to restart the launcher for the action to take effect you can do so now, or if you wish to change the location of the shared cache folder and select to download all resources you can make those selections and then close and relaunch the launcher.

After the launcher re-opens select 'OK' at this dialogue: http://eve-files.com/dl/272658
And if it doesn't crash then that will no longer be an issue. Now just let it download the res update stuff, if it hangs at 100% just let it keep running and eventually it should do something. In my case I have a custom location set for the shared cache folder and I also chose to download all resources. So after it downloaded the res update it then downloaded a larger 12 gb res update. And now my SISI launcher says it is ready.
Tuttomenui II
Aliastra
Gallente Federation
#18 - 2015-03-04 07:12:44 UTC
Annexe wrote:
And now, i closed eve to copy my saved UI files back into the user local folder.. restarted client... 7.4GB patch..

Please someone help me restore the client. This is bullsh*t.


Not sure how to help you sorry. But from what you describe your settings should still be intact somewhere.

To be safe you should put the test copy on another hhd if available. and be sure the shortcuts you use point to the right install. I know when copying my TQ stuff I have to be careful not to copy a shortcut I made in that folder to copy to my desktop (I should probably just delete it.) moving the .exe will make the .exe point to stuff in its new location but copying a shortcut of the .exe the new short cut will point to the old location. Something to look out for.
Torgeir Hekard
I MYSELF AND ME
#19 - 2015-03-04 18:50:33 UTC
The new launcher build fixed the linux issues for me.