These forums have been archived and are now read-only.

The new forums are live and can be found at https://forums.eveonline.com/

EVE Technology Lab

 
  • Topic is locked indefinitely.
 

EveHQ 2.16.0 | Proteus release

Author
Slivo
Beehive Surveillance
X877.
#41 - 2015-02-10 01:02:54 UTC
Morgan Agrivar wrote:
Slivo wrote:
Thanks for your report, it look like there's an error with your evehq data or the way it's handled.

I added this problem to the bugs I need to fix.


Thank you. I miss EveHQ very much and PYFA/EFT isn't cutting it for me. I look forward to the fixes.


If you got not much fittings or data you want to keep from EveHQ, you may try to delete the appdata evehq folder.
this will start evehq from fresh like if you just installed it. This should solve your issue without waiting for a fix
McChicken Combo HalfMayo
The Happy Meal
#42 - 2015-02-10 02:46:58 UTC
Thank you for taking over the project. I have a quick question/request.

I've noticed the taskbar at the top (core, plugins, reports) now auto-hides. Is there an option to keep it expanded? If not, it would be nice to have such an option, as there's a lot of extra mouse clicks to keep expanding it when using things like the fitter where the taskbar is used a lot.

Thank you for your time o7

There are all our dominion

Gate camps: "Its like the lowsec watercooler, just with explosions and boose" - Ralph King-Griffin

Slivo
Beehive Surveillance
X877.
#43 - 2015-02-10 14:43:50 UTC
McChicken Combo HalfMayo wrote:
Thank you for taking over the project. I have a quick question/request.

I've noticed the taskbar at the top (core, plugins, reports) now auto-hides. Is there an option to keep it expanded? If not, it would be nice to have such an option, as there's a lot of extra mouse clicks to keep expanding it when using things like the fitter where the taskbar is used a lot.

Thank you for your time o7


You are welcome.
There is a little arrow next to the main button, at the top left. You can uncheck "minimize the ribbon"
It should solve your issue !
Gavin Tremlor
30plus
#44 - 2015-02-10 16:51:01 UTC

How/where can I donate to keep this project going? EVEHQ is an amazing program once you learn it. I do not want to have to ever go back to using any of the other lesser functionality 3rd party tools (Evemon, EFT, Pifa, etc).

Thanks for picking this up.
McChicken Combo HalfMayo
The Happy Meal
#45 - 2015-02-10 18:40:59 UTC
Slivo wrote:
McChicken Combo HalfMayo wrote:
Thank you for taking over the project. I have a quick question/request.

I've noticed the taskbar at the top (core, plugins, reports) now auto-hides. Is there an option to keep it expanded? If not, it would be nice to have such an option, as there's a lot of extra mouse clicks to keep expanding it when using things like the fitter where the taskbar is used a lot.

Thank you for your time o7


You are welcome.
There is a little arrow next to the main button, at the top left. You can uncheck "minimize the ribbon"
It should solve your issue !

Thank you! Smile

There are all our dominion

Gate camps: "Its like the lowsec watercooler, just with explosions and boose" - Ralph King-Griffin

Nycha
Pator Tech School
Minmatar Republic
#46 - 2015-02-11 04:19:24 UTC
I managed to crash evehq. Closed a fitting and opened the hqf implantmanager, maybe too fast.

*****START Exception Details*****
Message: Object reference not set to an instance of an object.
Source: EveHQ.HQF
StackTrace: at EveHQ.HQF.Forms.FrmHQF.OpenPilotManagerForm(Int32 tabIdx) in C:\Workspace\EveHQ\EveHQ.HQF\Forms\frmHQF.vb:line 2287
at EveHQ.HQF.Forms.FrmHQF.btnImplantManager_Click(Object sender, EventArgs e) in C:\Workspace\EveHQ\EveHQ.HQF\Forms\frmHQF.vb:line 2280
at DevComponents.DotNetBar.BaseItem.RaiseClick(eEventSource source)
at DevComponents.DotNetBar.BaseItem.InternalMouseUp(MouseEventArgs objArg)
at DevComponents.DotNetBar.PopupItem.InternalMouseUp(MouseEventArgs objArg)
at DevComponents.DotNetBar.ButtonItem.InternalMouseUp(MouseEventArgs objArg)
at DevComponents.DotNetBar.BaseItem.InternalMouseUp(MouseEventArgs objArg)
at DevComponents.DotNetBar.ItemContainer.InternalMouseUp(MouseEventArgs objArg)
at DevComponents.DotNetBar.ItemControl.OnMouseUp(MouseEventArgs e)
at DevComponents.DotNetBar.RibbonBar.OnMouseUp(MouseEventArgs e)
at System.Windows.Forms.Control.WmMouseUp(Message& m, MouseButtons button, Int32 clicks)
at System.Windows.Forms.Control.WndProc(Message& m)
at System.Windows.Forms.ScrollableControl.WndProc(Message& m)
at System.Windows.Forms.ContainerControl.WndProc(Message& m)
at DevComponents.DotNetBar.ItemControl.WndProc(Message& m)
at System.Windows.Forms.Control.ControlNativeWindow.OnMessage(Message& m)
at System.Windows.Forms.Control.ControlNativeWindow.WndProc(Message& m)
at System.Windows.Forms.NativeWindow.Callback(IntPtr hWnd, Int32 msg, IntPtr wparam, IntPtr lparam)
*****END Exception Details*****


========== Plug-ins ==========

EveHQ.HQF.dll (1.0.0.0)
EveHQ.KillMailViewer.dll (1.0.0.0)
EveHQ.Prism.dll (1.0.0.0)
EveHQ.Void.dll (1.0.0.0)


========= System Info =========

Operating System: Microsoft Windows NT 6.2.9200.0
.Net Framework Version: 4.0.30319.34014
EveHQ Location: I:\eve etc\evehq
EveHQ Cache Locations: C:\Users\Siosena\AppData\Roaming\EveHQ
Morgan Agrivar
Doomheim
#47 - 2015-02-11 08:33:37 UTC
Slivo wrote:
Morgan Agrivar wrote:
Slivo wrote:
Thanks for your report, it look like there's an error with your evehq data or the way it's handled.

I added this problem to the bugs I need to fix.


Thank you. I miss EveHQ very much and PYFA/EFT isn't cutting it for me. I look forward to the fixes.


If you got not much fittings or data you want to keep from EveHQ, you may try to delete the appdata evehq folder.
this will start evehq from fresh like if you just installed it. This should solve your issue without waiting for a fix


How would I go about doing this?
Slivo
Beehive Surveillance
X877.
#48 - 2015-02-11 11:13:57 UTC  |  Edited by: Slivo
Morgan Agrivar wrote:
How would I go about doing this?


type %appdata% in the adress bar of your file explorer or in the execute (windows + R) window and delete the EveHQ folder.

WARNING : YOU WILL LOOSE ALL EVEHQ DATA, FITTINGS INCLUDED


@Nycha : I got your report, and will try to find out what can be wrong. Thanks for reporting. Do EveHQ still work fine for you ?


On another topic, I need some people who would like to test the beta release of EveHQ before making it available, Please contact me if you are interested giving some help.
Nycha
Pator Tech School
Minmatar Republic
#49 - 2015-02-11 17:40:05 UTC
Evehq works fine for me with one problem but Im pretty sure its next to impossible to fix.
If I run evehq for a very long time (hours) and changing a lot of fittings it suddenly happens that the undo (1 step back in fitting option) stops working and instead of replacing the module it only deletes the module, but never replaces the module.
Example: My original fitting is an 10mn afterburner -> delete -> replace with 10mn microwarp.
Undo: 10mn microwarp -> delete -> nothing, empty line. Repeatable pressing undo will only producing more empty module slots.
I have to restart evehq and than it works again.

This seems to be completely random and happens very seldom (once a day I would say). Maybe a memory fault. I cant reproduce it and I know I offer no helpful info.

Beside that evehq works wonderful for me.
Slivo
Beehive Surveillance
X877.
#50 - 2015-02-11 22:19:19 UTC
Fine, your bug will be a bit tricky to identify.
If your last problem don't block you that's fine for now :)
Che Biko
Alexylva Paradox
#51 - 2015-02-12 18:39:16 UTC  |  Edited by: Che Biko
This happens whenever I try to select a w-hole type on the dashboard W-hole data widget:

*EveHQ Error Report*

EveHQ Version: 2.16.2.0
Date: 12/02/2015 19:36:38
Error: Conversion from string "" to type 'Integer' is not valid.

\\{panel:title=StackTrace|borderStyle=dashed|bordercolor=#ccc|titleBGColor=#eee|bgColor=#eee}*****START Exception Details*****
Message: Conversion from string "" to type 'Integer' is not valid.
Source: Microsoft.VisualBasic
StackTrace: at Microsoft.VisualBasic.CompilerServices.Conversions.ToInteger(String Value)
at EveHQ.Controls.DBControls.DBCWHole.cboWHType_SelectedIndexChanged(Object sender, EventArgs e) in C:\Workspace\EveHQ\EveHQ\Controls\DBControls\DBCWHole.vb:line 159
at System.Windows.Forms.ComboBox.OnSelectedIndexChanged(EventArgs e)
at DevComponents.DotNetBar.Controls.ComboBoxEx.OnSelectedIndexChanged(EventArgs e)
at System.Windows.Forms.ComboBox.WmReflectCommand(Message& m)
at System.Windows.Forms.ComboBox.WndProc(Message& m)
at DevComponents.DotNetBar.Controls.ComboBoxEx.WndProc(Message& m)
at System.Windows.Forms.Control.ControlNativeWindow.OnMessage(Message& m)
at System.Windows.Forms.Control.ControlNativeWindow.WndProc(Message& m)
at System.Windows.Forms.NativeWindow.Callback(IntPtr hWnd, Int32 msg, IntPtr wparam, IntPtr lparam)
*****Inner Exception*****
*****START Exception Details*****
Message: Input string was not in a correct format.
Source: Microsoft.VisualBasic
StackTrace: at Microsoft.VisualBasic.CompilerServices.Conversions.ParseDouble(String Value, NumberFormatInfo NumberFormat)
at Microsoft.VisualBasic.CompilerServices.Conversions.ToInteger(String Value)
*****END Exception Details*****
*****END Exception Details*****


========== Plug-ins ==========

EveHQ.HQF.dll (1.0.0.0)
EveHQ.KillMailViewer.dll (1.0.0.0)
EveHQ.Prism.dll (1.0.0.0)
EveHQ.Void.dll (1.0.0.0)


========= System Info =========

Operating System: Microsoft Windows NT 6.0.6002 Service Pack 2
.Net Framework Version: 4.0.30319.34209
EveHQ Location: E:\Programs\EveHQ
EveHQ Cache Locations: C:\Users\FicaReedal\AppData\Roaming\EveHQ
\\{panel}
Luccul
Sebiestor Tribe
Minmatar Republic
#52 - 2015-02-14 05:40:19 UTC
Is there a problem with the web site? When I go there (http://evehq.co/) I get a page containing only this:

It works!

This is the default web page for this server.

The web server software is running but no content has been added, yet.
MKTheReaver
Questionable Ethics.
Ministry of Inappropriate Footwork
#53 - 2015-02-14 12:30:29 UTC
Hello, i'm glad to see the EveHQ project is getting picked up again.

I recently started to play EVE more actively again and wasn't happy to learn that EveHQ wasn't getting developed any more. So im very glad to see people picking it up, thanks.

Right now im getting the same error as someone else already posted here, i'll post it below.
This is after doing an upgrade from 2.13 -> 2.15 -> 2.16. After that i removed everything including the %AppData% folder, and did a clean re-install of 2.16 latest version. I am still getting the same error.

Also i tried to install it on 2 Clean Win8.1 VMs, really clean like only windows + updates, and also on those 2 VMs im getting the exact same error.

If you need more info, post back here or PM me so hopefully i can provide more details needed to solve the problem.

Regards, MK

*EveHQ Error Report*

EveHQ Version: 2.16.2.0
Date: 14/02/2015 13:17:34
Error: Index was out of range. Must be non-negative and less than the size of the collection.
Parameter name: index

\\{panel:title=StackTrace|borderStyle=dashed|bordercolor=#ccc|titleBGColor=#eee|bgColor=#eee}*****START Exception Details*****
Message: Index was out of range. Must be non-negative and less than the size of the collection.
Parameter name: index
Source: mscorlib
StackTrace: at System.Collections.CollectionBase.System.Collections.IList.get_Item(Int32 index)
at DevComponents.DotNetBar.SubItemsCollection.get_Item(String name)
at EveHQ.Forms.FrmEveHQ.frmEveHQ_Load(Object sender, EventArgs e) in C:\Workspace\EveHQ\EveHQ\Forms\frmEveHQ.vb:line 374
at System.EventHandler.Invoke(Object sender, EventArgs e)
at System.Windows.Forms.Form.OnLoad(EventArgs e)
at DevComponents.DotNetBar.RibbonForm.OnLoad(EventArgs e)
at System.Windows.Forms.Form.OnCreateControl()
at System.Windows.Forms.Control.CreateControl(Boolean fIgnoreVisible)
at System.Windows.Forms.Control.CreateControl()
at System.Windows.Forms.Control.WmShowWindow(Message& m)
at System.Windows.Forms.Control.WndProc(Message& m)
at System.Windows.Forms.ScrollableControl.WndProc(Message& m)
at System.Windows.Forms.ContainerControl.WndProc(Message& m)
at System.Windows.Forms.Form.WmShowWindow(Message& m)
at System.Windows.Forms.Form.WndProc(Message& m)
at DevComponents.DotNetBar.RibbonForm.WndProc(Message& m)
at System.Windows.Forms.Control.ControlNativeWindow.OnMessage(Message& m)
at System.Windows.Forms.Control.ControlNativeWindow.WndProc(Message& m)
at System.Windows.Forms.NativeWindow.Callback(IntPtr hWnd, Int32 msg, IntPtr wparam, IntPtr lparam)
*****END Exception Details*****


========== Plug-ins ==========

EveHQ.HQF.dll (1.0.0.0)
EveHQ.KillMailViewer.dll (1.0.0.0)
EveHQ.Prism.dll (1.0.0.0)
EveHQ.Void.dll (1.0.0.0)


========= System Info =========

Operating System: Microsoft Windows NT 6.2.9200.0
.Net Framework Version: 4.0.30319.34209
EveHQ Location: D:\Varia\EveHQ
EveHQ Cache Locations: C:\Users\UserName\AppData\Roaming\EveHQ
\\{panel}
Slivo
Beehive Surveillance
X877.
#54 - 2015-02-14 13:44:52 UTC
Luccul wrote:
Is there a problem with the web site? When I go there (http://evehq.co/) I get a page containing only this:

It works!

This is the default web page for this server.

The web server software is running but no content has been added, yet.


We just migrated the server to a new linux OS. Everything is now working fine.


@ Che Biko & MKTheReaver

It look like an issue with the windows 8 theme. Jena foud a workaround on our forum at : http://evehq.co/forum/viewtopic.php?f=5&t=108
Can you please try it ?
MKTheReaver
Questionable Ethics.
Ministry of Inappropriate Footwork
#55 - 2015-02-14 14:45:50 UTC
Slivo wrote:
Luccul wrote:
Is there a problem with the web site? When I go there (http://evehq.co/) I get a page containing only this:

It works!

This is the default web page for this server.

The web server software is running but no content has been added, yet.


We just migrated the server to a new linux OS. Everything is now working fine.


@ Che Biko & MKTheReaver

It look like an issue with the windows 8 theme. Jena foud a workaround on our forum at : http://evehq.co/forum/viewtopic.php?f=5&t=108
Can you please try it ?


Thank you, that solved the problem indeed.
Just to put the answer also on here directly:

The problem happens when you switched to the "Metro" theme. When you switch to it, it works, but as soon as you close the program and start it again the problems presents itself.

Solution:
Open with some txt editor: %AppData%\EveHQ\EveHQSettings.json
Find the line: "ThemeStyle": 9,
And change the value to 7 for example for the Windows 7 Blue theme.


Once again, thanks for picking the project up and the quick response.
Che Biko
Alexylva Paradox
#56 - 2015-02-14 15:36:50 UTC
Hmm, acording to the json file, I was using theme 2, but I changed it to 0 to see if it would work anyway, but it did not. For me, this issue only started to appear in the last weeks.
MKTheReaver
Questionable Ethics.
Ministry of Inappropriate Footwork
#57 - 2015-02-14 16:24:27 UTC
Che Biko wrote:
Hmm, acording to the json file, I was using theme 2, but I changed it to 0 to see if it would work anyway, but it did not. For me, this issue only started to appear in the last weeks.


You sure it is the exact same error then?
You could try changing the "ThemeSetByUser" option to false but I think that's not going to solve it.
Slivo
Beehive Surveillance
X877.
#58 - 2015-02-15 01:46:32 UTC
Che Biko wrote:
Hmm, acording to the json file, I was using theme 2, but I changed it to 0 to see if it would work anyway, but it did not. For me, this issue only started to appear in the last weeks.


Your problem is indeed different than MKTheReaver.
I don't know this bug yet. I can only reproduce it with QA A and QA B choices.
I'm adding this to the buglist
Hayden Oakenshield
Dickhead Corner
Eternal Requiem
#59 - 2015-02-16 14:14:28 UTC
Bless you people for keeping EVEHQ going.
Leonardo Bonacci
Resurrection Complex
RAZOR Alliance
#60 - 2015-02-17 17:57:44 UTC
there is a bug in EveHQ Prism, apparently all values under columns Value/Price are set to 0(zero), thus total asset value comes out wrong.....look at the picture below to see what am i talking about:
http://i.imgur.com/UUfCBeY.png

keep up the good work