These forums have been archived and are now read-only.

The new forums are live and can be found at https://forums.eveonline.com/

Macintosh

 
  • Topic is locked indefinitely.
 

SiSi - Launcher updated itself and now fails to start

First post
Author
Yinmatook
Skilled Refugees
#1 - 2014-12-11 12:59:51 UTC
System: iMac 27-inch, Late 2009
Processor: 2.8 GHz Intel Core i7
Memory: 16GB 1067 MHz DDR3
Graphics: ATI Radeon HD 4850 512 MB
Software: OS X 10.9.5 (13F34)

open /Applications/EVE Online Singularity.app --args /server:87.237.38.50

worked once - downloaded a launcher update and applied it. Launcher failed to restart (as normal)

subsequent attempts to open the app (as above) now fail with:

LSOpenURLsWithRole() failed with error -10810 for the file /Applications/EVE Online Singularity.app.

Yinmatook
Skilled Refugees
#2 - 2014-12-11 13:19:49 UTC
I have now repeated the failure by moving the SISI app to the trash and copying over the TQ app, then starting it to point at SISI. It did the same thing. downloaded and applied about three launcher updates then closed and fails to start with the same error message as above.
Aeries Kalma
The Scope
Gallente Federation
#3 - 2014-12-11 17:03:34 UTC
Same problem on my MacBook Pro.

15-inch, Mid 2010
Processor 2.66 GHz Intel Core i7
Memory 8 GB 1067 MHz DDR3
Graphics NVIDIA GeForce GT 330M 512 MB
Software OS X 10.9.5 (13F34)
Maya DeReneau
Amazing Super Slackers
Eternal Requiem
#4 - 2014-12-11 21:08:34 UTC
Same problem on my iMac. The launcher for SISI updated and now crashes on startup.
CCP Habakuk
C C P
C C P Alliance
#5 - 2014-12-12 17:59:10 UTC
Hi,

Sorry for the late reply. Unfortunately I cannot provide you with good news so far and I am experiencing the same problems. I asked the relevant developers to post here as soon as they fixed the issue and/or found a workaround.

CCP Habakuk | EVE Quality Assurance | Team Five 0 | (Team Gridlock)

Bug reporting | Mass Testing

CCP Atropos
C C P
C C P Alliance
#6 - 2014-12-12 18:38:18 UTC
I put a fixed build out yesterday, so recopying from TQ should work.
Maya DeReneau
Amazing Super Slackers
Eternal Requiem
#7 - 2014-12-13 02:16:36 UTC
I downloaded the full client to start clean. When it connected to Singularity it downloaded and installed what seemed like 3 or 4 launcher updates and quit. When I try to start it again I get a crash report. Same as before.
Maya DeReneau
Amazing Super Slackers
Eternal Requiem
#8 - 2014-12-13 20:07:06 UTC
Ok. I deleted the client and the folder in Application Support and copied a new clean client again. There were only two updates as the launcher disabled itself. This is the first part of the crash report:

Process: launcher [8520]
Path: /Users/USER/*/EVE Online Sing.app/Contents/MacOS/launcher
Identifier: com.ccpgames.eveonline
Version: 2.2.852273 (852273)
Code Type: X86 (Native)
Parent Process: launchd [173]
User ID: 502

Date/Time: 2014-12-13 14:55:57.755 -0500
OS Version: Mac OS X 10.8.5 (12F45)
Report Version: 10

Interval Since Last Report: 33562 sec
Crashes Since Last Report: 1
Per-App Crashes Since Last Report: 1
Anonymous UUID: 704E3C8E-4571-3135-F411-6723F9C002BB

Crashed Thread: 0 Dispatch queue: com.apple.main-thread

Exception Type: EXC_BAD_INSTRUCTION (SIGILL)
Exception Codes: 0x0000000000000001, 0x0000000000000000

Thread 0 Crashed:: Dispatch queue: com.apple.main-thread
0 org.python.python 0x006b01ab PyThread_allocate_lock + 54
1 org.python.python 0x0069e666 PyInterpreterState_New + 47
2 org.python.python 0x0069f241 Py_InitializeEx + 360
3 org.python.python 0x0069f9b6 Py_Initialize + 18
4 com.ccpgames.eveonline 0x00006481 py2app_main + 2625
5 com.ccpgames.eveonline 0x00006e28 main + 1640
6 com.ccpgames.eveonline 0x00001fd2 _start + 216
7 com.ccpgames.eveonline 0x00001ef9 start + 41

Thread 1:
0 libsystem_kernel.dylib 0x9895b0ee __workq_kernreturn + 10
1 libsystem_c.dylib 0x98ece0ac _pthread_workq_return + 45
2 libsystem_c.dylib 0x98ecde79 _pthread_wqthread + 448
3 libsystem_c.dylib 0x98eb5daa start_wqthread + 30

Thread 2:: Dispatch queue: com.apple.libdispatch-manager
0 libsystem_kernel.dylib 0x9895b9ae kevent + 10
1 libdispatch.dylib 0x9481ec71 _dispatch_mgr_invoke + 993
2 libdispatch.dylib 0x9481e7a9 _dispatch_mgr_thread + 53

Thread 3:
0 libsystem_kernel.dylib 0x9895b0ee __workq_kernreturn + 10
1 libsystem_c.dylib 0x98ece0ac _pthread_workq_return + 45
2 libsystem_c.dylib 0x98ecde79 _pthread_wqthread + 448
3 libsystem_c.dylib 0x98eb5daa start_wqthread + 30

Thread 4:
0 libsystem_kernel.dylib 0x9895b0ee __workq_kernreturn + 10
1 libsystem_c.dylib 0x98ece0ac _pthread_workq_return + 45
2 libsystem_c.dylib 0x98ecde79 _pthread_wqthread + 448
3 libsystem_c.dylib 0x98eb5daa start_wqthread + 30

Thread 0 crashed with X86 Thread State (32-bit):
eax: 0x0046c320 ebx: 0x0069f0e7 ecx: 0x0000d000 edx: 0x00800000
edi: 0x006b0183 esi: 0x0046c320 ebp: 0xbfffd3b8 esp: 0xbfffd3a0
ss: 0x00000023 efl: 0x00010202 eip: 0x006b01ab cs: 0x0000001b
ds: 0x00000023 es: 0x00000023 fs: 0x00000000 gs: 0x0000000f
cr2: 0x0071ba04
Logical CPU: 1
Captain Skarlet
Elemental Exploration
Quantum Decadence
#9 - 2014-12-14 09:50:28 UTC
CCP Atropos wrote:
I put a fixed build out yesterday, so recopying from TQ should work.


Nop it dosen't..!!

Copied from eve TQ, renamed it, laucher stats up installs updates....Then..>>>>

Process: launcher [773]
Path: /Volumes/VOLUME/EVE Online Singularity.app/Contents/MacOS/launcher
Identifier: com.ccpgames.eveonline
Version: 2.2.852273 (852273)
Code Type: X86 (Native)
Parent Process: ??? [1]
Responsible: launcher [773]
User ID: 501

Date/Time: 2014-12-14 09:45:30.326 +0000
OS Version: Mac OS X 10.10.1 (14B25)
Report Version: 11
Anonymous UUID: 7798DE8D-BEE6-E0F5-DC7E-05E1E6ABE439


Time Awake Since Boot: 7700 seconds

Crashed Thread: 0 Dispatch queue: com.apple.main-thread

Exception Type: EXC_BAD_INSTRUCTION (SIGILL)
Exception Codes: 0x0000000000000001, 0x0000000000000000

Thread 0 Crashed:: Dispatch queue: com.apple.main-thread
0 org.python.python 0x005b01ab PyThread_allocate_lock + 54
1 org.python.python 0x0059e666 PyInterpreterState_New + 47
2 org.python.python 0x0059f241 Py_InitializeEx + 360
3 org.python.python 0x0059f9b6 Py_Initialize + 18
4 com.ccpgames.eveonline 0x00006481 py2app_main + 2625
5 com.ccpgames.eveonline 0x00006e28 main + 1640
6 com.ccpgames.eveonline 0x00001fd2 _start + 216
7 com.ccpgames.eveonline 0x00001ef9 start + 41

Thread 1:: Dispatch queue: com.apple.libdispatch-manager
0 libsystem_kernel.dylib 0x9173d8d2 kevent64 + 10
1 libdispatch.dylib 0x9714b73f _dispatch_mgr_invoke + 245
2 libdispatch.dylib 0x9714b3a2 _dispatch_mgr_thread + 52

Thread 2:
0 libsystem_kernel.dylib 0x9173ce6e __workq_kernreturn + 10
1 libsystem_pthread.dylib 0x9bd0436d _pthread_wqthread + 939
2 libsystem_pthread.dylib 0x9bd01eea start_wqthread + 30

Thread 3:
0 libsystem_kernel.dylib 0x9173ce6e __workq_kernreturn + 10
1 libsystem_pthread.dylib 0x9bd0436d _pthread_wqthread + 939
2 libsystem_pthread.dylib 0x9bd01eea start_wqthread + 30

Thread 4:
0 libsystem_kernel.dylib 0x9173ce6e __workq_kernreturn + 10
1 libsystem_pthread.dylib 0x9bd0436d _pthread_wqthread + 939
2 libsystem_pthread.dylib 0x9bd01eea start_wqthread + 30

Thread 5:
0 libsystem_kernel.dylib 0x9173ce6e __workq_kernreturn + 10
1 libsystem_pthread.dylib 0x9bd0436d _pthread_wqthread + 939
2 libsystem_pthread.dylib 0x9bd01eea start_wqthread + 30

Thread 0 crashed with X86 Thread State (32-bit):
eax: 0x00211f20 ebx: 0x0059f0e7 ecx: 0x0000e000 edx: 0x00000400
edi: 0x005b0183 esi: 0x00211f20 ebp: 0xbfffd2f8 esp: 0xbfffd2e0
ss: 0x00000023 efl: 0x00010202 eip: 0x005b01ab cs: 0x0000001b
ds: 0x00000023 es: 0x00000023 fs: 0x00000000 gs: 0x0000000f
cr2: 0x0061ba04

Logical CPU: 0
Error Code: 0x00000000
Trap Number: 6
Yinmatook
Skilled Refugees
#10 - 2014-12-15 00:53:20 UTC
CCP Atropos wrote:
I put a fixed build out yesterday, so recopying from TQ should work.


Like others, I am still having the same problem:


Process: launcher [39484]
Path: /Applications/EVE Online Singularity.app/Contents/MacOS/launcher
Identifier: com.ccpgames.eveonline
Version: 2.2.852273 (852273)
Code Type: X86 (Native)
Parent Process: launchd [292]
Responsible: launcher [39484]
User ID: 1000

Date/Time: 2014-12-14 19:48:08.476 -0500
OS Version: Mac OS X 10.9.5 (13F34)
Report Version: 11
Anonymous UUID: 2A40FCB8-F055-F94E-C6BA-0D806447AE8B


Crashed Thread: 0 Dispatch queue: com.apple.main-thread

Exception Type: EXC_BAD_INSTRUCTION (SIGILL)
Exception Codes: 0x0000000000000001, 0x0000000000000000

Thread 0 Crashed:: Dispatch queue: com.apple.main-thread
0 org.python.python 0x01ab01ab PyThread_allocate_lock + 54
1 org.python.python 0x01a9e666 PyInterpreterState_New + 47
2 org.python.python 0x01a9f241 Py_InitializeEx + 360
3 org.python.python 0x01a9f9b6 Py_Initialize + 18
4 com.ccpgames.eveonline 0x00006481 py2app_main + 2625
5 com.ccpgames.eveonline 0x00006e28 main + 1640
6 com.ccpgames.eveonline 0x00001fd2 _start + 216
7 com.ccpgames.eveonline 0x00001ef9 start + 41

Thread 1:: Dispatch queue: com.apple.libdispatch-manager
0 libsystem_kernel.dylib 0x9a5bf992 kevent64 + 10
1 libdispatch.dylib 0x96e4c899 _dispatch_mgr_invoke + 238
2 libdispatch.dylib 0x96e4c532 _dispatch_mgr_thread + 52

Thread 2:
0 libsystem_kernel.dylib 0x9a5bf046 __workq_kernreturn + 10
1 libsystem_pthread.dylib 0x974fddcf _pthread_wqthread + 372
2 libsystem_pthread.dylib 0x97501cce start_wqthread + 30

Thread 3:
0 libsystem_kernel.dylib 0x9a5bf046 __workq_kernreturn + 10
1 libsystem_pthread.dylib 0x974fddcf _pthread_wqthread + 372
2 libsystem_pthread.dylib 0x97501cce start_wqthread + 30

Thread 0 crashed with X86 Thread State (32-bit):
eax: 0x00219060 ebx: 0x01a9f0e7 ecx: 0x0000e000 edx: 0xfffff800
edi: 0x01ab0183 esi: 0x00219060 ebp: 0xbfffd388 esp: 0xbfffd370
ss: 0x00000023 efl: 0x00010206 eip: 0x01ab01ab cs: 0x0000001b
ds: 0x00000023 es: 0x00000023 fs: 0x00000000 gs: 0x0000000f
cr2: 0x01b1ba04

Logical CPU: 4
Error Code: 0x00000000
Trap Number: 6
Utremi Fasolasi
La Dolce Vita
#11 - 2014-12-15 05:45:30 UTC
Glad I found this and it is not just me.
Sandar Orontur
Federal Navy Academy
Gallente Federation
#12 - 2014-12-15 10:02:01 UTC
Same problem, patch didn't fix it.

Copied TQ client over again, changed IP to SiSi. When starting launcher, it shows the correct server (SiSi), launcher updates a few times, then nothing....

Mac OS X 10.9.5, MBP 2013
Yinmatook
Skilled Refugees
#13 - 2014-12-16 12:19:21 UTC
Today, I made my daily copy of TQ and attempted to update it to SiSi. And the results are different.

The Launcher has successfully updated itself (or claims that it has). Now, when I start it back up, the Launcher has displayed, but the grey bar at the bottom has no label and has remained grey. And having logged in, the "PLAY" button is greyed out.

Progress...
CCP Atropos
C C P
C C P Alliance
#14 - 2014-12-16 13:32:21 UTC
Yea, I don't rightly know what's wrong, since it works on three out of the four Mac's I've tested on. I'll roll back the update, and try to work out what's happening.
CCP Atropos
C C P
C C P Alliance
#15 - 2014-12-16 15:55:30 UTC
I unpublished that version. Recopying from TQ should work.
Quantum Lotus
Aliastra
Gallente Federation
#16 - 2014-12-16 21:24:20 UTC  |  Edited by: Quantum Lotus
bump:

also having the same issue, launcher goes through a series of updates, then crashes.

i've tried clearing the cache after copying a fresh TQ install as well, same result.

opening console gives me a generic:

12/16/14 11:23:33.849 PM launcher[484]: EVE Online Error

and nothing more.


update:

this command helps me bypass the launcher and gets me to the old login screen

"/Applications/EVE Online SiSi.app/Contents/Resources/EVE Online.app/Contents/MacOS/cider" --cmdline " /server:87.237.38.50"

while the screen confirms that its trying to connect to sisi, it says that it cannot on port 26000

screenshot here
Sandar Orontur
Federal Navy Academy
Gallente Federation
#17 - 2014-12-18 13:02:58 UTC
CCP Atropos wrote:
I unpublished that version. Recopying from TQ should work.



Yes, this worked for me. SiSi client happily running again. Thx !
Yinmatook
Skilled Refugees
#18 - 2014-12-19 00:38:00 UTC
CCP Atropos wrote:
I unpublished that version. Recopying from TQ should work.


Yes, it is working again now.

Thank you.