These forums have been archived and are now read-only.

The new forums are live and can be found at https://forums.eveonline.com/

Macintosh

 
  • Topic is locked indefinitely.
 

Python Exception on Launcher - All found methods not working.

First post
Author
Zalik Rapture
The Scope
Gallente Federation
#1 - 2014-08-15 13:32:16 UTC  |  Edited by: Zalik Rapture
Just did a fresh install of my Mac, downloaded the latest Eve client (twice), copied and installed, and get the following python exception each time.

Exception can be found here.
https://gist.github.com/dustinblackman/e77abccd4137a09540b5

Now, after searching around the forums I've tried the following methods with no luck.

-Delete, redownload, reinstall
-Delete Cache folder
-Copying in the LauncherUpdate tar
-Run the oldschool Mac Repair Tool

I'm stuck. Would anyone happen to have a solution for this? Thanks!

EDIT:
Just to add, currently running Mavericks on a 2012 Macbook Pro. I do have Python installed through Brew, but as far as I know CCP has their own executable packaged in for their installer so it shouldn't be touching the one on system (or am I wrong?)

[center]The Rapture Chronicles - https://forums.eveonline.com/default.aspx?g=posts&t=22445&find=unread[/center]

Sam Terranomar
Jump Drive Appreciation Society
#2 - 2014-08-15 14:37:05 UTC  |  Edited by: Sam Terranomar
I'm getting the same problem on my OS X machine. It's a mid-2010 MacBook Pro running Mavericks, if that helps.
Cow K
The Kohporation
#3 - 2014-08-16 01:03:00 UTC  |  Edited by: Cow K
i've had this for like a week now.
But i could just click on the start eve button, and eve would start. And i could log in from the old login screen.


[IMG]http://i.imgur.com/OwWJIcL.png[/IMG]

But today it's not even connecting to the server.

[IMG]http://i.imgur.com/arP0bcA.png[/IMG]
Scourer Gengod
Akademia Leniwych
Greater Western Co-Prosperity Sphere
#4 - 2014-08-16 14:42:23 UTC  |  Edited by: Scourer Gengod
@up
Same here.
MBP 2013 - Mavericks
update: OSX - fresh install >> :(
Zalik Rapture
The Scope
Gallente Federation
#5 - 2014-08-16 16:41:19 UTC
To add to my first post:

Currently running Mavericks on a 2012 Macbook Pro. I do have Python installed through Brew, but as far as I know CCP has their own executable packaged in for their installer so it shouldn't be touching the one on system (or am I wrong?)

[center]The Rapture Chronicles - https://forums.eveonline.com/default.aspx?g=posts&t=22445&find=unread[/center]

Scourer Gengod
Akademia Leniwych
Greater Western Co-Prosperity Sphere
#6 - 2014-08-17 07:46:31 UTC
Repaired.

1> check python interpreter
>> terminal > python > enter > exit() > enter
or
>> terminal > python3 > enter > exit() > enter

if python is functional go step 3 if no step 2,

2> Launchpad >> Others >> Disk Tool >> select Mac HD > Check permissions, Check disk >> run Repair if needed or AHT to check hardware,

3> https://forums.eveonline.com/default.aspx?g=posts&t=316715&find=unread but after that instruction reboot OSX,

4> run AppCleaner (delete EVE),

5> download fresh eve-premium(…).dmg, mount and install
Zalik Rapture
The Scope
Gallente Federation
#7 - 2014-08-17 15:10:59 UTC
Scourer Gengod wrote:
Repaired.

1> check python interpreter
>> terminal > python > enter > exit() > enter
or
>> terminal > python3 > enter > exit() > enter

if python is functional go step 3 if no step 2,

2> Launchpad >> Others >> Disk Tool >> select Mac HD > Check permissions, Check disk >> run Repair if needed or AHT to check hardware,

3> https://forums.eveonline.com/default.aspx?g=posts&t=316715&find=unread but after that instruction reboot OSX,

4> run AppCleaner (delete EVE),

5> download fresh eve-premium(…).dmg, mount and install



Gave it a shot, unfortunately no luck. :(
Going to send in a support ticket and see where I get. Thanks for the help though!

[center]The Rapture Chronicles - https://forums.eveonline.com/default.aspx?g=posts&t=22445&find=unread[/center]

Cow K
The Kohporation
#8 - 2014-08-19 10:58:20 UTC
i downloaded the client for the 3 time yesterday this week, and it seems to have been fixed.
CCP Atropos
C C P
C C P Alliance
#9 - 2014-08-19 17:54:14 UTC
Downloading and installing the latest client should resolve this.