These forums have been archived and are now read-only.

The new forums are live and can be found at https://forums.eveonline.com/

Test Server Feedback

 
  • Topic is locked indefinitely.
 

Updated EVE Launcher builds available on SIngularity

First post
Author
Gajatu D'Gorah
Sebiestor Tribe
Minmatar Republic
#21 - 2013-11-11 15:02:08 UTC
I'm getting:

2013-11-11 09:19:05,786 - root - selfupdate - INFO - Installing version 2.1.645308
2013-11-11 09:19:05,957 - root - selfupdate - ERROR - Error during self update
Traceback (most recent call last):
File "lib\selfUpdate.pyo", line 321, in startUpdate
File "lib\selfUpdate.pyo", line 288, in initUpdate
File "lib\selfUpdate.pyo", line 234, in doUpdate
File "esky\__init__.pyo", line 895, in install_version
File "esky\__init__.pyo", line 927, in _unpack_bootstrap_env
File "esky\fstransact\win32txf.pyo", line 117, in move
File "esky\fstransact\win32txf.pyo", line 126, in _move
File "esky\fstransact\win32txf.pyo", line 24, in wrapper
WindowsError: [Error 32] The process cannot access the file because it is being used by another process.

in the launcher logs when i try to log in to SiSi. Like the person a couple posts back, it's stuck on "installing files".

I've tried logging out and back in, running as admin and disabling antivirus. any suggestions?
CCP Atropos
C C P
C C P Alliance
#22 - 2013-11-11 15:25:17 UTC
I don't know why that would be being thrown. Do you happen to have the full log, ideally with the /log:debug parameter enabled, that I could dig through?

The exception shows that there's an issue applying the downloaded update to the EVE Launcher, in a transactional manner, since the file is being used by another process. I'm unable to tell from the exception you've pasted, what file that might be or what process might be retaining a lock on the file and why that would be.

Thanks for your help with debugging this Smile
Gajatu D'Gorah
Sebiestor Tribe
Minmatar Republic
#23 - 2013-11-11 15:56:56 UTC
CCP Atropos wrote:
I don't know why that would be being thrown. Do you happen to have the full log, ideally with the /log:debug parameter enabled, that I could dig through?

The exception shows that there's an issue applying the downloaded update to the EVE Launcher, in a transactional manner, since the file is being used by another process. I'm unable to tell from the exception you've pasted, what file that might be or what process might be retaining a lock on the file and why that would be.

Thanks for your help with debugging this Smile



I know this is a stupid question, but how do I get the logs to you?
CCP Atropos
C C P
C C P Alliance
#24 - 2013-11-11 15:59:08 UTC
You can try copy/pasting them to http://pastebin.com/
Salpun
Global Telstar Federation Offices
SLYCE Pirates
#25 - 2013-11-11 16:02:47 UTC
CCP Atropos wrote:
You can try copy/pasting them to http://pastebin.com/

The bug reporting webpage in the community web page works wonders alsoTwisted

https://community.eveonline.com/support/submit-bug-report/

If i dont know something about EVE. I check https://wiki.eveonline.com/en/wiki/ISK_The_Guide

See you around the universe.

Gajatu D'Gorah
Sebiestor Tribe
Minmatar Republic
#26 - 2013-11-11 16:08:31 UTC
CCP Atropos wrote:
You can try copy/pasting them to http://pastebin.com/


try this:

http://pastebin.com/U6PyJeHy

hopefully it helps, let me know what else, if anything, you'd like me to do.
Krixtal Icefluxor
INLAND EMPIRE Galactic
#27 - 2013-11-11 19:16:29 UTC  |  Edited by: Krixtal Icefluxor
CCP Atropos wrote:


Can you provide me with the Launcher log files? they should be in launcher\cache\*.log


Unfortunately, the only launcher files in that client's directory is the one from after the finally successful process was completed.

The 4 or 5 times the Launcher came up and just sat there doing nothing have absolutely no record.

Sorry.

"He has mounted his hind-legs, and blown crass vapidities through the bowel of his neck."  - Ambrose Bierce on Oscar Wilde's Lecture in San Francisco 1882

CCP Atropos
C C P
C C P Alliance
#28 - 2013-11-11 23:10:50 UTC
I just deployed a new build of the EVE Launcher with a large range of under the hood download changes. If you're experiencing problems with the update process, let me know, and try and grab the log. It will probably take at least one or two more builds to be deployed until any fixes would be in your hands since you would be updating from builds which don't contain the fix (ie: current broke build A errors when updating to B, but if B includes the fixes then a deployment of build C would be OK).

Keep me posted.
Makari Aeron
Imperial Shipment
Amarr Empire
#29 - 2013-11-12 03:03:40 UTC
CCP Atropos: so far so good. The launcher updated itself and the client successfully on Win8.1 x64.

CCP RedDawn: Ugly people are just playing life on HARD mode. Personally, I'm playing on an INFERNO difficulty.

CCP Goliath: I often believe that the best way to get something done is to shout at the person trying to help you. http://goo.gl/PKGDP

Chainsaw Plankton
FaDoyToy
#30 - 2013-11-14 03:04:39 UTC
woohoo, new launcher, although I updated and it still breaks. looks like the log goes over pastebin's file size limit.

so part 1: http://pastebin.com/GfZz1bmi part 2: http://pastebin.com/SDRmyaXi

looks like it is still the femalehires02.stuff but can't really say anymore than that.

@ChainsawPlankto on twitter

CCP Atropos
C C P
C C P Alliance
#31 - 2013-11-14 10:59:55 UTC
OK, thanks for the logfile. I'm going to deploy a new build today with some IOError debugging in it, to see if it can be resolved, so if possible it would be good if you could try it again later today.
CCP Atropos
C C P
C C P Alliance
#32 - 2013-11-14 12:00:23 UTC  |  Edited by: CCP Atropos
If anyone gets any errors when attempting to install the latest EVE Launcher update for Windows, it's because I broke it. You can fix it by going into your EVE installation and going into the launcher\appdata folder and deleting the folders named updates and EVE_Online_Launcher-2.1.651555.win32

Alternatively you can download and install the EVE Launcher from this link, just be sure to point it at your Singularity installation: http://content.eveonline.com/EveOnlineLauncher/beta/EVEOnlineLauncher_2_1_651614.exe
Anomander Onzo
Tactically Challenged
Tactical Supremacy
#33 - 2013-11-14 12:04:46 UTC
Getting a error when trying to open the launcher.
http://pastebin.com/YQkBCBsZ
Nitko Koraka
Flashover Freight
#34 - 2013-11-14 12:05:23 UTC  |  Edited by: Nitko Koraka
I've been unable to patch SiSi for the past few days. The launcher usually stops downloading a couple minutes into the process. Have tried to reinstall SiSi to no effect. Here is the pastbin: http://pastebin.com/sve7sMXn. Would really appreciate some help. Thanks.

Edit: Was finally able to completely download the patch, albeit extremely slowly. Now I'm wondering if the problem was on my end.
CCP Atropos
C C P
C C P Alliance
#35 - 2013-11-14 12:08:40 UTC
Anomander Onzo wrote:
Getting a error when trying to open the launcher.
http://pastebin.com/YQkBCBsZ

See my post above yours with the links to reinstall/fix the issue.
DoToo Foo
Garoun Investment Bank
Gallente Federation
#36 - 2013-11-14 14:09:07 UTC  |  Edited by: DoToo Foo
Tried and failed with repair tool

Cleared logfile.

Tried and failed with /server:sisi /log:debug /debughttp /uniquelog

Got as far as trying to install patches, but nothing further

Then *succeeded* with running shortcut as administrator; at least as far as now getting to client is ready.

Still have some issues with "Could not connect to the specified address. Odds are that you have not established an internet connection, the server isn't running, or the server address or port number was wrong." but that appears to be a different problem.

http://pastebin.com/rWKgCd2g


(redownloading loader patch etc as above suggestion

http://foo-eve.blogspot.com.au/

CCP Atropos
C C P
C C P Alliance
#37 - 2013-11-14 15:27:05 UTC
DoToo Foo wrote:
Tried and failed with repair tool

Cleared logfile.

Tried and failed with /server:sisi /log:debug /debughttp /uniquelog

Got as far as trying to install patches, but nothing further

Then *succeeded* with running shortcut as administrator; at least as far as now getting to client is ready.

Still have some issues with "Could not connect to the specified address. Odds are that you have not established an internet connection, the server isn't running, or the server address or port number was wrong." but that appears to be a different problem.

http://pastebin.com/rWKgCd2g


(redownloading loader patch etc as above suggestion

Yea, your log just shows that your EVE Launcher detected an update to itself, and fetched it and applied it. What's weird is that it took you about 3 minutes to download a ~30MB update; are you on a particularly slow connection, or just unfortunately far from the servers?
BlackDeathVirus
Vanishing Point.
The Initiative.
#38 - 2013-11-14 17:40:19 UTC
i'm using a mack and the sisi launcher hangs at 25%. what should i do, was on already today and had some nice ships ready for the test ?
BlackDeathVirus
Vanishing Point.
The Initiative.
#39 - 2013-11-14 17:41:04 UTC
while patching hangs at 25% that is*
BlackDeathVirus
Vanishing Point.
The Initiative.
#40 - 2013-11-14 18:04:47 UTC
tried clearing cache, bot of them. eve client and normal cache and still not working. 25% stuck with patch.
any help pls ?