These forums have been archived and are now read-only.

The new forums are live and can be found at https://forums.eveonline.com/

EVE Technology Lab

 
  • Topic is locked indefinitely.
 

[EVEOTS] Eve Online Teamspeak 3 API Registration with PHP5 v1.8

First post
Author
MJ Maverick
Hybrid Industrial
#201 - 2013-03-15 00:20:34 UTC
What do you mean you don't have rights? You have to edit the config.php to set up the server. Are you the admin?
TheCorporal Hakoke
Caldari Provisions
Caldari State
#202 - 2013-03-15 07:21:14 UTC
I'm the admin on EVEOTS, i made the changes to the config.php setting the group to be '18' that is a channel group on my teamspeak server.
So when i tried from another computer that never signed into teamspeak i go the error F25.....for some reason it think i have the right already but i don't...Once any new person log's into my teamspeak they are automatic are put as a guest. But what i am hoping to slove with your awesome tool is to allow corp members and ally members to have the write that i have setup.


Thank for your help
MJ Maverick
Hybrid Industrial
#203 - 2013-03-17 16:51:38 UTC
I thin I understand, but it sounds like something isn't set right in your config. Look at the readme section for the config.php. Make sure you fully understand what goes in each field.

F25 is failing to find your Teamspeak server. make sure your web server is on the whitelist too. There is a readme for that also.
CrazyKiller6226
The Scope
Gallente Federation
#204 - 2013-04-10 21:39:42 UTC
How do I set up for different corps in alliances to get different server groups? Also is there a way I can make it so it doesn't require the ticker to give them server perms as my server groups adds the ticker infront of their name.
MJ Maverick
Hybrid Industrial
#205 - 2013-04-10 22:38:28 UTC
That is not supported but you can mod it in if you know what you're doing.

As for the tickers, see page 2 of this thread.
Jetro Grissom
Global Dynamics Production
#206 - 2013-04-30 19:36:08 UTC  |  Edited by: Jetro Grissom
Hello, i'm check everything, but all the time getting error A281.... Have no idea what to do here...


Quote:
An error occured: Make sure you have entered the character name correctly. (Error: API Date could not be read / parsed, original exception: Couldn't resolve host 'api.eveonline.com') [A281]
Jetro Grissom
Global Dynamics Production
#207 - 2013-05-14 10:51:56 UTC
I fix it Big smile



But now i have different problem.
I put my alliance and corp name in conf file:

Quote:
config.php [B---] 32 L:[ 4+29 33/ 40] *(1425/1630b) 0010 0x00A
*/^M
class Config {^M
<------>// Administrators character, you.^M
<------>public $admin = "[G D P] - Jetro Grissom";^M
<------>// Database ID of the ROOT admin (from "admins" table), this admin cannot be deleted by a rogue ****. Make it your ID.^M
<------>public $adminID = 2<--->;^M
<------>// (REQUIRED) Teamspeak 3 Server Query Information^M
<------>public $tshost = "www.globaldynamic.ru";^M
<------>public $tsname = "eveots";^M
<------>public $tspass = "9nrjHAvI";^M
<------>public $tsport = "10011"; //ServerQuery Port^M
<------>public $tscport = "9987"; //TeamSpeak client port^M
<------>// (OPTIONAL) Teamspeak 3 Client Connect Password^M
<------>public $tspassword = "";^M
<------>// (REQUIRED) Database Information^M
<------>public $db_host = "localhost";^M
<------>public $db_user = "grissom_ts3";^M
<------>public $db_pass = "Kxpos23o";^M
<------>public $db_name = "grissom_ts3";^M
<------>// (REQUIRED) API Connection Testing Information - TESTID and TESTname MUST be the characterID and characterName of the SAME character respectively. You may use mine.^M
<------>public $TESTID = 935338328;^M
<------>public $TESTname = "MJ Maverick";^M
<------>// (REQUIRED) Your alliance/corp name^M
<------>public $ourname = "Trifectas Syndicate/Global Dynamics Production";^M
<------>// Debug Mode? (true/false)^M
<------>public $verbose = true;^M
<------>// (REQUIRED) Teamspeak 3 group for alliance/corp members^M
<------>public $group = 10;^M
<------>// (REQUIRED) Teamspeak 3 group for people on the whitelist but not in your alliance/corp^M
<------>public $bluegroup = 9;^M
<------>// Banner Image^M
<------>public $banner = "images/banner.jpg";^M
<------>// (OPTIONAL) Ticker spacers. - Example: For "IRNP | MJ Maverick" use "|". Leave blank for "IRNP MJ Maverick".^M
<------>public $spacer = " - ";^M
}^M
?>^M

1Help 2Save 3Mark 4Replac 5Copy 6Move 7Search 8Delete 9PullDn 10Quit


And when i'm trying to register, i'm getting this:
Quote:

Debug: Running: Teamspeak 3 PHP Framework version: 1.1.12

API Connection was established.

Checking...
Character: HolyShishkabob
Debug: Key ID: 1241867
Debug: vCode: E8Ww16M1GQEFePRCTi7ZTXVhBjSaelSULBsys2eWSvKuJNUjsXcIvldZPEIb38PU

Debug: Character ID: 631058178

Debug: Character List:
Debug: Lolshto Ivanovich [91120824]
Debug: Roksana Babayan [91290564]
Debug: HolyShishkabob [631058178]

Debug: API verified.

You are not allowed to register on this server.



Help me to fix it, and btw if i add my corp to blue list, i'm register ok, then just copy paste corp name (for test) to conf file and getting error again)
Blood Stains
Syndicate Enterprise
Test Alliance Please Ignore
#208 - 2013-05-28 20:55:32 UTC
Ok, so i've downloaded EveTos and have been playing with it attempting too get it working.
I've everything setup, but I can not register any users neither can I get a whitelist setup from the admin panel.
My config.php is as follows

http://pastebin.com/RNga6yVP

I get the following error when attempting to register any corp mate via EveTos

"You are not allowed to register on this server."

So after some reading I figure maybe this is due too the white list. so I setup my user in the admin panel as per the readme.html then once I attempt to add my corp too the white list I get this error.

Invalid query: Field 'corpAlliance' doesn't have a default value

Can someone please offer me some assistance ? I been slowly working on this for a few days now. and can not find anything in reference too a default value.
CCP Eterne
C C P
C C P Alliance
#209 - 2013-09-06 10:17:38 UTC
Unlocked per request.

EVE Online/DUST 514 Community Representative ※ EVE Illuminati ※ Fiction Adept

@CCP_Eterne ※ @EVE_LiveEvents

MJ Maverick
Hybrid Industrial
#210 - 2013-09-06 17:36:16 UTC
Thanks Eterne.

Hi guys, sorry about the slow response, had some problems with the thread and went on a real life holiday. Do you guys still have issues?
StarCrash
Spirit Corp
#211 - 2013-09-24 14:47:50 UTC
Hi

I seem to have a issue when cron is trying to run the bot.php file the errors i m getting are below

Output from command /eveots/bot.php ..

k/eveots/bot.php: line 1: ?php: No such file or directory
/eveots/bot.php: line 2: /*: No such file or directory
/eveots/bot.php: line 3: ==========: command not found
/eveots/bot.php: line 4: */: No such file or directory
/eveots/bot.php: line 5: //: is a directory
/eveots/bot.php: line 6: syntax error near unexpected token `'display_errors','
eveots/bot.php: line 6: `//ini_set('display_errors', 'On');
Khan Farshatok
Hateful Intent
Hostile Intervention
#212 - 2013-11-13 16:07:49 UTC
ok so this is GREAT for ts3. but what about making it auto create logins for a jabber server and a phpbb forum?
Don Abele
The Scope
Gallente Federation
#213 - 2014-01-17 01:25:25 UTC
After I unzip the files to my plug in folder, how to I use them? I don't see them on the list of plug ins for my TS client.
jant peuk
Sebiestor Tribe
Minmatar Republic
#214 - 2014-02-18 17:24:13 UTC  |  Edited by: jant peuk
am getting this error
its probably easy to fix
however i cant find anything

Error: Could not find you on the server, your nickname should be exactly 'GOB | GOBH | jant peuk'. Either that or you already have permissions. (Error: invalid group ID [F26])

getting that my nickname is precise
Plain213
Macabre Votum
Northern Coalition.
#215 - 2014-02-18 17:50:37 UTC
possibility for Jabber intergration?
Garric Shadowbane
Stimulus
Rote Kapelle
#216 - 2014-02-21 03:24:06 UTC
I'd love to get this working for my own alliance.

Unfortunately i'm not too tech savvy when it comes to web hosting.

Could someone explain in laymen terms how do install the database on to my web server and importing eve OTS on there?

the read me only explains how to program user privileges. or so it seems. I appreciate any help you guys can give. Thanks.