These forums have been archived and are now read-only.

The new forums are live and can be found at https://forums.eveonline.com/

Linux

 
  • Topic is locked indefinitely.
 

Fix for the patch after down time on the 14th

Author
Nuvaro
RePeX.
Dead Heaven Syndicate
#1 - 2012-03-14 14:22:33 UTC
If the patcher fails to download the patch, revert to (native, builtin):

msvcr10 (native, builtin)
msvcr8 (native, builtin)
msvcr9 (native, builtin)
msvcrt (native, builtin)

It should download and patch up fine.
But in order to play the game, you'll have to revert back again:

msvcr100 (builtin, native)
msvcr80 (builtin, native)
msvcr90 (builtin, native)
msvcrt (builtin, native)

Worked for me.Blink
Raidon Beinoit
Eve Corporation 69
#2 - 2012-03-14 14:26:54 UTC
works.
thx
Ryo Ishikawa
Garoun Investment Bank
Gallente Federation
#3 - 2012-03-14 14:52:50 UTC
Kudos, works like a charm on wine 1.4
Rastuasi
Native Freshfood
Minmatar Republic
#4 - 2012-03-14 14:56:09 UTC  |  Edited by: Rastuasi
Did that, now I have

wine explorer /desktop=eve$RANDOM,1600x900 "/home/*********/.wine/drive_c/Program Files/CCP/EVE/eve.exe"
fixme:heap:HeapSetInformation (nil) 1 (nil) 0
fixme:gameux:GameExplorerImpl_VerifyAccess (0x132bc8, L"C:\\Program Files\\CCP\\EVE\\eve.exe", 0x33fdb8)
wine: Unhandled page fault on read access to 0x00000400 at address 0x7eaf0b15 (thread 0022), starting debugger...


Any thoughts? Doesnt even get to the launcher.

Ubuntu 11.10
Wine 1.3.28

Edit: I dont have msvcrt...and winetricks msvcrt doesnt work to get it, how'd you get that library?
Edit2: Putting msvcrt80 and 90 back to the previous way allows launcher to start...if I have to switch every time it's gonna suck just to start the game
Clare Normandi
The Scope
Gallente Federation
#5 - 2012-03-14 15:11:26 UTC
Worked, thanks!
Reboot Mizuno
Xtreme insidious Corporation
#6 - 2012-03-14 18:59:18 UTC
Rastuasi wrote:

Edit2: Putting msvcrt80 and 90 back to the previous way allows launcher to start...if I have to switch every time it's gonna suck just to start the game


You can configure the DLL overrides for the msvcr* DLLs only for the ExeFile.exe in winecfg. Just click "Add application..." on the applications tab and select the ExeFile.exe from the bin folder of your EvE install folder. If it is selected you can configure the DLL overrides only for this file. That should make the launcher and EvE work without changing the settings every time.
Darkpepper
Lost World Compagny
#7 - 2012-03-14 19:21:21 UTC
Reboot Mizuno wrote:
Rastuasi wrote:

Edit2: Putting msvcrt80 and 90 back to the previous way allows launcher to start...if I have to switch every time it's gonna suck just to start the game


You can configure the DLL overrides for the msvcr* DLLs only for the ExeFile.exe in winecfg. Just click "Add application..." on the applications tab and select the ExeFile.exe from the bin folder of your EvE install folder. If it is selected you can configure the DLL overrides only for this file. That should make the launcher and EvE work without changing the settings every time.



P-E-R-F-E-C-T sir :)

Thanks!

**W**ormhole space, **L**inux Mint, **F**ree cookies

Rastuasi
Native Freshfood
Minmatar Republic
#8 - 2012-03-15 06:36:31 UTC
Reboot Mizuno wrote:
Rastuasi wrote:

Edit2: Putting msvcrt80 and 90 back to the previous way allows launcher to start...if I have to switch every time it's gonna suck just to start the game


You can configure the DLL overrides for the msvcr* DLLs only for the ExeFile.exe in winecfg. Just click "Add application..." on the applications tab and select the ExeFile.exe from the bin folder of your EvE install folder. If it is selected you can configure the DLL overrides only for this file. That should make the launcher and EvE work without changing the settings every time.



Did not work for me, do I have to also put all the other "natives" into the new ones? Cause I just get a blank screen when i tried those and when I tried eve.exe it launched launcher but crashed on the client.

Darkpepper
Lost World Compagny
#9 - 2012-03-15 08:23:50 UTC
Rastuasi wrote:


Did not work for me, do I have to also put all the other "natives" into the new ones? Cause I just get a blank screen when i tried those and when I tried eve.exe it launched launcher but crashed on the client.




Here is what i've done :

in winecfg : i've removed all the mscvr80/90/100/t from the default profil, librairies tab.
added two new programs :ExeFile.exe and eve.exe
added all the mscvr80/90/100/t in both program librairies tab
and changed for eve.exe

*msvcr100 (Builtin, Native)
*msvcr90 (Builtin, Native)
*msvcr80 (Builtin, Native)
*msvcrt (Builtin,Native)

So far it works for me... until next update ..... ;_;

**W**ormhole space, **L**inux Mint, **F**ree cookies

prettypenguins
Perkone
Caldari State
#10 - 2012-03-15 12:08:45 UTC
thanks for the heads up. I really hope CCP doesn't expect us to do this every update.
Rammix
TheMurk
#11 - 2012-03-15 15:03:17 UTC
That helped, thanks.
I love EVE's community. Roll

OpenSUSE Leap 42.1, wine >1.9

Covert cyno in highsec: https://forums.eveonline.com/default.aspx?g=posts&t=296129&find=unread