These forums have been archived and are now read-only.

The new forums are live and can be found at https://forums.eveonline.com/

Issues, Workarounds & Localization

 
 

[Linux] Freeze after character selection

Author
Solyaris Chtonium
#1 - 2017-08-02 15:08:26 UTC  |  Edited by: Hol Vegr
Running EVE on wine under linux, I logged in this morning and the game just goes to a black screen after character selection. I was on last night without any issue, and suddenly this morning I can't play. Anyone else having this issue, or know how to solve it?
Silent Infinity
#2 - 2017-08-02 15:27:08 UTC
I am having the same issue. I am running wine-staging 2.13 and mesa 17.1.5 with an r9 fury under arch linux. What distro and drivers are you using?
Solyaris Chtonium
#3 - 2017-08-02 15:52:49 UTC
Gentoo Linux
Kernel 4.9.16

Nvidia GTX 960
nvidia-drivers 384.59-r1

Wine 2.3 with staging patches

Someone else had reported it a few days ago as well:
https://forums.eveonline.com/default.aspx?g=posts&t=524295&find=unread

As a side note, I just caved and installed the linux launcher and it's working. Not sure how I feel about a separate wine instance being pulled for this, but it's working and my wine isn't, so for the time being that's what I'll be using.

https://forums.eveonline.com/default.aspx?g=posts&t=482663

Thanks CCP Snorlax o7

-Hol



Silent Infinity
#4 - 2017-08-02 16:01:10 UTC  |  Edited by: Guy Patrouette
I also fixed mine by deleting all the launcher settings (backing up `.eve/wineenv`, `rm -rf .cache/CCP/; rm -rf .eve; rm -rf .EVE; rm -rf .local/share/CCP; rm -rf .config/CCP/`, and then restoring .eve/wineenv).

You can also use a custom wine installation with the linux launcher in the settings.

EDIT: It turns out I may have spoken too soon. After relogging, I am getting the issue again.

EDIT2: It appears that it may be a wine-staging problem. If I switch to regular wine, it seems to work.

EDIT3: Nope, it seems to be an intermittent, random problem.
Forum Jump