These forums have been archived and are now read-only.

The new forums are live and can be found at https://forums.eveonline.com/

Linux

 
  • Topic is locked indefinitely.
 

launcher not working anymore after 11july

Author
Nalana Vos
Space P0lice
#1 - 2017-07-11 13:18:45 UTC
Hey guys i have the eve launcher for linux installed per instructions. All was fine for months, but the 11th july deployment just crashes the game after it logs in.

Some details Ubuntu 16.04. (here be snipet of backtrace log ) i can't post it cause its html code? . How can i help you guys? and thus help me? is anyone having this problem too?

Elon Muusto
Tribal Liberation Force
Minmatar Republic
#2 - 2017-07-11 13:27:17 UTC
Same issue here
Zoe Atruin
F-I-N-K Industry
Brothers in Arms Alliance
#3 - 2017-07-11 14:05:27 UTC
Same here.

Quick fix:
* disable xaudio2_7 library.
Nalana Vos
Space P0lice
#4 - 2017-07-11 14:15:25 UTC
How do i disable it?
Zoe Atruin
F-I-N-K Industry
Brothers in Arms Alliance
#5 - 2017-07-11 14:20:22 UTC
Nalana Vos wrote:
How do i disable it?


if u have the linux launcher:
WINEPREFIX=~/.eve/wineenv/ ~/.eve/wine/bin/winecfg

Then go to libraries tab:
* add xaudio2_7
* edit to disabled
Nalana Vos
Space P0lice
#6 - 2017-07-11 14:24:18 UTC
Thank you Zoe, It worked! :) i had no idea i could have done that to it :)
Elon Muusto
Tribal Liberation Force
Minmatar Republic
#7 - 2017-07-11 14:41:06 UTC
Thanks Zoe, that saved my bacon too!
Ragnar STS
Minmatar Brotherhood
Ushra'Khan
#8 - 2017-07-12 01:20:57 UTC  |  Edited by: Ragnar STS
I did not follow the instructions above perfectly....

Instead I did:
WINEPREFIX=~/.eve/wineenv/ ~/.eve/wine/bin/winecfg


And under Application Windows Version ... I chose Windows 10.

Not quite sure after reading the changelog what would cause cause exefile.exe to crash immediately based on a piece of audio code...but this might be another valid workaround. I haven't tested it fully, but I can undock and fly around and then dock again.

Still no dx11...but at least the game still runs.
Renatus Lucifer
Ascending Angels
#9 - 2017-07-12 17:27:42 UTC
Ragnar STS wrote:

And under Application Windows Version ... I chose Windows 10.


This fixed it for me. Thanks a lot! Using PlayOnLinux on Debian. It was at "Windows 7" before.
Now with "Windows 10" set all starts fine, no exefile.exe crash anymore.
Fenix Inferni
Dark Fenix Rising
Elemental Tide
#10 - 2017-07-12 19:32:25 UTC
Ragnar STS solution worked here!

Manjaro, kernel 4.9.35-1

THX!