These forums have been archived and are now read-only.

The new forums are live and can be found at https://forums.eveonline.com/

Macintosh

 
  • Topic is locked indefinitely.
 

USB Sound issues on Mac

First post
Author
Ender Tunin
Adhocracy Incorporated
Adhocracy
#1 - 2017-06-08 06:48:08 UTC
I've been successfully using a USB sound dongle for quite a while with my ear buds/mic. It's an iMic by Griffin and works great. I wanted to try some earphones and picked up a set of Razer corded earphones. They come with their own USB sound dongle which I plugged in in place of my old one. Sound works great over the whole system (Mumble, iTunes, etc) but sound doesn't work anymore in Eve. So I swapped the USB dongle back to the iMic, still no sound in Eve. Sound from everything else works through both my usual earbuds, and my earphones, but not from Eve.

The best I can think of was that something in Wine got corrupted to change over for the new USB dongle. I tried changing versions of Wine to no avail. I currently use "dev versions : ccp-master : Latest Wine". (currently Launcher ver 1150265.1058) I then pulled the nuclear option and just uninstalled all of Eve (so I thought), and reinstalled it. Somehow my launcher knew about my three accounts, so I've missed something on the "uninstall". Eve finally finished it's 8+ gigs of download, and I still have no sound.

I've missed something somewhere and I'm at a loss as to where to look next.

Searching the forums found no similar issues. In fact, it led to my reinstallation decision because like another user I too have crashes mostly on undocking from Jita, and his issues got better with a reinstall.
Ender Tunin
Adhocracy Incorporated
Adhocracy
#2 - 2017-06-08 19:30:34 UTC
ok, some digging through loglite finds this related to Razer:


So it seems even though I don't have the Razer dongle hooked up, it's trying to load Razer drivers and they've highjacked my audio. I don't know how to undo wine/EVE trying to load these drivers.



+++++++++++
info 2017-06-08T14:13:30 822 /Applications/EVE Launcher.app/Contents/MacOS/evelauncher evelauncher default "err = 1 /Applications/buildAgent/work/3698a4f6f0fc2ed5/source/RazerManOWar7.1Audio/TwinkleMac/NahimicAPO_Mac/NahimicAPO_Mac/Source/mach_override.c:243"
info 2017-06-08T14:13:30 822 /Applications/EVE Launcher.app/Contents/MacOS/evelauncher evelauncher default "err = 1 /Applications/buildAgent/work/3698a4f6f0fc2ed5/source/RazerManOWar7.1Audio/TwinkleMac/NahimicAPO_Mac/NahimicAPO_Mac/Source/mach_override.c:257"
info 2017-06-08T14:13:30 822 /Applications/EVE Launcher.app/Contents/MacOS/evelauncher evelauncher default "err = 1 /Applications/buildAgent/work/3698a4f6f0fc2ed5/source/RazerManOWar7.1Audio/TwinkleMac/NahimicAPO_Mac/NahimicAPO_Mac/Source/mach_override.c:262"
info 2017-06-08T14:13:30 822 /Applications/EVE Launcher.app/Contents/MacOS/evelauncher evelauncher default "Assertion failed: (!err), function New_PlugIn, file /Applications/buildAgent/work/3698a4f6f0fc2ed5/source/RazerManOWar7.1Audio/TwinkleMac/NahimicAPO_Mac/NahimicAPO_Mac/Source/APO_PlugIn.mm, line 1751."
info 2017-06-08T14:22:53 822 /Applications/EVE Launcher.app/Contents/MacOS/evelauncher evelauncher default "err = 1 /Applications/buildAgent/work/3698a4f6f0fc2ed5/source/RazerManOWar7.1Audio/TwinkleMac/NahimicAPO_Mac/NahimicAPO_Mac/Source/mach_override.c:243"
info 2017-06-08T14:22:53 822 /Applications/EVE Launcher.app/Contents/MacOS/evelauncher evelauncher default "err = 1 /Applications/buildAgent/work/3698a4f6f0fc2ed5/source/RazerManOWar7.1Audio/TwinkleMac/NahimicAPO_Mac/NahimicAPO_Mac/Source/mach_override.c:257"
info 2017-06-08T14:22:53 822 /Applications/EVE Launcher.app/Contents/MacOS/evelauncher evelauncher default "err = 1 /Applications/buildAgent/work/3698a4f6f0fc2ed5/source/RazerManOWar7.1Audio/TwinkleMac/NahimicAPO_Mac/NahimicAPO_Mac/Source/mach_override.c:262"
info 2017-06-08T14:22:53 822 /Applications/EVE Launcher.app/Contents/MacOS/evelauncher evelauncher default "Assertion failed: (!err), function New_PlugIn, file /Applications/buildAgent/work/3698a4f6f0fc2ed5/source/RazerManOWar7.1Audio/TwinkleMac/NahimicAPO_Mac/NahimicAPO_Mac/Source/APO_PlugIn.mm, line 1751."



++++++++++++++++++

Ender Tunin
Adhocracy Incorporated
Adhocracy
#3 - 2017-06-09 03:03:18 UTC
I guess the easiest question is, is there a way to completely uninstall Eve without having to redownload the whole client? i.e. I've tried uninstalling/reinstalling EVE Launcher and it still has my account info in it, so something is escaping the uninstall. I've deleted what I think the wine directory, to force a reinstall, but gets reinstalled immediately on EVE Launcher startup. I've just not found a way to get a truly fresh install, which I think will fix my sound issues.
GM Mechanic
Game Masters
C C P Alliance
#4 - 2017-06-09 15:07:20 UTC
To completely remove EVE Online from your Mac and all it's settings Drag and drop EVE to the trash. Then please do the following.

* Open the finder.
* Press Command + shift + G to open go to folder.
* Copy and paste the following and press enter.

~/Library/Application Support

Now see if you can find two folder, CCP and EVE Online, and move those to the trash. This should completely remove EVE Online and all it's settings from your Mac.

With regards,

GM Mechanic,

CCP Customer Service | EVE Online | EVE Valkyrie

Ender Tunin
Adhocracy Incorporated
Adhocracy
#5 - 2017-06-09 18:26:37 UTC
OK, thanks. Game uninstalled.

On re-downloading the game I followed these instructions on the Mac Download page:

"If you want to download EVE on Windows in full up front, download the following file in addition to the installer above and place it in the same folder as the installer before running it. The installer will then extract the full set of resources for EVE from that file into the shared cache. Please have in mind that this file can be +7GB large."

I now have a file, "EVEResources.7z". I've redownloaded and started the EveLauncher, it's downloaded wine's files, and is now trying to redownload the 8 gigs worth of data again. I downloaded the file as above last night so it wouldn't have to do this again. Where exactly do I put the EVEResources.7z file so it doesn't have to be downloaded again? I currently have a copy of it both in "~/Downloads" and in "~/Applications", depending on your reading of the statement it's hard to determine which it goes in. Apparently both are not correct.

Thanks for your time and effort.
Ender Tunin
Adhocracy Incorporated
Adhocracy
#6 - 2017-06-09 19:35:57 UTC
Original problem solved. Razer Synapse was highjacking everything having to do with sound in Eve. Uninstalling it fixed sound in Eve.

The reinstall wasn't a bad thing. I'm sure there was lots of cruft laying around from previous upgrades. Hopefully the Jita crash will fix with this.

However, I am currently stuck downloading everything while I play. I previously downloaded the EVEResources7.z file. Should I be able to use this instead of all the current game downloads?