These forums have been archived and are now read-only.

The new forums are live and can be found at https://forums.eveonline.com/

Linux

 
  • Topic is locked indefinitely.
 

Issues with Fedora

Author
Gurney Madeveda
KarmaFleet
Goonswarm Federation
#1 - 2017-05-14 09:01:13 UTC
Running fedora 25. Trying to get eve to run but receive this error when I run ./evelauncher


This application failed to start because it could not find or load the Qt platform plugin "xcb"
in "".

Available platform plugins are: eglfs, linuxfb, minimal, minimalegl, offscreen, xcb.

Reinstalling the application may fix this problem.
Aborted (core dumped)


When I run ./evelauncher.sh it launches and tells me that there is a update. I click ok and it shuts down

I get this error in the terminal

[0514/035945:WARNING:resource_bundle.cc(291)] locale_file_path.empty() for locale 
Installed Qt WebEngine locales directory not found at location /home/usr/Downloads/evelauncher/translations/qtwebengine_locales. Trying application directory...
Qt WebEngine locales directory not found at location /home/usr/Downloads/evelauncher/qtwebengine_locales. Trying fallback directory... Translations MAY NOT not be correct.
[0514/035945:WARNING:resource_bundle.cc(291)] locale_file_path.empty() for locale
[S_API FAIL] SteamAPI_Init() failed; no appID found.
Either launch the game from Steam, or put the file steam_appid.txt containing the correct appID in your game folder.
nouveau: kernel rejected pushbuf: No such file or directory
nouveau: ch11: krec 0 pushes 1 bufs 2 relocs 0
nouveau: ch11: buf 00000000 00000002 00000004 00000004 00000000
nouveau: ch11: buf 00000001 00000006 00000004 00000000 00000004
./evelauncher.sh: line 12: 15782 Segmentation fault      (core dumped) $dirname/$appname "$@"
COMM4NDER
Legendary Umbrellas
#2 - 2017-05-15 21:42:50 UTC  |  Edited by: COMM4NDER
Gurney Madeveda wrote:
Running fedora 25. Trying to get eve to run but receive this error when I run ./evelauncher


This application failed to start because it could not find or load the Qt platform plugin "xcb"
in "".

Available platform plugins are: eglfs, linuxfb, minimal, minimalegl, offscreen, xcb.

Reinstalling the application may fix this problem.
Aborted (core dumped)


When I run ./evelauncher.sh it launches and tells me that there is a update. I click ok and it shuts down

I get this error in the terminal

[0514/035945:WARNING:resource_bundle.cc(291)] locale_file_path.empty() for locale 
Installed Qt WebEngine locales directory not found at location /home/usr/Downloads/evelauncher/translations/qtwebengine_locales. Trying application directory...
Qt WebEngine locales directory not found at location /home/usr/Downloads/evelauncher/qtwebengine_locales. Trying fallback directory... Translations MAY NOT not be correct.
[0514/035945:WARNING:resource_bundle.cc(291)] locale_file_path.empty() for locale
[S_API FAIL] SteamAPI_Init() failed; no appID found.
Either launch the game from Steam, or put the file steam_appid.txt containing the correct appID in your game folder.
nouveau: kernel rejected pushbuf: No such file or directory
nouveau: ch11: krec 0 pushes 1 bufs 2 relocs 0
nouveau: ch11: buf 00000000 00000002 00000004 00000004 00000000
nouveau: ch11: buf 00000001 00000006 00000004 00000000 00000004
./evelauncher.sh: line 12: 15782 Segmentation fault      (core dumped) $dirname/$appname "$@"


Its an issue with openssl, you need a compability version and preload it, check other threads about this and you will find your solution.

Check; https://forums.eveonline.com/default.aspx?g=posts&t=482663&p=31

[url=https://github.com/CommanderAlchemy/.bin/blob/master/eve] EVE - Online Launcher [Linux] [/url] Installs, launches character prefixes (both SISI & Tranquility). Simplescreenrecorder shm inject