These forums have been archived and are now read-only.

The new forums are live and can be found at https://forums.eveonline.com/

Linux

 
  • Topic is locked indefinitely.
 

can't start eve after update to ubuntu 17.04 and wine 2.5

Author
guigui lechat
the no fock given
#1 - 2017-04-18 20:46:25 UTC  |  Edited by: guigui lechat
I upgraded to 17.04 this morning, then I added the wine hq build ( sudo apt-add-repository https://dl.winehq.org/wine-builds/ubuntu/ ) and updated my packages

now I have a beautiful "can't find file" when lmauncing the launcher.
When I try the network diagnostics all fail

maybe the new wine (2.5-staging) has issues ?
It may be related to the new ubuntu dns https://wiki.ubuntu.com/ZestyZapus/ReleaseNotes " The default DNS resolver is now systemd-resolved. "
guigui lechat
the no fock given
#2 - 2017-04-18 21:04:02 UTC
replaced winehq-staging by wine-stable (2.0.0) and still same issue. seems like a network issue.
guigui lechat
the no fock given
#3 - 2017-04-18 22:00:43 UTC
sudo apt install libnss-resolve:i386


FFS !
Adara Starkiss
Blackstone Holdings
Sev3rance
#4 - 2017-04-19 05:43:59 UTC
I personally have never upgraded my Ubuntu distro... as long as it works I stay on the same one. If for some reason I need to upgrade, I back up and nuke my installation and start from scratch.

Im using Wine 2.4staging and its working good for me, but Im on 15.04.

Ubuntu Mate 16.04.2 64bit // Amd A8-5600K with RX460 4GB // 6GB DDR3 // Sandisk 120GB SSD Plus // Wine Stable 2.01 // Native Linux Launcher // TS3 working // Happy to be back in Ubuntu :)

guigui lechat
the no fock given
#5 - 2017-04-19 19:37:05 UTC
I do the same with children. My wife doesnt like it, but I am confident she will get used to it.
Labarna Hattusillas
Brave Newbies Inc.
Brave Collective
#6 - 2017-04-20 02:52:44 UTC
guigui lechat wrote:
sudo apt install libnss-resolve:i386


FFS !


Thanks so much, this was driving me crazy. It affects steam too, none of my steam games were updating.
3psylon
Avalon Flying Circus
Advent of Fate
#7 - 2017-04-22 21:26:56 UTC
After update to ubuntu 17.04 i can login but when i chose pg i receive black window.

Ubuntu 17.04 and wine 2.0.1

Some ideas?
Bud Friedman SaidHi
SaidHi LLC
#8 - 2017-04-23 23:05:49 UTC
I upgraded to 17.04 yesterday and the launcher stopped working for me. I have an older laptop with the 560M Nvidia chipset. In my case, the upgrade process re-asserted the nouveau, and for some reason the launcher doesn't seem to work well with it on my machine. The obvious solution was to install the Nvidia drivers, but for some reason the nouveau driver wouldn't completely go away.

Here's what I did:

1) reboot ubuntu, at the login screen go to console Ctrl + alt + F1
2) login with an account that has root privileges, which is probably your standard user account
3) run sudo service lightdm stop
4) Follow the steps outlined here: http://www.allaboutlinux.eu/remove-nouveau-and-install-nvidia-driver-in-ubuntu-15-04/
- HOWEVER, the part where he says to go to nvidia.com to get the driver, instead call this command:
- wget http://us.download.nvidia.com/XFree86/Linux-x86_64/381.09/NVIDIA-Linux-x86_64-381.09.run

6) then run chmod u+x NVIDIA-Linux-x86_64-381.09.run

7) run sudo NVIDIA-Linux-x86_64-381.09.run
8) agree to everything, OK everything, etc.
9) at the conclusion of the process, run sudo reboot


In my case, by following these steps, the evelauncher was able to load up and not crash
3psylon
Avalon Flying Circus
Advent of Fate
#9 - 2017-04-24 20:02:35 UTC
Bud Friedman SaidHi wrote:
I upgraded to 17.04 yesterday and the launcher stopped working for me. I have an older laptop with the 560M Nvidia chipset. In my case, the upgrade process re-asserted the nouveau, and for some reason the launcher doesn't seem to work well with it on my machine. The obvious solution was to install the Nvidia drivers, but for some reason the nouveau driver wouldn't completely go away.

Here's what I did:

1) reboot ubuntu, at the login screen go to console Ctrl + alt + F1
2) login with an account that has root privileges, which is probably your standard user account
3) run sudo service lightdm stop
4) Follow the steps outlined here: http://www.allaboutlinux.eu/remove-nouveau-and-install-nvidia-driver-in-ubuntu-15-04/
- HOWEVER, the part where he says to go to nvidia.com to get the driver, instead call this command:
- wget http://us.download.nvidia.com/XFree86/Linux-x86_64/381.09/NVIDIA-Linux-x86_64-381.09.run

6) then run chmod u+x NVIDIA-Linux-x86_64-381.09.run

7) run sudo NVIDIA-Linux-x86_64-381.09.run
8) agree to everything, OK everything, etc.
9) at the conclusion of the process, run sudo reboot


In my case, by following these steps, the evelauncher was able to load up and not crash


I've ATI R9 380 and there are not new driver for it in ubuntu 17.04

The problem is only with the Linux launcher, if i use the launcher istalled with PoL the game run