These forums have been archived and are now read-only.

The new forums are live and can be found at

EVE Technology Lab

  • Topic is locked indefinitely.

Can not get skills -> Invalid token

Aeriis Praesentia
#1 - 2017-01-20 20:07:21 UTC  |  Edited by: Aeriis Praesentia

Im trying to get Skills for my character using this endpoint

The app is using this for getting the right scope and authorize:


And when I authenticate for allowing the apps permissions it states that my app wants to have access to:
read_skillqueue and read_skills

But when i fire the call above I get

01-20 20:48:00.386 3615 3977 I ReactNativeJS: {"error": "SSO responded with a 400: Invalid token"}

I also tried to refresh my access token (which is succefull) but the above code still fails....

Here is part of my get call:

                method: 'Get',
                headers: {
                    Authorization: `Bearer ${'access_token'}`,

Any suggestions is most appreciated!
Aeriis Praesentia
#2 - 2017-01-21 12:45:25 UTC
Found the issue :) And i'm abit ashamed.... Roll

Authorization: `Bearer ${'access_token'}`,

sent the following
Bearer access_token


 `Bearer ${'access_token'}`
did not use the variable.... it sent it as string "access_token"

so by sending

 `Bearer ${access_token}`
it worked cause now it sends the real access_token Lol