These forums have been archived and are now read-only.

The new forums are live and can be found at https://forums.eveonline.com/

Linux

 
  • Topic is locked indefinitely.
 

Snorlauncher & custom wine

Author
Neuntausend
Rens Nursing Home
#1 - 2016-12-07 00:30:04 UTC
So far I have used the Snorlauncher with my own wine build, and that worked just fine. However, by the looks of things it broke today. Eve starts up fine when I use one of the CCP builds, but when I check the "Custom Wine" checkbox and put in the wine path (neither "wine" nor "/usr/bin/wine" seems to work) nothing happens when I click the launch button.

My wine build works, and I can for example start the exefile.exe with it, but the launcher does not want to cooperate anymore. I would like to keep using my own build, though, as it allows me to enable CSMT or gallium nine support.

The launcher log contains the following:

2016-12-07T01:27:13.617Z    default    debug    "wine client error:0: version mismatch 504/524."
2016-12-07T01:27:13.617Z    default    debug    "Your wineserver binary was not upgraded correctly,"
2016-12-07T01:27:13.617Z    default    debug    "or you have an older one somewhere in your PATH."
2016-12-07T01:27:13.617Z    default    debug    "Or maybe the wrong wineserver is still running?"
2016-12-07T01:27:13.617Z    default    debug    Process 3879 finished with exit code 1


Bug or PEBCAK?
Zerzzes Markarian
McCloud and Markarian Trade and Logistics Corp.
#2 - 2016-12-07 09:24:29 UTC
The Linux launcher stopped working for me today as well. I always get a segmentation fault.
Ami Sentokia
The Cruciform
Keep Calm and Parley
#3 - 2016-12-07 09:34:00 UTC
i solved the issue by deleting SharedCache/winenv and SharedCache/wine. You also (sadly) have to set your WINEPREFIX to SharedCache/wineenv and run winecfg/winetricks with that env setting. Make sure you backup all your game and overview settings ... i deleted mine which was annoying.
Neuntausend
Rens Nursing Home
#4 - 2016-12-07 13:04:51 UTC
Thanks, that worked. I deleted everything in ~/.eve/ except ResFiles/ and wineenv/drive_c/users/ and even kept all my settings.
FerroTiC
Z3R0 Return Mining Inc.
Illusion of Solitude
#5 - 2016-12-07 19:43:57 UTC  |  Edited by: FerroTiC
Ami Sentokia's solution worked for me.

However I managed to launch the game with only renaming/deleting '~/.eve/wine/' and not touching any other folders in ~/.eve/. That way you keep all the overview and game settings intact. Might not work for everyone.
Roesjka
The Last Solution Inc
#6 - 2016-12-08 22:24:02 UTC  |  Edited by: Roesjka
Ok to summarize steps to be taken when on Debian testing/stretch and using wine-staging,
might also be helpful for ppl on other distro's.

Check if you have still installed libssl1.0.2, normally libssl1.0.2_1.0.2j-4 should still be installed,
otherwise reinstall it from Debian testing/stretch or your distro's repo..

Make a symlinks in the evelauncher directory:
ln -s /usr/lib/x86_64-linux-gnu/libssl.so.1.0.2 libssl.so
ln -s /usr/lib/x86_64-linux-gnu/libcrypto.so.1.0.2 libcrypto.so

In case you are running into the wineserver mismatch versions rename SharedCache/wine/bin/wineserver to wineserver.org or just remove it.

I can now launch and run EVE with my custom wine-staging 1.9.23 but might also help with other wine versions.

Thx guys for giving me the pointers to get it working again.

Cheers

Cheers,

Retired UNIX/Linux IT Specialist.

AsRock 990FX Extreme4, FX-8320, 16GB mem, GTX 1070

y50-70, i7, 16GB mem, GTX 860M

Both running Debian stretch 64bit