These forums have been archived and are now read-only.

The new forums are live and can be found at https://forums.eveonline.com/

Skill Discussions

 
  • Topic is locked indefinitely.
 

Boosters don't do anything?

Author
Ora Boreshaa
Brutor Tribe
Minmatar Republic
#1 - 2016-07-12 00:23:00 UTC
Bought and used one of the ouroboros boosters on a character. 14H to Destroyer V before using it, 14H to Destroyer V after using it.

Am I missing something?
Tau Cabalander
Retirement Retreat
Working Stiffs
#2 - 2016-07-12 20:45:42 UTC
Remove the skill from the queue and re-add it.
Chan'aar
State War Academy
Caldari State
#3 - 2016-07-16 11:34:34 UTC
I'm having this issue as well.

Training Capital Ships 5. Was taking 46 days.

After booster, still taking 46 days.

I have removed all skills from the queue, hit apply, added the skill back in .. no difference.

I have tried removing skills and leaving the ship, no difference.

I have tried removing the skills then logging out and back in before adding the skills back in.

I wonder if it is a display issue?
Abra Ka Dabra
FOUR HORSEMAN SYNDACATE
O.U.Z.O. Alliance
#4 - 2016-08-23 20:55:54 UTC
Has the serpentis thing finished now??

The implant had to be used before the thing finished.
Tau Cabalander
Retirement Retreat
Working Stiffs
#5 - 2016-08-25 21:03:54 UTC
Abra Ka Dabra wrote:
Has the serpentis thing finished now??

The implant had to be used before the thing finished.

Really?

Heck, I never saw that mentioned anywhere Cry

What a waste.
Morgan Agrivar
Doomheim
#6 - 2016-09-04 02:38:34 UTC
Christopher Mabata
Sentinel Incorporium
#7 - 2016-09-11 16:48:16 UTC
Throw em in the crate with the anaconda mines

♣ Small Gang PVP, Large Fleet PVP, Black Ops, Incursions, Trade, and Industry ♣ 70% Lethal / 30% Super-Snuggly / 110% No idea what im doing ♣

This Message Brought to you by a sweet and sour bittervet