These forums have been archived and are now read-only.

The new forums are live and can be found at https://forums.eveonline.com/

Macintosh

 
  • Topic is locked indefinitely.
 

January release - Mac feedback and issues

First post
Author
CCP Phantom
C C P
C C P Alliance
#1 - 2016-01-12 10:38:16 UTC  |  Edited by: CCP Logibro
The January release has been deployed on January during a regular downtime. Please use this thread for general discussion and to report issues with the release on the Mac.

This release brought an Electronic Warfare effects bar and the new Tronhadar Ink SKIN line starting with Minmatar hulls, as well as, improvements to the new star map and further enhancements to the opt-in camera controls. Additionally, numerous smaller, yet not less important tweaks, fixes and improvements have been deployed. And finally new CREST options have been introduced which allows for better third party tools.

The full details of all changes and improvements are available in the January release patch notes.

For general discussion of this release on the PC, please use the general feedback thread.
To report release related issues on the PC, please post in the PC issues thread.

CCP Phantom - Senior Community Developer

Ransu Asanari
V0LTA
WE FORM V0LTA
#2 - 2016-01-12 12:06:00 UTC  |  Edited by: Ransu Asanari
[moved]
Noene Drops
Deep Chain Diving
#3 - 2016-01-12 14:03:23 UTC
Quote:
New map:
- Removed star field
- Increased visible range of jump lines and markers

Unfortunately there is still a star field in the background of the new map and lines are barely visible.
Lizzie Lefthand Marstolt
Aperture Interstellar Innovations
#4 - 2016-01-12 14:22:47 UTC
Game still freezing for 15-60s after jumping through gates. Bug report submitted: EBR-63101
Manssell
OmiHyperMultiNationalDrunksConglomerate
Together We Solo
#5 - 2016-01-12 16:37:34 UTC
So no where in the patch notes does it mention the new impact effects for ships being finally released for us Mac users (unless I missed something). When they came out during the last patch CCP Darwin made it seem like they had just missed getting the release of the new effects for the mac.
https://forums.eveonline.com/default.aspx?g=posts&m=6217683#post6217683

Yet here we are a full patch cycle latter and still no impact effects? I'm guessing then that CCP Darwin's original comment was underplaying the problem and you really can't get these to work for you mac customers?
Winnefuego Daytona
Phoenix Enterprise Inc
From The Ashes.
#6 - 2016-01-13 04:46:30 UTC
I'm getting freezes A LOT more frequently now. Before the patch I had gotten them down to maybe once a day but now loading any none pilot windows (market, training schedule, etc.) results in a crash.

My client also freezes after about 5-10 minutes of farming. I'm playing in a window on a macbook pro, with my graphic config set to memory performance. The game freezes and normally results in a socket error if I wait around long enough.

Full computer specs: https://support.apple.com/kb/SP704



carynn
School of Applied Knowledge
Caldari State
#7 - 2016-01-14 02:41:08 UTC
Since yesterday I've had four crashes with an "Exception Raised" error and a request to submit a crash report.

I'm running a new hi-end iMac....
Amarisen Gream
Pleasant Peninsula Productions
Digital Vendetta
#8 - 2016-01-14 06:31:59 UTC
Looks like I need to do more testing - played for an hour or so yesterday - logged due to high level of red traffic.
Two clients
Had main client open Market - normal 10-30 second delay. Opened industrial window, normal delay. Never undocked. Check skill queue.
Had Alt client do pretty much the same, but undocked and killed some rats. No issues.

I don't use the IGB, even with the fix CCP gave @ https://forums.eveonline.com/default.aspx?g=posts&t=453546&p=6
Page 6 post 117
I still get errors or did and just refuse to retry. Easier to just use Safari.

Are you all that are suffering crashes using full or window mode. Do you have App Nap disabled for EVE.
As I have the day off, I will try to run my game through some stuff to try to crash it. If I can't crash it. I will post my congfig and settings.

"The Lord loosed upon them his fierce anger All of his fury and rage. He dispatched against them a band of Avenging Angels" - The Scriptures, Book II, Apocalypse 10:1

#NPCLivesMatter #Freetheboobs

Winnefuego Daytona
Phoenix Enterprise Inc
From The Ashes.
#9 - 2016-01-15 14:49:55 UTC
Yesterday I bought an ethernet cable and adapter and it RESOLVED the issue I was having with game freezes and disconnects. It seems like Eve just isn't meant to be played over Wifi. Cry

I DID receive a few crashes with the following error on the network at work, which I HAVEN'T been able to reproduce at home. https://www.dropbox.com/s/wnfbegx7b6rty2l/Screenshot%202016-01-13%2020.34.55.png?dl=0

Otherwise, I'm a happy camper. Thanks! PirateBearBlink
Nometh Xergent
#10 - 2016-01-18 23:28:58 UTC
Manssell wrote:
So no where in the patch notes does it mention the new impact effects for ships being finally released for us Mac users (unless I missed something). When they came out during the last patch CCP Darwin made it seem like they had just missed getting the release of the new effects for the mac.
https://forums.eveonline.com/default.aspx?g=posts&m=6217683#post6217683

Yet here we are a full patch cycle latter and still no impact effects? I'm guessing then that CCP Darwin's original comment was underplaying the problem and you really can't get these to work for you mac customers?

Yeah, and still no visual on reppers aswell. And no answers either....

“I’ve always loathed the necessity of sleep. Like death, it puts even the most powerful men on their backs.”

U7evel
Zero-Tax-Best-Tax
#11 - 2016-01-21 16:12:43 UTC
anyone gets a network error?

since today i have a message that pops up saying:

"An error was encountered while downloading (see log for details ). Do you want to run network diagnostics?"

I would like to attach the log file, but it is empty. I did the diagnostic but that has no change and it looks like the network it self is actually ok.

i filed a bug report issue ID: EBR-64512

thx for fixing the IGB..that is awesome...keep up CCP

Big smile
Fee Seize
Brutor Tribe
Minmatar Republic
#12 - 2016-01-21 16:32:02 UTC  |  Edited by: Fee Seize
Getting the same error as U7evel. Started with a clean installation and continuous "An error was encountered while downloading (see log for details). Do you want to run network diagnostics?" Diagnostics are fine. I can't find the logs, there's nothing in the Application bundle and I don't see them anywhere else I've thought to look. Download did seem to complete and a launcher restart gives the same error every time. Client runs as usual, but the modal dialog pop-ups are difficult to work around.

I LIKE the new launcher except for this one issue.

EDIT: I found the log files at ~/Library/Application Support/CCP/EVE/Launcher

Here's the relevant issue:
2016-01-21T11:32:11.922Z debug refreshServers ""
2016-01-21T11:32:11.922Z debug Calling refresh on "tq"
2016-01-21T11:32:11.956Z debug Scheduled task "Patch info downloader for Tranquility"
2016-01-21T11:32:11.956Z debug Starting task "Patch info downloader for Tranquility"
2016-01-21T11:32:11.956Z debug "Patch info downloader for Tranquility" go: 0
2016-01-21T11:32:12.161Z debug Finished task "Patch info downloader for Tranquility"
2016-01-21T11:32:12.161Z debug refreshServers "tq"
2016-01-21T11:32:12.161Z debug Calling refresh on "sisi"
2016-01-21T11:32:12.162Z debug Scheduled task "Patch info downloader for Singularity"
2016-01-21T11:32:12.162Z debug Starting task "Patch info downloader for Singularity"
2016-01-21T11:32:12.162Z debug "Patch info downloader for Singularity" go: 0
2016-01-21T11:32:12.368Z debug Finished task "Patch info downloader for Singularity"
2016-01-21T11:32:12.368Z debug Scheduled task "Cider version downloader for Singularity"
2016-01-21T11:32:12.368Z debug Starting task "Cider version downloader for Singularity"
2016-01-21T11:32:12.368Z debug "Cider version downloader for Singularity" go: 0
2016-01-21T11:32:12.485Z debug Finished task "Cider version downloader for Singularity"
2016-01-21T11:32:12.485Z error "Error downloading https://binaries.eveonline.com/eveonline_mac_999630.json - server replied: Forbidden"
2016-01-21T11:32:12.485Z warning Update failed for "Singularity" with error: 2
2016-01-21T11:32:12.485Z error "sisi" update failed with a download error


Can't post the actual JSON that comes back, but here's the relevant info:

Error:
Code: AccessDenied
Message: Access Denied
RequestId: C2F3F5773170924F
HostId: oepJLVLzTRLsd1hL5xjQxZluw9EoqEDSIiJq65Syc+dMWSDuocurf7fWTdzlksxnPuwHeeU6hjY=
Akeicher Kaparov
Enigmatic Pixelators
Blind Squirrels
#13 - 2016-01-21 21:41:27 UTC
I have the same problem, as I'm a noob i just feel myself around.
I disabeld both test servers on my launcher and got rid of the error since it's no longer trying to patch the test servers.

It's not fixed but it helps with the annoying bug report and the game is playable so far.
Planeten Schreck
The Scope
Gallente Federation
#14 - 2016-01-22 06:20:52 UTC
U7evel wrote:
anyone gets a network error?

since today i have a message that pops up saying:

"An error was encountered while downloading (see log for details ). Do you want to run network diagnostics?"

I would like to attach the log file, but it is empty. I did the diagnostic but that has no change and it looks like the network it self is actually ok.

i filed a bug report issue ID: EBR-64512

thx for fixing the IGB..that is awesome...keep up CCP

Big smile


Same for me, Bug report send.
Ruthless eficiency
Garoun Investment Bank
Gallente Federation
#15 - 2016-01-28 13:54:57 UTC  |  Edited by: Ruthless eficiency
Verification failure after new patch.

"Your EVE client installation may have modified, damaged or corrupt files. Please run repair.exe located in the EVE game directory or re-install the game client.
Verification failed: 'C:\tq\resfileindex.txt', crc:b637bf39, expected:2535de8d."

Typically I fix these issues by deleting that particular file and letting launcher repair/redownload it. It seems, however, that the directories/file paths have changed and I can't locate the transgaming file to start this method. Where is the transgaming file now located?

Edit 1: A reinstall did not solve the issue.
Edit 2: Apparently it was a cache issue, verify seems to have fixed the issue.
Maya DeReneau
Amazing Super Slackers
Requiem Eternal
#16 - 2016-01-29 23:49:35 UTC
Lizzie Lefthand Marstolt wrote:
Game still freezing for 15-60s after jumping through gates. Bug report submitted: EBR-63101


Same for me. It doesn't always happen, but it's probably close to 50% of the times I jump. There are delays opening the market, industry, get info on anything etc., but those I can tolerate. This really makes the game hard to play anywhere but highsec. There seem to be two separate delays: one for the overview to show anything and one for my d-scan window (always open) to update. I can't do anything until both happen and it can take up to a minute, using up the entire cloak timer. Local seems to update before the client is responsive so I can see if the system is full of hostiles, I just can't do anything about it. If I was in a fleet trying to move fast I'd be left behind. It also takes a long time to start the client sometimes and I just put it in the background and do something else for a while. Also maybe 15% of the time when I undock for the first time after logging in the client crashes. That bug has been there for a few months and it used to be more like 25% so I guess there's an improvement. At least the IGB works again.
Amarisen Gream
Pleasant Peninsula Productions
Digital Vendetta
#17 - 2016-02-04 08:18:23 UTC
Just rereading all the feed back - it seems so weird that so many people (assuming more than those who post here and in other parts of the forum) have so many issues when the system they use is so controlled.

I have been trying to get a new internet provider, but the installation team seems to be made up of monkeys with the owners being a baboon.
Even though I don't have as many issues as others, I have need to do a complete system reinstall (my SMC is stupid and the Apple fix doesn't work)
I wonder which parts of the hardware effect everyone. When posting, would you all be willing to incliud your computers configs?

"The Lord loosed upon them his fierce anger All of his fury and rage. He dispatched against them a band of Avenging Angels" - The Scriptures, Book II, Apocalypse 10:1

#NPCLivesMatter #Freetheboobs

Lelira Cirim
Doomheim
#18 - 2016-02-08 19:36:31 UTC  |  Edited by: Lelira Cirim
Well I am not certain if this thread or the new Cider thread is better....

At this point I can now feel confident that the EVE client will cause a kernel panic on my primary machine (mid 2011 iMac with 10.11.2). It is purely a matter of time leaving the client running, no matter what I am doing or other apps running.

Other games in the past have done this as well, but much faster (within 30-60 minutes). A couple of OSX versions ago, a Quicktime memory leak was the biggest culprit in my kernel panics.

Because it is not apparent to me that the system crash report is identifying the EVE client in its output, I'm wondering if I should start sending these logs directly, instead of trusting Apple to inform their parties (or solve the panic themselves).

Do not actively tank my patience.