These forums have been archived and are now read-only.

The new forums are live and can be found at https://forums.eveonline.com/

EVE Technology Lab

 
  • Topic is locked indefinitely.
12Next page
 

phpBB 3.x.x API Mod Revisited

Author
Mr Twinkie
Dreddit
Test Alliance Please Ignore
#1 - 2015-11-04 09:17:00 UTC  |  Edited by: Mr Twinkie
phpBB 3.x.x API Mod Revisited


This is a phpBB3.0.14 mod that is a continuation of the great mod made by Cyerus. This is done with his blessing as he no longer has the time to maintain it.

https://github.com/shibdib/API-Registration-Mod-Revisited

The mod is hosted on github so as to allow everyone including Cyerus to contribute!

--

Original posthttps://forums.eveonline.com/default.aspx?g=posts&t=21281&find=unread

Quote:
This modification for phpBB 3.x allows integration of the EVE Online API into the forum, creating a way to filter registrations (cronjob for already registered members on scheduled intervals).
In other words, with this set of tools you can define which criteria characters (players) must have in the world of EVE in order to be (and stay) a member of your forum.

None, One, or Multiple Corporations
None, One, or Multiple Alliances
Standings (Terrible, Bad, Neutral, Good, Excellent)
Faction Warfare (Amarr, Caldari, Gallente, Minmatar)
...or a mixture of the above.


With this new release you will also be able to integrate TeamSpeak 3 using the settings above, making this mod a valuable package. Other things included are, but not limited to;

Ship fitting mod, including ingame linking and EFT export
EVE Portrait as forum Avatar
Linking of items and solarsystems within ingame browser
Stable and feature rich forum environment for you, your friends, or even your enemies..
...and much, much more!

~Cyerus


If you need help installing I'll do a fresh install for 1b just message me. If you have any issues just post here or post a bug in github and I'll do my best to get it fixed!!
Mr Twinkie
Dreddit
Test Alliance Please Ignore
#2 - 2015-11-04 17:36:45 UTC  |  Edited by: Mr Twinkie
Current Full Release - 7.0.7

Latest DB Update - 7.0.7
Cymion
Ministry of War
Amarr Empire
#3 - 2015-11-06 07:51:02 UTC
So I have to ask, is this being upgraded for the latest version of phpbb 3.1.x or still only for 3.0.x

Wake early if you want another man's life or land. No lamb for the lazy wolf. No battles won in bed.

Mr Twinkie
Dreddit
Test Alliance Please Ignore
#4 - 2015-11-06 09:20:09 UTC  |  Edited by: Mr Twinkie
Cymion wrote:
So I have to ask, is this being upgraded for the latest version of phpbb 3.1.x or still only for 3.0.x



Automod is not being added to 3.1 so this cannot be upgraded to it.

I do plan on making something similar tho once I'm happy that this is stable.
Palmbeach
Suicidal Decisions
#5 - 2015-11-08 21:36:04 UTC  |  Edited by: Palmbeach
I updated from Cyerus API Mod and phpBB 3.0.12 to your version and 3.0.14.
I found a bug in the Registration Form: http://clip2net.com/clip/m334665/a19f5-clip-23kb.png
I can register a new User if I fill out both API forms.


And i still have the same Password problem with Openfire. Lol

Reagrds
Mr Twinkie
Dreddit
Test Alliance Please Ignore
#6 - 2015-11-08 23:39:28 UTC
Palmbeach wrote:
I updated from Cyerus API Mod and phpBB 3.0.12 to your version and 3.0.14.
I found a bug in the Registration Form: http://clip2net.com/clip/m334665/a19f5-clip-23kb.png
I can register a new User if I fill out both API forms.


And i still have the same Password problem with Openfire. Lol

Reagrds


What password problem?
Palmbeach
Suicidal Decisions
#7 - 2015-11-09 08:48:43 UTC
Mr Twinkie wrote:


What password problem?


If a User is newly registred on Openfire he gets an 6Letter Random Password and not his own.

Openfire, Version: 3.10.2
User Service 2.0.2
Mr Twinkie
Dreddit
Test Alliance Please Ignore
#8 - 2015-11-09 13:31:35 UTC
Palmbeach wrote:
Mr Twinkie wrote:


What password problem?


If a User is newly registred on Openfire he gets an 6Letter Random Password and not his own.

Openfire, Version: 3.10.2
User Service 2.0.2



This isn't so much a bug but I can see about switching it to using the forum password or creating a password change page.
vipeer
Infinite Point
Test Alliance Please Ignore
#9 - 2015-11-11 11:28:52 UTC
Please make it use the same password for all the services.
And preferably also make it so if you change password in Forum it will also change for the other services.

Thanks for your hard work and your commitment!
Mr Twinkie
Dreddit
Test Alliance Please Ignore
#10 - 2015-11-14 22:26:32 UTC
vipeer wrote:
Please make it use the same password for all the services.
And preferably also make it so if you change password in Forum it will also change for the other services.

Thanks for your hard work and your commitment!


I've got this halfway working, once I get some more time to sit down with it I'll push something out.
Dharr Guartonzec
Non-Sedentary
T U A R E G
#11 - 2015-11-15 22:05:09 UTC  |  Edited by: Dharr Guartonzec
When a user registers, he gets an SQL error message. Same issue was already with the Mod from Ceyrus. Also happens when a user does something with his account, like setting new password.

General Error

SQL ERROR [ mysqli ]

You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near '' at line 4 [1064]

An SQL error occurred while fetching this page. Please contact the Board Administrator if this problem persists.

Any idea?

Apache error log is empty. It is a fresh installed VPS.

PHP Version 5.5.9-1ubuntu4.14

MySQL server version 5.5.46

-Dharr Guartonzec-

CEO of Non-Sedentary

Mr Twinkie
Dreddit
Test Alliance Please Ignore
#12 - 2015-11-16 00:12:53 UTC
Dharr Guartonzec wrote:
When a user registers, he gets an SQL error message. Same issue was already with the Mod from Ceyrus. Also happens when a user does something with his account, like setting new password.

General Error

SQL ERROR [ mysqli ]

You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near '' at line 4 [1064]

An SQL error occurred while fetching this page. Please contact the Board Administrator if this problem persists.

Any idea?

Apache error log is empty. It is a fresh installed VPS.

PHP Version 5.5.9-1ubuntu4.14

MySQL server version 5.5.46


I've never gotten that error, does it specify which file is giving the error? Line 4 doesn't help much when I don't know which file.
Dharr Guartonzec
Non-Sedentary
T U A R E G
#13 - 2015-11-16 11:38:33 UTC
Sadly no. I was also expecting at least to get a file / module or syntax in that error but NOPE. :/

Can i activate some extra logging somewhere? I'm no php pro so, every help is appreciated.

-Dharr Guartonzec-

CEO of Non-Sedentary

Lars Wolfgang
Doomheim
#14 - 2015-11-16 13:23:19 UTC
Palmbeach wrote:
I found a bug in the Registration Form: http://clip2net.com/clip/m334665/a19f5-clip-23kb.png


I am seeing this as well, I assume it has been in place since I upgraded to 7.0.6, but I was not aware until it was reported to me last Friday.


∴ "Virtus junxit, mors non separabit", I am but a traveling man...

Dharr Guartonzec
Non-Sedentary
T U A R E G
#15 - 2015-11-16 14:17:22 UTC  |  Edited by: Dharr Guartonzec
My issue is fixed. my bad. i forgot to setup at least one group Oops

-Dharr Guartonzec-

CEO of Non-Sedentary

Staysin Jita
#16 - 2015-11-16 17:33:51 UTC
Lars Wolfgang wrote:
Palmbeach wrote:
I found a bug in the Registration Form: http://clip2net.com/clip/m334665/a19f5-clip-23kb.png


I am seeing this as well, I assume it has been in place since I upgraded to 7.0.6, but I was not aware until it was reported to me last Friday.




Actually....

Would this be possible to add as a feature?

1. An 'ADD +' button to add API Keys for Alts (without them going through the verification process - just to have them stored in the database and for the API Keys to be seen on the back end.)
This could also go in the profiles to add more api keys.

2. An Option in admin to add Corp Tickers to the Usernames, and/or to add the Corp and/or Alliance name under the Avatars in the forum (similar to this forum)

3. Adding the 2 missing items to the API Key options in the access mask - I think its bookmarks and chat tabs missing

4. Possibly the ability to automatically create groups when you add corps or alliances in the settings.

5. My personal favourite... adding verification for Mumble as well as TS to the back end.
Staysin Jita
#17 - 2015-11-18 11:16:10 UTC  |  Edited by: Staysin Jita
Staysin Jita wrote:


Would this be possible to add as a feature?

1. An 'ADD +' button to add API Keys for Alts (without them going through the verification process - just to have them stored in the database and for the API Keys to be seen on the back end.)
This could also go in the profiles to add more api keys.

2. An Option in admin to add Corp Tickers to the Usernames, and/or to add the Corp and/or Alliance name under the Avatars in the forum (similar to this forum)

3. Adding the 2 missing items to the API Key options in the access mask - I think its bookmarks and chat tabs missing

4. Possibly the ability to automatically create groups when you add corps or alliances in the settings.

5. My personal favourite... adding verification for Mumble as well as TS to the back end.



Hmmm... It just got even more interesting..

https://community.eveonline.com/news/dev-blogs/save-ship-fittings-to-eve-online-from-kill-boards-and-external-applications/

possibilities??
Dharr Guartonzec
Non-Sedentary
T U A R E G
#18 - 2015-11-19 16:59:49 UTC
Question:

Am i just blind or does this mod not include the ship fitting and system / item linking feature from Cyerus original mod ?

if it is included, sorry for my noobness but where can i activate it?

-Dharr Guartonzec-

CEO of Non-Sedentary

Lyron-Baktos
The Scope
Gallente Federation
#19 - 2015-11-22 16:46:30 UTC
Any chance of getting a CTA count down timer mod for phpBB forums?
Annexe
I N E X T R E M I S
Tactical Narcotics Team
#20 - 2015-11-24 02:06:31 UTC
Hi, I need a bit of help.

I can't get the fitting mod to work anymore.

The bbcode is set up, but when I post a fit with the tags, it is not showing the fitting mod image.
It just posts it as text;

[evefit][Taranis, Taranis]

Damage Control II
Magnetic Field Stabilizer II
Small Ancillary Armor Repairer, Nanite Repair Paste

1MN Monopropellant Enduring Afterburner
Warp Scrambler II
Fleeting Propulsion Inhibitor I

Small 'Knave' Energy Drain
Light Ion Blaster II, Caldari Navy Antimatter Charge S
Light Ion Blaster II, Caldari Navy Antimatter Charge S
Light Ion Blaster II, Caldari Navy Antimatter Charge S

Small Hybrid Burst Aerator I
Small Ancillary Current Router I[/evefit]

Item types and Systems still work. And past eve fittings still display correctly.
I have a feeling there is a php page or some link missing.

Any idea how I would fix this?

Annexe

ITAI - VIP

"i will pop your wreck with faction loot"

12Next page