These forums have been archived and are now read-only.

The new forums are live and can be found at https://forums.eveonline.com/

EVE Information Portal

 
  • Topic is locked indefinitely.
123Next pageLast page
 

Dev blog: Testing a new EVE Launcher

First post First post
Author
CCP Phantom
C C P
C C P Alliance
#1 - 2015-10-06 14:59:23 UTC  |  Edited by: CCP Phantom
A new version of the Launcher is available here.



Team RnB and Team Webster come with a first beta version of the new EVE Launcher. While this new launcher is still under development and not in its final state, we would like to share our progress with you and invite you to test this new launcher.

You already can test setting profiles, quick selection of the server (TQ, Singularity etc.), quick logon of multiple accounts and more.

Read all about this test version of the new Launcher in CCP Snorlax' latest dev blog Testing a new EVE Launcher.

We most welcome you to join this test! Please let us know what you like and what is still missing or not working, thank you.

CCP Phantom - Senior Community Developer

CCP raRaRa
C C P
C C P Alliance
#2 - 2015-10-06 15:04:20 UTC  |  Edited by: CCP Avalon
Reserved for Team Webster & Team RnB
We will try to answer questions related to the Web GUI (The main interface where you add accounts, click on play, etc).

Known issues updated 2015-10-23:

  • GUI - Authentication token expired ungracefully overnight, with no option of re-entering password
  • GUI - Background elements can be selected (website behavior)
  • GUI - Scroll bars show up red and/or mismatched in sizes when multiple accounts are added
  • GUI - Unlink account option is still displayed when only one account has been added
  • GUI - MOTD overlaps settings window
  • GUI - EULA buttons may appear under advertisement (work-around: resize launcher)
  • Launcher - does not minimize if you click on the icon in the taskbar
  • Launcher - doesn't have a unique icon in the taskbar
  • Settings - Changes are not cleared when you hit Cancel or close the settings menu. They are not applied either.
  • Settings - Initial settings can go missing, as their folder is not numbered
  • Settings - There is no delay between launching clients, as such the order may not be followed or cause bottlenecking of user's resources.


Frequently requested items in this thread Updated 2015-10-23:

  • GUI - Checkbox for selecting accounts is not visually clear enough
  • GUI - Display portrait of characters near the account
  • GUI - Launch & Unlink account icons are too close together. Add confirmation dialogue to unlink.
  • GUI - Play/Quit process button should be more visible in relation to other icons
  • GUI - Server selection should maintain order TQ > Sisi > Duality regardless of what server is picked
  • GUI - Settings window should not be translucent, give it a solid color
  • GUI - Would be great to have the latest news back
  • Launcher - Prevent multiple instances of the launcher
  • Launcher - Should be able to minimize to system tray
  • Launcher - Start client with a specific character selected
  • Launcher / GUI - option to have the launcher minimize when launching clients
  • Security - Yubico Two-Factor support
  • Settings - Ability to migrate / import / export / clone client settings
  • Settings - Renaming & management (on to-do list)
  • Settings - Store client settings in server / cloud
  • Settings - Option to enable the launcher asking whether to download new builds (for 4g/bandwidth restriction)


FAQ:

  • Can we focus on a running account from the Launcher GUI? - Yes, double click the running account, either in the account list or from processes view.
  • Can we use Steam with the new launcher? - There is currently no Steam integration with the new launcher, but you may join the beta by setting an account name for account created through Steam
  • Had # accounts logged in, changed servers and returned back to Tranquility, only one account remained logged in. - This happens if "Remember This Account" is not enabled, only the account last logged in will remain.
  • Information pop-ups overlay advertisement. As-is this falls under intended design, as we deem messaging to users important.
  • Switching between servers does not maintain a list of accounts. This is intended as each server has its own SSO. The tokens supplied for Tranquility may therefore not be valid for other servers.
  • The 'E' menu is hidden. - We haven't decided if we will keep that menu. It's a place for CCP Snorlax to add features that do not have proper UI support yet.

CCP raRaRa // Web Developer // Team Webster

Ralph King-Griffin
Lords.Of.Midnight
The Devil's Warrior Alliance
#3 - 2015-10-06 15:09:42 UTC
Yeaaaay \o/

Regardless of the little hissy fit a few of us threw over in gd(myself included) I'm actually really glad to see this,
will be downloading later and giving feedback.

Thanks for the work.
Ashterothi
Malevelon Roe Industries
#4 - 2015-10-06 15:11:42 UTC  |  Edited by: Ashterothi
BTW this is the best feature for corp leaders I have seen in a long time...

That being said I cannot log in. I use Google authenticator and upon entering my code I get:
"We have detected that your browser has cookies disabled. To provide the best experience on this site we use cookies. Please enable cookies in your browser and reload this page."

I am investigating.

Edit: I was able to log in with my account that has no authenticator.

Edit 2: Closing the launcher and reopening it, I was able to log in without being prompted for authenticator (perhaps because I checked don't ask me again last time?)
Mister Ripley
Ministry of War
Amarr Empire
#5 - 2015-10-06 15:21:15 UTC  |  Edited by: Mister Ripley

  • Would be nice to be able to manage the settings in some way to change the names. So one can have a laptop setting and a desktop setting without the need to remember which was setting 1 or setting 2.
  • Changing the server while logged in on sisi and tq first loads a grey box (the one that usually contains username and pw fields) and dismisses it after a second to load the logged in accounts overview.
  • The drop down menu for changing server changes the order after changing the server. It's kinda irritating Smile
  • You are on the testserver message overlays the left advertisement.
  • Resizing the launcher window is very clunky. It stutters. It creates a white area when makeing the window bigger.
  • The "quit process" button only works on double click. Very iritating since it's a button... not a shortcut on the desktop or a folder Smile
  • Launcher doesn't recognise a running process after restarting it while a client is still running.
  • In the "WebGUI" there are 7 settings. Setting 1..7. In the server list there are 10 settings. Setting 1..9 + Main Setting?!
Bam Stroker
Deep Core Mining Inc.
Caldari State
#6 - 2015-10-06 15:27:58 UTC  |  Edited by: Bam Stroker
This is really cool. Being able to store multiple accounts and then select them and launch several at the click of a button is great. I have no complaints about this new implementation, I think it's an improvement over the old launcher in every respect.

That said, I wouldn't be an EVE player if I didn't have something to complain about. In this case, it's the music. Or rather, lack thereof. Bring it back.

When I open up the EVE launcher I want it to play the music from the latest expansion/release while it patches or even while it just sits there waiting for me to do something. As it stands Jon's great work is wasted because most people go straight from the launcher into the client and since the jukebox was removed many people have the music turned off. Bring it back in at least a somewhat meaningful way and let people appreciate Jon's creativity again - add the expansion/release theme music back to the launcher.

EVE Down Under - a community for players in the AUTZ

In-game channel: evedownunder // Twitter: @evedownunder

https://www.facebook.com/evedownunder

Servanda
Liga Freier Terraner
Northern Coalition.
#7 - 2015-10-06 15:31:17 UTC
Takes a long time to load content to the launcher like background or login forms(like a minute or so). My Internet connection is most certanly not the issue
CCP raRaRa
C C P
C C P Alliance
#8 - 2015-10-06 15:31:46 UTC
Mister Ripley wrote:
Would be nice to be able to manage the settings in some way to change the names. So one can have a laptop setting and a desktop setting without the need to remember which was setting 1 or setting 2.


Totally agree, this is on our to-do list. The current list of available settings was quickly hard-coded for testing purposes.

Bare in mind that the settings are stored in files on your computer, so "Setting 1" on your PC is not the same as on your laptop, unless you configured the EVE client the same on both PCs.

CCP raRaRa // Web Developer // Team Webster

Bam Stroker
Deep Core Mining Inc.
Caldari State
#9 - 2015-10-06 15:32:18 UTC  |  Edited by: Bam Stroker
Servanda wrote:
Takes a long time to load content to the launcher like background or login forms(like a minute or so). My Internet connection is most certanly not the issue

Really? It was nearly instantaneous for me. I experienced no delays at all.

EVE Down Under - a community for players in the AUTZ

In-game channel: evedownunder // Twitter: @evedownunder

https://www.facebook.com/evedownunder

Servanda
Liga Freier Terraner
Northern Coalition.
#10 - 2015-10-06 15:32:56 UTC  |  Edited by: Servanda
double post
Bam Stroker
Deep Core Mining Inc.
Caldari State
#11 - 2015-10-06 15:35:26 UTC  |  Edited by: Bam Stroker
AN ENTIRE MINUTE?!

CCPls. We're talking 60 whole seconds here! Unsubbing my 15 accounts.

EVE Down Under - a community for players in the AUTZ

In-game channel: evedownunder // Twitter: @evedownunder

https://www.facebook.com/evedownunder

Sentient Blade
Crisis Atmosphere
Coalition of the Unfortunate
#12 - 2015-10-06 15:35:57 UTC
Same here, it's agonizingly slow to load the page, and the forms on top are just as slow.
CCP raRaRa
C C P
C C P Alliance
#13 - 2015-10-06 15:36:24 UTC
Servanda wrote:
Launcher seems to be verry slow to load new content took almost a minute until the login form was there.


Is this happening on TQ for you? I'm seeing slow response on SISI because the SSO there is really slow at the moment.

CCP raRaRa // Web Developer // Team Webster

Aiko Wisemane
Moira.
Villore Accords
#14 - 2015-10-06 15:38:27 UTC  |  Edited by: Aiko Wisemane
Great work!

But I think i borked it a little bit :|

red bar screenshot

There are 6 accounts in the list ^^

Edit: red bar appeared as i entered the sixth account.

Edit 2: Red bar disappears if I resize the launcher so that no scroll bar is needed. (the arrows down right)
kaike
Native Freshfood
Minmatar Republic
#15 - 2015-10-06 15:40:20 UTC
Are you gonna support more then 3 account login's in the future or ?

So far i only seems to be able to login 3 when i add 2 more there appears a red bar.

Servanda
Liga Freier Terraner
Northern Coalition.
#16 - 2015-10-06 15:40:25 UTC
CCP raRaRa wrote:
Servanda wrote:
Launcher seems to be verry slow to load new content took almost a minute until the login form was there.


Is this happening on TQ for you? I'm seeing slow response on SISI because the SSO there is really slow at the moment.


This is with TQ forums and stuff load almost instantly in the browser so it is probably not the Internetconnection. Also adding new accounts takes like 10 secs between each step.
Alan Mathison
Signal Cartel
EvE-Scout Enclave
#17 - 2015-10-06 15:41:22 UTC
Hi Folks:

I run EVE on LInux under Wine (v1.7.50, set to Windows 7 emulation). I installed the new launcher and it crashed immediately upon running.

I can provide details and a stack trace in case any Dev is interested. I understand an emulated environment is certainly not your first concern!
---
Alan Mathison

-- Alan Mathison, Explorer & Industrialist, Star Tide Industries

CCP Snorlax
C C P
C C P Alliance
#18 - 2015-10-06 15:41:28 UTC
Sentient Blade wrote:
Same here, it's agonizingly slow to load the page, and the forms on top are just as slow.

If you find the web gui is slow, it may be due to your Internet settings. Chrome sometimes suffers from the same thing: https://support.google.com/chrome/answer/106010?hl=en-GB

Turning off 'Automatically detect settings' for LAN settings in Internet Properties (Connections) might fix this. I'm hoping to have this addressed before too long in our code.

CCP Snorlax - Software Architect - Team RnB - @CCP_Snorlax - http://ccpsnorlax.blogspot.is/

Sandange Shihari
Perkone
Caldari State
#19 - 2015-10-06 15:41:41 UTC
How can I make it work with STEAM ?
Raphendyr Nardieu
Avanto
#20 - 2015-10-06 15:42:44 UTC
First, super big applause for the good work!!! Amazing job!


Issues I wanted to raise up:

  • Test the launcher with regular HDD or bad one of those. The UI froze a bit annoyingly at start.
  • The Launch Account and Unlink Account are a bit close. Could the Unlink be in context menu or something.
  • If there is only one account, there is still the Unlink option.
  • Checkbox for multilaunch is not very visually clear.
  • "Web GUI" should probably be something else.. Like "Accounts"
  • There is 2 different windows and places for nearly same settings.
  • Can't do other stuff with launcher while shared cache tool is open
  • Had 2 accounts logged in, changed server from TQ to Sisi (showed requiring account to login) and then back to TQ, only the account I logged in last was showing (didn't click remember ,me on login)


Other ideas:

  • In future, could we get thumbnails of the characters in the accounts and could we start a client as that character. Those characters that have their client running (other char on account) would be grayed out.
  • When clicking the running account on "Web GUI" page, could it focus that client (is this possible in windows?)
  • Show similar info than on running processes page, on WEb GUI


I'll add another comment if I find more things.
123Next pageLast page