These forums have been archived and are now read-only.

The new forums are live and can be found at https://forums.eveonline.com/

Issues, Workarounds & Localization

 
  • Topic is locked indefinitely.
Previous page123Next page
 

Button Spamming

First post
Author
CCP Turtlepower
C C P
C C P Alliance
#21 - 2015-04-30 16:22:24 UTC
Daemun Khanid wrote:

Bug report sent.


Thanks for the excellent bug report, we are working on it Smile
Cpt JeanLucPicard
Vanu Sovereignty.
#22 - 2015-04-30 16:27:05 UTC
Daemun Khanid wrote:
CCP Turtlepower wrote:
Daemun Khanid wrote:
I'm afraid the patch did not correct the problem. Just tested after updating client and launcher and rapidly spamming activate or warp buttons while coming out of warp will still leave you sitting there clicking indefinitely. There seems to be a threshold on how quickly you can spam a button before the client just basically ignores you. Click slowly and it may work as soon as the function becomes available, click too fast and you can sit there all day and nothing will happen.


Could you please reproduce the error in client, then file an in-game bug report directly afterwards? This will give us your client logs so that we can hopefully diagnose the issue better. Also please include reproduction steps that are as detailed as possible!

Thanks!


In progress

Bug report sent. Performed two tests, one where I land and spam with client failing to respond until I pause. And a second where I land and begin gradually reducing my click speed until my client responds. Hopefully you'll be able to access logs for both events. I did dock after the test, war targets in system. Hopefully that wont effect the range of logs available, if so I will repeat and send the report from safe BM.


Thanks for your effort here, mate! Much appreciated.

Thanks to you too, CCP, for checking it out and trying to fix it! Big smile
Tipa Riot
Federal Navy Academy
Gallente Federation
#23 - 2015-04-30 16:51:33 UTC  |  Edited by: Tipa Riot
May you share your reproduction steps here?

I'm my own NPC alt.

CCP karkur
C C P
C C P Alliance
#24 - 2015-04-30 17:08:10 UTC
Daemun Khanid wrote:
CCP Turtlepower wrote:
Daemun Khanid wrote:
I'm afraid the patch did not correct the problem. Just tested after updating client and launcher and rapidly spamming activate or warp buttons while coming out of warp will still leave you sitting there clicking indefinitely. There seems to be a threshold on how quickly you can spam a button before the client just basically ignores you. Click slowly and it may work as soon as the function becomes available, click too fast and you can sit there all day and nothing will happen.


Could you please reproduce the error in client, then file an in-game bug report directly afterwards? This will give us your client logs so that we can hopefully diagnose the issue better. Also please include reproduction steps that are as detailed as possible!

Thanks!


In progress

Bug report sent. Performed two tests, one where I land and spam with client failing to respond until I pause. And a second where I land and begin gradually reducing my click speed until my client responds. Hopefully you'll be able to access logs for both events. I did dock after the test, war targets in system. Hopefully that wont effect the range of logs available, if so I will repeat and send the report from safe BM.
Thanks for the thorough bug report! We have been able to track down the issue, and it has to do with spam clicking a button that is changing state, that is going from inactive to active.
We are working on a fix and can hopefully deploy it soon.

CCP karkur | Programmer | Team Five 0 | @CCP_karkur

Daemun Khanid
Corbeau de sang
#25 - 2015-04-30 17:17:14 UTC
Just warp to a FW complex and select the gate as soon as its on overview. Before you finish coming out of warp start rapidly spamming the "activate gate" button. In the past this would result in activating the gate immediately upon landing, now (if you are clicking too rapidly) your ship will just sit there and fail to respond.
If you're not in FW, try warping to a random celestial (gate, station etc) then while in warp select a new destination and start spamming "warp to" before you land. Results are same as above. Clicking too quickly will result in a non-responsive ship.
There's a similar issue (may or may not be related) where spamming "lock target" when coming out of warp or decloaking results in a "target lock failed" error. Forcing you to restart the lock timer. This one unlike the others results in an actual logged error but is not as easy to reproduce unless you have some buds to test it on. (Pre-activated modules also have a tendancy not to activate however that issue, like the failed lock issue, has been going on for some time prior to the current build and aren't likely related)

Daemun of Khanid

Daemun Khanid
Corbeau de sang
#26 - 2015-04-30 17:19:09 UTC
CCP karkur wrote:
Daemun Khanid wrote:
CCP Turtlepower wrote:
Daemun Khanid wrote:
I'm afraid the patch did not correct the problem. Just tested after updating client and launcher and rapidly spamming activate or warp buttons while coming out of warp will still leave you sitting there clicking indefinitely. There seems to be a threshold on how quickly you can spam a button before the client just basically ignores you. Click slowly and it may work as soon as the function becomes available, click too fast and you can sit there all day and nothing will happen.


Could you please reproduce the error in client, then file an in-game bug report directly afterwards? This will give us your client logs so that we can hopefully diagnose the issue better. Also please include reproduction steps that are as detailed as possible!

Thanks!


In progress

Bug report sent. Performed two tests, one where I land and spam with client failing to respond until I pause. And a second where I land and begin gradually reducing my click speed until my client responds. Hopefully you'll be able to access logs for both events. I did dock after the test, war targets in system. Hopefully that wont effect the range of logs available, if so I will repeat and send the report from safe BM.
Thanks for the thorough bug report! We have been able to track down the issue, and it has to do with spam clicking a button that is changing state, that is going from inactive to active.
We are working on a fix and can hopefully deploy it soon.


Outstanding :) o7 to CCP for a rapid and thorough response.

Daemun of Khanid

Sven Viko VIkolander
Allemannsrett
#27 - 2015-04-30 17:21:00 UTC  |  Edited by: Sven Viko VIkolander
Yup, lost 2-3 ships due to this last night when trying to manually pilot or warp out and the client was simply not responsive, though I am glad to hear others experience this bug and that CCP has acknowledged and identified it.

I also saw multiple PVP streamers last night experiencing this bug. One streamer kept saying he is terrible at manually piloting at the moment. Nope, just EVE being broken.
CCP karkur
C C P
C C P Alliance
#28 - 2015-04-30 17:31:59 UTC  |  Edited by: CCP karkur
Sven Viko VIkolander wrote:
Yup, lost 2-3 ships due to this last night when trying to manually pilot or warp out and the client was simply not responsive, though I am glad to hear others experience this bug and that CCP has acknowledged and identified it.

I also saw multiple PVP streamers last night experiencing this bug. One streamer kept saying he is terrible at manually piloting at the moment. Nope, just EVE being broken.
he's probably also pretty terrible at manual piloting Cool

Daemun Khanid wrote:
Just warp to a FW complex and select the gate as soon as its on overview. Before you finish coming out of warp start rapidly spamming the "activate gate" button. In the past this would result in activating the gate immediately upon landing, now (if you are clicking too rapidly) your ship will just sit there and fail to respond.
If you're not in FW, try warping to a random celestial (gate, station etc) then while in warp select a new destination and start spamming "warp to" before you land. Results are same as above. Clicking too quickly will result in a non-responsive ship.
There's a similar issue (may or may not be related) where spamming "lock target" when coming out of warp or decloaking results in a "target lock failed" error. Forcing you to restart the lock timer. This one unlike the others results in an actual logged error but is not as easy to reproduce unless you have some buds to test it on. (Pre-activated modules also have a tendancy not to activate however that issue, like the failed lock issue, has been going on for some time prior to the current build and aren't likely related)


Some people will make fun of me for always pushing the radial menu, but I'm just offering a workaround for you:
When you are in warp, you can bring up the radial menu on the item you want to warp to after you land, and mouse over the "warp" button in it. When the option becomes available, the option will light up and you can release the mouse and warp there right away.

CCP karkur | Programmer | Team Five 0 | @CCP_karkur

Daemun Khanid
Corbeau de sang
#29 - 2015-04-30 17:48:57 UTC  |  Edited by: Daemun Khanid
CCP karkur wrote:
Sven Viko VIkolander wrote:
Yup, lost 2-3 ships due to this last night when trying to manually pilot or warp out and the client was simply not responsive, though I am glad to hear others experience this bug and that CCP has acknowledged and identified it.

I also saw multiple PVP streamers last night experiencing this bug. One streamer kept saying he is terrible at manually piloting at the moment. Nope, just EVE being broken.
he's probably also pretty terrible at manual piloting Cool

Daemun Khanid wrote:
Just warp to a FW complex and select the gate as soon as its on overview. Before you finish coming out of warp start rapidly spamming the "activate gate" button. In the past this would result in activating the gate immediately upon landing, now (if you are clicking too rapidly) your ship will just sit there and fail to respond.
If you're not in FW, try warping to a random celestial (gate, station etc) then while in warp select a new destination and start spamming "warp to" before you land. Results are same as above. Clicking too quickly will result in a non-responsive ship.
There's a similar issue (may or may not be related) where spamming "lock target" when coming out of warp or decloaking results in a "target lock failed" error. Forcing you to restart the lock timer. This one unlike the others results in an actual logged error but is not as easy to reproduce unless you have some buds to test it on. (Pre-activated modules also have a tendancy not to activate however that issue, like the failed lock issue, has been going on for some time prior to the current build and aren't likely related)


Some people will make fun of me for always pushing the radial menu, but I'm just offering a workaround for you:
When you are in warp, you can bring up the radial menu on the item you want to warp to after you land, and mouse over the "warp" button in it. When the option becomes available, the option will light up and you can release the mouse and warp there right away.


Waiting for the button above overview (or where ever you may have moved it to) to highlight before clicking works as well however when trying to get into or away from a fight where fractions of a second can count it can put you behind by a full server tick depending on how quick you are in your clicking. Seems minor but in some situations 1 second is all that separates you from a win or a loss. Preemptive spam FTW. :)

It's a little off topic but while the thread has attention, what are the chances of getting BM's added as an option on the overview? Being able to spam warp to BM using the button would be lovely as well as allow me to remove 2 windows of BM clutter from my screen layout. :)

Daemun of Khanid

Daemun Khanid
Corbeau de sang
#30 - 2015-05-01 19:34:44 UTC
Any further updates?

Daemun of Khanid

Joy
State Protectorate
Caldari State
#31 - 2015-05-01 23:23:55 UTC
On the plus side we are getting lots of billion isk pod kills.

They spam warp to get their pod out and just sit there.

Does my bum look big in this ?

Daemun Khanid
Corbeau de sang
#32 - 2015-05-01 23:55:20 UTC
Joy wrote:
On the plus side we are getting lots of billion isk pod kills.

They spam warp to get their pod out and just sit there.


Probably replacable by ticket since its a confirmed bug.

Daemun of Khanid

Joy
State Protectorate
Caldari State
#33 - 2015-05-02 06:38:19 UTC
Daemun Khanid wrote:
Joy wrote:
On the plus side we are getting lots of billion isk pod kills.

They spam warp to get their pod out and just sit there.


Probably replacable by ticket since its a confirmed bug.


I agree I think every pod kill not involving a warp bubble should automatically be reimbursed. This is a particularly nasty bug that will annoy a lot of people.

Does my bum look big in this ?

CCP karkur
C C P
C C P Alliance
#34 - 2015-05-02 22:20:40 UTC
Joy wrote:
Daemun Khanid wrote:
Joy wrote:
On the plus side we are getting lots of billion isk pod kills.

They spam warp to get their pod out and just sit there.


Probably replacable by ticket since its a confirmed bug.


I agree I think every pod kill not involving a warp bubble should automatically be reimbursed. This is a particularly nasty bug that will annoy a lot of people.

Well, this is only an issue when the button changes states while you are spamming it (going from inactive to active). When you are getting your pod out, the warp button you are hitting is normally just active, right?

CCP karkur | Programmer | Team Five 0 | @CCP_karkur

Zappity
Pandemic Horde Inc.
Pandemic Horde
#35 - 2015-05-02 23:17:47 UTC  |  Edited by: Zappity
CCP karkur wrote:
Joy wrote:
Daemun Khanid wrote:
Joy wrote:
On the plus side we are getting lots of billion isk pod kills.

They spam warp to get their pod out and just sit there.


Probably replacable by ticket since its a confirmed bug.


I agree I think every pod kill not involving a warp bubble should automatically be reimbursed. This is a particularly nasty bug that will annoy a lot of people.

Well, this is only an issue when the button changes states while you are spamming it (going from inactive to active). When you are getting your pod out, the warp button you are hitting is normally just active, right?

When your tackled ship is going to die you align out and spam warp. Your pod will insta-warp when ejected. Please read the Lecture. I think he means that this is not working. Bad news for lowsec PvP if so.

Zappity's Adventures for a taste of lowsec and nullsec.

Daemun Khanid
Corbeau de sang
#36 - 2015-05-02 23:34:10 UTC
If the issue effects the warping of pod's I'm not aware of it and haven't been in the situation frequently enough to test it and confirm. An exploding ship is something I try to avoid. :)

Daemun of Khanid

Zappity
Pandemic Horde Inc.
Pandemic Horde
#37 - 2015-05-03 02:42:54 UTC
What a boring life your character must lead :)

Zappity's Adventures for a taste of lowsec and nullsec.

Daemun Khanid
Corbeau de sang
#38 - 2015-05-03 14:32:14 UTC
Zappity wrote:
What a boring life your character must lead :)


I try to avoid being "in" an exploding ship. Not exploding them. :)

Daemun of Khanid

CCP karkur
C C P
C C P Alliance
#39 - 2015-05-04 09:43:16 UTC
Zappity wrote:
When your tackled ship is going to die you align out and spam warp. Your pod will insta-warp when ejected. Please read the Lecture. I think he means that this is not working. Bad news for lowsec PvP if so.
Yeah, but in that case the "warp" button is active the whole time, the action just cannot be performed due to the ship being tackled.

CCP karkur | Programmer | Team Five 0 | @CCP_karkur

CCP Turtlepower
C C P
C C P Alliance
#40 - 2015-05-04 11:23:26 UTC
Joy wrote:
I think every pod kill not involving a warp bubble should automatically be reimbursed. This is a particularly nasty bug that will annoy a lot of people.


Spamming the warp button during and right after a ship death/pod eject is working normally. Players are of course welcome to file reimbursement tickets for any losses, but they should not assume this is an auto-reimburse.
Previous page123Next page