These forums have been archived and are now read-only.

The new forums are live and can be found at https://forums.eveonline.com/

EVE Information Portal

 
  • Topic is locked indefinitely.
123Next pageLast page
 

EVE Launcher update on May 21, 2013

First post First post
Author
CCP Phantom
C C P
C C P Alliance
#1 - 2013-05-21 14:31:03 UTC  |  Edited by: CCP Phantom
The EVE Launcher will be upgraded with new features on May 21, 2013.

This update will be performed automatically as soon as you start your current EVE Launcher. If the launcher doesn't automatically update as expected you can download the new EVE Launcher manually here: http://cdn1.eveonline.com/EveOnlineLauncher/release/EVEOnlineLauncher_2_1_545736.exe

The main change is a new and improved landing page and a new login mechanism which will allow you to log into EVE Online using our SSO (single sign on) service.

We’ve also included a new self-update mechanism in the EVE Launcher, which will make the update process for the EVE Launcher itself more reliable and allow us to deploy more updates as we work on improving the flow into the game.

In addition to these features, we’ve worked on a new version for the Mac which should also be deployed soon, which brings much closer parity between the Windows and Mac EVE Launchers, with a new embedded browser and low level tweaks to the EVE Launcher.

A devblog about the EVE Launcher upgrade can be found here, further information about SSO is available here.

We welcome all constructive feedback and comments and our developers will monitor the comments closely.


Important issues
EVE user settings appear to be gone - Dev post reply 1, Dev post reply 2
Steam users receiving error messages - Dev post reply

Dev updates
Connection problems with the launcher showing no internet connection - Dev post reply #1
Connection problems with the launcher showing no internet connection - Dev post reply #2
Web server issues - News item
Further explanations on current issues and workarounds - Workarounds and further explanations
Further background information about the EVE Launcher, SSO and multiboxing - Dev post

Update on 20:47 UTC at May 21
The web server issues are fixed and the EVE Laucher should be able to properly update and connect to Tranquility again.

CCP Phantom - Senior Community Developer

highonpop
UK Corp
Goonswarm Federation
#2 - 2013-05-21 14:39:50 UTC  |  Edited by: highonpop
1st.

P

edit:

I spoke too soon. CCP Y U OFFLINE?

FC, what do?

Smoking Blunts
ZC Omega
Goonswarm Federation
#3 - 2013-05-21 14:43:28 UTC  |  Edited by: ISD Suvetar
the new launcher is a pile of ****, many have said it and you don't hear what was said and rolled it out anyway.

edit to include this little gem


looks like as soon as the launcher is closed, account names are removed from it. not all, just some

way to go ccp, your making it annoying as hell to log in

OMG when can i get a pic here

Istyn
Freight Club
#4 - 2013-05-21 14:45:06 UTC
It just seems to want to claim I'm offline. While I'm posting this.
n0th1nk
Fail Department
#5 - 2013-05-21 14:45:12 UTC
now that there is no login screen, does that mean that we won't have new login music and screen at each expansion ??
I loved login screen
Chillya
Sanctuary of Shadows
Triumvirate.
#6 - 2013-05-21 14:45:17 UTC
Well, the launcher updated and broke.

OFFLINE MODE
You are seeing this because no connection could be made to the content server or something went wrong while loading the online content.

Tranquility server: Status unknown
Remulon McNab
Caldari Provisions
Caldari State
#7 - 2013-05-21 14:45:32 UTC  |  Edited by: Remulon McNab
did you guys properly QA test this new launcher as it did not update by itself.

had to force a manual update through the logfile it tends to write in \launcher\cache\

After this particular nice update the launcher is in offline Modus :/

Pastebin log:
http://pastebin.com/9cva1mCA

got #tweetfleet? Follow @ZeroNRG

Destination SkillQueue
Doomheim
#8 - 2013-05-21 14:46:10 UTC
Quote:
You are seeing this because no connection could be made to the content server or something went wrong while loading the online content.


Is something wrong or did I just get molested by the launcher update?
Emizeko Chai
Freight Club
#9 - 2013-05-21 14:46:22 UTC  |  Edited by: Emizeko Chai
Istyn wrote:
It just seems to want to claim I'm offline. While I'm posting this.


You can get online? That must be nice.

EDIT for detail:

New launcher does this despite working internet:

You are seeing this because no connection could be made to the content server or something went wrong while loading the online content.
drummendejef maaktnietuit
Belgian Bunnies v3
#10 - 2013-05-21 14:46:40 UTC
Looks awesome!

Changing language to Chinese (or what language that may be) maked the launcher almost crash.
Noddy Comet
Lysdexic Agnostics - Thier is no Dog
#11 - 2013-05-21 14:46:50 UTC


Absolutely Fabulous....

Quote:
OFFLINE MODE
You are seeing this because no connection could be made to the content server or something went wrong while loading the online content.

Restart Launcher

[i]"The biggest problem with quotes on the Internet, is that just because it's on the Internet too many believe them to be real" -[/i]Abraham Lincoln's "Berlin Wall" speech at the 1984 Winter Olympics.

Istyn
Freight Club
#12 - 2013-05-21 14:47:09 UTC
Emizeko Chai wrote:
Istyn wrote:
It just seems to want to claim I'm offline. While I'm posting this.


You can get online? That must be nice.

New launcher is throwing errors for me constantly.


I got to log in at first then nothing happened :3
Agrippa Arkaral
Viziam
Amarr Empire
#13 - 2013-05-21 14:47:36 UTC
Got the offline mode message, managed to get a working one and log in after 5 tries.
Gempei
Marvinovi pratele
Brothers in Arms Alliance
#14 - 2013-05-21 14:47:59 UTC
cant start eve, any solution? :D http://i.imgur.com/JQAkVPa.png
NoxiousPluK
Surelock Holmes Mercenaries
We shoot stuff
#15 - 2013-05-21 14:48:06 UTC
Updated.

Launcher.exe was running 6 times (with ~70mb of memory in use for each) but no launcher being shown.
Killed the processes, started it again, it now claims that I'm offline and that the server status is unknown.
Sarah Nahrnid
Ministry of War
Amarr Empire
#16 - 2013-05-21 14:48:13 UTC
Confirming the new launcher claims I have no internet connection. Interesting...

CCP, please fix this. Launcher *looks* good but please don't exchange usefulness for looks.
MAX OVERLOADED
Pan Galactic Ancient Tech Institute
#17 - 2013-05-21 14:48:20 UTC
so now that we have a new launcher that doesnt work how am I supposed to train my skills. also any idea on when it will be fixed. all im getting is a white screen for a launcher.
CCP Atropos
C C P
C C P Alliance
#18 - 2013-05-21 14:48:30 UTC
It you're having exceptions, then please file a Bug Report or link us to some logs.
Pritovsky Pootis
Eschelon Directive
#19 - 2013-05-21 14:48:50 UTC
Keep getting error messages after logging in on the launcher e.g.

Unable to download remote build number
Traceback (most recent call last):
File "lib\update.pyo", line 597, in run
File "lib\update.pyo", line 654, in IsUpdateRequired
File "lib\update.pyo", line 215, in __init__
File "lib\decorators.pyo", line 18, in __call__
File "lib\info.pyo", line 182, in GetRemoteBuildNumber
RemoteBuildNumberUnavailable: Unable to fetch build number from server
... (then about 500 words of other text)

But it just gives the option to launch EVE though anyway. To be honest I preferred the old launcher because rather than being able to launch 2 clients at once and THEN log in, you have to "switch character" and then launch it, which is rather annoying.
Half12Hardcore Aideron
The Scope
Gallente Federation
#20 - 2013-05-21 14:49:13 UTC
123Next pageLast page