These forums have been archived and are now read-only.

The new forums are live and can be found at https://forums.eveonline.com/

EVE Technology Lab

 
  • Topic is locked indefinitely.
 

phpBB 3.x API Registration Mod v6+

Author
Eagles Beak
Eagles United
#1201 - 2015-04-05 06:32:40 UTC
Hey Guys...

I would like that the mod looked for a certain corp role, eg Director, and assign it to a froum group. I know it's posible to get from the API which corp role the person have but i don't see how to incorporated it in the mod.

Anyone that have success with this and can it maybe be incorporated into a new release?
Ncc 1709
Fusion Enterprises Ltd
Test Alliance Please Ignore
#1202 - 2015-04-07 17:12:08 UTC  |  Edited by: Ncc 1709
mine isn't saving the uid
its also not actioning it
any help would be appreciated
Aleksander Allah
Perkone
Caldari State
#1203 - 2015-04-07 19:23:14 UTC
Ncc 1709 wrote:
mine isn't saving the uid
its also not actioning it
any help would be appreciated


The Alliance that use this mod had the same problem... they said it was because the mod couldn't connect to the teamspeak server... have you check that the api has been white listet and that the settings are correct?
Ncc 1709
Fusion Enterprises Ltd
Test Alliance Please Ignore
#1204 - 2015-04-07 21:22:46 UTC  |  Edited by: Ncc 1709
I know the whitelist is fine, tamars works fine off of it.


edit. it just randomly started working...
Laurent Jay
Sorry We Are French Unicorns
PURPLE HELMETED WARRIORS
#1205 - 2015-04-10 12:24:41 UTC  |  Edited by: Laurent Jay
o/

Openfire 3.9.3
User Service 2.0.2
phpBB 3.0.12
EvE API 6.3.1

so, :)

With the original OpenFireUserService.php on openfire : 'RequestNotAuthorised' : Null

I change:
Line 47
Quote:
'useCurl' => false,


Users transfert phpBB to openfire work

But phpBB password not working for user jabber connection (in pigdim)

Have u any ideas ?


Thx

Laurent

----- update-----
1. Isee that it's Openfire who send mail for password but:
- Openfrie not send password mail with good SMTP config (test ok)
- When a user change something on phpBB, openfire not update with cron


---Re-update---
I see that "0mni Ca" find problem but
https://almostawesome.org/download/openfire_userservice.txt
no working
no one have a save ?


-
Momitsu
Deep Exploration Projects and Programs
#1206 - 2015-04-15 18:40:23 UTC


Link doesn't work for me, always getting to filedropper starting page
Staysin Jita
#1207 - 2015-04-22 11:37:26 UTC
Would there be any way to add Mumble authentication to this as well as Teamspeak ?

There is a script for doing this HERE
Could this be integrated into your mod at any stage?
Snitch Ashor
The Mjolnir Bloc
Templis CALSF
#1208 - 2015-05-18 15:13:28 UTC
Momitsu wrote:


Link doesn't work for me, always getting to filedropper starting page


Sorry that one does delete inactive files pretty fast, heres the new one for mosaic:

http://ge.tt/api/1/files/52JuscG2/0/blob?download

As usual, you'd better have a backup. Also keep in mind that this one is recreated from the static DB dump so all skinned ships have been removed.

Cheers, Snitch
Subsparx
Crimson Serpent Syndicate
#1209 - 2015-05-29 20:41:07 UTC
It appears this broke last night:

Warning

SSL certificate problem: unable to get local issuer certificate

Did CCP update the SSL cert used by their API system?

CEO of Crimson Serpent Syndicate - www.crimsonserpent.com

Chairman of Heiian Conglomerate - www.heiian.com

Owner of FWC - www.factionwarfare.com

Go0fBall
Perkone
Caldari State
#1210 - 2015-05-30 05:14:17 UTC
Yeah I've noticed this for the past couple of days as well. When running the script, I am getting:

EVE API Connection error: 60 -> SSL certificate problem: unable to get local issuer certificate

Any workaround for this? Thx.
Subsparx
Crimson Serpent Syndicate
#1211 - 2015-05-30 17:55:41 UTC
I experienced a similar issue at work with authorize.net making changes to SSL certs and nobody notifying me. Had very similar problems until I updated the root certificates on our web servers then it started working. I suspect the issue here is similar but I don't know what trusted root certs to install. GeoTrust maybe?

CEO of Crimson Serpent Syndicate - www.crimsonserpent.com

Chairman of Heiian Conglomerate - www.heiian.com

Owner of FWC - www.factionwarfare.com

Go0fBall
Perkone
Caldari State
#1212 - 2015-05-30 20:58:33 UTC
From what I see, the certificates seem fine. Mind you I am self-taught at all this lol. Also I seem to have fixed the issue on my end, or maybe it's just coincidence and fixed itself, but this is what I just changed to get it to work again.

ArrowIn the forums directory, navigate to includes\eveapi\Pheal

ArrowOpen PhealConfig.php , and go to line 79, or somewhere around there, and change the public $http_method from curl, to file. Example below:

* which http request method should be used 'curl' or 'file'
* @var String
*/
public $http_method = "file";


This seems to have done the trick for us, no more certificate errors, and the script successfully runs once again! Hope this helps, and maybe Cyrus can verify that this does actually fix the issue till something more permanent is developed.
Subsparx
Crimson Serpent Syndicate
#1213 - 2015-05-31 20:40:52 UTC
I can confirm that using the file method instead of curl fixes it. I wonder what caused curl to stop working out of the blue though, and for multiple people at that. Go0fBall, are you hosting on a Windows machine? If you are, perhaps a security update from Windows caused something to break when using curl?

CEO of Crimson Serpent Syndicate - www.crimsonserpent.com

Chairman of Heiian Conglomerate - www.heiian.com

Owner of FWC - www.factionwarfare.com

Go0fBall
Perkone
Caldari State
#1214 - 2015-06-01 06:56:57 UTC
Subsparx wrote:
I can confirm that using the file method instead of curl fixes it. I wonder what caused curl to stop working out of the blue though, and for multiple people at that. Go0fBall, are you hosting on a Windows machine? If you are, perhaps a security update from Windows caused something to break when using curl?



Glad to hear that the fix worked for you as well! Yes, we do run a Windows Server 2008 box, and I thought the same thing that possibly an update messed something up, but when checking through our Windows update log, the last update was from May 20th, (KB3054476) and reading the description of that update, I do not think that is what broke the script from running.

I'm thinking this is more of something on CCP's end, but again I am sure Cyrus will be able to confirm/verify once he gets around to reading this thread.
Snitch Ashor
The Mjolnir Bloc
Templis CALSF
#1215 - 2015-06-08 12:38:37 UTC
Updated item database for Carnyx:

http://ge.tt/60AMtvH2/v/0?c

As usual, backup before.

I'm working on a way to batch rename all item occurences in the posts to update all existing items and fittings to the new names, but it's a little more tricky then i thought... stupid hashing.

Cheers!
Momitsu
Deep Exploration Projects and Programs
#1216 - 2015-06-09 13:51:10 UTC
Works like a charm, thanks mate
VangDo
Nemesis Logistics
Goonswarm Federation
#1217 - 2015-06-11 10:04:40 UTC
Hi,

i have the problem, my EVE Online BBCodes does not work.

Iv been installed this --> https://github.com/Cyerus/phpBB-mod-EVE-Online-BBcode
whith Automod.

After the Installation, i can´t see any posting Topics, i get a white site only.

any Ideas?
1upnate
School of Applied Knowledge
Caldari State
#1218 - 2015-06-14 17:06:31 UTC
VangDo wrote:
Hi,

i have the problem, my EVE Online BBCodes does not work.

Iv been installed this --> https://github.com/Cyerus/phpBB-mod-EVE-Online-BBcode
whith Automod.

After the Installation, i can´t see any posting Topics, i get a white site only.

any Ideas?


one thing I found was giving me the white page was not having php5-curl installed
VangDo
Nemesis Logistics
Goonswarm Federation
#1219 - 2015-07-06 19:50:37 UTC
Hey

I have problems with EVEFITTING in phpbb

http://eon-alliance.com/forum/viewtopic.php?f=12&t=234

the loadout is not complete.
any Ideas?
Momitsu
Deep Exploration Projects and Programs
#1220 - 2015-07-08 09:17:26 UTC
What Version of phpbb are you running?

The mod is designed for 3.0.x and I'm pretty sure it will not work with 3.1.x until there's a new version of the mod.