These forums have been archived and are now read-only.

The new forums are live and can be found at https://forums.eveonline.com/

Issues, Workarounds & Localization

 
  • Topic is locked indefinitely.
 

Esacpe Key, Function Keys, Tab, Enter not working

First post
Author
Mirei Jun
Garoun Investment Bank
Gallente Federation
#1 - 2011-10-10 15:41:32 UTC
This problem was originally described here: http://www.eveonline.com/ingameboard.asp?a=topic&threadID=1456529&page=2

I just logged in today to find this problem. Nothing has changed on my computer since.. yesterday. I ahve gone through the generic steps:

Looking at all running processes on my comp.
Testing the keys in all other applications (they work)
Repairing the Eve client
Clearing cache and settings
Testing the problem on Sisi (The keys don't work in any version of Eve)

This problem is quite sudden and I know other have experienced it. Was a fix found?
GM Xamother
Game Masters
C C P Alliance
#2 - 2011-10-10 17:14:01 UTC  |  Edited by: GM Xamother
I have to say, I'm not quite sure what causes this.

Assuming you have Windows, could you try and use Windows System Restore and restore the computer to a date before the problem happened, and then see if the problem persists?

GM Xamother | Senior Game Master

Mirei Jun
Garoun Investment Bank
Gallente Federation
#3 - 2011-10-10 22:03:11 UTC
GM Xamother wrote:
I have to say, I'm not quite sure what causes this.

Assuming you have Windows, could you try and use Windows System Restore and restore the computer to a date before the problem happened, and then see if the problem persists?

Best regards,
Senior GM Xamother
EVE Online Customer Support



Well, no, I disabled system restore as it requires a lot of resources and severely hinders SSD performance.

While the response is appreciated, I am not pleased with its contents. Your response did make it clear that this bug is known, it has not been successfully reproduced, and there is no known fix.

I'm going to do more testing as I have time before coming to any final decisions, but the part of Eve I participate in is unplayable with this bug.
GM Xamother
Game Masters
C C P Alliance
#4 - 2011-10-10 22:18:09 UTC  |  Edited by: GM Xamother
Could you try and use the Windows On Screen keyboard and see if the ESC key, Tab and Enter works via that (it doesn't have function keys so obviously those cannot be tested).

GM Xamother | Senior Game Master

GM Xamother
Game Masters
C C P Alliance
#5 - 2011-10-10 22:33:38 UTC  |  Edited by: GM Xamother
One thing you can also try:

1) Go to Control Panel -> Region and Language -> Keyboard and Language tab -> Change keyboards...
2) Under General tab, add English (United States) - US keyboard, and then select the English (United States) - US as the default input language and press 'Apply', and after that remove all the other keyboards on the list and press Ok
3) Now start the EVE client normally and see if they keys would work.

I realize that this might not be the keyboard layout you normally use, but I ask to try this and see if it works. You can then off course change it back to your normal layout after testing.

If you already have the US keyboard layout, then check if there's any other layouts in the list, and remove them, and select the US layout as the default one. You can also try and change it to English (United Kingdom) - UK if you already have the US layout.

GM Xamother | Senior Game Master

Mirei Jun
Garoun Investment Bank
Gallente Federation
#6 - 2011-10-11 05:24:16 UTC
GM Xamother wrote:
One thing you can also try:

1) Go to Control Panel -> Region and Language -> Keyboard and Language tab -> Change keyboards...
2) Under General tab, add English (United States) - US keyboard, and then select the English (United States) - US as the default input language and press 'Apply', and after that remove all the other keyboards on the list and press Ok
3) Now start the EVE client normally and see if they keys would work.

I realize that this might not be the keyboard layout you normally use, but I ask to try this and see if it works. You can then off course change it back to your normal layout after testing.

If you already have the US keyboard layout, then check if there's any other layouts in the list, and remove them, and select the US layout as the default one. You can also try and change it to English (United Kingdom) - UK if you already have the US layout.

Best regards,
Senior GM Xamother
EVE Online Customer Support


Again, thanks for your reply. Oddly, the problem went away... I have done nothing different, but can use all buttons again.

If the problem returns I will try your suggestion.
GM Retrofire
Game Masters
C C P Alliance
#7 - 2011-10-12 06:17:31 UTC
Do you by any chance have Adobe Photoshop or Adobe Suite installed?

I remember one case where ( for some strange reason ) CS4 was the cause of this exact problem and having any of the CS4 programs running, background programs included, caused this to happen.

GM Retrofire| Senior Game Master

Renan Ruivo
Hengetools Consumer Products S.A.
#8 - 2011-10-12 15:36:23 UTC
I have just posted this in GD and opened a ticket as well. Fixed the problem by rebooting.

The world is a community of idiots doing a series of things until it explodes and we all die.

Mirei Jun
Garoun Investment Bank
Gallente Federation
#9 - 2011-10-15 00:38:58 UTC
GM Retrofire wrote:
Do you by any chance have Adobe Photoshop or Adobe Suite installed?

I remember one case where ( for some strange reason ) CS4 was the cause of this exact problem and having any of the CS4 programs running, background programs included, caused this to happen.


Nope, I don't have either of those installed.

Like I said in the original post, there was no differences in installed apps from before, or after the problem appeared then went away... Odd.

Thanks
Mirei Jun
Garoun Investment Bank
Gallente Federation
#10 - 2011-10-25 01:10:32 UTC

Well, this cute little problem has returned. As an update:

- On screen keyboard does not work

- Changing Keyboard type to an English US keyboard does not work

Really odd bug...
Daevid Mardieu
The Scope
Gallente Federation
#11 - 2011-10-25 09:06:56 UTC
Dude, just got the same problem. Pretty lame. I've recently installed VMWare though, so it might be that.
Mirei Jun
Garoun Investment Bank
Gallente Federation
#12 - 2011-10-25 14:49:53 UTC

And the problem went away....

Been going over anything and everything that could possibly cause a problem.

Over the weekend this computer is used to watch dramas and television on the Pandora Video site. Absolutely nothing else is different.

It sounds like there is a list of programs causing issue... Perhaps someone in QA will be able to pin the problem down.

Lucius Regall
CTRL-Q
#13 - 2012-01-12 12:12:23 UTC
I had this issue as well. It began when I started using a microsoft keyboard at the same time as a logitech mouse, causing both logitech setpoint and microsoft intellipoint to run at the same time. Disabling or removing one caused the problem to go away. So the issue it seems to me is with software that customizes mouse/keyboards.
Shiro McCloud
Sebiestor Tribe
Minmatar Republic
#14 - 2012-01-12 16:29:24 UTC
I had been suffering with something similar to this that caused keyboard shortcuts to fall over, and it was due to my touchpad driver not being current despite Windows thinking it was. Can you do anything different in space than in station keys wise? Have any Windows updates installed themselves quietly that might have altered your settings? Why don't you try Windows in safe mode, and see what happens?
Becha Nilg
Tensenn Industries
#15 - 2012-04-11 14:47:21 UTC
I am sorry if noone is still interested in this. I just have a little information to add to the issue. When I get this problem (very rare, once every 2 weeks maybe.. often after changing from power to battery on mouse i think), i usually return to the lockscreen (ctrl+alt+delete, windows 7 64) a few times, and the problem dissappaers. Thisfixes it even while eve is running, windowed mode.
Furucius
InterG Mining and Transport
Vulkaran Coalition
#16 - 2012-04-20 03:55:39 UTC
I would like to just pipe in and say I was having this problem and I can confirm that the problem for my computer was that I had Photoshop Cs2 running on my computer. I saw the post about photoshop, and so I closed photoshop and magically my esc key started working again. It is a bizarre bug.