These forums have been archived and are now read-only.

The new forums are live and can be found at https://forums.eveonline.com/

Linux

 
 

OpenSSL Updates on Arch (and others) Cause Launcher Infinite Waiting

Author
NanDe YaNen
Liberal Universalists
#1 - 2017-08-03 05:22:20 UTC
Observed:

Launcher program provides no feedback to the terminal. Warnings are emitted into the logs:

themooch@whitehouse ~ $ tail -f /home/themooch/.local/share/CCP/EVE/Launcher/launcherlog-2017.08.03-00.08.15.346.txt
2017-08-03T00:08:15.352Z    qt.network.ssl    warning    QSslSocket: cannot resolve SSLv3_client_method
2017-08-03T00:08:15.352Z    qt.network.ssl    warning    QSslSocket: cannot resolve SSLv23_client_method
2017-08-03T00:08:15.352Z    qt.network.ssl    warning    QSslSocket: cannot resolve SSLv2_server_method
2017-08-03T00:08:15.352Z    qt.network.ssl    warning    QSslSocket: cannot resolve SSLv3_server_method
2017-08-03T00:08:15.352Z    qt.network.ssl    warning    QSslSocket: cannot resolve SSLv23_server_method
2017-08-03T00:08:15.352Z    qt.network.ssl    warning    QSslSocket: cannot resolve X509_STORE_CTX_get_chain
2017-08-03T00:08:15.352Z    qt.network.ssl    warning    QSslSocket: cannot resolve OPENSSL_add_all_algorithms_noconf
2017-08-03T00:08:15.353Z    qt.network.ssl    warning    QSslSocket: cannot resolve OPENSSL_add_all_algorithms_conf
2017-08-03T00:08:15.353Z    qt.network.ssl    warning    QSslSocket: cannot resolve SSLeay
2017-08-03T00:08:15.353Z    qt.network.ssl    warning    QSslSocket: cannot resolve SSLeay_version


To fix it, I copied my SSL 1.0 version files for libssl and libcrypto to the launcher directory. I credit Ailatan. This is an ongoing change that I believe should be stickied until the built-in Qt libs have the appropriate support statically compiled in or a better solution is reached.


Quote:

Ailatan wrote:
I have updated to Debian 9 Stretch today and launcher is not working. No error messages in console, it just wait infinitely after typing: ./evelauncher.sh

Any ideas? Anybody have this problem too?


Solved copying: libssl.so.1.0.2 and libcrypto.so.1.0.2 are in /usr/lib/x86_64linux-gnu/ into launcher folder and renaming them without version.