These forums have been archived and are now read-only.

The new forums are live and can be found at https://forums.eveonline.com/

Linux

 
 

Launcher Trying to Copy Non-Existent Files

Author
NanDe YaNen
Liberal Universalists
#1 - 2017-08-03 00:44:36 UTC
info    2017-08-02T19:38:08    2046    /home/themooch/eve/evelauncher/evelauncher    whitehouse    evelauncher    default    Copying "/home/themooch/.eve//ResFiles/1d/1d34143a37d4b739_6a455bd4aa3accbae6969654d08f77ab" to "/home/themooch/.eve//wineenv/drive_c/duality/resfileindex.txt"
info    2017-08-02T19:38:08    2046    /home/themooch/eve/evelauncher/evelauncher    whitehouse    evelauncher    default    Source file does not exists:  /home/themooch/.eve//ResFiles/1d/1d34143a37d4b739_6a455bd4aa3accbae6969654d08f77ab ( /home/themooch/.eve//wineenv/drive_c/duality/resfileindex.txt )


Launcher gets through about 500 of these and then just says "Error! see log for details"

I also had the black screen after character select that other players were experiencing. Decided to re-install. Deleted everything in:

.eve
.cache/CCP
.local/share/CCP
.EVE
evelauncher
*fresh tmp with nothing*

NanDe YaNen
Liberal Universalists
#2 - 2017-08-03 00:48:37 UTC
This hunk contains the first error that occurs during each 2min refresh cycle

info    2017-08-02T19:46:08    2046    /home/themooch/eve/evelauncher/evelauncher    whitehouse    evelauncher    download    "Downloader for Tranquility" addMissingFilesToQueue checking 169 files
info    2017-08-02T19:46:09    2046    /home/themooch/eve/evelauncher/evelauncher    whitehouse    evelauncher    download    Downloader for Tranquility addMissingFilesToQueue took 0.005 seconds
info    2017-08-02T19:46:09    2046    /home/themooch/eve/evelauncher/evelauncher    whitehouse    evelauncher    default    Downloading bundle for "eveonline_1170582.txt"
info    2017-08-02T19:46:09    2046    /home/themooch/eve/evelauncher/evelauncher    whitehouse    evelauncher    download    Resuming "Downloader for Tranquility"
info    2017-08-02T19:46:09    2046    /home/themooch/eve/evelauncher/evelauncher    whitehouse    evelauncher    download    "Downloader for Tranquility" has 8 files to download
info    2017-08-02T19:46:09    2046    /home/themooch/eve/evelauncher/evelauncher    whitehouse    evelauncher    download    Downloaded 0 files ( 0.00B )
info    2017-08-02T19:46:09    2046    /home/themooch/eve/evelauncher/evelauncher    whitehouse    evelauncher    default    No patches requested
info    2017-08-02T19:46:09    2046    /home/themooch/eve/evelauncher/evelauncher    whitehouse    evelauncher    default    Bundle chunks passed verification
info    2017-08-02T19:46:09    2046    /home/themooch/eve/evelauncher/evelauncher    whitehouse    evelauncher    default    Finished task "Downloader for Tranquility"
error    2017-08-02T19:46:09    2046    /home/themooch/eve/evelauncher/evelauncher    whitehouse    evelauncher    default    Couldn't open index file "/home/themooch/.eve//ResFiles/56/5610a6eb8b5a4975_868ce55bcacafaf337076a6b628a7540"
info    2017-08-02T19:46:09    2046    /home/themooch/eve/evelauncher/evelauncher    whitehouse    evelauncher    default    No prefetch index found for "Tranquility"
info    2017-08-02T19:46:09    2046    /home/themooch/eve/evelauncher/evelauncher    whitehouse    evelauncher    default    Scheduled task "Copier for Tranquility"
info    2017-08-02T19:46:09    2046    /home/themooch/eve/evelauncher/evelauncher    whitehouse    evelauncher    default    Starting task "Copier for Tranquility"

NanDe YaNen
Liberal Universalists
#3 - 2017-08-03 03:56:42 UTC
I created a new system user and ran the launcher from a pristine home directory. Same issue reproduced. I have no special wine installed and try to use the vanilla CCP wine with no tuning.
NanDe YaNen
Liberal Universalists
#4 - 2017-08-03 05:36:37 UTC
Got over the openssl version changes. Currently I'm watching the log tail indicate that bundles are being downloaded, but as in the past, the visual feedback is missing. Usually I get some visual feedback. In this case, there is none.

Tailing the logs looks like:

2017-08-03T00:33:55.621Z    default    debug    Downloading 77/7796dd360927a011_4d500456a6e4ea404d3e1049f2010fe5 ( app:/bulkdata/2002200009.cache2 )
2017-08-03T00:33:55.703Z    default    debug    Downloading 79/793eabc55b8f7528_7d13e582651c8af29f3ba436800136fd ( app:/bin/geo2.dll )
2017-08-03T00:33:55.786Z    default    debug    Downloading 89/8919ffe2ee5749cc_9439c2bbcaf68a505b12e4cee6e4b6be ( app:/bulkdata/mapbulk.db )
2017-08-03T00:33:56.585Z    default    debug    Downloading 8f/8f52eb0dd3f74c34_e7ef35499b7cad964ed20b336eba35d8 ( app:/bin/packages/certifi/cacert.pem )
2017-08-03T00:33:56.627Z    default    debug    Do


There is no visual indication that there is work being done that will complete at some point. The logs are the UI =)

Seems to be progressing. I believe that I may have been witnessing an instance of the Openssl bug but I'm not sure if they are related since I am not sure why the launcher continued to fail to copy non-existent files.