These forums have been archived and are now read-only.

The new forums are live and can be found at https://forums.eveonline.com/

Linux

 
  • Topic is locked indefinitely.
 

Launcher not working after update (SOLVED)

Author
Debian Severasse
The Scope
Gallente Federation
#1 - 2017-04-25 01:25:02 UTC  |  Edited by: Debian Severasse
The launcher wanted to do an update this morning (7 am Pacific time) & I OK'd it. Afterward, nothing would start. I try to start it in terminal & I see quite a period of time downloading---but no launcher & after the download period everything just hangs. I do not see anything in logs....generally without a clue as to which direction to go to find answers for this.......

Running Debian Sid (all updates current)...no major problems with the old launcher.

See the posts below---was a ssl problem.

"Let's nobody be dead today----Looks very bad on my report" One of my favorite lines from AVATAR :) Linux User# 395230

Hamish Nuwen
Escuadron Federal de Asalto
#2 - 2017-04-25 14:16:42 UTC
The same using an up-to-date Debian Stretch, the new launcher version doesn't work.
Boyamin
African Atomic.
Two Maidens One Chalice
#3 - 2017-04-25 21:25:50 UTC
I am running stretch and have the same issue after updating. I solved it by running:

apt-get install libssl1.0-dev


Background: QT does not support the openssl version 1.1 shipped by debian, which is linked by default as a shared library. Installing the dev header files the evelauncher linker switches to the older version of libssl.
Debian Severasse
The Scope
Gallente Federation
#4 - 2017-04-26 00:53:37 UTC
(Groan.....) Not another ssl problem....... THANK YOU for the "heads up" This is the 3rd time I've run into a ssl issue......will be glad when that is ironed out finally.

"Let's nobody be dead today----Looks very bad on my report" One of my favorite lines from AVATAR :) Linux User# 395230

Lonami Rainfeld
Caldari Provisions
Caldari State
#5 - 2017-04-28 16:46:20 UTC
If someone else is having problems with this on Arch, the solution for me was to install
libopenssl-1.0-compat
from the AUR, and then running evelauncher.sh with the environment variable LD_LIBRARY_PATH set to /usr/lib/openssl-1.0-compat/, i.e., running the game with the command
LD_LIBRARY_PATH=/usr/lib/openssl-1.0-compat/ ./evelauncher.sh
in the evelauncher directory.
Fenix Inferni
Dark Fenix Rising
#6 - 2017-05-14 08:44:49 UTC
Lonami Rainfeld wrote:
If someone else is having problems with this on Arch, the solution for me was to install
libopenssl-1.0-compat
from the AUR, and then running evelauncher.sh with the environment variable LD_LIBRARY_PATH set to /usr/lib/openssl-1.0-compat/, i.e., running the game with the command
LD_LIBRARY_PATH=/usr/lib/openssl-1.0-compat/ ./evelauncher.sh
in the evelauncher directory.



Works for manjaro too

Thx a lot!!!
Kossak Valkyrie
Bean-shidh
The Nameless Alliance
#7 - 2017-05-16 17:10:26 UTC
Lonami Rainfeld wrote:
If someone else is having problems with this on Arch, the solution for me was to install
libopenssl-1.0-compat
from the AUR, and then running evelauncher.sh with the environment variable LD_LIBRARY_PATH set to /usr/lib/openssl-1.0-compat/, i.e., running the game with the command
LD_LIBRARY_PATH=/usr/lib/openssl-1.0-compat/ ./evelauncher.sh
in the evelauncher directory.


Thank you, worked for Manjaro!
Roesjka
The Last Solution Inc
#8 - 2017-05-17 16:59:02 UTC
See also post https://forums.eveonline.com/default.aspx?g=posts&m=6943810#post6943810

Cheers,

Retired UNIX/Linux IT Specialist.

AsRock 990FX Extreme4, FX-8320, 16GB mem, GTX 1070

y50-70, i7, 16GB mem, GTX 860M

Both running Debian stretch 64bit

Babylelin
No Tears Just Dreams
#9 - 2017-05-21 03:03:18 UTC
Lonami Rainfeld wrote:
If someone else is having problems with this on Arch, the solution for me was to install
libopenssl-1.0-compat
from the AUR, and then running evelauncher.sh with the environment variable LD_LIBRARY_PATH set to /usr/lib/openssl-1.0-compat/, i.e., running the game with the command
LD_LIBRARY_PATH=/usr/lib/openssl-1.0-compat/ ./evelauncher.sh
in the evelauncher directory.




anyone have this NOT work?
Vashan Tar
GoonWaffe
Goonswarm Federation
#10 - 2017-05-27 13:23:45 UTC
Boyamin wrote:
I am running stretch and have the same issue after updating. I solved it by running:

apt-get install libssl1.0-dev


Background: QT does not support the openssl version 1.1 shipped by debian, which is linked by default as a shared library. Installing the dev header files the evelauncher linker switches to the older version of libssl.


Running ubuntu 17.04 and this did not work for me. Did you do anything else (symbolic links, etc)?