These forums have been archived and are now read-only.

The new forums are live and can be found at

Test Server Feedback

  • Topic is locked indefinitely.

Can't log into test server, it worked fine last week

Path of Now and Forever
#1 - 2017-02-13 19:20:02 UTC
When I try to log into singularity, where normally the "play" button is, it just says please wait.

Things I have tried:

- Restarted launcher (several times)
- Restarted computer
- Let it sit to see if it was updating, for hours
- Reset cache

Nothing worked so far.

Please help!

P.S. Tranquility works fine
State War Academy
Caldari State
#2 - 2017-02-13 19:58:51 UTC
This sounds like its related to the issue I and others are suffering from


I suspect that some client / server timeout values are different between TQ and SISI.

Where in the (real) world are you and what is your internet connection bandwidth?
Path of Now and Forever
#3 - 2017-02-13 20:10:02 UTC
I live in California, near San Francisco (just north of silicon valley) I have cable internet... not sure on the exact bandwidth.