These forums have been archived and are now read-only.

The new forums are live and can be found at https://forums.eveonline.com/

Linux

 
  • Topic is locked indefinitely.
 

Arch: could not find or load the Qt platform plugin "xcb" in "".

Author
Fraksken
The Scope
Gallente Federation
#1 - 2016-11-20 10:27:42 UTC
I am trying to get eve running on Arch.
After successfully installing steam I thought it would be easy. I am however running into some issues when running evelauncher:
Quote:
./evelauncher
This application failed to start because it could not find or load the Qt platform plugin "xcb"
in "".

Available platform plugins are: eglfs, linuxfb, minimal, minimalegl, offscreen, xcb.

Reinstalling the application may fix this problem.
Aborted (core dumped)


in the evelauncher dir there is this however:
Quote:
-rw-r--r-- 1 jos jos 967 Jun 2 17:16 libQt5XcbQpa.la
-rw-r--r-- 1 jos jos 973 Jun 2 17:16 libQt5XcbQpa.prl
lrwxrwxrwx 1 jos jos 21 Jun 2 17:16 libQt5XcbQpa.so -> libQt5XcbQpa.so.5.6.0
lrwxrwxrwx 1 jos jos 21 Jun 2 17:16 libQt5XcbQpa.so.5 -> libQt5XcbQpa.so.5.6.0
lrwxrwxrwx 1 jos jos 21 Jun 2 17:16 libQt5XcbQpa.so.5.6 -> libQt5XcbQpa.so.5.6.0
-rwxr-xr-x 1 jos jos 1409400 Mar 3 2016 libQt5XcbQpa.so.5.6.0


I also installed qt5-base qt5-tools and qt5-x11extras.
xcb is installed on the system:

Quote:
ldd /usr/lib/qt/plugins/platforms/libqxcb.so
linux-vdso.so.1 (0x00007ffc919fc000)
libQt5XcbQpa.so.5 => /usr/lib/libQt5XcbQpa.so.5 (0x00007fe204c1f000)
libQt5Gui.so.5 => /usr/lib/libQt5Gui.so.5 (0x00007fe2044e3000)
libQt5Core.so.5 => /usr/lib/libQt5Core.so.5 (0x00007fe203e0c000)
libstdc++.so.6 => /usr/lib/libstdc++.so.6 (0x00007fe203a84000)
libc.so.6 => /usr/lib/libc.so.6 (0x00007fe2036e6000)
libX11-xcb.so.1 => /usr/lib/libX11-xcb.so.1 (0x00007fe2034e4000)
libXi.so.6 => /usr/lib/libXi.so.6 (0x00007fe2032d1000)
libSM.so.6 => /usr/lib/libSM.so.6 (0x00007fe2030c9000)
libICE.so.6 => /usr/lib/libICE.so.6 (0x00007fe202eac000)
libxcb.so.1 => /usr/lib/libxcb.so.1 (0x00007fe202c83000)
libxcb-image.so.0 => /usr/lib/libxcb-image.so.0 (0x00007fe202a7e000)
libxcb-icccm.so.4 => /usr/lib/libxcb-icccm.so.4 (0x00007fe202879000)
libxcb-sync.so.1 => /usr/lib/libxcb-sync.so.1 (0x00007fe202670000)
libxcb-xfixes.so.0 => /usr/lib/libxcb-xfixes.so.0 (0x00007fe202468000)
libxcb-shm.so.0 => /usr/lib/libxcb-shm.so.0 (0x00007fe202264000)
libxcb-randr.so.0 => /usr/lib/libxcb-randr.so.0 (0x00007fe202054000)
libxcb-shape.so.0 => /usr/lib/libxcb-shape.so.0 (0x00007fe201e50000)
libxcb-keysyms.so.1 => /usr/lib/libxcb-keysyms.so.1 (0x00007fe201c4d000)
libxcb-xinerama.so.0 => /usr/lib/libxcb-xinerama.so.0 (0x00007fe201a48000)
libxcb-xkb.so.1 => /usr/lib/libxcb-xkb.so.1 (0x00007fe20182b000)
libxkbcommon-x11.so.0 => /usr/lib/libxkbcommon-x11.so.0 (0x00007fe201623000)
libfontconfig.so.1 => /usr/lib/libfontconfig.so.1 (0x00007fe2013df000)
libfreetype.so.6 => /usr/lib/libfreetype.so.6 (0x00007fe201122000)
libglib-2.0.so.0 => /usr/lib/libglib-2.0.so.0 (0x00007fe200e0f000)
libX11.so.6 => /usr/lib/libX11.so.6 (0x00007fe200ace000)
libxkbcommon.so.0 => /usr/lib/libxkbcommon.so.0 (0x00007fe20088e000)
libQt5DBus.so.5 => /usr/lib/libQt5DBus.so.5 (0x00007fe200603000)
libpthread.so.0 => /usr/lib/libpthread.so.0 (0x00007fe2003e6000)
libm.so.6 => /usr/lib/libm.so.6 (0x00007fe2000e2000)
libgcc_s.so.1 => /usr/lib/libgcc_s.so.1 (0x00007fe1ffecb000)
libpng16.so.16 => /usr/lib/libpng16.so.16 (0x00007fe1ffc93000)
libharfbuzz.so.0 => /usr/lib/libharfbuzz.so.0 (0x00007fe1ffa32000)
libz.so.1 => /usr/lib/libz.so.1 (0x00007fe1ff81c000)
libGL.so.1 => /usr/lib/libGL.so.1 (0x00007fe1ff5aa000)
libicui18n.so.57 => /usr/lib/libicui18n.so.57 (0x00007fe1ff130000)
libicuuc.so.57 => /usr/lib/libicuuc.so.57 (0x00007fe1fed88000)
libpcre16.so.0 => /usr/lib/libpcre16.so.0 (0x00007fe1feb1d000)
libdl.so.2 => /usr/lib/libdl.so.2 (0x00007fe1fe919000)
librt.so.1 => /usr/lib/librt.so.1 (0x00007fe1fe711000)
libsystemd.so.0 => /usr/lib/libsystemd.so.0 (0x00007fe1fe689000)
/usr/lib64/ld-linux-x86-64.so.2 (0x00005576e6f61000)
libXext.so.6 => /usr/lib/libXext.so.6 (0x00007fe1fe477000)
libuuid.so.1 => /usr/lib/libuuid.so.1 (0x00007fe1fe272000)
libXau.so.6 => /usr/lib/libXau.so.6 (0x00007fe1fe06c000)
libXdmcp.so.6 => /usr/lib/libXdmcp.so.6 (0x00007fe1fde66000)
libxcb-util.so.1 => /usr/lib/libxcb-util.so.1 (0x00007fe1fdc60000)
libexpat.so.1 => /usr/lib/libexpat.so.1 (0x00007fe1fda36000)
libbz2.so.1.0 => /usr/lib/libbz2.so.1.0 (0x00007fe1fd826000)
libpcre.so.1 => /usr/lib/libpcre.so.1 (0x00007fe1fd5b1000)
libdbus-1.so.3 => /usr/lib/libdbus-1.so.3 (0x00007fe1fd361000)
libgraphite2.so.3 => /usr/lib/libgraphite2.so.3 (0x00007fe1fd135000)
libxcb-dri3.so.0 => /usr/lib/libxcb-dri3.so.0 (0x00007fe1fcf32000)
libxcb-present.so.0 => /usr/lib/libxcb-present.so.0 (0x00007fe1fcd2f000)
libxshmfence.so.1 => /usr/lib/libxshmfence.so.1 (0x00007fe1fcb2c000)
libglapi.so.0 => /usr/lib/libglapi.so.0 (0x00007fe1fc8fb000)
libXdamage.so.1 => /usr/lib/libXdamage.so.1 (0x00007fe1fc6f8000)
libXfixes.so.3 => /usr/lib/libXfixes.so.3 (0x00007fe1fc4f2000)
libxcb-glx.so.0 => /usr/lib/libxcb-glx.so.0 (0x00007fe1fc2d6000)
libxcb-dri2.so.0 => /usr/lib/libxcb-dri2.so.0 (0x00007fe1fc0d1000)
libXxf86vm.so.1 => /usr/lib/libXxf86vm.so.1 (0x00007fe1fbecb000)
libdrm.so.2 => /usr/lib/libdrm.so.2 (0x00007fe1fbcb9000)
libicudata.so.57 => /usr/lib/libicudata.so.57 (0x00007fe1fa23d000)
libresolv.so.2 => /usr/lib/libresolv.so.2 (0x00007fe1fa026000)
libcap.so.2 => /usr/lib/libcap.so.2 (0x00007fe1f9e22000)
liblzma.so.5 => /usr/lib/liblzma.so.5 (0x00007fe1f9bfc000)
liblz4.so.1 => /usr/lib/liblz4.so.1 (0x00007fe1f99ea000)
libgcrypt.so.20 => /usr/lib/libgcrypt.so.20 (0x00007fe1f96d9000)
libgpg-error.so.0 => /usr/lib/libgpg-error.so.0 (0x00007fe1f94c5000)


Not sure how to fix this.
Mister Ripley
Ministry of War
Amarr Empire
#2 - 2016-11-20 14:08:51 UTC
Make sure you run the "evelauncher.sh" file, not the binary itself. Blink