These forums have been archived and are now read-only.

The new forums are live and can be found at https://forums.eveonline.com/

Skill Discussions

 
  • Topic is locked indefinitely.
 

EVEMon - The Open Source Character Planner (v3.0.2)

First post
Author
Areen Sassel
Dirac Angestun Gesept
#21 - 2016-06-30 23:15:28 UTC
I changed the skill queue warning (Tools, Options, Main Window, Skill Queue Warning Threshold) to 7 days. The popup message from the System Tray still says that there is less than a day's skill queue left. I am sorry that I cannot quote the exact message but it was transient. To be clear, the warning itself works - less than 7 days - but the message itself is inaccurate.
Kuatthlor
Pigs have eaten my car
#22 - 2016-07-01 13:25:23 UTC  |  Edited by: Kuatthlor
I managed to run the latest evemon under Linux, specifically Ubuntu 14.04. It will probably work on all later versions of Ubuntu (or mint, Debian ...) Similar procedure will probably work for any other Linux distro that is not apt based (are there any massochists around who use those at home?)

Here is how I achieved it:

1. remove wine installed by the system:
apt --installed list | grep wine | awk -F/ '{ print $1 }' | sudo xargs apt remove


2. add winehq wine repository:
sudo dpkg --add-architecture i386 
sudo add-apt-repository ppa:wine/wine-builds
sudo apt-get update
sudo apt-get install --install-recommends winehq-devel


3. clean any old wine settings:
mv ~/.wine ~/.wine_old


4. set wine to 32bit mode (yeah it sux but ...)
export WINEARCH=win32



5. get latest winetricks
wget https://raw.githubusercontent.com/Winetricks/winetricks/master/src/winetricks
chmod 755 winetricks


6. use winetricks to install dotnet 4.5.2:
./winetricks

Select the default wineprefix (click ok)
Install a Windows DLL or component (click ok)
select the following:

  • dotnet20
  • dotnet20sp1
  • dotnet30sp1
  • dotnet35
  • dotnet40
  • dotnet45
  • dotnet452


Winetricks will install them all, it will pop a few errors about mono not being installed that you can ignore. If it tells you to reboot, choose to reboot later

Dotnet installation will set your windows version to 2003 and that is just not enough!

7. Set windows version
run winecfg
In the first window set windows version to Windows 7

8. Download dotnet 4.6.1 from Microsoft site:
https://www.microsoft.com/en-us/download/details.aspx?id=49982
If this link doesn't work for any reason, goodle dot net 4.6.1 offline installer (online wont work)
run the downloaded file in wine:
wine ~/Downloads/NDP461-KB3102436-x86-x64-AllOS-ENU.exe /q 
(you have to run it with /q or it will fail)

9. Download evemon binaries, and run them with wine (and enjoy!!)
Runme Hackme3
Occipital Mining
#23 - 2016-07-03 01:53:44 UTC
Is there a known bug with importing skillplans or a cap on apis? I cannot, for the life of me, add an api key on windows 10 without causing the application to crash.
Osiato
Deep Core Mining Inc.
Caldari State
#24 - 2016-07-03 10:05:54 UTC
@Kuatthlor

1. I had to add -y after the 'apt' to get it to run. According to SE, the problem (auto aborting rather than asking y/n) was caused by the fact 'it wants interactive confirmation but can't read input from stdin' and -y skips the confirmation.

2. No problems encountered.

3. No problems encountered.

4. No problems encountered.

5. No problems encountered.

6. I got a bunch of fixmes but nothing stopped installation until:
error: dotnet30sp1 conflicts with dotnet20sp1, which is already installed.

I set it up to install the rest (35->452), but 35, 45 and 452 had the same problem.

7. My version was set to XP, not 2003 (I assume due to a missed install), but set it to 7 without problems anyway.

8. I'm not sure if it installed.. I ran it, but it threw a lot of fixmes and I didn't get any installer.

9. Didn't run. Here's the logs from trying to run it: https://bpaste.net/show/69e7e6147f99 and the ones for the entire process: https://bpaste.net/show/690236ef368d
Syrix Death
24th Imperial Crusade
Amarr Empire
#25 - 2016-07-03 11:06:35 UTC
Guys, dont do whatever that goon is telling you. Just install GtKEVEMon. There is even a official GtkEveMon PPA available for Ubuntu users.
Kuatthlor
Pigs have eaten my car
#26 - 2016-07-03 17:15:11 UTC
Osiato wrote:
@Kuatthlor

1. I had to add -y after the 'apt' to get it to run. According to SE, the problem (auto aborting rather than asking y/n) was caused by the fact 'it wants interactive confirmation but can't read input from stdin' and -y skips the confirmation.

2. No problems encountered.

3. No problems encountered.

4. No problems encountered.

5. No problems encountered.

6. I got a bunch of fixmes but nothing stopped installation until:
error: dotnet30sp1 conflicts with dotnet20sp1, which is already installed.

I set it up to install the rest (35->452), but 35, 45 and 452 had the same problem.

7. My version was set to XP, not 2003 (I assume due to a missed install), but set it to 7 without problems anyway.

8. I'm not sure if it installed.. I ran it, but it threw a lot of fixmes and I didn't get any installer.

9. Didn't run. Here's the logs from trying to run it: https://bpaste.net/show/69e7e6147f99 and the ones for the entire process: https://bpaste.net/show/690236ef368d


What distro are you on?
Kuatthlor
Pigs have eaten my car
#27 - 2016-07-03 17:29:42 UTC
Syrix Death wrote:
Guys, dont do whatever that goon is telling you. Just install GtKEVEMon. There is even a official GtkEveMon PPA available for Ubuntu users.


Can you give a single reason why GtkEVEMon is better than EVEMon (except that it doesn't need wine to run?)

It misses 70% of the features EVEMon has, starting with the overview tab, the interface is confusing, it lags behind EVE versions, and it likes to crash every once in a while.

EVEMon on the other hand works in wine perfectly
Osiato
Deep Core Mining Inc.
Caldari State
#28 - 2016-07-03 23:54:42 UTC
Kuatthlor wrote:
What distro are you on?

Ubuntu 16.04
Blitz Bandis
Republic Military School
Minmatar Republic
#29 - 2016-07-04 00:44:13 UTC
Runme Hackme3 wrote:
Is there a known bug with importing skillplans or a cap on apis? I cannot, for the life of me, add an api key on windows 10 without causing the application to crash.



Could you EvEMail me the exception?
Tsumoto Yoken
Republic Military School
Minmatar Republic
#30 - 2016-07-04 14:09:57 UTC  |  Edited by: Tsumoto Yoken
1) How do I set up cloud storage with Google Drive for my settings? Seems to be bugged: https://gyazo.com/e15f74f923ec742b18f044a43ad478b4

2) Everytime I added a schedule entry, EVEMon failed to open the next time and corrupted my settings file.

Sorry if these were already reported, I couldn't find anything related.

Edit: EVEMon 3.0.2 64bit on Windows 7.
Zhilia Mann
Tide Way Out Productions
#31 - 2016-07-05 06:05:26 UTC
I'm getting a crash every time I get a market order completion. New binaries haven't helped. I imagine this is the relevant section of the crash report?

System.NullReferenceException: Object reference not set to an instance of an object.
at EVEMon.Controls.NotificationList.MarketOrdersEndedMessage(MarketOrdersNotificationEventArgs ordersNotification) in EVEMon\Controls\NotificationList.cs:line 624
at EVEMon.Controls.NotificationList.DisplayTooltip(NotificationEventArgs notification) in EVEMon\Controls\NotificationList.cs:line 522
at EVEMon.Controls.NotificationList.listBox_MouseMove(Object sender, MouseEventArgs e) in EVEMon\Controls\NotificationList.cs:line 294
Anthar Thebess
#32 - 2016-07-06 08:26:34 UTC
Where can i find logs, it is constantly crashing for me.
Last thing that i see is something like skill violation, and then crash.
Athos warrior
Doomheim
#33 - 2016-07-08 19:24:43 UTC
Its almost unusable for me now. It will crash about every hour. I checked the fram type and its correct. I did backup and import my old evemon files to a clean install.

Any thoughts as the constant crashing is making me look at other options.
re ld
The Not So Jolly Rogers Academy
Goonswarm Federation
#34 - 2016-07-10 05:57:16 UTC
Athos warrior wrote:
Its almost unusable for me now. It will crash about every hour. I checked the fram type and its correct. I did backup and import my old evemon files to a clean install.

Any thoughts as the constant crashing is making me look at other options.



^ This. I cannot find any logs and it is not remotely useable. I have something like 50-100 characters and am wondering if its just overloaded on api pulls?

Regardless, i cannot even make new plans on existing characters.
Snopzet
Inglourious Squirrels
That Escalated Quickly.
#35 - 2016-07-10 19:01:52 UTC
I might have found a bug... I created a skill plan with a remap point in the middle of the plan. There are only two different skills with different attributes and ranks after the remap point, but the optimizer fails to find the better attribute distribution :/ take a look

At the top you can see what I get when I hit the "Optimized" button. There are two strange things you might notice:

  1. The training time after the remap is ~35 days, yet the optimizer shows ~15d
  2. Since "Scrapmetal Processing" has a higher rank, the better remap should focus on its attributes (as you can see in the second screenshot, which I fixed manually)



I'm using EveMON 3.0.2
Ae Zathras
Crabs Have Their Own Ways
#36 - 2016-07-11 15:57:27 UTC
Possible steps to reproduce a bug:
1. Start to train a skill.
2. Run EveMon, look at the queue.
3. Close EveMon.
4. Move a skill down to the training queue.
5. Start EveMon again:
http://imgur.com/97M7KJ9

What is wrong on the picture:
1. A false notification that the skill (Warhead Upgrades IV in this example) is complete.
2. The skill is partially complete, but EveMon says it's 0%

Version 3.0.2.
Taeron Ikkonen
Spit and Sawdust
#37 - 2016-07-11 16:37:06 UTC
Just one thing I've noticed.

When importing a loadout with rigs, it adds the rigging skills as requirements. They're not really required, they just reduce drawbacks.
Random User83
Royal Amarr Institute
Amarr Empire
#38 - 2016-07-12 10:39:55 UTC  |  Edited by: Random User83
The Skill Explorer has Mechanics V listed as the requirement for Large Armor Repairer II and Hull II. It only takes mechanics 3

EDIT: DERP WAS LOOKING AT REMOTE ARMOR REPAIRER DISREGARD

I'm a strong independant alt that don't need no main...

Ae Zathras
Crabs Have Their Own Ways
#39 - 2016-07-12 11:09:13 UTC
Correct tooltip but wrong percentage in the queue list:
http://imgur.com/G2mC0Nl
J'aurai
Aliastra
Gallente Federation
#40 - 2016-07-20 21:37:13 UTC
Tried the "Linux binary" for wine version and get a wine error box: "Path not found." and:

Unhandled exception: unimplemented function mscoree.dll.CorIsLatestSvc called in 32-bit code (0x7b83936c).

Running Ubuntu:

System information:
Wine build: wine-1.6.2
Platform: i386 (WOW64)
Host system: Linux
Host version: 4.4.0-31-generic

My other wine apps were fine before installing 4.61.. now it seems I get this error on any wine app I launch.

The actual windows exe gives same error but no wine error box saying path not found.

Guessing I'm missing some dot net crap. When I run winetricks, it doesnt let me select any option.. What a hassle. Wine was fine till I found this thread.. Remembering why I reboot into actual Windows before jacking with anything "eve".