These forums have been archived and are now read-only.

The new forums are live and can be found at https://forums.eveonline.com/

Linux

 
  • Topic is locked indefinitely.
 

Ubuntu16.04LTS error

Author
oEnomel Psy
Sebiestor Tribe
Minmatar Republic
#1 - 2016-06-21 05:39:05 UTC
im having difficulty getting Eve running under linux. first i tried fedora now im trying Ubuntu16.04LTS
ive tried playonlinux and linux installer, neither working
running geforce 570gtx with nvidia 367.27

for evelauncher-1043593
the launcher loads but nothing happens when i launch the game
Quote:
[0621/152407:ERROR:nss_util.cc(96)] Failed to create /home/user/.pki/nssdb directory.
[0621/152407:WARNING:resource_bundle.cc(291)] locale_file_path.empty() for locale
Installed Qt WebEngine locales directory not found at location /home/user/evelauncher/translations/qtwebengine_locales. Trying application directory...
Qt WebEngine locales directory not found at location /home/user/evelauncher/qtwebengine_locales. Trying fallback directory... Translations MAY NOT not be correct.
[0621/152407:ERROR:nss_util.cc(96)] Failed to create /home/user/.pki/nssdb directory.
[0621/152407:WARNING:resource_bundle.cc(291)] locale_file_path.empty() for locale
[S_API FAIL] SteamAPI_Init() failed; SteamAPI_IsSteamRunning() failed.
[S_API FAIL] SteamAPI_Init() failed; unable to locate a running instance of Steam, or a local steamclient.so.


for playonlinux eve
the launcher opens but the box is blank except for the top-right menu buttons
Quote:
Unhandled exception: unimplemented function msvcr120.dll.nextafter called in 32-bit code (0x7b83de72).
Register dump:
CS:0023 SS:002b DS:002b ES:002b FS:0063 GS:006b
EIP:7b83de72 ESP:0033ddb4 EBP:0033de28 EFLAGS:00200202( - -- I - - - )
EAX:7b829511 EBX:7b8beab4 ECX:00000008 EDX:0033ddd4
ESI:00000002 EDI:238382c0
Backtrace:
=>0 0x7b83de72 in kernel32 (+0x1de72) (0x0033de28)
1 0x7e4135a8 in msvcr120 (+0x735a7) (0x0033de60)
2 0x7e3af05d in msvcr120 (+0xf05c) (0x0033dea8)
3 0x111abaee in qt5webenginecore (+0x11abaed) (0x0033dea8)
4 0x111ab812 in qt5webenginecore (+0x11ab811) (0x0033df58)
5 0x111ab355 in qt5webenginecore (+0x11ab354) (0x0033df70)
6 0x111a90ae in qt5webenginecore (+0x11a90ad) (0x0033df88)
7 0x111ae3ed in qt5webenginecore (+0x11ae3ec) (0x0033e03c)
8 0x111af2eb in qt5webenginecore (+0x11af2ea) (0x0033e0d0)
9 0x111bbb80 in qt5webenginecore (+0x11bbb7f) (0x0033e3c4)
10 0x111bc7c5 in qt5webenginecore (+0x11bc7c4) (0x0033e400)
11 0x111c1b1e in qt5webenginecore (+0x11c1b1d) (0x0033e4c8)
12 0x111c1879 in qt5webenginecore (+0x11c1878) (0x0033e524)
13 0x111c199b in qt5webenginecore (+0x11c199a) (0x0033e550)
14 0x111c301e in qt5webenginecore (+0x11c301d) (0x0033e570)
15 0x111c2dfd in qt5webenginecore (+0x11c2dfc) (0x0033e5ac)
16 0x111c45dd in qt5webenginecore (+0x11c45dc) (0x0033eea4)
17 0x110f6681 in qt5webenginecore (+0x10f6680) (0x0033eeb8)
18 0x11019f4c in qt5webenginecore (+0x1019f4b) (0x0033ef3c)
19 0x11019f12 in qt5webenginecore (+0x1019f11) (0x0033ef54)
20 0x1113c619 in qt5webenginecore (+0x113c618) (0x0033efd8)
21 0x1113b8ce in qt5webenginecore (+0x113b8cd) (0x0033f008)
22 0x1113c526 in qt5webenginecore (+0x113c525) (0x0033f020)
23 0x1109267b in qt5webenginecore (+0x109267a) (0x0033f038)
24 0x110933e8 in qt5webenginecore (+0x10933e7) (0x0033f060)
25 0x1127fc64 in qt5webenginecore (+0x127fc63) (0x0033f0b8)
26 0x1124d799 in qt5webenginecore (+0x124d798) (0x0033f0fc)
27 0x10ff7ca2 in qt5webenginecore (+0xff7ca1) (0x0033f128)
28 0x10ff6f96 in qt5webenginecore (+0xff6f95) (0x0033f158)
29 0x110837f6 in qt5webenginecore (+0x10837f5) (0x0033f16c)
30 0x10afbd21 in qt5webenginecore (+0xafbd20) (0x0033f178)
31 0x10ad04f2 in qt5webenginecore (+0xad04f1) (0x0033f1b0)
32 0x10ad286c in qt5webenginecore (+0xad286b) (0x0033f1c0)
33 0x1008dc9a in qt5webenginecore (+0x8dc99) (0x0033f228)
34 0x10888547 in qt5webenginecore (+0x888546) (0x0033f628)
35 0x10c686de in qt5webenginecore (+0xc686dd) (0x0033f640)
36 0x1156a785 in qt5webenginecore (+0x156a784) (0x0033f6c8)
37 0x10d84531 in qt5webenginecore (+0xd84530) (0x0033f720)
38 0x104027ac in qt5webenginecore (+0x4027ab) (0x0033f730)
39 0x10a3bc0f in qt5webenginecore (+0xa3bc0e) (0x0033f7e0)
40 0x10bf2810 in qt5webenginecore (+0xbf280f) (0x0033f844)
41 0x10bf1e5d in qt5webenginecore (+0xbf1e5c) (0x0033f95c)
42 0x10bf2b2f in qt5webenginecore (+0xbf2b2e) (0x0033f974)
43 0x10a3bc0f in qt5webenginecore (+0xa3bc0e) (0x0033fa24)
44 0x109fa401 in qt5webenginecore (+0x9fa400) (0x0033fb08)
45 0x109f9fa9 in qt5webenginecore (+0x9f9fa8) (0x0033fb8c)
46 0x10a3d4c4 in qt5webenginecore (+0xa3d4c3) (0x0033fbb0)
47 0x109fa2c0 in qt5webenginecore (+0x9fa2bf) (0x0033fbe0)
48 0x109fa27d in qt5webenginecore (+0x9fa27c) (0x0033fc08)
49 0x1088fb0e in qt5webenginecore (+0x88fb0d) (0x0033fd14)
50 0x1029898e in qt5webenginecore (+0x29898d) (0x0033fd34)
51 0x1029883d in qt5webenginecore (+0x29883c) (0x0033fd80)
52 0x10297f93 in qt5webenginecore (+0x297f92) (0x0033fd90)
53 0x10087561 in qt5webenginecore (+0x87560) (0x0033fdc8)
54 0x004015cd in qtwebengineprocess (+0x15cc) (0x00b62410)
55 0x00b62460 (0x00b62248)
56 0x4c5c4556 (0x455c3a43)
0x7b83de72: movl 0xfffffff4(%ebp),%ecx
System information:
Wine build: wine-1.7.46
Platform: i386
Host system: Linux
Host version: 4.4.0-24-generic


so something to do with qtwebengine but it should be included yes?
Adara Starkiss
Argentum Holdings
Strategic Executions
#2 - 2016-06-21 14:05:04 UTC  |  Edited by: Adara Starkiss
Im not a guru around here, but Id think that you need to provide more details :)

For example, which evelauncher are you running, as we have 2 online launchers (the native and what it used to be the beta launcher) and there's also the off line installer, which is what I ended up doing originally.

I originally installed it with the offline installer, and then did the beta-launcher so that I could patch the game and play it (that launcher didnt work as intended with my system, but I could essentially do the updates and launch the game). (Of course, I had to install wine first).

Then when we got the native linux launcher, I basically downloaded it, and since Im on a limited data plan (2GB) I had to copy the shared cache from my original install to the new location that this new launcher uses, and then execute the launcher.

Anyways, whatever more details you can throw Im sure someone here will be able to help you :)

Ubuntu Mate 16.04.2 64bit // Amd A8-5600K with RX460 4GB // 6GB DDR3 // Sandisk 120GB SSD Plus // Wine Stable 2.01 // Native Linux Launcher // TS3 working // Happy to be back in Ubuntu :)

oEnomel Psy
Sebiestor Tribe
Minmatar Republic
#3 - 2016-06-22 03:12:51 UTC  |  Edited by: oEnomel Psy
oops newb mistake
i think it might be working now
Som Boty
Super Mother Fan Club
#4 - 2016-06-22 04:08:47 UTC
What was the mistake?
oEnomel Psy
Sebiestor Tribe
Minmatar Republic
#5 - 2016-06-22 04:35:27 UTC
Som Boty wrote:
What was the mistake?


i didnt include sudo when launching
but that wasnt the problem last time i was trying to get it working
i think maybe just the resources were really slow to load
Ragnar STS
Arcane Odyssey
Electus Matari
#6 - 2016-06-22 04:43:01 UTC
Actually you don't need sudo. I actually made this mistake too with the native launcher. It is a bugger because if you sudo it, the program proceeds to litter your regular user home directory with a dozen folders full of stuff....all with root ownership instead of your user. All further attempts to run the game would then fail miserably because it doesn't have access to do anything.

Sorting through the folders is kind of a bugger. can try a sudo chown oops:oops /home/oops -R .... but I have a feeling that wouldn't work out so well. I was testing a new load when I did it...so I just spent the extra 10 minutes to start from scratch again. :)
Viktor Keres
#7 - 2016-06-23 00:13:56 UTC
my problem is the launcher working as intended, but when i play... nothing loads... nothing happens...

anyone know how to fix this? also i have the same error crap on terminal as the OP.

Elmore Jones
Nebula II
#8 - 2016-06-23 00:49:37 UTC
You may need to install the 32bit libs (to linux as opposed to the eve dir). Installing playonlinux or wine will bundle in the extras.

ubuntu/debian/mint/derivatives : sudo apt-get install wine
opensuse : sudo zypper in wine

+++ Reality Error 404 - Reboot Cosmos +++

Viktor Keres
#9 - 2016-06-23 01:36:55 UTC
ah ya, that was the problem, i had to download wine. problem fixed.
Viktor Keres
#10 - 2016-06-25 01:58:25 UTC
how do you uninstall? i want to install it on another drive.