These forums have been archived and are now read-only.

The new forums are live and can be found at https://forums.eveonline.com/

Linux

 
  • Topic is locked indefinitely.
 

Has anyone gotten the newest launcher to work?

Author
Som Boty
Super Mother Fan Club
#1 - 2016-03-18 17:06:22 UTC
I really like using the newest launcher on Windows with the ability to keep multiple accounts logged in and easily activated. As well as the ability to move to Sisi.


Has anyone been able to get it working on Linux? if so, what were the steps?
Elegbara
White Wolf Enterprises
Harmonious Ascent
#2 - 2016-03-19 08:01:22 UTC
Works fine for me, no extra steps needed.

Open your eyes. And awaken.

Sir Francis Bacon
Weary Travelers
#3 - 2016-03-19 14:12:25 UTC
It works for me on Ubuntu 15.10 with wine 1.9.5 with mscvr80.dll set to (builtin,native), however after the last update it crashes 2/3 times I launch it, but it will eventually work if I keep trying. Haven't had much time to troubleshoot it yet though.
Som Boty
Super Mother Fan Club
#4 - 2016-03-19 18:06:35 UTC
Elegbara wrote:
Works fine for me, no extra steps needed.



did you just download the windows exe and then run with Vine?
Rounon Dax
Terra Nanotech
Evictus.
#5 - 2016-03-20 13:00:58 UTC
You need to install vcrun2013 via winetricks in order to get the new launcher work.
Sir Francis Bacon
Weary Travelers
#6 - 2016-03-20 14:17:27 UTC
Rounon Dax wrote:
You need to install vcrun2013 via winetricks in order to get the new launcher work.


Oh yeah, that's right. I totally forgot that the new launcher needs that. It's been awhile since I've installed it Oops
Elegbara
White Wolf Enterprises
Harmonious Ascent
#7 - 2016-03-20 21:45:56 UTC
Som Boty wrote:
Elegbara wrote:
Works fine for me, no extra steps needed.



did you just download the windows exe and then run with Vine?

Well, I do have a prefix for Eve, it's set up as described at winehq. I am rebuilding wine from source for every release but I don't have any modifications to the code (anymore).

Open your eyes. And awaken.

Ragnar STS
Arcane Odyssey
Electus Matari
#8 - 2016-03-21 02:34:40 UTC  |  Edited by: Ragnar STS
Confirm new launcher works now. Sweet hotness. Will be so nice to be able to swap between test and live servers.

Biggest complaint is that it doesn't auto-find the existing install, and doesn't re-use all the window location and settings bits. It does a full reinstall by default.

Maybe it was time to start fresh anyway.

**EDIT** Found the settings migration. I guess I would have made it so that it launched automatically if it senses and old setup. Worky worky and didn't have to start over!
Kismeteer
Bat Country
Pandemic Horde
#9 - 2016-04-13 18:35:42 UTC
note, for the new launcher, I've been using this to launch singularity:
/usr/bin/env WINEPREFIX="$HOME/.wine" DISPLAY=":0.0" wine explorer /desktop=eve1,1024x768 "C:\users\Public\Application Data\CCP\EVE\SharedCache\sisi\bin\exefile.exe" \/triPlatform=dx9 \/server:Singularity