These forums have been archived and are now read-only.

The new forums are live and can be found at https://forums.eveonline.com/

Linux

 
  • Topic is locked indefinitely.
 

Easy Ubuntu + EVE guide and a variety of things.

Author
Jenshae Chiroptera
#1 - 2015-12-28 08:24:28 UTC  |  Edited by: Jenshae Chiroptera
EVE + Ubuntu for Dummies


March 2016:


  1. Use Ubuntu 14.04 LTS
  2. Install PlayOnLinux
  3. Download the EVE Offline Installer
  4. Go to the properties of the .MSI file and make it executable.
  5. Open PlayOnLinux, click Install -> Games -> EVE Online -> Next, Next and allow it to prepare a Virtual Drive for you.
  6. Fail the install.
  7. Open the main PlayOnLinux screen and select Configure -> EVEonline -> Miscellaneous -> Run a Windows Executable file -> Select the .MSI file from the EVE installer -> Install EVE.
  8. PoL -> General -> Make a new shortcut -> exefile.exe -> Name it
  9. Put the Repair.exe in the same folder as your eve.exe file using -> Miscellaneous -> Open virtual drive's directory and create a shortcut as above for it.
  10. Run the repair.exe, let it update itself and your client.
  11. Run the Launcher short cut and send me 1 ISK so I can see how many people use this successfully. Blink




Okay, I can see how I could end up making many threads in this section, so instead of doing that, I will keep updating this original post.

Arrow R3 390 card being detected as HD 5600

Which is clearly not the case.
Now, EVE runs just fine most of the time.
However, this weekend we fought Pandemic Legion and had the Russians on field. My client locked up either the CTRL key or the V key and it was lagging like I had my old machine again.
Mid fight I was altering settings, dropped HDR enabled and Post Processing first from everything max. Then shadows, then shaders, still no improvement. Eventually I hit the Optimize Settings and went for Best Performance.
It did not help much.
I did forget to turn off sound.

Later I tried various 1.8 Wine versions. So far all I get, which is different from them are a constant repeating noise, like an old film machine with your ear close to it.

Wine config, libraries:

Default - *d3d11 (disabled)
Launcher.exe - * msvcr90 (native, builtin)
Repair.exe - * msvcr90 (native, builtin)

... that's it.
Strange.
I did install and I do manage EVE via PlayOnLinux.

To repeat, most of the time, gangs, small fleets (wing or two against another wing or two), PVE, et cetera it has worked perfectly at maximum settings. It was just this one large engagement (the first since getting this machine) where everything went haywire.

CCP - Building ant hills and magnifying glasses for fat kids

Not even once

EVE is becoming shallow and puerile; it will satisfy neither the veteran nor the "WoW" type crowd in the transition.

Jenshae Chiroptera
#2 - 2015-12-28 08:25:31 UTC  |  Edited by: Jenshae Chiroptera
I have reverted for the moment back to 1.7.42 for the sounds.

I have also noted that there is no 64bit support for EVE as it is a 32bit program.
There have been cases with various games where they use 1/12 threads to 100% and lock up the machine. I don't know if this was happening at the time of the fleet fight.

Getting typing lag now with no discernible reason.

CCP - Building ant hills and magnifying glasses for fat kids

Not even once

EVE is becoming shallow and puerile; it will satisfy neither the veteran nor the "WoW" type crowd in the transition.

Torgeir Hekard
I MYSELF AND ME
#3 - 2015-12-29 20:58:03 UTC
Wine isn't stellar on exact videocard model detection

My GT645M is 760GTX or something like that for example. It was 8800GT before.

HD4870 was detecting as HD4600 IIRC.

Doesn't mean much though.

As for performance drop in big fights, sadly it happens. I have a feeling that most of the fault lies in overview and brackets.

I suspect for amd cards it's worth to try opensource drivers + latest kernel/mesa/llvm + gallium-nine + wine-nine.
Jenshae Chiroptera
#4 - 2015-12-30 07:09:55 UTC
Torgeir Hekard wrote:
I have a feeling that most of the fault lies in overview and brackets.
I suspect for amd cards it's worth to try opensource drivers + latest kernel/mesa/llvm + gallium-nine + wine-nine.

My brackets are pretty much ships only on PVP tab.
Need to try some of that last line of yours.
Thanks

CCP - Building ant hills and magnifying glasses for fat kids

Not even once

EVE is becoming shallow and puerile; it will satisfy neither the veteran nor the "WoW" type crowd in the transition.

Jenshae Chiroptera
#5 - 2016-01-17 23:51:14 UTC
EVE is running pretty much the same on Wine 1.9.0

CCP - Building ant hills and magnifying glasses for fat kids

Not even once

EVE is becoming shallow and puerile; it will satisfy neither the veteran nor the "WoW" type crowd in the transition.

Jenshae Chiroptera
#6 - 2016-01-24 17:51:38 UTC
Jenshae Chiroptera wrote:
EVE is running pretty much the same on Wine 1.9.0
Didn't think to turn on audio.
Getting weird sort of machine gun fire noise.
Went back to 1.7.42 and it is fine again on audio but I am hoping newer versions of Wine will fix bugs I am having.

I am now having weird disconnects with EVE. My net is still up, can keep talking on voice comms etc, streaming music.
I tried to target drones with my drones.
It kept doing it over and over.
Waited a little then asked on comms, I had left the fleet and warped off, so the server had lost me.


CCP - Building ant hills and magnifying glasses for fat kids

Not even once

EVE is becoming shallow and puerile; it will satisfy neither the veteran nor the "WoW" type crowd in the transition.

Jenshae Chiroptera
#7 - 2016-01-30 00:17:06 UTC
Source
Kismeteer wrote:
I hear reports of PYFA working on Linux, it's like EFT. https://forums.eveonline.com/default.aspx?g=posts&t=247609 (Must compile)

Kasutra wrote:
Compile? You just run the script.
But yes, it works perfectly. No fiddling. Just remember to install the dependencies.
I'm not getting far on the dependencies part.
Considering this I don't think I have specific information on what I exactly need and to do with Pyfa.

CCP - Building ant hills and magnifying glasses for fat kids

Not even once

EVE is becoming shallow and puerile; it will satisfy neither the veteran nor the "WoW" type crowd in the transition.

Torgeir Hekard
I MYSELF AND ME
#8 - 2016-01-31 14:28:56 UTC  |  Edited by: Torgeir Hekard
Jenshae Chiroptera wrote:
Source
Kismeteer wrote:
I hear reports of PYFA working on Linux, it's like EFT. https://forums.eveonline.com/default.aspx?g=posts&t=247609 (Must compile)

Kasutra wrote:
Compile? You just run the script.
But yes, it works perfectly. No fiddling. Just remember to install the dependencies.
I'm not getting far on the dependencies part.
Considering this I don't think I have specific information on what I exactly need and to do with Pyfa.


Depends On     : python2 wxpython python2-sqlalchemy python2-dateutil python2-requests python2-urllib3
Optional Deps  : python2-matplotlib: for graph plotting
                 python2-numpy: for graph plotting


Pyfa is written in python, it depends on everything python and thus is pretty much platform agnostic.
Jenshae Chiroptera
#9 - 2016-01-31 22:29:06 UTC
Thanks, will look into what those include some time this week.

CCP - Building ant hills and magnifying glasses for fat kids

Not even once

EVE is becoming shallow and puerile; it will satisfy neither the veteran nor the "WoW" type crowd in the transition.

Jenshae Chiroptera
#10 - 2016-03-14 12:39:34 UTC  |  Edited by: Jenshae Chiroptera
My client was freezing quite a lot despite resetting the cache, etc, so I decided to do a fresh install in case there was some legacy patch bug I had.

However, the new install has hidden the exefile.exe despite downloading the entire ~8GB.

User@Machine:~/.wine/drive_c/EVE$ ls
components.xml       maintenancetool.dat.new  network.xml
InstallationLog.txt  maintenancetool.exe.new  ** SharedCache
** Launcher             maintenancetool.ini

--------
Launcher folder ls

bearer                                    Qt5Core.dll
crash_history.crs                         Qt5Gui.dll
crash.txt                                 Qt5Network.dll
d3dcompiler_47.dll                        Qt5Positioning.dll
** eve.exe                                Qt5Qml.dll
evelauncher_de.qm                         Qt5Quick.dll
evelauncher.exe                           Qt5Svg.dll
evelauncher_fr.qm                         Qt5WebChannel.dll
evelauncher_ja.qm                         Qt5WebEngineCore.dll
evelauncher_ru.qm                         Qt5WebEngine.dll
fb4c612e-6a32-4938-9c68-00cac54b51c2.dmp  Qt5WebEngineWidgets.dll
fixpermissions.exe                        Qt5Widgets.dll
iconengines                               Qt5WinExtras.dll
icudtl.dat                                qt.conf
imageformats                              qtwebengine
libeay32.dll                              QtWebEngineProcess.exe
libEGL.dll                                qtwebengine_resources_100p.pak
libGLESV2.dll                             qtwebengine_resources_200p.pak
LogLite.exe                               qtwebengine_resources.pak
msvcp120.dll                              ssleay32.dll
msvcr120.dll                              steam_api.dll
opengl32sw.dll                            translations
platforms                                 updater.exe
position                                  vccorlib120.dll
Qt5Concurrent.dll



... and yeah, the launcher seems to be a large contributor to "socket closed" which only now do I get.

If eve.exe is the right file. what are the wine arguments to run it? Been using delicious PlayOnLinux up until now.

Edit:
Scratch that, the Launcher must have been spying on me, now I click "Play" and it says "Launching ..." then after a bit it flips back to "Play" after doing nothing.

CCP - Building ant hills and magnifying glasses for fat kids

Not even once

EVE is becoming shallow and puerile; it will satisfy neither the veteran nor the "WoW" type crowd in the transition.

Lucius Kalkoken
Ubiquitous Hurt
The WeHurt Initiative
#11 - 2016-03-14 22:26:25 UTC
Jenshae Chiroptera wrote:


Arrow R3 390 card being detected as HD 5600


You'll need to get it added to wine. They keep a list so they can map cards to features they support (and quirks that need to be worked around).

The card that you see is the fallback card for d3d11 capable devices if you use an AMD driver.

There is no shame in not knowing, only in not wanting to know

Jenshae Chiroptera
#12 - 2016-03-15 02:59:42 UTC
Lucius Kalkoken wrote:
You'll need to get it added to wine. They keep a list ...
Thank you but I can't even log in at this point. P

CCP - Building ant hills and magnifying glasses for fat kids

Not even once

EVE is becoming shallow and puerile; it will satisfy neither the veteran nor the "WoW" type crowd in the transition.

Ravow
Black Force Navy
Deep Space Alliance
#13 - 2016-03-16 15:15:30 UTC  |  Edited by: Ravow
You might get better performance if you use OSS drivers with native D3D instead of wine D3D->OpenGL conversion layer. Plus, with these Wine patch, card detection work (for me at least).

In my case with all setting to max, if I put "immediate", I get between 150 and 220 fps with a Radeon 7970. And using EVE with intervale 1 use about 30% CPU only instead of a full core plus about 30%

https://wiki.ixit.cz/d3d9_install

EDIT : You need bleeding edge graphic stack (git libdrm, llvm, mesa, xf86-video-ati, d3d patched wine)

EDIT2 : for the freezing, go in eve setting and disable ALL the camera stuff (shake, offseting and all other)
Jenshae Chiroptera
#14 - 2016-03-16 15:43:25 UTC  |  Edited by: Jenshae Chiroptera
Thank you. Will do if I get a working client.

Success! Adding my dummy's guide to the OP.

CCP - Building ant hills and magnifying glasses for fat kids

Not even once

EVE is becoming shallow and puerile; it will satisfy neither the veteran nor the "WoW" type crowd in the transition.

Oswald Stone
Sunrise Services
#15 - 2016-03-17 06:33:19 UTC
Installed on Gentoo Linux, running PoL 4.2.8
elitatwo
Zansha Expansion
Brave Collective
#16 - 2016-03-25 17:43:08 UTC  |  Edited by: elitatwo
I am running on Mint 17.3 (Rosa) which is based on Ubuntu 14.4 LTS.

Works like a charm and if you have an AMD Radeon HD series graphic card, do not install kernel 4.0 and up. AMD doesn't support kernel 4 (yet).

Here is something you may like: http://gtkevemon.battleclinic.com/ which is a version on EVEmon.

On the PyFA website you can read what you need to do to get and build it.


On the wineHQ website you can read how to install the developer branch build which add support for dx11 BUT it doesn't work yet. I tried Sad

I hope dx11 comes soon because I miss the shield effects (which requires tessellation).


Oh and Jenshae. you should ask if we could get a sticky here.

Eve Minions is recruiting.

This is the law of ship progression!

Aura sound-clips: Aura forever

ColeraX Cervantes
The Scope
Gallente Federation
#17 - 2016-04-05 20:30:02 UTC  |  Edited by: ColeraX Cervantes
I am running on Mint 17.3 (Rosa) which is based on Ubuntu 14.4 LTS.

all use step but installer frozen I need help

Screenshot
Lazyshot Zanjoahir
Doomheim
#18 - 2016-04-25 14:38:37 UTC  |  Edited by: Lazyshot Zanjoahir
I'm also experiencing that on the install screen.

Were you able to resolve it?

--

DIsregard, after just letting it run for a bit It continued on with the rest of the install process no problems. Just took quite a while.
SET K
Ministry of War
Amarr Empire
#19 - 2016-05-21 21:02:11 UTC  |  Edited by: SET K
ColeraX Cervantes wrote:
I am running on Mint 17.3 (Rosa) which is based on Ubuntu 14.4 LTS.

all use step but installer frozen I need help

Screenshot


This step take from 5 to 10 minutes but then installation continues. (I'm also using linux Mint)
However after installation I was able to run launcher and login but then game just does not run.

if I run it from console the last lines is:


fixme:dxgi:dxgi_output_GetDisplayModeList iface 0x1469a8, format DXGI_FORMAT_B8G8R8A8_UNORM, flags 0, mode_count 0x339380, desc (nil) partial stub!
fixme:dxgi:dxgi_output_GetDisplayModeList iface 0x1469a8, format DXGI_FORMAT_B8G8R8A8_UNORM, flags 0, mode_count 0x339380, desc 0x2969b10 partial stub!


Can any one help me with this? I'm using x64 machine, should I make any additional tricks because of this?
Kodirovshchik
Ministry of War
Amarr Empire
#20 - 2016-05-22 21:35:13 UTC
Hi guys. I do not think my question deserves a separate topic. So... Do you have a CrossOver bottle for EveMon v3.0.0? I just can't make it work.