These forums have been archived and are now read-only.

The new forums are live and can be found at https://forums.eveonline.com/

Linux

 
  • Topic is locked indefinitely.
 

[Closed]HOW TO: Ubuntu 14.04 LTS with Eve (And most other lesser distr

Author
Montoo Laeman
Imperial Shipment
Amarr Empire
#121 - 2015-09-29 10:23:49 UTC
Thanks for the extensive guide! I do have a problem though. When I start the launcher it starts patching and will always get stuck at the same point (13.73/17.02 MB 80.7%). This happens both with and without launching using the shell script. Now it could be Iḿ not waiting long enough, but I've been sitting here for around 50 minutes now without anything happening.

Kismeteer
Bat Country
Pandemic Horde
#122 - 2015-09-30 17:57:01 UTC
Montoo Laeman wrote:
Thanks for the extensive guide! I do have a problem though. When I start the launcher it starts patching and will always get stuck at the same point (13.73/17.02 MB 80.7%). This happens both with and without launching using the shell script. Now it could be Iḿ not waiting long enough, but I've been sitting here for around 50 minutes now without anything happening.



Are you sure you have enough space on the device? Can you write to it? Anyway, complicate write up follows.

If you have a space problem, clear some for eve. It takes a lot, like 28G for me right now.

Also, make sure you own all the files by doing:
sudo chown -R $USER ~/.wine #This will change the ownership of everything in .wine to your $USER account. Or put bob or whomever you log in as if you want.

You might have a problem with your eve in general, there are a couple places you can look. Unfortunately, I'm not sure where they keep patches anymore.

You can clear your patches folder, which I do'nt even know if they use them anymore. This one command should do the trick:
rm ~/.wine/drive_c/users/${USER}/Local\ Settings/Application\ Data/CCP/Eve/Patches/* #It should be empty, if it exists.

Your settings are in ~/.wine/drive_c/users/${USER}/Local Settings/Application Data/CCP/EVE/c_games_ccp_eve_tranquility so you could clean out the 'cache' folder in there, but that will take time to restock as well. If you are super aggressive, you might wipe out your overview settings. Feel free to use my own private overview by joining the in game mailing list 'KisOver', and you can load the overviews from there. Or use the sarah's pack like everyone else.

You can clear out your temp directory, which will be filled with crap. rm -rf ~/.wine/drive_c/users/${USER}/Temp/*

Secondarily, you might consider purging your Shared Cache, which will take a long time to download again. that is in ~/.wine/drive_c/users/Public/Application Data/CCP/EVE/SharedCache. You can also clear this cache if you can launch eve. This can clear temporary space too.
Eddie Miromme
The Scope
Gallente Federation
#123 - 2015-10-25 07:56:02 UTC
http://pastebin.com/1LkaRAP4

I get to the windowed environment (running the non-launcher script) and it launches the launcher anyways, and once I press play, it closes the environment. That paste is the error I get, and I've been working on this for quite some time...

DISTRIB_ID=Ubuntu
DISTRIB_RELEASE=14.04
DISTRIB_CODENAME=trusty
DISTRIB_DESCRIPTION="Ubuntu 14.04.3 LTS"

wine-1.7.50

00:01.0 VGA compatible controller: Advanced Micro Devices, Inc. [AMD/ATI] Kaveri [Radeon R7 200 Series] (rev d4)

I have the latest drivers (15.9) for my a10-7870, with catalyst control.

Not really sure what else I should tell you... but I'm desperate to get this working!!!
Torgeir Hekard
I MYSELF AND ME
#124 - 2015-10-25 10:50:43 UTC
Well, teh obvious part is it can't find the i386 version of libGL.
Teh hard question is, how to fix that, because that's probably some kind of ldconfig magic I don't understand.

But let's start with the easier parts.

1) is your wineprefix 32bit?
2) ldconfig -p | grep libGL please
3) ls /etc/ld.so.conf.d/ please

Since I run bumblebee, I've got no idea how fglrx handles libGL shenanigans, but the general idea is, you've got (or, rather, should have) 2 separate libGLs. One for 64bit programs. One for 32bit programs. They are (or, rather, should be) bundled with your graphics driver.

If the driver package/installer fails to create proper symlinks/ldconfig, **** happens.

Your options then are to fix it either by reinstalling the driver and hoping it gets it right, or manually finding the libraries and creating proper symlinks/ldconfig. Or maybe trying to run with LD_PRELOAD=path_to_proper_libGL EVE.sh

judging by apt-file output, you should search for i386 libgl in /usr/lib32/fglrx/ and probably do something with ldconfig
Eddie Miromme
The Scope
Gallente Federation
#125 - 2015-10-25 19:35:42 UTC
My prefix seems to be 64 bit

libGLU.so.1 (libc6,x86-64) => /usr/lib/x86_64-linux-gnu/libGLU.so.1
libGLU.so.1 (libc6) => /usr/lib/i386-linux-gnu/libGLU.so.1
libGLU.so (libc6,x86-64) => /usr/lib/x86_64-linux-gnu/libGLU.so
libGLEWmx.so.1.10 (libc6,x86-64) => /usr/lib/x86_64-linux-gnu/libGLEWmx.so.1.10
libGLEW.so.1.10 (libc6,x86-64) => /usr/lib/x86_64-linux-gnu/libGLEW.so.1.10
libGLEW.so (libc6,x86-64) => /usr/lib/x86_64-linux-gnu/libGLEW.so
libGLESv2.so.2 (libc6,x86-64) => /usr/lib/x86_64-linux-gnu/mesa-egl/libGLESv2.so.2
libGL.so.1 (libc6,x86-64) => /usr/lib/libGL.so.1
libGL.so.1 (libc6) => /usr/lib/i386-linux-gnu/mesa/libGL.so.1
libGL.so.1 (libc6) => /usr/lib/i386-linux-gnu/libGL.so.1
libGL.so.1 (libc6) => /usr/lib32/libGL.so.1
libGL.so (libc6,x86-64) => /usr/lib/libGL.so
libGL.so (libc6) => /usr/lib/i386-linux-gnu/libGL.so
libGL.so (libc6) => /usr/lib32/libGL.so

fakeroot-x86_64-linux-gnu.conf x86_64-linux-gnu_EGL.conf
i386-linux-gnu_GL.conf x86_64-linux-gnu_GL.conf
i686-linux-gnu.conf zz_i386-biarch-compat.conf
libc.conf zz_x32-biarch-compat.conf
x86_64-linux-gnu.conf
Eddie Miromme
The Scope
Gallente Federation
#126 - 2015-10-26 02:39:39 UTC
problem solved, reinstalled ubuntu, used proprietary drivers, but dont have catalyst control installed... should i just sudo apt-get the control center? also the offline installer has never worked for me, and since both are .msi i just did the normal online windows install and it works great. I can even tab out and into the game and suffer no performance loss at the standard script settings, definitely want to set my monitor back to 144hz though, so if anyone has any suggestions for what i can do to make my experience better that would be awesome!!!
Kismeteer
Bat Country
Pandemic Horde
#127 - 2015-10-27 18:34:01 UTC
BTW, I spoke to someone at Eve Vegas who was in Wingspan about the Linux thread. It was really nice talking to you. I was the dude dressed as The Dude from Big Lebowski on Friday, and had an EFF hat on otherwise btw.
Django Toralen
State Protectorate
Caldari State
#128 - 2015-11-07 16:54:07 UTC  |  Edited by: Django Toralen
Hi! First of all: Thanks for this Topic! AWESOME!

As next ... I have a problem :)

I installed EvE Online - Launcher is starting without any problems any time I try. But if I click "play" it says "starting" for some time (10 to 20 seconds) and then the blue "starting" button just says "play" again. So the game itself seems not to start. What could I try to fix this?


Ubuntu 14.04 LTS
Wine 1.7.50

//EDIT

FIXED....
Had to change DirectX from 11 to 9 in the launcher :D
Adara Starkiss
Argentum Holdings
#129 - 2015-11-14 20:50:54 UTC
Having trouble as well, but in my case, the error Im getting is while its applying the patch. I have to mention that I was getting this same error in my windows installation and Im running out of ideas on what to do.

The error:

"Exception during UpdaterModule.Update
Traceback (most recent call last):
File "lib\update.pyo", line 117, in run
File "lib\update.pyo", line 381, in _Update
File "lib\update.pyo", line 267, in ApplyPatch
File "lib\steps\applyHttpPatch.pyo", line 43, in Run
File "zsync\zsync.pyo", line 708, in ApplyPatch
File "zsync\zsync.pyo", line 708, in ApplyPatch
File "zsync\zsync.pyo", line 661, in PatchFile
File "zsync\zsync.pyo", line 653, in PatchFile
File "zsync\fileSync.pyo", line 382, in GetBlock...." (too many lines to copy).

My system info:

DISTRIB_ID=Ubuntu
DISTRIB_RELEASE=15.04
DISTRIB_CODENAME=vivid
DISTRIB_DESCRIPTION="Ubuntu 15.04"

wine-1.7.50

00:01.0 VGA compatible controller: Advanced Micro Devices, Inc. [AMD/ATI] Trinity [Radeon HD 7560D]

Its a FM2 A8-5600K cpu, 4GB RAM, brand new Sandisk 120GB SSD

While in windows, I would try the repair and it would download the new version, then get to the 6/7 step, starts download and stops exactly at 70%, always. Havent tried the repair on this Linux installation yet. The last windows install I used the online installer, but for this Linux install I went with the offline installer, cause Im running on a limited data plan.

Any ideas?

Ubuntu Mate 16.04.2 64bit // Amd A8-5600K with RX460 4GB // 6GB DDR3 // Sandisk 120GB SSD Plus // Wine Stable 2.01 // Native Linux Launcher // TS3 working // Happy to be back in Ubuntu :)

Adara Starkiss
Argentum Holdings
#130 - 2015-11-16 11:05:13 UTC
The beta launcher did it for me. Its working now. Its not perfect, but looks good and it works. In-game browser is not working for me and I have lag when going into industry, show info and some others, but other than that, its going great.

Ubuntu Mate 16.04.2 64bit // Amd A8-5600K with RX460 4GB // 6GB DDR3 // Sandisk 120GB SSD Plus // Wine Stable 2.01 // Native Linux Launcher // TS3 working // Happy to be back in Ubuntu :)

Zosius
Epicentre Syndicate
The Singularity.
#131 - 2015-11-21 11:30:34 UTC
Hello,

I got few questions:

1. I would like to know if it's possible to move EVE windows through my 3 monitor screens, When I launch EVE1/2.. it gets stuck to the 0.0 monitor which is my left one. I would like to be able to move them same way if I used EVE Launcher.

2. Can I launch v1 v2 scripts without opening separate terminal windows? If I try to get 4 clients I have to have 4 terminals open.

In the end if I could run all my accounts via launcher that would be great, but it always freezes after I get first instance running.

DISTRIB_ID=Ubuntu
DISTRIB_RELEASE=14.04
DISTRIB_CODENAME=trusty
DISTRIB_DESCRIPTION="Ubuntu 14.04.3 LTS"

wine-1.7.50

01:00.0 VGA compatible controller: NVIDIA Corporation Device 17c8 (rev a1)
Neither command shows me video card reference, but it is GTX 980 ti;
Nvidia driver: 346.96
Jenshae Chiroptera
#132 - 2015-11-28 00:15:08 UTC  |  Edited by: Jenshae Chiroptera
Learned Vagrant wrote:
Learned Vagrant... Naturally, I blame the whole thing on CCP. ...
My favourite line in this thread.
Adara Starkiss wrote:
My system info:

DISTRIB_ID=Ubuntu
DISTRIB_RELEASE=15.04

Any ideas?
Not a LTS. Could be a factor but have you changed any hardware lately?



Odd little thing. My EVE client thinks my R9 390 is a 5600 Seems to work fine, however.

Overview is lagging.



I ♥ PlayOnLinux + this thread.

CCP - Building ant hills and magnifying glasses for fat kids

Not even once

EVE is becoming shallow and puerile; it will satisfy neither the veteran nor the "WoW" type crowd in the transition.

Saya Sakamoto
Happyness Realization Party
#133 - 2015-12-09 18:35:08 UTC
Hey there, new player here.

Thanks a lot for the guide! Made a few things easier.

Maybe you should add a note that at step 4 (Install Eve) the installer freezes for about 5 Minutes. I've spend 2 hours or so trying to fix that damn thing before I noticed that I just have to sit it out..

Then the next day everything breaks again because of the december update Roll but I got everything sorted now (using wine-development 1.7.49).
Xtoph Adler
The Scope
Gallente Federation
#134 - 2015-12-22 15:22:16 UTC
opening a web page in the ingame browser crashes the browser.

the game itself keeps working.

ubuntu 14.04 LTS
wine 1.7.55

error log:
https://www.dropbox.com/s/tr8qp3j6mjsd4eb/backtrace.txt?dl=0

let me know if i can provide more info.

thx for any help!!!
Kismeteer
Bat Country
Pandemic Horde
#135 - 2016-01-27 20:58:05 UTC
BTW, if you have not moved to the new launcher, you should, it's pretty handy. I am still having problems multiboxing with it with this current setup, but works well for most other things. At some point, I'll update the OP with the new launcher options.
Rastuasi
Native Freshfood
Minmatar Republic
#136 - 2016-01-28 17:30:02 UTC
Xtoph Adler wrote:
opening a web page in the ingame browser crashes the browser.

the game itself keeps working.

ubuntu 14.04 LTS
wine 1.7.55

error log:
https://www.dropbox.com/s/tr8qp3j6mjsd4eb/backtrace.txt?dl=0

let me know if i can provide more info.

thx for any help!!!

Did you install winhttp via winetricks like WineHQ says? Without it the browser crashes.
Som Boty
Super Mother Fan Club
#137 - 2016-02-02 05:00:42 UTC  |  Edited by: Som Boty
Hey,

First, thank you for this guide. It made the installation very easy and straight forward. The first time I tried this, I was able to get eve up and running almost effortlessly. It was a really great experience.

I had to reformat my laptop and now I am trying to reinstall eve. i get all the way to the point of running the installer but instead of launching and asking me for a directory, the box greys itself out, waits about 5 minutes, then closes without anything happening. Where do I go from here?


edit: not sure what the problem was, maybe a driver issue, but it resolved itself after I finished updating/upgrading ubuntu with apt-get update and apt-get upgrade
Kismeteer
Bat Country
Pandemic Horde
#138 - 2016-03-09 17:13:47 UTC
There have been a couple hiccups with launcher problems, but generally this guide still works well.
Jenshae Chiroptera
#139 - 2016-03-14 16:00:17 UTC  |  Edited by: Jenshae Chiroptera
Kismeteer wrote:
Hit this point and it froze on the first splash screen. Edit: ... and it just unfroze.

CCP - Building ant hills and magnifying glasses for fat kids

Not even once

EVE is becoming shallow and puerile; it will satisfy neither the veteran nor the "WoW" type crowd in the transition.

Kismeteer
Bat Country
Pandemic Horde
#140 - 2016-04-13 18:34:44 UTC
Note, I have tested this on the latest singurlarity, seems to be working fine. GG CCPAttention