These forums have been archived and are now read-only.

The new forums are live and can be found at https://forums.eveonline.com/

EVE Information Portal

 
  • Topic is locked indefinitely.
 

Update to the EVE Launcher (beta)

First post
Author
CCP Avalon
C C P
C C P Alliance
#21 - 2015-11-25 15:43:58 UTC
Stefan Silviu wrote:

FFS ALL SETTINGS LOST

Instructions on how to recover the client settings: https://forums.eveonline.com/default.aspx?g=posts&m=6187370#post6187370

CCP Avalon // Web Developer // Team Webster // @ccp_avalon

Twitch: CCP_Avalon

Richard TheLordOfDance
Operation Fishbowl Inc.
#22 - 2015-11-25 15:57:31 UTC
I like it!

Can we speed up the server drop down animation though?

Otherwise very nice, very pretty.
Rivr Luzade
Coreli Corporation
Pandemic Legion
#23 - 2015-11-25 16:17:23 UTC  |  Edited by: Rivr Luzade
Some things:

  • Please move the Play button back to the right. It is also somewhat harder to hit the play button as it is not clear where it ends and where it starts. the previous Play button with the ring was by far easier and more straightforward to use. When I hover some 10 px next to the button, it is highlighted in blue (indicating that I am in the hitbox), but clicking it does not start the game. Instead, I need to move my mouse directly over the arrow.
  • Please make the multi launch a check box again and not this skeuomorphic switch.
  • There is no tooltip when you hover your mouse over the gear button to access settings.
  • You missing a way to access the settings folder in your Manage Settings window, because your latest version of the launcher wiped all settings again.
  • Clicking again on the notification button (the speech bubble in the to right corner) does not close opened notifications, which is very unintuitive.
  • And this one is without please, because it is a completely stupid move: Get rid of that faint line below the accounts to indicate whether an account is running. This is already ridiculous and hard to read and understand in the new probe scanning window, it is even worse here. The previous indication with the full row being highlighted is so much better, easier to read and understand and to distinguish. Whoever is responsible for that line stuff should be send to the Reykjavik uni to get some lessons in proper UI design.

  • Another thing is the placement of the elements. Why is there so much wasted space around the client list box? Instead, the window should be divided into 2 parts: Left side - the list of the clients logged in. Right side - Ads, Notifications, other rubbish. 2 clearly distinguishable areas that do not interfere with each other and that use the available room a lot more efficiently than in your version. Right now, there's no system behind it. The list, had I more than my limited number of chars, would just create a scrollbar or vanish under the ads at the bottom. Then there are ads at the bottom, but notifications and other ad-like content on the left, smashed onto the list box. Instead, the window should look like this. Before someone complains about it, notifications overlapping the ads is intentional and also already happens right now when there are more than 2 notifications, so that's no big deal.

And something else: Right now, the launcher remembers all logged in clients even though I have not ticked the box. In other words, when I log in with one client, all other clients are also (still) logged in in the launcher. Will this be a permanent feature on release or is this an unintentional behavior/bug? I have to say that, even though it might be a bug, it's really convenient that I only have to log in one client and not several every day. Big smile

UI Improvement Collective

My ridicule, heavy criticism and general pale outlook about your or CCP's ideas is nothing but an encouragement to prove me wrong. Give it a try.

Cherri Minoa
IronPig
Sev3rance
#24 - 2015-11-25 16:33:27 UTC
CCP Avalon wrote:
Snooowi wrote:
Chino Saisima wrote:
A few things came to mind:
- for future patches: please please please backup the current userprofile settings, i had to reimport old ones from 2 month ago :(


This please! Is there a way to get at the ones I was using in my previous version of the Beta Launcher?

Is there are reason you guys don't copy previous Beta-launcher settings before you do the update and then re-import them automatically?

This update for the BETA Launcher should have renamed the folder containing client settings. If this did not happen, your settings may have been left behind, and does not display in the migration tool.

The following information should help in recovering these settings.

For Windows users (7 and up):

* Hit the Windows key + R (or hit the start menu and type "run")
* Type "%localappdata%/ccp/eve"
* Open the folder that ends with "..._tq_87.237.38.200" (ex. c_ccp_eve_sharedcache_tq_87.237.38.200)
* Copy any "settings_" folders
* Return to the parent folder and enter the folder that replaced the IP address with _tranquility (ex. c_ccp_eve_sharedcache_tq_tranquility)
* Paste the "settings_" folders here
* Restart launcher


Thanks for the fix.

Just to add, if like me you have a lot of settings folders (backups etc) then once you have restarted the launcher you will need to select which profile to use. For me it is the one that begins c_program_files_(x86)_ it may vary depending on system.

"If I had been censured every time I have run my ship, or fleets under my command, into great danger, I should have long ago been out of the Service" - Horatio Nelson

Torgeir Hekard
I MYSELF AND ME
#25 - 2015-11-25 16:38:20 UTC  |  Edited by: Torgeir Hekard
General look is better, but I prefer the old account selection part. The new font is too bold, the switches don't really make sense, the old play button was better.

Also server selection animation is t o o o s s s l l o o o o o w w w
McBarnacle
Grey Templars
Initiative Mercenaries
#26 - 2015-11-25 16:59:12 UTC
CCP Avalon wrote:
Snooowi wrote:
Chino Saisima wrote:
A few things came to mind:
- for future patches: please please please backup the current userprofile settings, i had to reimport old ones from 2 month ago :(


This please! Is there a way to get at the ones I was using in my previous version of the Beta Launcher?

Is there are reason you guys don't copy previous Beta-launcher settings before you do the update and then re-import them automatically?

This update for the BETA Launcher should have renamed the folder containing client settings. If this did not happen, your settings may have been left behind, and does not display in the migration tool.

The following information should help in recovering these settings.

For Windows users (7 and up):

* Hit the Windows key + R (or hit the start menu and type "run")
* Type "%localappdata%/ccp/eve"
* Open the folder that ends with "..._tq_87.237.38.200" (ex. c_ccp_eve_sharedcache_tq_87.237.38.200)
* Copy any "settings_" folders
* Return to the parent folder and enter the folder that replaced the IP address with _tranquility (ex. c_ccp_eve_sharedcache_tq_tranquility)
* Paste the "settings_" folders here
* Restart launcher


Thanks for that Avalon, worked perfectly. I have let my corp know as well for anyone having similar issues.

McB
Sheldor Frye
Fratres Miliciae
#27 - 2015-11-25 17:52:27 UTC
Just one thing, please include the Eve time somwhere on the client. Would help to keep track when those events and streams start without hurting my brain too much.
Rivr Luzade
Coreli Corporation
Pandemic Legion
#28 - 2015-11-25 18:50:16 UTC
For some reason, I just managed to open the twitch page in the Launcher window. I know that the launcher is just a chromium browser window, but is this intentional? The first time, I just left clicked somewhere on the notification, the second time I right clicked the URL'd link and used "Navigate to..."; left clicking the URL'd text opens the link normally in my real browser.

UI Improvement Collective

My ridicule, heavy criticism and general pale outlook about your or CCP's ideas is nothing but an encouragement to prove me wrong. Give it a try.

Chino Saisima
Caldari Provisions
Caldari State
#29 - 2015-11-25 19:08:02 UTC
two more things:

- it infuriates me to no end that the icon in the taskbar shows a "loading bar" after launching a client. the bar doesnt move or disappears after closing a client though. see here

- everytime a new launcher version is deployed, i get a black screen after launching an additional client. it loads bulkdata and all that jazz, but afterwards theres just the small download circle in the bottom left circling, and thats it. no matter how often you relaunch other clients, still same picture. doesnt matter either which account is launched at first, all subsequent launched accounts dont work.
CCP Snorlax
C C P
C C P Alliance
#30 - 2015-11-25 19:50:12 UTC
Chino Saisima wrote:
two more things:

- it infuriates me to no end that the icon in the taskbar shows a "loading bar" after launching a client. the bar doesnt move or disappears after closing a client though. see here

- everytime a new launcher version is deployed, i get a black screen after launching an additional client. it loads bulkdata and all that jazz, but afterwards theres just the small download circle in the bottom left circling, and thats it. no matter how often you relaunch other clients, still same picture. doesnt matter either which account is launched at first, all subsequent launched accounts dont work.

First, take a deep breath and relax - life's too short to get infuriated by the little things.

The launcher is probably still downloading binaries and/or resources for any test servers you may have selected. By default, Singularity and Duality are enabled - you can turn them off in Settings.

The problem with the black screen - is that only after updating? If you restart the launcher, can you then launch multiple clients?

CCP Snorlax - Software Architect - Team RnB - @CCP_Snorlax - http://ccpsnorlax.blogspot.is/

Chino Saisima
Caldari Provisions
Caldari State
#31 - 2015-11-25 20:15:02 UTC
CCP Snorlax wrote:
Chino Saisima wrote:
two more things:

- it infuriates me to no end that the icon in the taskbar shows a "loading bar" after launching a client. the bar doesnt move or disappears after closing a client though. see here

- everytime a new launcher version is deployed, i get a black screen after launching an additional client. it loads bulkdata and all that jazz, but afterwards theres just the small download circle in the bottom left circling, and thats it. no matter how often you relaunch other clients, still same picture. doesnt matter either which account is launched at first, all subsequent launched accounts dont work.

First, take a deep breath and relax - life's too short to get infuriated by the little things.

The launcher is probably still downloading binaries and/or resources for any test servers you may have selected. By default, Singularity and Duality are enabled - you can turn them off in Settings.

The problem with the black screen - is that only after updating? If you restart the launcher, can you then launch multiple clients?


thanks for your response, though the infuriation was more literally spoken :)

the launcher shouldnt download anything - i just have tranq and sisi as usable servers checked. still, ive checked my net connections and there isnt any download going on from the evelauncher.exe

the black-screen problem appeared after the launcher-update before this. when i restart, i can launch multiple clients. now if i close one of those, i run into the black screen problem. already submitted a bug report but it was closed with "clear cache or open a 'character stuck' ticket". point is, its not related to a single character, but to all accounts.
CCP Snorlax
C C P
C C P Alliance
#32 - 2015-11-25 20:25:40 UTC
Chino Saisima wrote:

...

thanks for your response, though the infuriation was more literally spoken :)

the launcher shouldnt download anything - i just have tranq and sisi as usable servers checked. still, ive checked my net connections and there isnt any download going on from the evelauncher.exe

the black-screen problem appeared after the launcher-update before this. when i restart, i can launch multiple clients. now if i close one of those, i run into the black screen problem. already submitted a bug report but it was closed with "clear cache or open a 'character stuck' ticket". point is, its not related to a single character, but to all accounts.

Alright, I'll investigate the progress bar issue, maybe there are some edge cases I've missed where it isn't updated properly. If this persists, please file a bug report attaching the launcher log (from AppData/Local/CCP/EVE/Launcher).

Not sure what to say about the black screen issue. If the problem persists, run the clients with logging enabled, file a new bug report and attach the logs (AppData/Local/CCP/EVE/ClientLogs). Mention my name in the title so it gets routed to me, I'll take a closer look.

CCP Snorlax - Software Architect - Team RnB - @CCP_Snorlax - http://ccpsnorlax.blogspot.is/

Seth Mardassan
New Eden Organized Fusion
Apocalypse Now.
#33 - 2015-11-25 20:41:44 UTC
The issue about losing settings was posted in our corp mail, and for that reason I decided to skip the update when the client asked me to update.

Yet for some dark reason the client believed my preference was irrelevant and decided to update itself anyway!

Luckily there's the fix but it would be nice if the software actually does what I tell it to do.
Rain6637
NulzSec
#34 - 2015-11-25 21:46:32 UTC
While exploring the buttons on the new launcher, I clicked the "Account" link and saw the black friday sale, which led to the purchase of a 6-pack. Thanks!
KIller Wabbit
MEME Thoughts
#35 - 2015-11-25 22:07:49 UTC  |  Edited by: KIller Wabbit
CCP Maxwell wrote:
KIller Wabbit wrote:
2 items

1) Norton yanked it for high disk activity
2) Uses way too much screen real estate. Could easily be half the size.


Is it possible to white-list the launcher in the Norton application? We have already contacted Norton about white-listing the launcher, but that may only have worked for that particular version of the launcher.



It is possible to have Norton put it back/whitelist, but since the install was aborted you need to run the install yet again in order for it to complete. I dunno what the install is doing, but I have my install on a bulk hard drive to save hits on my SSD and the hard drive is being hammered hard for about a minute before Norton steps in. This would seem extremely odd for a launcher install, even if it does have a ridiculous 250MB image while running.

Edit: To give a comparison - I have never had Norton step in on a big client patch. It never hammers my hard disk in the same manner the launcher patching doesn.
KIller Wabbit
MEME Thoughts
#36 - 2015-11-25 22:11:06 UTC
Lair Osen wrote:
KIller Wabbit wrote:
2 items

2) Uses way too much screen real estate. Could easily be half the size.


You know you can resize it right?


Yes. Even minimum size it is way too big. A LOT of unused graphic space. The only thing forcing it to the minimum size is the two side by side product adverts. Stacking them, or even better kill one, would allow a more reasonable sized UI.
Kaliba Mort
Dark-Rising
Wrecking Machine.
#37 - 2015-11-25 22:17:21 UTC
Works well. Just a few suggestions and comments,

1. under Wine, anti-aliasing is off making things "ugly" and text on right side "buttons" is unreadable
2. checkboxes may have been simpler to recognize than those slide-buttons

Keep up the good work Smile
Kal'Han
Kador Trade Company
#38 - 2015-11-25 23:18:04 UTC  |  Edited by: Kal'Han
ohh what a nice suprise, nice UI brush up, more compact and small ads are nice

Thanks god for patch note

interesting drag and drop to reorder the account, but no double clic to launch, me sad, but the play button is easier to clic on for singular launch.


the right clic is still an issue, even more now that there are link that work : right clic on the patch notes, and "navigate to"
the launcher turns into a browser, go on the forum from there, navigate here in this post and clic https://www.google.com yay internet browsing inside the launcher
oh and middle clic spawns additional windows, I'd prefer tabs, but you take what you can.

I don't know if the tokens from login site are available in the browser session or something but that's a big "meh" from me.

I'll try some streaming and download, just to check if it stores random stuff on my computer



Edit: back from adventure land
so YouTube html5 videos plays nicely, no fullscreen though, but at least you know YouTube ccp channel will work in the launcher.
no file download working
cache folders and settings folder for qtwebengine are of coures getting a lot bigger
c:\Users\%USERNAME%\AppData\Local\CCP\EVE\cache\QtWebEngine\Default\Cache\
c:\Users\%USERNAME%\AppData\Local\CCP\EVE\QtWebEngine\Default\
I'm resetting all that to clear all the stuff I did

I did notice in the 2nd folder a "GPUCache" folder, does that means QTWebEngine / Chromium uses 3D gpu acceleration? there were some people reporting huge fps drops when using new launcher, I hope it will not be an issue in the long run
Adara Starkiss
Argentum Holdings
#39 - 2015-11-26 00:19:41 UTC
- Server list and process views are now a standalone windows

And that was a good idea why? It was great as it was, I could see same thing from the same window before and now I have an additional window in the way when I alt tab.... thanks for screwing it up.

Ubuntu Mate 16.04.2 64bit // Amd A8-5600K with RX460 4GB // 6GB DDR3 // Sandisk 120GB SSD Plus // Wine Stable 2.01 // Native Linux Launcher // TS3 working // Happy to be back in Ubuntu :)

Jack Tronic
borkedLabs
#40 - 2015-11-26 03:14:26 UTC  |  Edited by: Jack Tronic
The MOTD popup placement is still awkward when you have the launcher at its most "compact" size. It overlaps the account list so its visually annoying. If at least there was an option to never show the popup without clicking the button that would be great. I honestly don't care for the eve news personally.

You also seem to now have two settings windows, the left hand side settings and the "EVE icon" dropdown at the top open two different types of settings dialogs with identical options.

Also +1 for the suggestion above to include the current EVE time in the launcher, you don't know how useful this is as most of us don't live in UTC/GMT+0 ;)