These forums have been archived and are now read-only.

The new forums are live and can be found at https://forums.eveonline.com/

Linux

 
  • Topic is locked indefinitely.
 

Heads up with wine 1.7.50- hangs on starting client & solution

Author
Merende Macaco
Tr0pa de elite.
Test Alliance Please Ignore
#1 - 2015-08-24 14:19:24 UTC
Just a heads up for those of you on the bleeding edge:

Wine 1.7.50 has started initial dx11 support but it is not ready for prime time -
This means the launcher and exefile will now detect dx11 compatibility (YAY!) but it doesn't work yet (BOO!)
solution: you will need to set launcher to use dx9 mode. (I am not sure how to force it with exefile)

Cheers.
Torgeir Hekard
I MYSELF AND ME
#2 - 2015-08-25 15:26:19 UTC
I assume you can just set d3d11 to disabled via winecfg.

At least I have that and don't have any problems. Or maybe it's WinXP compatibility mode. Not sure which one is responsible.
Merende Macaco
Tr0pa de elite.
Test Alliance Please Ignore
#3 - 2015-08-25 16:42:28 UTC
Yes I would assume that in XP mode WINE would not expose any DX11 compatibility, I have been using win 7 mode for quite a while, but this was the first time DX11 was detected - before that the launcher gave a not supported on your system message. I am planning on re-enabling after each upgrade as I look forward to the extra eye candy, & am curious to see if they get a working implementation before 2016.
Null More
Garoun Investment Bank
Gallente Federation
#4 - 2015-08-30 14:00:06 UTC
Merende Macaco wrote:
...
solution: you will need to set launcher to use dx9 mode. (I am not sure how to force it with exefile)


I start it like so:

wine PATH/TO/EVE/BIN/exefile.exe \/triPlatform=dx9
Tux Tango
TallyWhackers
The Bastion
#5 - 2015-08-30 19:05:22 UTC  |  Edited by: Tux Tango
Torgeir Hekard wrote:
I assume you can just set d3d11 to disabled via winecfg.

At least I have that and don't have any problems. Or maybe it's WinXP compatibility mode. Not sure which one is responsible.

yep, disable the d3d11 in the library tab in wine config
worked for me
Ragnar STS
Arcane Odyssey
Electus Matari
#6 - 2015-09-04 01:10:13 UTC
Null More wrote:

I start it like so:

wine PATH/TO/EVE/BIN/exefile.exe \/triPlatform=dx9


Thank you for the tip. I sat here for a good 10 minutes trying to figure out why eve was actually running...but not showing a damned thing on the screen.
Kismeteer
Bat Country
Pandemic Horde
#7 - 2015-09-10 21:50:39 UTC
Null More wrote:
I start it like so:

wine PATH/TO/EVE/BIN/exefile.exe \/triPlatform=dx9


This is beautiful, adding it to my HOWTO.