These forums have been archived and are now read-only.

The new forums are live and can be found at https://forums.eveonline.com/

Issues, Workarounds & Localization

 
  • Topic is locked indefinitely.
123Next page
 

[Windows 10] Should we hold off on our upgrades?

First post First post
Author
Ele Rebellion
Fat Dragon Mining Co.
Darwinism.
#1 - 2015-07-29 07:17:52 UTC
As Windows 10 officially released a couple hours ago, (Granted it is being released in waves) should we anticipate EvE having any issues with it?

Does CCP recommend that we upgrade or hold off until some patching can be done for it?
Darkblad
Doomheim
#2 - 2015-07-29 08:09:28 UTC  |  Edited by: Darkblad
I'd wait, as the client may still not be tested fully with Windows 10.
That's at least the last I read by a Dev on that matter (on July 7th):

CCP Darwin wrote:
Just for right now, for anyone else who runs across this issue or reads this, please be aware that we have not yet fully tested the EVE Online client against Windows 10. Until we do, your experience with Windows 10 and EVE may or may not be satisfactory. We're working on getting to a known stable point with it, but until then, thanks for your patience.

The download page, though, has Windows 10 in the list of System requirements. Question

NPEISDRIP

CCP Savior
C C P
C C P Alliance
#3 - 2015-07-29 09:57:52 UTC
Hi guys,

We do officially support Windows 10 and we have tested the client on the OS and have found it to run without errors.

But as with anything new, there could be bugs with the OS during its initial first few months so it could be a bumpy road to begin with.

Graphical QA Analyst | EVE Quality Assurance | Team TriLambda

Darkblad
Doomheim
#4 - 2015-07-29 10:02:25 UTC
CCP Savior wrote:
Hi guys,

We do officially support Windows 10 and we have tested the client on the OS and have found it to run without errors.

But as with anything new, there could be bugs with the OS during its initial first few months so it could be a bumpy road to begin with.
Thank you for the confirmation. Smile

NPEISDRIP

CCP Savior
C C P
C C P Alliance
#5 - 2015-07-29 10:51:30 UTC
The only piece of advice I will give you all though is to make sure you run the launcher as an 'admin'. typically done by right clicking on the shortcut and clicking on the 'Run as Administrator', we have seen reports from players using the Windows 10 preview that they have seen performance issues when this is has not been done. So if you do upgrade your OS and notice performance issues this could solve the problem.

Graphical QA Analyst | EVE Quality Assurance | Team TriLambda

Elinari Rhodan
Itsukame-Zainou Hyperspatial Inquiries Ltd.
Arataka Research Consortium
#6 - 2015-07-29 11:12:17 UTC
Excellently timed post - my shiny new Surface arrived today, just in time to be updated to Windows 10 and become my new mobile EVE machine. Windows 10 + EVE + touchscreen = .... actually, not expecting any big problems.

Thanks!
FHM
Doomheim
#7 - 2015-07-29 12:42:11 UTC
Eve Launcher doesnt work for me after the W10 upgrade. Already deleted the Launcher directory and used repair.exe but still no way to start the launcher. Also with admin and compatibility its not working.
epicurus ataraxia
Illusion of Solitude.
Illusion of Solitude
#8 - 2015-07-29 12:52:10 UTC
FHM wrote:
Eve Launcher doesnt work for me after the W10 upgrade. Already deleted the Launcher directory and used repair.exe but still no way to start the launcher. Also with admin and compatibility its not working.

same problem and trying to access launcher settings hangs the whole launcher
What?

There is one EvE. Many people. Many lifestyles. WE are EvE

epicurus ataraxia
Illusion of Solitude.
Illusion of Solitude
#9 - 2015-07-29 13:10:44 UTC  |  Edited by: epicurus ataraxia
epicurus ataraxia wrote:
FHM wrote:
Eve Launcher doesnt work for me after the W10 upgrade. Already deleted the Launcher directory and used repair.exe but still no way to start the launcher. Also with admin and compatibility its not working.

same problem and trying to access launcher settings hangs the whole launcher
What?



ah well mac is working, not like anyone uses windows these days anyway? CCP you might want to look into this somewhat urgently!Shocked


logged on then frozen launcher after pressing play.
game started after 30 minutes when I went to have breakfast

subsequent launches around 2 minutes to respond.

looks like patience is required for first run.
If you have started multiple times, restart, login to eve, and wait for a while 30 mins is on a core i3 with SSD your wait may vary

There is one EvE. Many people. Many lifestyles. WE are EvE

FHM
Doomheim
#10 - 2015-07-29 15:24:25 UTC
for some reason it works now. However i got blurry text in the launcher and also in Steam... kinda strange
FHM
Doomheim
#11 - 2015-07-29 15:34:51 UTC
hm disabling DPI Scaling in the application compatibility settings has solve the fuzzy text and font display for the Eve Launcher.
Jonathan McLearnon
HaHa Industries
#12 - 2015-07-29 16:05:35 UTC
Having issues running multiple clients since I upgraded to windows 10. After about 10 minutes get socket closed messages... Downloaded windows 10 ISO and did fresh reinstall, same thing happens. Internet is working fine, tested on another computer when it happens and running multiple on windows 7 worked fine before install? Any ideas
Arsine Mayhem
Doomheim
#13 - 2015-07-29 18:03:52 UTC
Upgrading as opposed to installing a fresh copy will give you more problems.

I ran an image in case I want to go back to win 7, which is more likely to happen than not.

Copy ccp folder from c:\users\[username]\appdata\local to save settings.

Copy Desktop, Documents, any other data you want to keep.

Install fresh.
babyblue
Doomheim
#14 - 2015-07-29 18:41:48 UTC
Upgraded 8.1 to 10 (not a fresh install). Tried to run Eve and the Launch button remained disabled. It didn't seem to be able to contact the server to check versions/patches. So I ran the repair tool. The repair tool updated some things and then returned an error ("An existing connection was forcibly closed by the remote host"). I then ran the client again and it worked.

In conclusion it does work after the repair despite the returned error message.

Estella Osoka
Perkone
Caldari State
#15 - 2015-07-29 21:10:54 UTC  |  Edited by: Estella Osoka
Jonathan McLearnon wrote:
Having issues running multiple clients since I upgraded to windows 10. After about 10 minutes get socket closed messages... Downloaded windows 10 ISO and did fresh reinstall, same thing happens. Internet is working fine, tested on another computer when it happens and running multiple on windows 7 worked fine before install? Any ideas


Wrong thread. Disregard.

However, it does sound like a port issue. Did you try the stickyied Socket Closed thread?
Steve Ronuken
Fuzzwork Enterprises
Vote Steve Ronuken for CSM
#16 - 2015-07-29 21:48:51 UTC
For anyone that is running into launcher issues, I'd suggest bug reporting it, and including the log file which is in the launcher/cache directory. There might be something in it which lets CCP identify and fix the problem you have.


(not having any trouble on mine yet. Fingers crossed)

Woo! CSM XI!

Fuzzwork Enterprises

Twitter: @fuzzysteve on Twitter

Jonathan McLearnon
HaHa Industries
#17 - 2015-07-30 00:18:22 UTC
Believe my issue is with the driver for my network card. Internet dropped without running Eve couple times... Back to windows 7 for now :/
Stand Bie
Son's of Minerva
#18 - 2015-07-30 01:37:15 UTC
I had to completely delete out the launcher file and use the repair too since it just flipped between updating launcher and downloading launcher update, but haven't had any issues since.
Captain StringfellowHawk
Forsaken Reavers
#19 - 2015-07-30 02:56:24 UTC
I have the launcher running no issues. I didnt stick with the Upgrade version of Windows 10. I did the Upgrade as per most people then right away created a Install Disk using the Windows 10 ISO, Performed a Clean Install (you can only do this AFTER you do the upgrade) and installed EVE. I was able to get into EVE online with no issues thru the regular launcher.
Ms Sabine
Brave Newbies Inc.
Brave Collective
#20 - 2015-07-30 04:03:21 UTC
Arsine Mayhem wrote:
Upgrading as opposed to installing a fresh copy will give you more problems.

I ran an image in case I want to go back to win 7, which is more likely to happen than not.

Copy ccp folder from c:\users\[username]\appdata\local to save settings.

Copy Desktop, Documents, any other data you want to keep.

Install fresh.


what will save my bookmarks ?
123Next page