These forums have been archived and are now read-only.

The new forums are live and can be found at https://forums.eveonline.com/

Macintosh

 
  • Topic is locked indefinitely.
123Next pageLast page
 

MOSAIC - Macintosh Issues & Feedback

First post
Author
CCP Falcon
#1 - 2015-04-27 17:28:25 UTC  |  Edited by: CCP Phantom
We are happy to announce that the Mosaic Release has been successfully deployed!

Mosaic brings many changes to EVE Online, including permanent ship skins, new opportunities, cruiser sized burner missions, new assembly effects for structures in space, balancing to nullsec and lowsec ores, new forcefield efffects for control towers, a Tech 3 destroyer rebalance and an improved corporate role management UI. Also included in Mosaic are two factor authentication, nullsec infrastructure improvements, balancing of battlecruiser warp speeds and updates to the sensor overlay.

You can check out details of all these features on the new Updates webpage, here!

In addition to this, you can take a look at the full patch notes for the Mosaic release here, which gives an in depth breakdown of all the changes that have arrived with this release.

For general discussion and feedback regarding the mac release of Mosaic, please use this thread. For issues with the release on PC, please post here, and for PC related general feedback, please see here.

CCP Falcon || EVE Universe Community Manager || @CCP_Falcon

Happy Birthday To FAWLTY7! <3

Arthur Aihaken
CODE.d
#2 - 2015-04-28 11:49:16 UTC
The Mac Mosaic installation went off without a hitch. I had installed the launcher update prior, but there was apparently another launcher update (the launcher quit after completion and had to be restarted); just a head's up for other Mac owners. After the second launch it downloaded and applied the rest of the patch and EVE launched per usual.

I miss my anti-aliasing... Is this an interim fix or something permanent? Also, any possibility of getting high shader support for the Radeon R9 M290X/M295X graphics cards on the iMac Retinas? And we need some Caldari SKINs in the worst way.

I am currently away, traveling through time and will be returning last week.

CCP Sledgehammer
C C P
C C P Alliance
#3 - 2015-04-28 12:51:51 UTC
Arthur Aihaken wrote:
The Mac Mosaic installation went off without a hitch. I had installed the launcher update prior, but there was apparently another launcher update (the launcher quit after completion and had to be restarted); just a head's up for other Mac owners. After the second launch it downloaded and applied the rest of the patch and EVE launched per usual.

I miss my anti-aliasing... Is this an interim fix or something permanent? Also, any possibility of getting high shader support for the Radeon R9 M290X/M295X graphics cards on the iMac Retinas? And we need some Caldari SKINs in the worst way.


Hey Arthur,

The clamping of AA to disabled is temporary while we dig deeper into the root cause of the issues we were seeing in testing. High shader settings for AMD cards is being investigated.

Best,

Sledge.

Graphical QA Analyst | EVE Quality Assurance | Team TriLambda

Elementatia
Vision Inc
Hole Control
#4 - 2015-04-28 12:53:49 UTC
CanĀ“t import from EveMon.
Skill import lasts forever. No Error message displayed.
Deniedexponent
Caldari Provisions
Caldari State
#5 - 2015-04-28 13:01:20 UTC
my MAC client won't complete patching, just opens up and sits at 0mb /4.27mb.... then does nothing. Have to "force Quit" after a while...

CCP Sledgehammer
C C P
C C P Alliance
#6 - 2015-04-28 13:07:27 UTC
Deniedexponent wrote:
my MAC client won't complete patching, just opens up and sits at 0mb /4.27mb.... then does nothing. Have to "force Quit" after a while...



What version is shown in the top bar of the launcher?

Graphical QA Analyst | EVE Quality Assurance | Team TriLambda

Deniedexponent
Caldari Provisions
Caldari State
#7 - 2015-04-28 13:09:51 UTC
v2.2 878305
Vincent Athena
Photosynth
#8 - 2015-04-28 13:14:57 UTC
I noticed that the red B is still on the new map. I thought it was coming out of beta?

So far everything is working, including the clones. I did not have to re-make the clones for this update.

Know a Frozen fan? Check this out

Frozen fanfiction

CCP Sledgehammer
C C P
C C P Alliance
#9 - 2015-04-28 13:27:15 UTC
Deniedexponent wrote:
v2.2 878305

OK, can you try this and see what happens?

Open Launcher settings (Cog icon, top right) > Advanced > Clear All Cached Data

Let me know how that goes!

Graphical QA Analyst | EVE Quality Assurance | Team TriLambda

CCP Sledgehammer
C C P
C C P Alliance
#10 - 2015-04-28 13:27:48 UTC
Vincent Athena wrote:
I noticed that the red B is still on the new map. I thought it was coming out of beta?

So far everything is working, including the clones. I did not have to re-make the clones for this update.


Yeah it is out of Beta, probably an oversight. Will let the appropriate team know.

Graphical QA Analyst | EVE Quality Assurance | Team TriLambda

Deniedexponent
Caldari Provisions
Caldari State
#11 - 2015-04-28 14:05:04 UTC
I Got it working eventually....just restarted the launcher about a dozen times and it finished the updates....

Thanks for the quick response Big smile

Cheers

Denied
Vincent Athena
Photosynth
#12 - 2015-04-28 14:06:16 UTC
I double checked by running the game from the launcher, rather than bypassing the launcher via a clone. Yup, the red B is still on the neocom button for the new map, and in the esc menu, there is still an "experimental feature", a check box for "try new map".

Know a Frozen fan? Check this out

Frozen fanfiction

progstate
Assegai-Feisar
#13 - 2015-04-28 14:28:06 UTC
Mac clients still crash when you quite one of several \o/ good times 4 years in a row?
CCP Sledgehammer
C C P
C C P Alliance
#14 - 2015-04-28 14:39:56 UTC
progstate wrote:
Mac clients still crash when you quite one of several \o/ good times 4 years in a row?


Using Clonemaker to setup app clones of your master eve install, then using them to run multiple clients fixes this. We as a department are happy to endorse this method.

Full instructions here

Graphical QA Analyst | EVE Quality Assurance | Team TriLambda

CCP Sledgehammer
C C P
C C P Alliance
#15 - 2015-04-28 14:43:00 UTC
Vincent Athena wrote:
I double checked by running the game from the launcher, rather than bypassing the launcher via a clone. Yup, the red B is still on the neocom button for the new map, and in the esc menu, there is still an "experimental feature", a check box for "try new map".


So, both the new icon and the tickbox are being left in intentionally. In the Icon's case, to differentiate it from the old map; In the tickbox case, to allow people to opt out if they do not like it - It will be enabled by default from tomorrow.

Graphical QA Analyst | EVE Quality Assurance | Team TriLambda

progstate
Assegai-Feisar
#16 - 2015-04-28 14:50:16 UTC
CCP Sledgehammer wrote:
progstate wrote:
Mac clients still crash when you quite one of several \o/ good times 4 years in a row?


Using Clonemaker to setup app clones of your master eve install, then using them to run multiple clients fixes this. We as a department are happy to endorse this method.

Full instructions here


I've tried every major patch hopeful that it was fixed to no avail :) But I shall give it another go.

Did you ever consider endorsing the Wineskin alternative as well? A part from a few sticky keys after cycling through client windows and a ctrl-command swap around its more or less superior to the cider wrapper. Especially by being resolution aspect ratio agnostic and with good multi-threading

I wouldn't want to know how many mac users we lose from having the mac trial crash a few times. Not everyone is so investigative or patient.
Ian Blackbird
Imperial Shipment
Amarr Empire
#17 - 2015-04-28 16:15:05 UTC
Deniedexponent wrote:
my MAC client won't complete patching, just opens up and sits at 0mb /4.27mb.... then does nothing. Have to "force Quit" after a while...



Despite that one, i notice two improvements for me:

1. Overall Performance seems to have raised a bit.
2. It is now possible to switch audio-interface without having to restart EVE. thanks (to your partners?) for that one!
Nymriel Taur
MASHDEM
#18 - 2015-04-28 16:23:21 UTC  |  Edited by: Nymriel Taur
I noticed two issues...

1. Resizing the new map, renders the content all garbaged... it seems that all the images of the game are just in a mosaic in the new map; then trying to open the old map crashes the game
2. Resizing a ship preview window, crashes the game

Cheers,
Nym
Lotta TronIcs
Fano Plane Logistics
#19 - 2015-04-28 17:28:35 UTC
Install worked fine on recent iMac 2014/non-retina, MacPro (2013), and MacBookPro 2013. I also noticed the following:


  • missing anti-aliasing support
  • 4k textures? Are they supposed to be in this release? if so, how are then enabled?
  • does this release officially support Yosemite ? None of my Macs can run anything earlier.


Thanks,

Yoshi Katelo
Caldari Provisions
Caldari State
#20 - 2015-04-28 18:08:52 UTC  |  Edited by: Yoshi Katelo
the game won't start after update. while updating, when it was downloading the second file (the 30mbish one) the download got stuck at 99.8 percent. I waited a while, then forced quit the application (this happened with scylla update too). At launcher restart it showed as download complete/client ready, i was able to press play, but after that i get a black screen with the mouse cursor on it. I can move the cursor.
I did restart the launcher several time, restarted the mac, cleared launcher cache, still the same behaviour.
Launcher version 2.2.878305, macbook pro mid 2009, os x 10.9.5, 4Gb ram, 120 Gb sad

EDIT: i managed to start the game directly, not through the launcher; after that i deleted the common.ini file as suggested in the troubleshooting. it seems that it worked, now the game starts from launcher too
123Next pageLast page