These forums have been archived and are now read-only.

The new forums are live and can be found at https://forums.eveonline.com/

Macintosh

 
  • Topic is locked indefinitely.
12Next page
 

Proteus Macintosh Isues

First post
Author
CCP Falcon
#1 - 2015-01-13 10:18:31 UTC  |  Edited by: CCP Falcon
The Proteus release has been successfully deployed!

This release brings a whole host of module rebalancing and the introduction of several new module variants, as well as a redesign of the Exequror cruiser hull, new visual effects in asteroid belts to improve immersion, a re-balance of Recon cruisers, new features for the Beta Starmap, the introduction of small scale mining anomolies for rookie pilots in starter systems, the retiremement of Teams, new audio for Aura in Russian and German, and an awesome new theme tune from CCP RealX.

For more information on the Proteus release, and to see a full list of features, take a look at the Proteus release page, and read more about what's coming in CCP Seagull's "Coming to EVE in the Proteus release" dev blog. For a full and detailed breakdown of changes please see the patch notes for Proteus.

Please provide details of any issues you encounter with the mac client in this thread.

For issues relating to the PC build of Proteus, please post here, and please leave general feedback regarding the Rhea release here.

CCP Falcon || EVE Universe Community Manager || @CCP_Falcon

Happy Birthday To FAWLTY7! <3

Ian Blackbird
Imperial Shipment
Amarr Empire
#2 - 2015-01-13 13:30:50 UTC
The Multiboxing-Client-Quit-Freeze-Bug is still there.
Exactly the same as mentioned before: https://forums.eveonline.com/default.aspx?g=posts&m=5286296#post5286296
Ylmar
Spontaneous Massive Existence Failure
#3 - 2015-01-13 13:57:56 UTC  |  Edited by: Ylmar
Ian Blackbird wrote:
The Multiboxing-Client-Quit-Freeze-Bug is still there.

Indeed it is. When is this finally going to be fixed?

Before somebody points to the ancient EVE Clonemaker again: even if a proper code signature was added to allow clonemaker to be run on current OS X versions, clonemaker is just a crutch, and the real issue behind the quit/freeze bug needs to be taken care of.

For all the valid complaints of Windows users, we Mac users feel quite forgotten by CCP. X
S'No Flake
Native Freshfood
Minmatar Republic
#4 - 2015-01-13 14:05:05 UTC  |  Edited by: S'No Flake
Ian Blackbird wrote:
The Multiboxing-Client-Quit-Freeze-Bug is still there.
Exactly the same as mentioned before: https://forums.eveonline.com/default.aspx?g=posts&m=5286296#post5286296



Nobody cares.
This bug was reported every pach but nothing has been done.

The workaround it's to open an app before you close one of the clients so,
after you close eve the focus goes to the app you just opened.

My guess is ... nobody works on the mac version. They just pack the windows version with wine and then release it.

Nothing it's being done to fix MacOS related bugs. They don't even support Yosemite months after it was released.

I have a launcher bug. The launcher crashes every time a new patch it's released.
I have to kill it and run it again to work.

I created a petition and i was told to revert to Maveriks.
WTF?
Planeten Schreck
Green Screen
#5 - 2015-01-13 14:14:59 UTC  |  Edited by: Planeten Schreck
Hi

Char and agent portraits are missing for a large part of people in local and agents
Vincent Athena
Photosynth
#6 - 2015-01-13 14:37:32 UTC
The FPS in the new asteroid belts is very low, like 1.5. I have to turn that effect off for the game to be playable.

17" MBP, NVIDIA GeForce GT 330M

Know a Frozen fan? Check this out

Frozen fanfiction

Kimo Fukanaga
State War Academy
Caldari State
#7 - 2015-01-13 18:17:55 UTC
Now I can't connect. Get an "Incompatible (Version)" error message. Sent in a ticket.
Vincent Athena
Photosynth
#8 - 2015-01-13 19:27:31 UTC
This thread is not sticky, and the Rhea thread is still sticky. This needs to be swapped.

Know a Frozen fan? Check this out

Frozen fanfiction

Lillik Eoner
Singularity Expedition Services
Singularity Syndicate
#9 - 2015-01-13 20:48:12 UTC
After I closed and re-opened my client(s), they both updated and loaded without problem. *knocks wood*

I've been using multiple desktops/multiple clients with my 15" MBP for some time now; this generally alleviates the "crash on one client closing" issue. On the other hand, if I open a support app (such as Mumble) after the clients are running, then both clients crash with exceptions.
The Tallman
The Scope
Gallente Federation
#10 - 2015-01-13 22:35:33 UTC  |  Edited by: The Tallman
Machine:
27 in iMac OS 10.9.3 with 27in Second Monitor
3.4Ghz Intel Core i5,
8 GB 1600 MHZ DDR3 Ram
NVIDIA GeForce GTX 755M 2048 MB

Running two clients using the cloning system.
All clients (including the original full install) crash here and there, wether I am running any other applications in background or not.

I don't see anything consistent with when it crashes.

Other issues: Delay in client reacting when I click on something, sometimes long delay from clicking for things like jumping, opening corp hanger turning.
Video not syncing well as well, beginning and end of warp sometimes restarts animation just a few sec after it had started, like it's out of sync.


Would really appreciate a solid solution for running multiple clients on Mac.



When they crash it begs the question why do I have multiple EVE accounts???
Dybbuch
Mindstar Technology
Goonswarm Federation
#11 - 2015-01-14 13:10:39 UTC
Updated - no problem
MacBook Pro early 2011
Intel HD Graphics 3000 512 MB
16GB RAM

The client ran after update ..

closed it - it will now not reopen, either Beachballing at the login screen for the launcher or simply presenting a launcher page without the Username and Password boxes

Arthur Aihaken
CODE.d
#12 - 2015-01-14 13:42:39 UTC
There's still no "High" shader setting available under OS X 10.10 or any of the newer graphics cards.

I am currently away, traveling through time and will be returning last week.

perfecto ignori
F.U.N. Inc.
The Ancients.
#13 - 2015-01-15 11:43:25 UTC  |  Edited by: perfecto ignori
running mac book pro 2011 with Mavericks OpSyst:


-the right click to drag the star map doesn't work anymore: - 1

-the flashing lines on my route goes to fast, is not pretty at all and is too obvious , what was there on the old star map worked way better: - 1

-the star map opens itself way out and my current system is not elected by default: - 1

-i don't need to see the security status of all the systems around, it clutters the map too much, that should be an option: - 1

-the selection and zooming are still generally unintelligent. I click on a system and the camera zoom out and i loose sight on anything related to my selection ....
Need: one click to select, recenter and focus camera, 2x click to select the corresponding solar system map

-the short-cut button to select my current system is handy: + 1
Vincent Athena
Photosynth
#14 - 2015-01-15 14:00:19 UTC  |  Edited by: Vincent Athena
I am getting micro-freezes. The client will stop for a few seconds to up to a minute, than continue as though nothing happened. This tends to happen most often when something changes, like moving inventory. It also tends to happen when I am running 3 clients for over an hour.
This issue started two update cycles ago, with Oceanus.

Know a Frozen fan? Check this out

Frozen fanfiction

Salie Gaterau
Signal Cartel
EvE-Scout Enclave
#15 - 2015-01-15 22:31:10 UTC
I experienced two freeze crashes last night (normally these problems are very rare for me). Both times, the screen went white but all the music and SFX continued to play and I had to force quit the client when it didn't return. When the window closed, I was given the crash report prompt.

I'm running on max settings with the new asteroid and light rays turned on. No other slowdowns or general framerate issues are occurring. Also (if it matters) both crashes occurred in 2 different asteroid belts with a large mining crew (15-18 players).

Here's my overall system specs:

27" iMac
OS X Yosemite
3.2 ghz Intel Quad Core i5
16 GB RAM
Nvidia GeForce GT 755M 1GB
Utremi Fasolasi
La Dolce Vita
#16 - 2015-01-16 05:02:09 UTC
Vincent Athena wrote:
The FPS in the new asteroid belts is very low, like 1.5. I have to turn that effect off for the game to be playable.

17" MBP, NVIDIA GeForce GT 330M



I get around 7 fps which is still a huge drop compared to 60 fps with it off.

Mac Pro (Early 2008)
2 x 3.2 GHz Quad-Core Intel Xeon
8 GB 800 MHz DDR2 FB-DIMM
NVIDIA GeForce 8800 GT 512 MB
The Tallman
The Scope
Gallente Federation
#17 - 2015-01-16 23:46:45 UTC
More Freeze/Crashes today.

Several, on both the clone clients as well as the full install client. Nothing else running in background.

Clients froze while running anomalies, sitting in station, buying on markets.

Only way to fix was to force quit the eve client and restart it. But usually within 30 minutes clients would freeze again.

Last night I ran clients for about two hours without them freezing, today a different story.
Otego Ostus
Doomheim
#18 - 2015-01-19 10:00:17 UTC
It ran very well on the below specs :

rMBP 2012
OS X Yosemite 10.10.2 (Beta Seed)
8GB DDR3
256GB SSD
nVidia 650M 1GB

Only thing that i am still looking at is rare occasion of freezing of client. I am putting current ISP as my prime suspect
Dybbuch
Mindstar Technology
Goonswarm Federation
#19 - 2015-01-19 15:01:34 UTC
Dybbuch wrote:
Updated - no problem
MacBook Pro early 2011
Intel HD Graphics 3000 512 MB
16GB RAM

The client ran after update ..

closed it - it will now not reopen, either Beachballing at the login screen for the launcher or simply presenting a launcher page without the Username and Password boxes



Interestingly the trusty EVE Launcher Repair Tool tells me that

/Applications/Eve Online.app is not a valid EVE Online client, please try again

WHich is nice ..

Ill file a technical ticket
php3ch0 Isu
THE EXTORTIONISTS
#20 - 2015-01-19 18:20:00 UTC
Also experiencing problems with Proteus on Mac. Keeps freezing and I have to force-quit and reload on a regular basis.

Mac Spec

Model Name: iMac
Model Identifier: iMac15,1
Processor Name: Intel Core i5
Processor Speed: 3.5 GHz
Number of Processors: 1
Total Number of Cores: 4
L2 Cache (per Core): 256 KB
L3 Cache: 6 MB
Memory: 16 GB
Chipset Model: AMD Radeon R9 M290X
Type: GPU
Bus: PCIe
PCIe Lane Width: x16
VRAM (Total): 2048 MB
Vendor: ATI (0x1002)

Never had any issues with previous version
12Next page