These forums have been archived and are now read-only.

The new forums are live and can be found at https://forums.eveonline.com/

EVE Technology Lab

 
  • Topic is locked indefinitely.
 

API error Codes for ContractItems.xml.aspx

First post
Author
GiveMeATry
Mental Disorders Inc.
Guardians of the Asylum
#1 - 2011-09-13 07:02:23 UTC
i think the new Contracts API is awesome but I am having some problems.

I have one completed private contract within the 30 days I am trying to get a item listing but I get error code

error code="531" - Failed getting contract information.

How can I get more information on how to retreive the Contract items? All other requests work except for this charactor and contract.



CCP Prism X
C C P
C C P Alliance
#2 - 2011-09-13 08:20:34 UTC
I didn't write the code but I quickly skimmed over it over the morning coffee. Seems to me that the only way 531 is raised is that if the contractID parameter does not correspond to an existing contractID. Note that this (the contract items call) is not a matter of the contract being completed or any other case of conditional exclusion. However that would apply to the contract list call itself which will only display contracts in outstanding or in progress status or if they are older than a month.

So you should try the char/Contracts call again to see if you find the contract in there with a different ID than what you're using.
PsyKzz
Bat Country
Pandemic Horde
#3 - 2011-09-13 09:49:34 UTC
CCP Prism X wrote:
I didn't write the code but I quickly skimmed over it over the morning coffee. Seems to me that the only way 531 is raised is that if the contractID parameter does not correspond to an existing contractID. Note that this (the contract items call) is not a matter of the contract being completed or any other case of conditional exclusion. However that would apply to the contract list call itself which will only display contracts in outstanding or in progress status or if they are older than a month.

So you should try the char/Contracts call again to see if you find the contract in there with a different ID than what you're using.


I love how you can just 'skip over the code' with your morning coffee.
Makes me want to move to iceland and get a job.

Meh.

MCBurner
Viziam
Amarr Empire
#4 - 2011-09-13 12:06:53 UTC
I'm having similar problems with ContractItems.xml.aspx while trying to use it with a list of contractIDs.
What it the correct way to attach the contractID list to the xml request url?

Is it &contractIDs=xxxx,xxxx,xxxx,
or is it &contractIDlist=xxxx,xxxx,xxxx,

I always get "[error] => Invalid or missing contractID." but the IDs I'm using are correct.

Thanks in advance.
Johnathan Roark
Quantum Industries
#5 - 2011-09-13 12:23:28 UTC
MCBurner wrote:
I'm having similar problems with ContractItems.xml.aspx while trying to use it with a list of contractIDs.
What it the correct way to attach the contractID list to the xml request url?

Is it &contractIDs=xxxx,xxxx,xxxx,
or is it &contractIDlist=xxxx,xxxx,xxxx,

I always get "[error] => Invalid or missing contractID." but the IDs I'm using are correct.

Thanks in advance.



I don't think it will take a list like that. It would have been nice it would though. I would like it to act like the mail call and return a list of invalid ids instead of throwing an error.

EVEVERIFY - A recruiting API Verification and Audit Tool

Also try out Yapeal for your php api needs

GiveMeATry
Mental Disorders Inc.
Guardians of the Asylum
#6 - 2011-09-13 12:37:02 UTC  |  Edited by: GiveMeATry
Thanks for taking a look,

Tried again this morning

I am only having this problem with one toon and one contract. Every other toon and contract works fine.


https://api.eveonline.com/char/Contracts.xml.aspx?userID=x&apikey=y&characterID=z

{?xml version='1.0' encoding='UTF-8'?}
{eveapi version="2"}
{currentTime}2011-09-13 11:32:12{/currentTime}
{result}
{rowset name="contractList" key="contractID" columns="contractID,issuerID,issuerCorpID,assigneeID,acceptorID,startStationID,endStationID,type,status,title,forCorp,availability,dateIssued,dateExpired,dateAccepted,numDays,dateCompleted,price,reward,collateral,buyout,volume"}
{row contractID="45138369" issuerID="na" issuerCorpID="na" assigneeID="na" acceptorID="na" startStationID="na" endStationID="na" type="ItemExchange" status="Completed" title="" forCorp="0" availability="Private" dateIssued="2011-08-20 01:41:22" dateExpired="2011-08-21 01:41:22" dateAccepted="2011-08-20 01:58:02" numDays="0" dateCompleted="2011-08-20 01:58:02" price="0.00" reward="0.00" collateral="0.00" buyout="0.00" volume="380" /}
{/rowset}
{/result}
{cachedUntil}2011-09-13 11:32:13{/cachedUntil}
{/eveapi}


https://api.eveonline.com/char/ContractItems.xml.aspx?userID=x&apikey=y&characterID=z&contractID=45138369

{?xml version="1.0" encoding="UTF-8" ?}
{eveapi version="2"}
{currentTime}2011-09-13 11:48:23{/currentTime}
{error code="531"}Failed getting contract information.{/error}
{cachedUntil}2011-09-13 11:48:23{/cachedUntil}
{/eveapi}
TheCrazyT BCln
Green-Core
#7 - 2011-09-13 17:06:36 UTC
GiveMeATry wrote:
Thanks for taking a look,

Tried again this morning

I am only having this problem with one toon and one contract. Every other toon and contract works fine.


https://api.eveonline.com/char/Contracts.xml.aspx?userID=x&apikey=y&characterID=z

{?xml version='1.0' encoding='UTF-8'?}
{eveapi version="2"}
{currentTime}2011-09-13 11:32:12{/currentTime}
{result}
{rowset name="contractList" key="contractID" columns="contractID,issuerID,issuerCorpID,assigneeID,acceptorID,startStationID,endStationID,type,status,title,forCorp,availability,dateIssued,dateExpired,dateAccepted,numDays,dateCompleted,price,reward,collateral,buyout,volume"}
{row contractID="45138369" issuerID="na" issuerCorpID="na" assigneeID="na" acceptorID="na" startStationID="na" endStationID="na" type="ItemExchange" status="Completed" title="" forCorp="0" availability="Private" dateIssued="2011-08-20 01:41:22" dateExpired="2011-08-21 01:41:22" dateAccepted="2011-08-20 01:58:02" numDays="0" dateCompleted="2011-08-20 01:58:02" price="0.00" reward="0.00" collateral="0.00" buyout="0.00" volume="380" /}
{/rowset}
{/result}
{cachedUntil}2011-09-13 11:32:13{/cachedUntil}
{/eveapi}


https://api.eveonline.com/char/ContractItems.xml.aspx?userID=x&apikey=y&characterID=z&contractID=45138369

{?xml version="1.0" encoding="UTF-8" ?}
{eveapi version="2"}
{currentTime}2011-09-13 11:48:23{/currentTime}
{error code="531"}Failed getting contract information.{/error}
{cachedUntil}2011-09-13 11:48:23{/cachedUntil}
{/eveapi}


You are not alone ... i get the same error.("Failed getting contract information.")
Although i just copied the id from Contracts.xml.aspx.(type=ItemExchange)
No idea whats the problem.
Maybe it can't take special api keys?(mine just uses one of my toons so i do not need to give it a characterID param)
GiveMeATry
Mental Disorders Inc.
Guardians of the Asylum
#8 - 2011-09-14 00:08:48 UTC  |  Edited by: GiveMeATry
Quote:

You are not alone ... i get the same error.("Failed getting contract information.")
Although i just copied the id from Contracts.xml.aspx.(type=ItemExchange)
No idea whats the problem.
Maybe it can't take special api keys?(mine just uses one of my toons so i do not need to give it a characterID param)
[/quote]

Not sure,

The only thing i see that is different is the contracts are a mix of BPO and BPC while all the other characters have normal items.

Oh and it's the FULL Api key not a custom key.
Dragonaire
Here there be Dragons
#9 - 2011-09-14 04:52:37 UTC
Since it is a new API maybe you should try a new style CAK? Just a thought I guess they are suppose to work with both but I'd try both types just to make sure. I also always use characterID whether it's needed or not with the new keys just on general principal.

Finds camping stations from the inside much easier. Designer of Yapeal for the Eve API. Check out the Yapeal PHP API Library thread.

GiveMeATry
Mental Disorders Inc.
Guardians of the Asylum
#10 - 2011-09-14 14:06:00 UTC
Off Topic, but is there a API call to receive the permissions of the provided key?

Dragonaire
Here there be Dragons
#11 - 2011-09-14 14:12:29 UTC
account/APIKeyInfo

Finds camping stations from the inside much easier. Designer of Yapeal for the Eve API. Check out the Yapeal PHP API Library thread.

TheCrazyT BCln
Green-Core
#12 - 2011-09-16 15:57:04 UTC
Is there still no solution for that bug?

Is it already officially working?
Because i wonder why ContractItems.xml.aspx is not even listed here:
http://wiki.eve-id.net/APIv2_Page_Index

I already tried it with different api keys and all permissions, but still no luck.
I'm out of ideas ... and somehow i doubt that i'm doing something wrong.
Maybe that api does not work with single-item contracts?
Because i did not yet tested with multiple item contracts.
GiveMeATry
Mental Disorders Inc.
Guardians of the Asylum
#13 - 2011-09-16 18:55:58 UTC
I was told to submit a bug report.

I'm not sure how to submit a bug report, I hope this can get fixed before the 22nd.
Meryen Anais
Garoun Investment Bank
Gallente Federation
#14 - 2011-09-18 12:18:48 UTC
CCP Elerhino
C C P
C C P Alliance
#15 - 2011-09-20 10:39:13 UTC
I'll be taking a look at the contractitems issue soon, is this only happening on the character side?
Dragonaire
Here there be Dragons
#16 - 2011-09-20 14:24:31 UTC
I seem to be having problems with corp too.

Finds camping stations from the inside much easier. Designer of Yapeal for the Eve API. Check out the Yapeal PHP API Library thread.

CCP Elerhino
C C P
C C P Alliance
#17 - 2011-09-22 11:37:13 UTC
I belive we found the problem and it's been fixed but most likely there will be a delay in deploying the fix because we're re-structuring the deployment process and the serverfarm where the API runs. So everything is a bit up in the air right now. But if you flame me enough on this thread I'll see what I can do. Bear
Dragonaire
Here there be Dragons
#18 - 2011-09-23 20:08:50 UTC
This error does seem to be affecting everyone I've talked with and has made testing impossible so trying to add the API to Yapeal had to be halted for now Sad

So maybe there's hope the
[2011-09-23 19:43:15.638]
WARNING: API connection error: Operation too slow. Less than 10 bytes/sec transfered the last 12 seconds
might go away with re-structuring also Smile

Finds camping stations from the inside much easier. Designer of Yapeal for the Eve API. Check out the Yapeal PHP API Library thread.

Johnathan Roark
Quantum Industries
#19 - 2011-09-24 04:28:41 UTC
CCP Elerhino wrote:
I belive we found the problem and it's been fixed but most likely there will be a delay in deploying the fix because we're re-structuring the deployment process and the serverfarm where the API runs. So everything is a bit up in the air right now. But if you flame me enough on this thread I'll see what I can do. Bear



Restructuring the serverfarm where the API runs? Are we getting more hamsters for the API servers? I would love that.

And I'd like to see contracts fixed as well. Would also like to see the cache timer lowered.

EVEVERIFY - A recruiting API Verification and Audit Tool

Also try out Yapeal for your php api needs