These forums have been archived and are now read-only.

The new forums are live and can be found at https://forums.eveonline.com/

Linux

 
  • Topic is locked indefinitely.
12Next page
 

EVE - Probe

First post
Author
COMM4NDER
Legendary Umbrellas
#1 - 2014-09-19 21:46:32 UTC  |  Edited by: COMM4NDER
Anyone have any luck with launching eve-probe?
https://forums.eveonline.com/default.aspx?g=topics&f=6404

Tried to but it sems to crash.


Quote:
fixme:system:SetProcessDPIAware stub!
fixme:toolhelp:CreateToolhelp32Snapshot Unimplemented: heap list snapshot
fixme:toolhelp:Heap32ListFirst : stub
fixme:font:get_outline_text_metrics failed to read face_nameW for font L"Oxygen Mono"!
fixme:font:get_outline_text_metrics failed to read face_nameW for font L"Oxygen-Sans"!
fixme:win:FlashWindowEx 0x32f108
fixme:heap:HeapSetInformation 0x440000 0 0x33fd04 4
fixme:heap:HeapSetInformation (nil) 1 (nil) 0
fixme:heap:HeapSetInformation 0x440000 0 0x3386a4 4
trace:d3d9:Direct3DCreate9 sdk_version 0x20.
err:wgl:wglFinish wglFinish
fixme:win:EnumDisplayDevicesW ((null),0,0x338c68,0x00000000), stub!
trace:d3d9:Direct3DCreate9 Created d3d9 object 0x12d630.
trace:d3d9:d3d9_GetAdapterCount iface 0x12d630.
trace:d3d9:d3d9_Release 0x12d630 decreasing refcount to 0.
trace:d3d9:Direct3DCreate9 sdk_version 0x20.
err:wgl:wglFinish wglFinish
fixme:win:EnumDisplayDevicesW ((null),0,0x338c68,0x00000000), stub!
trace:d3d9:Direct3DCreate9 Created d3d9 object 0x129a20.
trace:d3d9:d3d9_GetAdapterCount iface 0x129a20.
trace:d3d9:d3d9_Release 0x129a20 decreasing refcount to 0.
No handlers could be found for logger "trinity"
Starting up Trinity through _trinity_dx9_deploy ...
trace:d3d9:Direct3DCreate9 sdk_version 0x20.
err:wgl:wglFinish wglFinish
fixme:win:EnumDisplayDevicesW ((null),0,0x3386a8,0x00000000), stub!
trace:d3d9:Direct3DCreate9 Created d3d9 object 0x134818.
trace:d3d9:d3d9_GetAdapterDisplayMode iface 0x134818, adapter 0, mode 0x33933c.
trace:d3d9:d3d9_GetAdapterIdentifier iface 0x134818, adapter 0, flags 0, identifier 0x339178.
fixme:win:EnumDisplayDevicesW ((null),0,0x339058,0x00000000), stub!
fixme:win:EnumDisplayDevicesW ((null),1,0x339058,0x00000000), stub!
trace:d3d9:d3d9_GetAdapterDisplayMode iface 0x134818, adapter 0, mode 0x339970.
trace:d3d9:d3d9_CheckDeviceFormat iface 0x134818, adapter 0, device_type 0x1, adapter_format 0x16, usage 0x2, resource_type 0x1, format 0x5a544e49.
trace:d3d9:d3d9_GetAdapterIdentifier iface 0x134818, adapter 0, flags 0, identifier 0x33a150.
Unhandled exception in run()
Traceback (most recent call last):
File "autoexec.py", line 414, in run
File "autoexec.py", line 396, in run_protected
File "infogatherer\__init__.py", line 110, in gather_info
File "infogatherer\__init__.py", line 103, in getGpuInfo
File "infogatherer\__init__.py", line 87, in getGpuDriverInfo
ALError: ALResult(80004005) E_FAIL: An undetermined error occurred
An exception has occurred. It has been logged in the log server as exception #1


Tried to add my own DeviceID and DeviceVendorID together with driver in regedit but it still fails.

[url=https://github.com/CommanderAlchemy/.bin/blob/master/eve] EVE - Online Launcher [Linux] [/url] Installs, launches character prefixes (both SISI & Tranquility). Simplescreenrecorder shm inject

Marsan
#2 - 2014-09-19 22:31:17 UTC
I think the crash and log upload says it all to CCP. We should all run it and set CCP a message about the number of linux users.

Former forum cheerleader CCP, now just a grumpy small portion of the community.

COMM4NDER
Legendary Umbrellas
#3 - 2014-09-20 03:25:53 UTC
Marsan wrote:
I think the crash and log upload says it all to CCP. We should all run it and set CCP a message about the number of linux users.

True, but does not help us that much. But it seems to crash in their code when trying to figure out my hardware.

[url=https://github.com/CommanderAlchemy/.bin/blob/master/eve] EVE - Online Launcher [Linux] [/url] Installs, launches character prefixes (both SISI & Tranquility). Simplescreenrecorder shm inject

Torgeir Hekard
I MYSELF AND ME
#4 - 2014-09-20 07:08:27 UTC
I wonder if it's possible to decrypt the file with the crashing function and make a bypass in it.

So far I've found something called evedec, but it appears to be windows-only (even though it's python). Could not manage to run it neither directly (fails at importing windll from ctypes) nor through wine with windows python (for some reason it fails to parse the configuration file).
Frank Heth
Caldari Provisions
Caldari State
#5 - 2014-09-20 07:46:15 UTC
Same here.

Fedora 20, all updated, but no luck so far.
I can "start" the test, but as soon as the launcher shows "RUNNING!" , nothing happens :(


I'd like a census of Windows / MAC / Linux users as well (not counting wine as Windows, that is...)
Phoeniix
Booster del Norte
#6 - 2014-09-21 20:57:12 UTC
Torgeir Hekard wrote:
I wonder if it's possible to decrypt the file with the crashing function and make a bypass in it.

So far I've found something called evedec, but it appears to be windows-only (even though it's python). Could not manage to run it neither directly (fails at importing windll from ctypes) nor through wine with windows python (for some reason it fails to parse the configuration file).


If the structure of the eve-probe stuff is the same as EVE (and it look like that), it should work but remember that using that tool is again the eula even if it's for fixing there code..
COMM4NDER
Legendary Umbrellas
#7 - 2014-09-24 20:12:36 UTC
New version and same issue. Seems that users of Windows XP have similar issue like we do so there is a possibility it may be the same cause.

[url=https://github.com/CommanderAlchemy/.bin/blob/master/eve] EVE - Online Launcher [Linux] [/url] Installs, launches character prefixes (both SISI & Tranquility). Simplescreenrecorder shm inject

COMM4NDER
Legendary Umbrellas
#8 - 2014-10-07 16:43:58 UTC
Another version and same issues.
...

[url=https://github.com/CommanderAlchemy/.bin/blob/master/eve] EVE - Online Launcher [Linux] [/url] Installs, launches character prefixes (both SISI & Tranquility). Simplescreenrecorder shm inject

Inef Tesseract
No Vision Just Failure
#9 - 2014-10-08 13:55:19 UTC
Does WINE support DX11 ?

Does EVE Probe run in DX9 or in DX11?

Kismeteer
Bat Country
Pandemic Horde
#10 - 2014-10-08 15:40:32 UTC
Inef Tesseract wrote:
Does WINE support DX11 ?

Does EVE Probe run in DX9 or in DX11?



Eve Probe does run in dx9, but it doesn't support the hooks that wine does. So it doesn't work. But that's okay because we're a low priority. We'll see how much longer we continue to work.
CCP Snorlax
C C P
C C P Alliance
#11 - 2014-10-08 21:27:55 UTC
I'll get EVE Probe running on Linux eventually, I just can't justify spending time on it at the moment as Linux isn't officially supported and all that, and I've got too much on my plate right now. So please bear with me, I'll make time eventually :)

The XP issue seems to be different, as it doesn't even start up there - the log above shows an exception thrown early in the startup, but that's still further in than what we're seeing on XP.

CCP Snorlax - Software Architect - Team RnB - @CCP_Snorlax - http://ccpsnorlax.blogspot.is/

Kismeteer
Bat Country
Pandemic Horde
#12 - 2014-10-09 15:53:26 UTC
CCP Snorlax wrote:
I'll get EVE Probe running on Linux eventually, I just can't justify spending time on it at the moment as Linux isn't officially supported and all that, and I've got too much on my plate right now. So please bear with me, I'll make time eventually :)


Thank you sir, we appreciate your continued work on our fringe operating system.
Wilhelm Ormand
The Scope
Gallente Federation
#13 - 2014-10-12 12:05:36 UTC  |  Edited by: Wilhelm Ormand
Thanks for the unofficial support, as a linux-only user I appreciate it a lot.
CCP Snorlax
C C P
C C P Alliance
#14 - 2014-10-13 14:17:49 UTC
I just put up a new build of EVE Probe that may fix the issue, or at least get you further. I haven't had a chance to test under Linux, but this at least addresses an error we see in logs for sessions that fail to start up and match with what I saw earlier in this thread.

Please post here if you try this and let me know if it worked or not.

Here's the installer:
http://files.eveprobe.ccpgames.com/eveprobe-0.83.5175.0.msi

CCP Snorlax - Software Architect - Team RnB - @CCP_Snorlax - http://ccpsnorlax.blogspot.is/

Rhyme Bittern
Signal Cartel
EvE-Scout Enclave
#15 - 2014-10-13 15:37:06 UTC
CCP Snorlax wrote:

Please post here if you try this and let me know if it worked or not.

Here's the installer:
http://files.eveprobe.ccpgames.com/eveprobe-0.83.5175.0.msi


Tried on ubuntu 14.10. I get this pop-up error message:

Your EVE client installation may have modified, damaged or corrupt files. Please run repair.exe located in the EVE game directory or re-install the game client.
Verification failed: 'C:\Program Files (x86)\CCP\EVE Probe\bin\python27.dll', crc:ffecd4d2,expected:1d201179.


Using repair.exe doesn't help.
Kismeteer
Bat Country
Pandemic Horde
#16 - 2014-10-13 18:22:38 UTC
Worked for me, though I specified where to install it. But pretty much 1 FPS across the board with effects on.

01:00.0 VGA compatible controller: NVIDIA Corporation GT218 [GeForce 210] (rev a2) (prog-if 00 [VGA controller])
Nvidia 331.38
wine 1.6.2
ubuntu 14.04
Kernel 3.13.0-34
8 gig of ram
4 cores - Intel(R) Core(TM)2 Quad CPU Q9400 @ 2.66GHz
encrypted home dir
COMM4NDER
Legendary Umbrellas
#17 - 2014-10-13 22:44:25 UTC  |  Edited by: COMM4NDER
CCP Snorlax wrote:
I just put up a new build of EVE Probe that may fix the issue, or at least get you further. I haven't had a chance to test under Linux, but this at least addresses an error we see in logs for sessions that fail to start up and match with what I saw earlier in this thread.

Please post here if you try this and let me know if it worked or not.

Here's the installer:
http://files.eveprobe.ccpgames.com/eveprobe-0.83.5175.0.msi


Seems you did it Attention

Launched this on latest Wine CSMT build from git based on Wine 1.7.24
1, Without any overrides the Launcher would not start the test.
2, With vcrun2005 it would launch however it could not send data (the button was stuck at running.
3, With vcrun2008 it would launch, stuck on end and most of the times the thread would not stop by itself giving black screen at end.
4, With vcrun2010 it ran without issues it seems.
Logserver from successfull run: http://dl.eve-files.com/media/1410/Cayman.2014.10.14.00.02.49.ERRORS.zip

Scene 1
Malloc: 62MB
FPS: 99

Scene 2
Malloc: 224MB
FPS: 26

Scene 3
Malloc: 111MB
FPS: 42

Scene 4
Malloc: 59MB
FPS: 108

Scene 5
Malloc: 224MB
FPS: 13

Scene 6
Malloc 100MB
FPS: 36

AMD 8359 @ 5GHz
nVidia Zotac GTX 670 AMP!
nVidia 343:22

Tried doing it a second time in new prefix but it fails to launch trinity for some reason. Nothing happens, Logserver does not even pick up anything and no error from what I can see in terminal.
Gonna have to dig through it.

WineHQ AppDB
I created Winehq appdb for eve probe, followed the EVE - Online using "current" since there was allot of patches between days it would just be spamming with new versions.
Remember to use clean wine and tell if you need winetricks and what to make it run etc...
https://appdb.winehq.org/objectManager.php?sClass=version&iId=31037 (try to copy-paste the link instead seems the forward is not working)

[url=https://github.com/CommanderAlchemy/.bin/blob/master/eve] EVE - Online Launcher [Linux] [/url] Installs, launches character prefixes (both SISI & Tranquility). Simplescreenrecorder shm inject

COMM4NDER
Legendary Umbrellas
#18 - 2014-10-14 01:28:38 UTC  |  Edited by: COMM4NDER
Found the culprint why it would fail silently.

Installing EVE Probe with:
  • WINEARCH=win32 WINEPREFIX=/path/ wine msiexec /i eveprobe-installer.msi
  • Follow through the installer (selected full install)

    Launch EVE - Probe
  • WINEPREFIX=/path/ wine ...drive_c/Program\ Files/CCP/EVE\ Probe/launcher/eveprobe.exe

  • Run Benchmark
    ------ Fails silently

    Create 2 folders
    CCP/EVE
  • /drive_c/users/$USER/Local Settings/Application Data/CCP/EVE

  • Run Benchmark
    ------ works ćompletly and posts results in the end
    ------ looks like engine trails are missing in few scenes but not sure if intended

    Runs, and finishes without any overrides whatsoever with Wine 1.7.28

    Question is now, when does it create those folders and how, ie Is the installer failing or is it something during first run
    Why did it work for me before and not anymore?

    Did a youtube video of the benchmark
    https://www.youtube.com/watch?v=5AkJybNb5GE&feature=youtu.be

    [url=https://github.com/CommanderAlchemy/.bin/blob/master/eve] EVE - Online Launcher [Linux] [/url] Installs, launches character prefixes (both SISI & Tranquility). Simplescreenrecorder shm inject

    Torgeir Hekard
    I MYSELF AND ME
    #19 - 2014-10-14 04:52:01 UTC  |  Edited by: Torgeir Hekard
    Yup. It worked after doing the shenanigans specified by COMM4NDER.

    That is, ubuntu 14.04 amd64, ppa wine 1.7.28, clean prefix, creating the specified directory.

    But.

    It launches fullscreen and is not stable for me that way. I think it starts having problems when I try to alt-tab or stop it or whatever. So it can hang or crash.

    If I launch it in wine desktop mode, it works fine.

    Also, lots of
    fixme:winhttp:get_system_proxy_autoconfig_url no support on this platform
    in console.

    PS: NVidia GT 645M with 331.38 driver running through bumblebee.
    Rhyme Bittern
    Signal Cartel
    EvE-Scout Enclave
    #20 - 2014-10-14 20:49:28 UTC
    Rhyme Bittern wrote:


    Tried on ubuntu 14.10. I get this pop-up error message:

    Your EVE client installation may have modified, damaged or corrupt files. Please run repair.exe located in the EVE game directory or re-install the game client.
    Verification failed: 'C:\Program Files (x86)\CCP\EVE Probe\bin\python27.dll', crc:ffecd4d2,expected:1d201179.


    Using repair.exe doesn't help.


    I solved it by:
    1. Manually deleting the EVE Probe folder in drive_c/Program Files (x86(/CCP (the supplied uninstaller does nothing).
    2. Running the .msi file again and choosing "repair".
    3. Installing vcrun2010 in my default wine prefix using winetricks.

    Nice scenes! I wish they were longer though.
    12Next page