These forums have been archived and are now read-only.

The new forums are live and can be found at https://forums.eveonline.com/

Issues, Workarounds & Localization

 
  • Topic is locked indefinitely.
123Next page
 

Black screens whilst multiboxing? I need your feedback

First post
Author
CCP Masterplan
C C P
C C P Alliance
#1 - 2014-09-04 13:43:04 UTC
We've seen in increase in reports of client 'black screen' lock-ups recently, particularly from players running multiple clients. Typically the black screen seems to occur when multiple clients are logged in from the same PC at the same time, and may coincide with mass dock/undock/jump session changes.

I'm investigating this issue and would like your help if you are experiencing this. Please note that other crashes or graphical lockups are also important to investigate, but I'm specifically looking for focused feedback related to this particular issue only in this thread: Multiboxing users that suffer black screens on some of their clients when those clients all attempt to login/jump/dock/undock at the same time.

If your clients suffer from this problem (especially if you've noticed an increase recently) please reply to this thread with the following info. I'm chasing up a few leads and this would help me to a) isolate the reproduction conditions and b) create a solution.

1] How many clients do you typically use
2] How frequently does the issue happen on Tranquility?
3] Are the characters in player corps or NPC corps?
4] Are they logging in to space or to a station?
5] Can you reproduce the issue with the same setup on Singularity

I'm particularly interested in anyone who is able to help reproduce this on Singularity, as there's things we can experiment with on there that we obviously couldn't do on TQ

Thanks for your help!

"This one time, on patch day..."

@ccp_masterplan  |  Team Five-0: Rewriting the law

Gilbaron
The Scope
Gallente Federation
#2 - 2014-09-04 13:49:56 UTC
i have an "issue" where my clients sometimes freeze for a while when logging in 2 or more alts. i always thought it was just my laptop taking more time to handle multiple logins at the same time.

is this the same thing ? or are you talking about something where the client doesn't recover ?
CCP Masterplan
C C P
C C P Alliance
#3 - 2014-09-04 13:55:11 UTC
Logins that are simply slow but eventually get there are most likely unrelated. These black screens I'm investigating seem to be unrecoverable without restarting the client

"This one time, on patch day..."

@ccp_masterplan  |  Team Five-0: Rewriting the law

Fonac
Imperial Academy
Amarr Empire
#4 - 2014-09-04 14:00:34 UTC
Gilbaron wrote:
i have an "issue" where my clients sometimes freeze for a while when logging in 2 or more alts. i always thought it was just my laptop taking more time to handle multiple logins at the same time.

is this the same thing ? or are you talking about something where the client doesn't recover ?



Probably your harddrive that can't cope with the amount of data it needs to read.
(This does not mean your harddrive is broken, just slow - Very normal for a laptop)

Tarsas Phage
Freight Club
#5 - 2014-09-04 14:44:26 UTC
I run 10 clients, all chars in the same player (non-NPC) corp. The station they log in to has a office for their corp. I have not had the time to test this on Singularity.

Usually, around half (4-7 of the 10) will black-screen upon undocking, and a reliable indicator that this will happen is that, while still docked after logging in, those specific clients which will black-screen will fail to see a Fleet advert meant for them. The clients which do see the fleet advert will not black-screen after undocking and work as expected.

In isboxer I use "full screen stacked" mode, with clients on a dedicated screen out of my 3 monitors.

I have found a work-around of sorts which seems to be reliable:

1) Use isboxer to start and log in to the 10 clients, arriving at the character selection screen.
2) Turn off (isboxer) broadcast, and serially go through each client to select the char and log it into the game. How fast one cycles through the clients does not appear to matter.

after all that is done:

3) Instead of using isboxer to join the chars into the same fleet by selecting a (in some client non-existant) fleet advert, I use an 11th char, which normally would create the fleet and its advert, to then manually send the 10 isbox'd chars fleet invites, which I serially go through on the isbox'd clients and accept. I can assert that this is a repeatable work-around, however it does of course mean more spin-up time for the entire setup.

I've also noticed an oddity which also seems related specifically to any black-screening clients:

I quit the clients by hitting [esc] and clicking the "Quit Game" button. This immediately quits all 10 clients, yet some of the chars which black-screen will persist in Local as seen by other, unrelated players. If the unrelated player leaves system and comes back, the ghost char in local will not be shown.

HTH
RoCkEt X
Hostile.
PURPLE HELMETED WARRIORS
#6 - 2014-09-04 15:19:25 UTC
1] How many clients do you typically use
2] How frequently does the issue happen on Tranquility?
3] Are the characters in player corps or NPC corps?
4] Are they logging in to space or to a station?
5] Can you reproduce the issue with the same setup on Singularity


1 - 10-15
2 - every time i log in
3 - some in npc corp, some in player corps

4 - space/station makes no difference:
Logging into station you will not black screen, but you may blackscreen on undock, the way to tell whether you've blackscreened before you undock is to open fleet finder. Even if there are fleets up that you can join, it won't display any. So basically, if some of your chars can't see the fleet and others can, the ones who can't will blackscreen on undock.

Logging into space will either produce blackscreen immediately, or not at all.

Ergo, this issue is something to do with being in space, and not to do with session change (because you can still switch ships whilst docked - thus session changing without an issue)

I have thus far found only rebooting the client helps, to avoid the issue completely, using ISboxer, log into all your accounts at the same time, at the character selection screen, you then log them in one by one. This solution has been 100% effective thus far.

5 - Yes, i can reproduce the issue consistantly on both SiSi and TQ.

Notes:
*The ingame ESC menu works as normal, even when blackscreened.
*Problem is constant across all GPU models and driver versions (i've been trying to find a fix for this for a long time).
*Is only existant when logging multiple clients in simultaneously.
*Problem has existed for the last 2 years, but before only 1-2 of 10 clients would blackscreen, since the Crius update, this is now 50% of all clients will blackscreen if logged in simultaneously.
*ISboxer can force eve to run in either Dx9, or Dx11. I've seen no difference in either setting.

If you have further questions, feel free to contact me.
-Rock
Ariel Rin
Tactically Challenged
Tactical Supremacy
#7 - 2014-09-04 15:37:08 UTC
1] How many clients do you typically use
The set in question is 4, but i usually have an additional 2 running with different activities - ie. not jumping together
2] How frequently does the issue happen on Tranquility?
once or twice a day
3] Are the characters in player corps or NPC corps?
Character corporations
4] Are they logging in to space or to a station?
Only experience it logging into station

Also experienced leaving station and jumping
5] Can you reproduce the issue with the same setup on Singularity
downloading now - will edit

NOTES:
esc menu works perfectly fine, but will not respond to mouse presses on GUI (if i know where the jump button is for example)
only ever happens to one of the four
"Usually" my last client to boot is the one experiencing it
all 4 running with identical (cloned from config files) configuration

Ariel Rin

Creator and Manager of EVE Meet, for notification and sharing of out of game meets.

Twitter - Ariel Rin - EVE Meet

CCP Masterplan
C C P
C C P Alliance
#8 - 2014-09-04 15:52:28 UTC
Thanks for your prompt feedback. The fleet-finder availability (or lack of) is quite useful info here. I've also seen someone else mention that the agent tab in the station info window also fails to display information if a client is broken in this way. This is making my spider-sense tingle :)

RoCkEt X wrote:
1] Ergo, this issue is something to do with being in space, and not to do with session change (because you can still switch ships whilst docked - thus session changing without an issue)

Just a quick comment on this: Switching ships whilst docked is no longer a session change (It used to be, until a couple of years ago). This is why you can switch quickly between different ships in your station hangar without requiring a 10s session timer between each.

"This one time, on patch day..."

@ccp_masterplan  |  Team Five-0: Rewriting the law

Tarsas Phage
Freight Club
#9 - 2014-09-04 16:36:32 UTC
CCP Masterplan wrote:
Thanks for your prompt feedback. The fleet-finder availability (or lack of) is quite useful info here. I've also seen someone else mention that the agent tab in the station info window also fails to display information if a client is broken in this way. This is making my spider-sense tingle :)


If you think that the problem might tie back to some common component related to these character services (idk what you call it internally, that's just a guess on my part) are there any other things that we can test specifically which might also use the same (sub)system?

Lady Spank
Get Out Nasty Face
#10 - 2014-09-04 18:13:32 UTC
Ban cheating boxers rather than supporting them please.

(ಠ_ృ) ~ It Takes a Million Years to Become Diamonds So Lets Just Burn Like Coal Until the Sky's Black ~ (ಠ_ృ)

HarlyQ
harlyq syrokos investment station
Goonswarm Federation
#11 - 2014-09-04 18:47:36 UTC
Lady Spank wrote:
Ban cheating boxers rather than supporting them please.

you know its not cheating right you can go get the same product or multiple accounts.

1] How many clients do you typically use. I use 8
2] How frequently does the issue happen on Tranquility? everytime i mass log in but its really rare when i have them all undock.
3] Are the characters in player corps or NPC corps? Player corps.
4] Are they logging in to space or to a station? space.
5] Can you reproduce the issue with the same setup on Singularity. have not downloaded.
oodell
Rotciv Rrama Industries
Goonswarm Federation
#12 - 2014-09-04 18:57:01 UTC
I use between 7 and 11 accounts at the same time regularly. All characters are in a player corp. The blackscreen thing has been going on for quite some time (6 months, at least) but lately it has stepped up significantly. Whereas it used to be a once-a-week glitch, now I can pretty much count on anywhere from 2-4 out of my 11 accounts to blackscreen every time I log in and undock.

The blackscreens only seem to happen on the first undock after the first time logging in. Once I close the bad accounts and re-launch them, the issue goes away. I don't think I have ever seen another black screen after this in a night, despite docking/undocking repeatedly and even logging/relogging a subset of my alts several times. I don't know the reason for this.

I mostly log in while docked in a station, but I'm fairly certain I have seen the problem happen while logging in while in space. I believe a corpmate lost a few ships while logging in this way last week.

When it happens, the client affected has no UI ability, the screen is 100% black. The client is still responsive. You can fleetwarp the affect alts to a safespot, but that's about it.

I haven't checked recently, but I believe you can open the fittings window to see if the client has been affected prior to undocking. If I remember correctly, the fittings window doesn't load correctly on the affect alts, and you can use this to relog them before undocking into a hostile situation and having a blackscreen. I can double check this when I log in later.

I don't have singularity set up.
Pain Time
Ministry of War
Amarr Empire
#13 - 2014-09-04 19:40:47 UTC  |  Edited by: Pain Time
1] How many clients do you typically use: 16
2] How frequently does the issue happen on Tranquility? every mass logon or undock, if you undock/logon slowly, these are avoided.
3] Are the characters in player corps or NPC corps? player corp, why bother with npc, right?
4] Are they logging in to space or to a station? space nowadays, stations have undock blackscreen ontop of logon blackscreen.
5] Can you reproduce the issue with the same setup on Singularity. Probably, i will need to figure out how to make sisi repair launcher to work again, but if you'd like to work with me personally, im sure we can find and squash this bug. feel free to get a contact line with me, email, whatever.

Cheers, hope we squash this thing, although as a programmer, i kinda wanna ask if a hotkey for a "forced" reload in eve, as if you hit the map button, let it load, and then return, it'd fix it [before hyper patch, no longer works now, hyper seems to broke it further]



edit: by slowly, i mean logon one every 10s, instead of just logging em in.
Nolak Ataru
Imperial Shipment
Amarr Empire
#14 - 2014-09-04 21:44:41 UTC
1] How many clients do you typically use
11 boxing, one "solo"
2] How frequently does the issue happen on Tranquility?
Every time on mass logon and undock.
3] Are the characters in player corps or NPC corps?
Player corps
4] Are they logging in to space or to a station?
Both occurs, but I get hit double when I log into station and then undock.
5] Can you reproduce the issue with the same setup on Singularity
Yes.
RoCkEt X
Hostile.
PURPLE HELMETED WARRIORS
#15 - 2014-09-04 21:50:35 UTC
CCP Masterplan wrote:
Thanks for your prompt feedback. The fleet-finder availability (or lack of) is quite useful info here. I've also seen someone else mention that the agent tab in the station info window also fails to display information if a client is broken in this way. This is making my spider-sense tingle :)

RoCkEt X wrote:
1] Ergo, this issue is something to do with being in space, and not to do with session change (because you can still switch ships whilst docked - thus session changing without an issue)

Just a quick comment on this: Switching ships whilst docked is no longer a session change (It used to be, until a couple of years ago). This is why you can switch quickly between different ships in your station hangar without requiring a 10s session timer between each.


Aye, i forgot switching ships has been changed - but even so, characters can still be manually invited to fleet, which causes a session change and it has no effect on blackscreening; the blackscreen will only ever exhibit itself if you either log in in-space, or when you undock after logging in in-station, but from the fleet-finder issue i mentioned; the issue already exists while you're docked, you just can't see it for whatever reason - hence you only see the 'blackscreen' when you undock.

-Rock
Pain Time
Ministry of War
Amarr Empire
#16 - 2014-09-04 23:24:44 UTC  |  Edited by: Pain Time
I feel this would be a good time to state that fleet itself is broke [logically] wing commander cannot recieve his own boosts, nor the fleet commander [how hard can this be to fix, or is this intended?]


further note on topic: the blackscreen doesnt have ANY impedeance on ability to undock, quit game, or anything like this, just uhh.... you gotta be great at memorization. might help.
Islena Inewen
School of Applied Knowledge
Caldari State
#17 - 2014-09-05 09:32:12 UTC
I had something similar to this before the patch, but as it turned out it was my own fault, kinda.

Problem was i had bumped the wifi antennae ad the back of my PC case so it was flush to the back of the case, not sticking straight out. this dropped me to 1 or 2 bars of signal instead of the usual 5/5.
everything was behaving normally but i would get black screens on undocking and frequent disconnections.

Since my day job is a software engineer I know that seemingly unrelated things can often have the same root cause (oh good how i hate that phrase) I'm just posting because you can never have too much information.

I think it possible that the problem will relate to packets getting dropped somewhere due to network overload. mebbe. in theory. as far as i can tell. perhaps.
CCP Masterplan
C C P
C C P Alliance
#18 - 2014-09-05 11:34:11 UTC
Thanks everyone for your reports so far. I've made some changes to the build we have just updated to Singularity. If anyone who was previously able to reproduce the issue there is able to update their test clients and see how it behaves now, I'd be very interested in your feedback.

"This one time, on patch day..."

@ccp_masterplan  |  Team Five-0: Rewriting the law

Tomas Marny
GreenSwarm
skill urself
#19 - 2014-09-07 08:46:52 UTC
my 5c:

1] How many clients do you typically use
-11
2] How frequently does the issue happen on Tranquility?
-for me rarely, I will explain below
3] Are the characters in player corps or NPC corps?
-some in player, some in npc
4] Are they logging in to space or to a station?
-either
5] Can you reproduce the issue with the same setup on Singularity
-quite possibly


-my pc is capable enough to handle 11 clients, the game is started from a very fast SSD drive and run under win8.1, so this shouldn't cause any bottlenecks. Multiboxing obviously setup runs under isboxer, with all clients set to lowest, resource caching disabled, DX9 forced on startup. I have 20GB of ram, windows swap set to 2GB.


-I noticed the blackscreen issue happens on my setup only when I use broadcast (either mouse or keyboard) to login or undock - if all clients try to undock at the same time, at least one usually (but not in 100% cases) blackscreens, with the same as RocketX mentioned - I can hit escape to see the options. If the client that blackscreens on undock is in fleet, it does actually take fleetwarps and follows them. This should be easily reproduced anywhere.

-If I login/undock chars one by one with like an alt+tab delay, then clients do rarely blackscreen.

that all above is valid for tq.

I'd love to help checking this on sisi, but all my chars are marked as expired (for like 6 months already).
Rain6637
NulzSec
#20 - 2014-09-07 13:39:29 UTC  |  Edited by: Rain6637
1] How many clients do you typically use

twelve. 5 reside on an SSD Raid 0 array, and 7 reside on an additional/separate SSD. I use separate installs for each account.

2] How frequently does the issue happen on Tranquility?

at least one client will blackscreen approximately once every 10th synchronized login or session change. the last one was just a couple days ago. ragelogging isn't always required, though. it has happened with just a few accounts running.

this latest blackscreen: the cursor was still visible. when I pressed escape, the cursor changed to the cross with a square in it, like it normally would. but the escape menu was not visible.

3] Are the characters in player corps or NPC corps?

most are in player corps.

4] Are they logging in to space or to a station?

both.

5] Can you reproduce the issue with the same setup on Singularity

I'm pretty sure I could induce it within a reasonable number of attempts. if i can help by doing this, just say so [it appears you have. are there any diagnostics I could run, to contribute in a more meaningful way than simply saying "it happened again" ?]

blackscreen is accompanied by a hard drive error in windows, usually in the form of an error dialog box, and sometimes the drive letter will disappear (requiring a system restart).
123Next page