These forums have been archived and are now read-only.

The new forums are live and can be found at https://forums.eveonline.com/

Linux

 
  • Topic is locked indefinitely.
 

[HELP] Fedora 18

Author
kaspa101
Original Sinners
Northern Coalition.
#1 - 2013-06-26 05:07:54 UTC
So got Fedora 18 up and running with drivers, wine, winetricks and Eve installed.. However I am getting this error...

Quote:

[kaspa@localhost bin]$ wine ExeFile.exe
fixme:heap:HeapSetInformation 0x48a000 0 0x33fce4 4
fixme:heap:HeapSetInformation (nil) 1 (nil) 0
Network layer using: CarbonIO
EVE Client version 8.3 build 561078 starting 0:57:06
Starting up Trinity through _trinity_dx9_deploy ...
libGL error: failed to load driver: swrast
libGL error: Try again with LIBGL_DEBUG=verbose for more details.
err:winediag:X11DRV_WineGL_InitOpenglInfo Direct rendering is disabled, most likely your OpenGL drivers haven't been installed correctly (using GL renderer "GeForce GTX 460/PCIe/SSE2", version "1.4 (2.1.2 NVIDIA 304.88)").
err:d3d:WineD3D_CreateFakeGLContext Failed to find a suitable pixel format.
err:d3d:wined3d_adapter_init Failed to get a GL context for adapter 0x159aa0.
err:d3d:WineD3D_CreateFakeGLContext Failed to find a suitable pixel format.
err:d3d:wined3d_adapter_init Failed to get a GL context for adapter 0x159aa0.
fixme:heap:HeapSetInformation 0x5512000 0 0x33983c 4
Cerberus localization module loaded on client
fixme:heap:HeapSetInformation 0x48a000 0 0x3382b4 4
EVE Client version 8.3 build 561078 started 0:57:09
Starting services
Service counter: 0.000s
Service sessionMgr: 0.000s
Service settings: 0.002s
Service machoNet: 0.001s
Service addressbook: 0.000s
err:d3d:WineD3D_CreateFakeGLContext Failed to find a suitable pixel format.
err:d3d:wined3d_adapter_init Failed to get a GL context for adapter 0x16b0e8.
Service bulkSvc: 0.000s
Service bookmarkSvc: 0.000s
Service alert: 0.000s
Service dataconfig: 0.017s
Service objectCaching: 0.000s
An exception has occurred. It has been logged in the log server as exception #1
Service photo: 0.000s
Service mailSvc: 0.000s
Service notificationSvc: 0.000s
Service LSC: 0.000s
Service patch: 0.000s
Service inv: 0.000s
Service pwn: 0.000s
Service focus: 0.000s
Service debug: 0.000s
Service jumpQueue: 0.000s
Service scanSvc: 0.000s
Service browserHostManager: 0.000s
Service localizationClient: 0.000s
Service launcher: 0.000s
Service jumpMonitor: 0.000s
Service calendar: 0.000s
Service liveUpdateSvc: 0.000s
err:d3d:WineD3D_CreateFakeGLContext Failed to find a suitable pixel format.
err:d3d:wined3d_adapter_init Failed to get a GL context for adapter 0x16b330.
fixme:win:EnumDisplayDevicesW ((null),0,0x33ab38,0x00000000), stub!
Service monitor: 0.006s
Service processHealth: 0.000s
Service planetInfo: 0.000s
Service district: 0.000s
Service devToolsClient: 0.000s
Service invCache: 0.000s
Service michelle: 0.000s
err:ole:CoInitializeEx Attempt to change threading model of this apartment from multi-threaded to apartment threaded
err:ole:CoInitializeEx Attempt to change threading model of this apartment from multi-threaded to apartment threaded
err:d3d:WineD3D_CreateFakeGLContext Failed to find a suitable pixel format.
err:d3d:wined3d_adapter_init Failed to get a GL context for adapter 0x1a15c0.
Service audio: 1.231s
Service crimewatchSvc: 0.000s
Service dungeonChecker: 0.000s
Service war: 0.000s
Service facwar: 0.000s
Service godma: 1.253s
Starting services - Done
An exception has occurred. It has been logged in the log server as exception #2


Any help would be awesome as I am puzzled and not a Linux expert.
After Shok
Ruthenia Co
#2 - 2013-06-26 07:10:55 UTC
Install i686 driver libs for video card

Правдой нельзя оскорбить, уважаемый адвокат!

Тот самый Мюнхгаузен

Золотая орка

kaspa101
Original Sinners
Northern Coalition.
#3 - 2013-06-26 17:21:14 UTC
I have those drivers..
kaspa101
Original Sinners
Northern Coalition.
#4 - 2013-06-26 18:53:22 UTC
Quick update.. I got it to work.. I was using yum install xorg-x11-drv-nvidia-libs-304.88-2.fc18.i686 which came back they were obsolete and already installed with updated package. Needed xorg-x11-drv-nvidia-304xx-libs.i686. Eve is now working