These forums have been archived and are now read-only.

The new forums are live and can be found at https://forums.eveonline.com/

Ships & Modules

 
  • Topic is locked indefinitely.
 

EVE Fit project: - pyfa 1.1.7 (Inferno 1.0)

First post
Author
Ulair Memmet
The Scope
Gallente Federation
#81 - 2011-10-09 15:45:08 UTC
Found a little bug when trying fits for the proteus:

here's how it is ingame:
proteus offensive - Hybrid propulsion armature: adds 5 hislots, 5 turret slots
proteus offensive - Drone synthesis projector: adds 5 hislots, 3 turret slots

pyfa on the other hand adds 5 turret slots for both. i guess it's ignoring the turrent hardpoint modifier property and assumes it's always the same as the hislot count.
Aamrr
#82 - 2011-10-09 15:57:44 UTC
Pyfa will allow you to fit more guns than your turrets allow -- but it displays your consumed hardpoints in the upper right corner and turns the text red if you've used more than your allocated amount.

The Drone Synthesis Projector correctly adds 3 to your maximum hardpoint count. Please do make sure that you're reading the results properly, because the error you're describing sounds like a case of PEBKAC.
Bienator II
madmen of the skies
#83 - 2011-10-10 19:23:21 UTC  |  Edited by: Bienator II
great tool. Changing t3 subsystems can trigger few bugs if you don't unfit the modules.

could you upload a clone to github?

how to fix eve: 1) remove ECM 2) rename dampeners to ECM 3) add new anti-drone ewar for caldari 4) give offgrid boosters ongrid combat value

Thorn Galen
Bene Gesserit ChapterHouse
#84 - 2011-10-16 12:18:23 UTC
This is an amazing tool!! Thank you so very much!
Aamrr
#85 - 2011-10-16 12:41:42 UTC
Bienator II wrote:
great tool. Changing t3 subsystems can trigger few bugs if you don't unfit the modules.

could you upload a clone to github?


It shouldn't. You might have more modules than you have slots, but it'll highlight the relevant modules in red to tell you to remove them.
Bienator II
madmen of the skies
#86 - 2011-10-16 17:15:33 UTC  |  Edited by: Bienator II
Aamrr wrote:
Bienator II wrote:
great tool. Changing t3 subsystems can trigger few bugs if you don't unfit the modules.

could you upload a clone to github?


It shouldn't. You might have more modules than you have slots, but it'll highlight the relevant modules in red to tell you to remove them.

well. my point was that it has a bug. I know that it shoudn't behave this way ;)

it gets confused as soon there are more modules fitted as there are slots. If I unfit a random module often some other module is unfitted. Restart is the only workaround i found so far.

how to fix eve: 1) remove ECM 2) rename dampeners to ECM 3) add new anti-drone ewar for caldari 4) give offgrid boosters ongrid combat value

Naso Gomez
#87 - 2011-10-16 18:11:44 UTC  |  Edited by: Naso Gomez
Does Pyfa support CAK keys yet?

Just updated from 1.0.3 to 1.0.5 and upon opening character editor Pyfa crashs.

Win 7 x64
Sakari Orisi
Doomheim
#88 - 2011-10-16 19:20:30 UTC  |  Edited by: Sakari Orisi
Naso Gomez wrote:
Does Pyfa support CAK keys yet?

Just updated from 1.0.3 to 1.0.5 and upon opening character editor Pyfa crashs.

Win 7 x64


Hi,

1.0.5 is currently in the process of being tested, it isn't stable yet. It was put on the wiki by mistake. Can you please revert to 1.0.4 for now ?

Edit: the new API is supported in 1.0.4
edit 2: if pyfa still crashes with 1.0.4, its because of the "border" bug in wxwidgets. You can work around it by changing your theme settings and putting a non zero border for windows
Phantom Slave
Ministry of War
Amarr Empire
#89 - 2011-10-17 02:41:37 UTC
I'm unable to get the evefit.org website to open up. Was working fine a few hours ago though.

Mmm, I love the smell of pod goo in the morning.

Evan183
EVE Exploration Inc
#90 - 2011-10-17 02:45:28 UTC
Phantom Slave wrote:
I'm unable to get the evefit.org website to open up. Was working fine a few hours ago though.


Confirmed. I've tried multiple times as well and I haven't been able to access it. Sad
Naso Gomez
#91 - 2011-10-17 02:54:42 UTC
Evan183 wrote:
Confirmed. I've tried multiple times as well and I haven't been able to access it. Sad

Down for me as well, bummer.
Ryan Startalker Zhang
Garoun Investment Bank
Gallente Federation
#92 - 2011-10-17 03:46:07 UTC
Confirm website down. Is there any other way to download the software?
Wa'roun
The Scope
Gallente Federation
#93 - 2011-10-17 04:37:12 UTC
Something I noticed while setting up a fitting is that there is no limit to the amount of drones you can place.
This program needs to limit drones based on drone cargo hold space like EFT does.
Naso Gomez
#94 - 2011-10-17 06:54:24 UTC
Ryan Startalker Zhang wrote:
Confirm website down. Is there any other way to download the software?


Yeah does anyone have version 1.0.4 installer / zip still on there hard drive, upload it to eve-files.com and link it up.
Kadesh Priestess
This Game Is Terrible
Warlords of the Deep
#95 - 2011-10-17 10:15:38 UTC  |  Edited by: Kadesh Priestess
Sakari Orisi wrote:
Naso Gomez wrote:
Does Pyfa support CAK keys yet?

Just updated from 1.0.3 to 1.0.5 and upon opening character editor Pyfa crashs.

Win 7 x64


edit 2: if pyfa still crashes with 1.0.4, its because of the "border" bug in wxwidgets. You can work around it by changing your theme settings and putting a non zero border for windows
Here's link to post on old forums mentioning this problem:

http://www.eveonline.com/ingameboard.asp?a=topic&threadID=1424096&page=4#120

As for 1.0.5 - it was killed right before release.
Sakari Orisi
Doomheim
#96 - 2011-10-17 14:47:25 UTC
Website seems to have gone back up. Is anyone still having problems accessing it ?
Kadesh Priestess
This Game Is Terrible
Warlords of the Deep
#97 - 2011-10-17 22:42:54 UTC  |  Edited by: Kadesh Priestess
As i mentioned, we dumped 1.0.5 during pre-release QA, so here's 1.0.6:

Windows: installer, archive
Mac: archive
Source: archive

Changes since last build:

  • EVE API should work now if you're behind proxy
  • Item browser sort order has been changed (most obvious thing - items from the same group are sorted by meta level now)
  • Several miscalculation fixes and optimizations


Completely forgot to add: this time we stomped bug which hammered pyfa since 1.0 release (last time it was seemi-okayish in 1.0 RC2), windows users had severe performance problems when opening market groups. As most of us use other platforms, nobody noticed that for a long time, until recently one of the guys posted note about it in our Trac. If you have some devastating performance problem - don't bury it, tell us and be heard.

And yet another thing: we've started reworking engine backing pyfa, and plan to switch pyfa to it at some point + make web-based fitting tool (Aurora). Some technical details hide under following link:
Pyfa: looking for web devs
Embrace My Hate
Caldari Provisions
Caldari State
#98 - 2011-10-18 05:42:44 UTC
How would we go about getting that sexy black theme/skin?
Zillam Reynardine
Stargazer Holdings
#99 - 2011-10-18 07:59:00 UTC
Naso Gomez wrote:
Ryan Startalker Zhang wrote:
Confirm website down. Is there any other way to download the software?


Yeah does anyone have version 1.0.4 installer / zip still on there hard drive, upload it to eve-files.com and link it up.

I got some invalid file error when trying to public upload, so have it off my public Dropbox.

pyfa 1.0.4 Win32 zip archive: http://dl.dropbox.com/u/3273892/pyfa-1.0.4-incarna-win32.zip
Wa'roun
The Scope
Gallente Federation
#100 - 2011-10-18 22:07:45 UTC
Zillam Reynardine wrote:
Naso Gomez wrote:
Ryan Startalker Zhang wrote:
Confirm website down. Is there any other way to download the software?


Yeah does anyone have version 1.0.4 installer / zip still on there hard drive, upload it to eve-files.com and link it up.

I got some invalid file error when trying to public upload, so have it off my public Dropbox.

pyfa 1.0.4 Win32 zip archive: http://dl.dropbox.com/u/3273892/pyfa-1.0.4-incarna-win32.zip



Old version unless you don't want to use the current version.