These forums have been archived and are now read-only.

The new forums are live and can be found at https://forums.eveonline.com/

Macintosh

 
  • Topic is locked indefinitely.
123Next pageLast page
 

Opt in beta test of new Mac Launcher

First post First post
Author
CCP Atropos
C C P
C C P Alliance
#1 - 2012-12-03 22:17:03 UTC  |  Edited by: CCP Atropos
Hello capsuleers!

Whilst there hasn't been much conversation about it, I'm here to say that we're currently testing out some new work we've been doing on the EVE Launcher.

One of the things we've been working on is wrapping the Chromium Embedded Framework for the Mac, so that we can bring the Windows and Mac EVE Launchers into feature parity.

What I'm asking for your help to do, is to simply run the application and to play with it. It's not a fully functional EVE Launcher so you won't be able to actually patch a version of the game.

I would dearly love for three things to happen:

  1. you to download and run the beta version
  2. to give us your feedback
  3. to give us any feature improvements you have (ideally for the Mac implementation of the Launcher but I'll take what I can get)


I can't promise anything in return beyond fixing any bugs you discover, but I'll see if I can rustle up some treats much as the mass test participants get, for those that really want an incentive Blink

Thank you for taking the time to help out!

Testing tips:

  • The .zip file contains the EVE Online.app so after extracting it, simply run the extracted .app
  • The EVE Launcher will generate a logfile inside itself, at the following path: EVE Online.app/EVE Online-2.1.488145-beta.2.macosx-10_3-fat/EVE Online.app/Contents/Resources/cache/*.log
  • When you encounter any errors, please reply here with a run down of what you were doing and what the issue was. It would be of great help if you're able to supply the log too. Sites such as Pastebin can handle the formatting in the EVE Launcher logs if necessary.
CCP Atropos
C C P
C C P Alliance
#2 - 2012-12-04 10:42:34 UTC  |  Edited by: CCP Atropos
Version History:

  1. 1.503
  2. 1.504
  3. 2.1.488145-beta.2
  4. 2.1.488552-beta.2


Known Issues:

  1. 1.503: No items in 'EVE Online' menu [1, 2, 3, ]
  2. 1.503: Ships in the ship viewer on eveonline.com have reversed x/y axes [1, 2, 3, 4, 5, 6, 7, 8, 9]
  3. 1.503: Video playback problems (wanting to install flash, rendering behind app) [1, 2, 3, 4, 5, ]
  4. 1.503: 'Allow Incoming Connections' dialog appears at every start of the app [1, 2, ]
  5. 1.503: The input boxes for ports in the EVE Launcher settings menu are too small [1, ]
  6. 1.503: The EVE game client settings menu doesn't show correctly [1, ]
  7. 1.503: The EVE Launcher can hang when terminating the process [1, ]
  8. 1.503: The EVE Launcher settings menu text doesn't wrap properly [1, ]
  9. 1.503: The EVE Launcher won't run when the OS is set to only run registered apps [1, ]
  10. 1.503: The app doesn't minimize and reappear correctly [1, ]
  11. 1.503: The app is not retina display aware [1, ]


Change History:

  • #1 - there is a menu with items on OS X (1.504)
  • #6 - game client settings menu loads properly (1.504)
  • #10 - the application now reappears when clicked from the dock (1.504)
  • the application has been resized for the duration of the beta test (1.504)


Watch this space!
Pyfintlyn Lukqplm
The Scope
Gallente Federation
#3 - 2012-12-05 03:09:24 UTC
Be glad to test the beta and provide any feedback. Anything I can do to help the DEV team that works on macs, I'm in.
Raketefrau
Deep Core Mining Inc.
Caldari State
#4 - 2012-12-07 15:48:45 UTC
I can't test much, as it doesn't seem to actually launch anything yet, but I can say this:

It seems to load up just fine, then Adobe wants to update my flashplayer. I know that with Chrome you don't *need* Adobe's flash player, which is why I like it -- I guess this isn't the case with Chromium itself?

I'm on 10.8.2 on a 2.4 C2D with 4GB.

Do we need to move this to the Applications folder so that it picks up our regular installs? I don't want to do that yet, in case it hoses my install....
Rees Noturana
Red Rock Mining Company
#5 - 2012-12-07 15:58:04 UTC  |  Edited by: Rees Noturana
Launched the app and the layout seemed off. I've posted a screen shot here:

https://dl.dropbox.com/u/9038939/Screen%20Shot%202012-12-07%20at%209.48.52%20AM.png

The normal Mac menu did not contain any menu items including an all important Quit option. I had to force quit the launcher.

The PLAY button was inactive.

I posted a log here but I didn't seen anything important in it:

http://pastebin.com/3Gi58ARE

I'm on a Mac Pro (Early 2009) OS X 10.8.2.

I ran this off the desktop to avoid doing anything to my normal EVE apps too.

_ _

Manssell
OmiHyperMultiNationalDrunksConglomerate
#6 - 2012-12-07 16:17:08 UTC
Seemed to work pretty good for me. As Rees pointed out the mac menu had no options, but closing the program from the little dot thinkgy (technical term) on the window worked fine. The browser worked fine, I even watched a youtube video on it, something the ingame one now can't handle.
CCP Atropos
C C P
C C P Alliance
#7 - 2012-12-07 16:51:14 UTC
Raketefrau wrote:
I can't test much, as it doesn't seem to actually launch anything yet, but I can say this:

It seems to load up just fine, then Adobe wants to update my flashplayer. I know that with Chrome you don't *need* Adobe's flash player, which is why I like it -- I guess this isn't the case with Chromium itself?

I'm on 10.8.2 on a 2.4 C2D with 4GB.

Do we need to move this to the Applications folder so that it picks up our regular installs? I don't want to do that yet, in case it hoses my install....

The current build won't do anything with any games. I've stubbed out the functionality to do that. What I'm interested in is

  1. does it even start Bear
  2. and if you navigate around does the website render properly


If it did those two, then that's great Big smile
CCP Atropos
C C P
C C P Alliance
#8 - 2012-12-07 16:55:07 UTC
Rees Noturana wrote:
Launched the app and the layout seemed off. I've posted a screen shot here:

https://dl.dropbox.com/u/9038939/Screen%20Shot%202012-12-07%20at%209.48.52%20AM.png

The normal Mac menu did not contain any menu items including an all important Quit option. I had to force quit the launcher.

The PLAY button was inactive.

I posted a log here but I didn't seen anything important in it:

http://pastebin.com/3Gi58ARE

I'm on a Mac Pro (Early 2009) OS X 10.8.2.

I ran this off the desktop to avoid doing anything to my normal EVE apps too.

To answer your points in turn:

  1. The webpage is off because I simply pointed it at one I knew to have dynamic content (videos and whatnot) and so it's not pointing to a webpage that's designed for the available space. That said, thank you for the screenshot, it's always good to double check that it's rendering correctly P
  2. By 'Mac menu' do you mean this: http://i.imgur.com/mrFmg.png ?
  3. The play button is meant to be inactive.
  4. Thanks for the log file!
Rees Noturana
Red Rock Mining Company
#9 - 2012-12-07 17:03:04 UTC
CCP Atropos wrote:
Rees Noturana wrote:
Launched the app and the layout seemed off. I've posted a screen shot here:

https://dl.dropbox.com/u/9038939/Screen%20Shot%202012-12-07%20at%209.48.52%20AM.png

The normal Mac menu did not contain any menu items including an all important Quit option. I had to force quit the launcher.

The PLAY button was inactive.

I posted a log here but I didn't seen anything important in it:

http://pastebin.com/3Gi58ARE

I'm on a Mac Pro (Early 2009) OS X 10.8.2.

I ran this off the desktop to avoid doing anything to my normal EVE apps too.

To answer your points in turn:

  1. The webpage is off because I simply pointed it at one I knew to have dynamic content (videos and whatnot) and so it's not pointing to a webpage that's designed for the available space. That said, thank you for the screenshot, it's always good to double check that it's rendering correctly P
  2. By 'Mac menu' do you mean this: http://i.imgur.com/mrFmg.png ?
  3. The play button is meant to be inactive.
  4. Thanks for the log file!


1. OK, cool.
2. Yes, the current launcher has options in there.
3. OK
4. No problem.

Always happy to help make EVE a better place. Any misunderstandings on my part I blame on the human inability to truly multitask.

_ _

Null Poynter
Viziam
Amarr Empire
#10 - 2012-12-07 19:23:33 UTC
Im running OSX 10.8.2

It started fine, had no problems, Videos, Sound and dynamic elements of the page all worked, as did navigation. Unlike an earlier comment, it did not ask me to update anything at all.

Syr Dread
Caldari Provisions
Caldari State
#11 - 2012-12-07 20:48:35 UTC
Here's a log:
https://dl.dropbox.com/u/5866878/eve/launcher.2012.12.07.log

Seems nice and responsive. No crashes or anything. But the videos under the videos section are not playable. I have no flash installed on system and i guess chromium doesn't find the h264 files or something because in safari i can play the videos just fine.

Tevi
Di-Tron Heavy Industries
Atlas. Alliance
#12 - 2012-12-07 21:18:35 UTC
I found a little wierd thing when navigating to this set of pages: http://www.eveonline.com/sandbox/freedom-fighter/
The spinnable 3d models of the ships are upside down.
Tien Ti
The Scope
Gallente Federation
#13 - 2012-12-08 00:47:28 UTC
Same as above, ship models in the ship viewer are all upside down
CCP Atropos
C C P
C C P Alliance
#14 - 2012-12-08 17:59:33 UTC
Syr Dread wrote:
Here's a log:
https://dl.dropbox.com/u/5866878/eve/launcher.2012.12.07.log

Seems nice and responsive. No crashes or anything. But the videos under the videos section are not playable. I have no flash installed on system and i guess chromium doesn't find the h264 files or something because in safari i can play the videos just fine.

Interesting, thanks for pointing that out. I thought they were HTML5 rather than flash, but will have to check it out further.
CCP Atropos
C C P
C C P Alliance
#15 - 2012-12-08 18:00:00 UTC
Tevi wrote:
I found a little wierd thing when navigating to this set of pages: http://www.eveonline.com/sandbox/freedom-fighter/
The spinnable 3d models of the ships are upside down.


Tien Ti wrote:
Same as above, ship models in the ship viewer are all upside down


Heh, awesome! Thanks for pointing this out.
Rafael Argus
Federal Navy Academy
Gallente Federation
#16 - 2012-12-09 00:36:07 UTC
I tested it out and noted the issues listed above, the ship being upside down, and the lack of standard Mac OS application menu items, such as Quit.

One feature I'd like to see added to the launcher in general is to enable the Play button as the default button so it could be pressed by using the Return/Enter key on the keyboard. For some reason, it really bugs me that one can not just press Enter to play! :)
CCP Atropos
C C P
C C P Alliance
#17 - 2012-12-09 16:45:03 UTC  |  Edited by: CCP Atropos
Rafael Argus wrote:
I tested it out and noted the issues listed above, the ship being upside down, and the lack of standard Mac OS application menu items, such as Quit.

One feature I'd like to see added to the launcher in general is to enable the Play button as the default button so it could be pressed by using the Return/Enter key on the keyboard. For some reason, it really bugs me that one can not just press Enter to play! :)

We've actually done a little work on this regard; pressing 'S' or 'G' brings up the EVE Launcher settings menu and EVE game client settings menu respectively (although the latter is currently broken). In addition, both enter and return will trigger the Play button, although not in this build, since it's not doing anything with a client.
Rakshasa Taisab
Sane Industries Inc.
#18 - 2012-12-11 13:45:21 UTC
Nothing blew up.

Nyan

Vincent Athena
Photosynth
#19 - 2012-12-11 13:56:36 UTC  |  Edited by: Vincent Athena
The videos did play for me. One oddity: When I pressed the button to go to full screen I got no video at all. It was still playing, I could hear the sound. But the screen was just what it was before I pressed the full screen button, less a video being played in its initial window. Pressing esc brought it back.

Edit: I do not know if its supposed to be there, but I see no way to make the launcher window a different size.

The ship viewer not only shows ships upside down, but the camera movement is upside down too. (Moving the mouse up and down causes the opposite movement of the ship model).

Know a Frozen fan? Check this out

Frozen fanfiction

Grukni
Caldari Provisions
Caldari State
#20 - 2012-12-11 14:02:57 UTC
Now that Linux is gaining momemtum in PC gaming thanks to, among other things, Valve, are you planing on supporting Linux again?

OpenGL is the way, and not the privative, un-interoperable, DirectX crap.
123Next pageLast page